Anda di halaman 1dari 4

Ordenar arreglo por mtodo burbuja en Pseudocdigo - Wiki Iniciar sesin / crear cuenta

Pgina Discusin

Leer Editar Ver historial

Buscar

Ir

Buscar

Navegacin Pgina principal Portal de la comunidad Actualidad Cambios recientes Pgina aleatoria Ayuda

Ordenar arreglo por mtodo burbuja en Pseudocdigo


Descripcin : Ordena un arreglo de 10 elementos de forma ascendente, mediante el mtodo burbuja en Pseudocdigo. La metodologa es la siguiente: En un arreglo con limite de 10 numeros, se comparan dos elementos. Si un elemento inferior que contiene un numero es mayor que el numero del elemento superior a esta se intercambiaran, con cada iteracin siempre se deja el elemento mayor al fin del arreglo por ende es ahi en donde entra el limite flexible que se usa para no comparar con elemento mayor ya definido por el ordenamiento burbuja, el contador j compara los elementos dentro del limite flexible y temp es una variable temporal encargada de intercambiar los elementos de los elementos sin perderlos Variables: Temp, Cantidad, i, j,Lim Publicado Por: Miguel Gonzlez Aravena . Editado por: El Lobo Soporte : Comente fallas del codigo en la discusin de esa pagina Cdigo en Pseudocdigo :
Programa Ordenar_Arreglo {El programa pide al usuario 10 numeros, y luego los ordena mediante mtodo burbuja.} {Temp, Cantidad, i, j,Lim son variables de tipo entero} A: Arreglo[1..10] de tipo entero. Inicio Hacer Cantidad<-10; //Arreglo de 10 elementos Repetir i desde 1 Hasta Cantidad //Relleno del arreglo Escribir "Ingrese un valor para el elemento ", i, ": "; //mensaje al usuario Leer A[i]; //lee el elemento Fin ciclo Repetir Escribir "Los elementos del arreglo A, ordenados con metodo burbuja, de forma ascendente: "; Escribir "Elementos del Arreglo = ", Cantidad; Repetir i desde 2 Hasta Cantidad //Comienza Ordenamiento Burbuja Escribir "i Vale ",i; //este contador recorre todos los elementos del arreglo. //tambien hace un papel protagonico en el limite flexible Hacer Lim <- Cantidad-i+1; Escribir "Limite Flexible = ",Lim; //Limite flexible: Cuando el arreglo encuentra un elemento mayor... //...El limite disminuye para no hacer una comparacion extra con el elemento mayor ya encontrado Escribir "-----"; //Separador comn Repetir j desde 1 Hasta Lim //J es otro contador que recorre solamente hasta el limite flexible Escribir "J Vale ",j; //Muestra el valor de j durante el recorrido Escribir "Elemento ",j," VS Elemento ",j+1; //mensaje de guia: comparando Elementos Escribir "Elemento ",j," Vale ",A[j]; //Muestra el Elemento inferior y su valor Escribir "Elemento ",j+1," Vale ",A[j+1]; //Muestra el Elemento superior y su valor Escribir "-----"; //Separador comn Si A[j] > A[j+1] Entonces Escribir "Desorden encontrado"; //Mensaje de Guia: El numero del Elemento inferior es... // ...mayor que el numero del Elemento superior

Herramientas Lo que enlaza aqu Cambios relacionados Pginas especiales Enlace permanente

Imprimir/exportar Crear un libro Descargar como PDF Versin para imprimir

http://wiki.decom-uv.cl/index.php/Ordenar_arreglo_por_mtodo_burbuja_en_Pseudocdigo[21/04/2014 22:52:55]

Ordenar arreglo por mtodo burbuja en Pseudocdigo - Wiki


Escribir "-----"; Temp<-A[j]; //temp guarda el valor mayor del Elemento inferior A[j]<-A[j+1]; //el valor menor del Elemento superior es intercambiado al Elemento inferior A[j+1]<-Temp; //el valor mayor guardado es intercambiado al Elemento superior Escribir "Nuevo Orden "; //Mensaje guia: Muestra los valores intercambiados y las propios Elementos Escribir "Elemento ",j," Vale ",A[j]; Escribir "Elemento ",j+1," Vale ",A[j+1]; Escribir "-----"; Sino Escribir "No hubo desorden"; //no hubo numeros desordenados en el orden ascendiente Escribir "-----"; Fin Condicional Si Fin Condicional Repetir Fin Condicional Repetir Repetir i desde 1 Hasta Cantidad Escribir A[i]; Fin Repetir Fin_programa

//muestra el nuevo arreglo ordenado

A continuacin, el cdigo para PSeINT :


Proceso Ordenar_Arreglo Definir A, Temp, Cantidad, i, j,Lim Como Entero; Dimension A[10]; Cantidad<-10; Para i<-1 Hasta Cantidad Hacer Escribir "Ingrese un valor para el elemento ", i, ": "; Leer A[i]; FinPara Escribir "Los elementos del arreglo A, ordenados con metodo burbuja, de forma ascendente: "; Escribir "Elementos del Arreglo = ", Cantidad; Para i<-2 Hasta Cantidad Hacer Escribir "i Vale ",i; Lim <- Cantidad-i+1; Escribir "Limite Flexible = ",Lim; Escribir "-----"; Para j<-1 Hasta Lim Hacer Escribir "J Vale ",j; Escribir "Elemento ",j," VS Elemento ",j+1; Escribir "Elemento ",j," Vale ",A[j]; Escribir "Elemento ",j+1," Vale ",A[j+1]; Escribir "-----"; Si A[j] > A[j+1] Entonces Escribir "Desorden encontrado"; Escribir "-----"; Temp<-A[j]; A[j]<-A[j+1]; A[j+1]<-Temp; Escribir "Nuevo Orden "; Escribir "Elemento ",j," Vale ",A[j]; Escribir "Elemento ",j+1," Vale ",A[j+1]; Escribir "-----"; Sino Escribir "No hubo desorden"; Escribir "-----"; FinSi FinPara FinPara Para i<-1 Hasta Cantidad Hacer Escribir A[i]; FinPara FinProceso

http://wiki.decom-uv.cl/index.php/Ordenar_arreglo_por_mtodo_burbuja_en_Pseudocdigo[21/04/2014 22:52:55]

Ordenar arreglo por mtodo burbuja en Pseudocdigo - Wiki

Publicado por: Daniel Arenas PSeINT:


Proceso Burbuja definir i,j,n,A,temp Como Entero; dimension A[10]; Escribir "Este programa ordena 10 numeros enteros ingresados por el usuario de manera creciente"; Escribir " "; para i<- 0 hasta 9 Hacer Escribir "Ingrese el ", (i+1), " numero"; Leer A[i]; FinPara para i<- 0 hasta 8 Hacer para j<- i+1 hasta 9 Hacer Si A[i] > A[j] Entonces temp <- A[i]; A[i] <- A[j]; A[j] <- temp; FinSi FinPara FinPara para i<-0 hasta 9 Hacer Escribir A[i]; FinPara FinProceso

Pseudocodigo:
Programa Burbuja {i,j,n,temp son variables de tipo entero} {A = ARREGLO[1...10] de tipo entero} Inicio Escribir "Este programa ordena 10 numeros enteros ingresados por el usuario de manera creciente" Escribir " " Hacer i<- 1 repetir i desde 1 hasta 10 Escribir "Ingrese el ", i, " numero" Leer A[i] {fin ciclo repetir} Hacer i<- 1 Repetir i desde 1 hasta 9 Hacer j<- i+1 Repetir j desde i+1 hasta 10 Si A[i] > A[j] Entonces Hacer temp <- A[i] Hacer A[i] <- A[j] Hacer A[j] <- temp {fin condicional si} Hacer j<- j+1 {fin ciclo repetir} Hacer i<- i+1 {fin ciclo repetir} repetir i desde 1 hasta 10 Escribir A[i] Hacer i<- i+1 {fin ciclo repetir} Fin

Publicado por Felipe Ascencio (Version alternativa) . Pseudocodigo:


Inicio A: Arreglo A[1...10] de tipo reale Hacer i<-1 Repetir con i desde 1 hasta 10 Escribir "Ingrese el dato para el arreglo ", i Leer A[i] Hacer i<-i+1 {Fin ciclo repetir} Hacer i<-2 Repetir con i desde 2 hasta 10

http://wiki.decom-uv.cl/index.php/Ordenar_arreglo_por_mtodo_burbuja_en_Pseudocdigo[21/04/2014 22:52:55]

Ordenar arreglo por mtodo burbuja en Pseudocdigo - Wiki


Hacer j<-1 Repetir con j desde 1 hasta 10-i+1 si A[j]>A[j+1] Entonces Hacer temp<-A[j] Hacer A[j]<-A[j+1] Hacer A[j+1]<-temp {Fin ciclo condicional} Hacer j<-j+1 {Fin ciclo repetir} Hacer i<-i+1; {Fin ciclo repetir} Escribir "EL arreglo ordenado de forma ascendente queda de la siguiente forma:" Hacer i<-1 Repetir con i desde 1 hasta 10 Escribir A[i] {Fin ciclo repetir} Hacer i<-2 Repetir con i desde 1 hasta 2 Hacer j<-1 Repetir con j desde 1 hasta 10-i+1 si A[j]<A[j+1] Entonces Hacer temp<-A[j] Hacer A[j]<-A[j+1] Hacer A[j+1]<-temp {Fin ciclo condicional si} Hacer j<-j+1 {Fin ciclo repetir} Hacer i<-i+1 {Fin ciclo repetir} Escribir "El arreglo ordenado de forma descendente queda de la siguiente forma:" Hacer i<-1 Repetir con i desde 1 hasta 10 Escribir A[i] Hacer i<-i+1 {Fin diclo repetir} Fin

Regresar a Fundamentos de Programacin Regresar a Arreglos en Pseudocdigo

Esta pgina fue modificada por ltima vez el 7 feb 2013, a las 01:54. Esta pgina ha sido visitada 8.718 veces. Poltica de proteccin de datos Acerca de Wiki Aviso legal Versin para mviles

http://wiki.decom-uv.cl/index.php/Ordenar_arreglo_por_mtodo_burbuja_en_Pseudocdigo[21/04/2014 22:52:55]