Anda di halaman 1dari 10

2/20/2014 ASA 8.

4 with ASDM on GNS3 - Step by Step Guide - XeruNetworks


http://www.xerunetworks.com/2012/03/asa-84-asdm-on-gns3-step-by-step-guide/ 1/10

Search Search
XeruNetworks
Its all about networks
GNS3
Securi ty
ASA
VPN
Routi ng & Swi tchi ng
EIGRP
Stackwise
Ti ps
Voi ce
Call Manager
CME
Licencing
Wi rel ess

ASA 8.3/8.4 NAT Migration Lab Guide
ASA 8.3/8.4 NAT Migration Lab Guide Lab 1.0
Mar 05
ASA 8.4 with ASDM on GNS3 Step by Step
Guide
Categories:
ASA, GNS3, Security
by malikyounas
This post details the method to connect to Firewall in GNS3 using
ASDM. You will establish ASDM session from your machine to GNS3
so we will be building connection/bridge between GNS3 and PC. Also
because first you will have to copy ASDM via TFTP to Firewall so this
connection is necessary.
1. Follow this guide about how to add a loopback adapter to Windows
7, Windows XP
Windows 7
2/20/2014 ASA 8.4 with ASDM on GNS3 - Step by Step Guide - XeruNetworks
http://www.xerunetworks.com/2012/03/asa-84-asdm-on-gns3-step-by-step-guide/ 2/10
http://social.technet.microsoft.com/Forums/en-
US/w7itpronetworking/thread/259c7ef2-3770-4212-8fca-c58936979851
Windows XP
http://support.microsoft.com/kb/839013
2. Restart your PC
3. Follow this guide about how to configure ASA 8.4(2) for GNS3.
http://www.xerunetworks.com/2012/02/cisco-asa-84-on-gns3/
4. Start a new Porject in GNS3 and drag/drop a ASA (8.4) firewall to the topology
5. Drag/Drop Cloud Object from Panel on the Left to the topology and right click it. Select 'Configure'.
Select 'C1' or whatever name of the object.
6. Now as per following diagram select the loopback adapter that you added in step 1.
7. Add the adapter as per following after selecting and press OK.
8. Drop an ethernet switch the topology. If you dont do this and try drawing a direct connection
between Firewall and Cloud it will come up with error saying 'Devices does not support this type of
NIO. Use an ETHSW to bridge the connection to the NIO Instead.
9. Connect both Cloud and Firewall to the Switch as following
2/20/2014 ASA 8.4 with ASDM on GNS3 - Step by Step Guide - XeruNetworks
http://www.xerunetworks.com/2012/03/asa-84-asdm-on-gns3-step-by-step-guide/ 3/10
10. Now start all devices in GNS and use following commands on the firewall to give it an IP.
ciscoasa# config t
ciscoasa(config)# int gi
ciscoasa(config)# int gigabitEthernet 0
ciscoasa(config-if)# ip address 10.10.10.1 255.255.255.0
ciscoasa(config-if)# nameif management
ciscoasa(config-if)# no shut
11. Now, go back to Windows 7 and open 'Network and Sharing Centre', Click on Change adapter
settings and Change the IP Address of the Loopback adapater as following
12. You will have to turn off your PC firewall as you will be copying ASDM to ASA firewall. If you
dont know this, stop studying networking or stop the Windows Firewall Service or if that doesnt work
then Base Filtering Service.
13. Now you PC is ready to talk to firewall, lets try.
ciscoasa# ping 10.10.10.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/6/20 ms
ciscoasa#
14. OK, Now the next step is to copy ASDM to Firewall. If you already have TFTP Server installed,
cool otherwise Download and start this TFTP Application from following website
2/20/2014 ASA 8.4 with ASDM on GNS3 - Step by Step Guide - XeruNetworks
http://www.xerunetworks.com/2012/03/asa-84-asdm-on-gns3-step-by-step-guide/ 4/10
http://tftpd32.jounin.net/tftpd32_download.html
15. Download ASDM from Cisco website or any other dodgy source you have. I have ASDM 6.4(7)
downloaed.
16. On the TFTP application browse to the folder where you have downloaded ASDM.
17. On the firewall use following command to download TFTP Image.
ciscoasa# copy tftp flash
Address or name of remote host []? 10.10.10.2
Source filename []? asdm-647.bin
Destination filename [asdm-647.bin]?
Accessing tftp://10.10.10.2/asdm-
647.bin!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Output Omited
Writing current ASDM file disk0:/asdm-647.bin
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Output Omited
17902288 bytes copied in 56.500 secs (319683 bytes/sec)
ciscoasa#
18. Set the Firewall to Load the ASDM at next reboot and also identify the management Station IP
address
ciscoasa# sh flash
# length date/time path
2 4096 Mar 05 2012 13:40:42 log
9 4096 Mar 05 2012 13:40:47 coredumpinfo
10 59 Mar 05 2012 13:40:47 coredumpinfo/coredump.cfg
11 196 Mar 05 2012 13:40:47 upgrade_startup_errors_201203051340.log
12 17902288 Mar 05 2012 14:00:48 asdm-647.bin
268136448 bytes total (250191872 bytes free)
ciscoasa# config t
ciscoasa(config)# asdm image flash:asdm-647.bin
ciscoasa(config)# http server enable
ciscoasa(config)# http 10.10.10.2 255.255.255.255 management
ciscoasa(config)# username cisco password cisco privilege 15
19. use 'wr' command and then reload the firewall using 'reload' command
20. Launch your browser and go to https://10.10.10.1 (Disable Proxy if you are using any)
21. Download and Install ASDM App from website you browsed to.
2/20/2014 ASA 8.4 with ASDM on GNS3 - Step by Step Guide - XeruNetworks
http://www.xerunetworks.com/2012/03/asa-84-asdm-on-gns3-step-by-step-guide/ 5/10
Share this:
Like this:
Like
Be the first to like this.

22. Launch the ASDM and here you go



You can follow the post below if you want to connect two GNS3 on two different PCs together or to
connect an external device on physcial network to the GNS3 network.
http://www.xerunetworks.com/2012/03/connect-gns3-network-to-real-networks-other-gns3-network/

You can use follwoing Lab guide for NAT migration from pre ASA 8.2 to 8.4

http://www.xerunetworks.com/2012/03/asa-8384-nat-migration-lab-guide/
Related Posts
ASA 8.3 / 8.4 Double NAT / Source Destination NAT Migration Lab Guide Lab 1.4
ASA 8.3/8.4 NAT Migration Lab Guide Lab 1.3
ASA 8.3/8.4 NAT Migration Lab Guide Lab 1.2
ASA 8.3/8.4 NAT Migration Lab Guide Lab 1.1
ASA 8.3/8.4 NAT Migration Lab Guide Lab 1.0
126 comments
8 pi ngs
Skip to comment form
1.
Namasi vayam
February 6, 2014 at 9:47 am (UTC 1)
Reply
Unable to Launch Cisco ASDM device manager from 192.168.1.1
Software Details:
asa842-initrd.gz
asa842-vmlinuz
Cisco asdm-647.bin
Download Free Software
mobogenie.com/download-software
Download Free PC Manager Software for Android. Download
Now !
2/20/2014 ASA 8.4 with ASDM on GNS3 - Step by Step Guide - XeruNetworks
http://www.xerunetworks.com/2012/03/asa-84-asdm-on-gns3-step-by-step-guide/ 6/10
jdk-7u51-windows-i586
Windows 7 32 bit O/s
Internet Explorer version 9
tftp32.exe
GNS3 0.8.6
Qemu Options: -vnc none -vga none -m 1024 -icount auto -hdachs 980,16,32
Kernel cmd line: -append ide_generic.probe_mask=001 ide_core.chs=0.0:980,16,32 auto
nousb console=ttyS0,9600 bigphysarea=65536

ciscoasa(config)#interface gigabitEthernet 0
ciscoasa(config-if)#ip address 192.168.1.1 255.255.255.0
ciscoasa(config-if)#nameif inside
ciscoasa(config-if)#no shutdown
ciscoasa(config-if)#exit
ciscoasa(config)#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!!!!
Success rate is 100 parcent (5/5), round-trip min/avg/max = 1/1/1 ms
ciscoasa(config)#http server enable
ciscoasa(config)#http 192.168.1.2 255.255.255.255 inside
ciscoasa(config)#username cisco password admin privilege 15
ciscoasa(config)#copy tftp: flash:
Address or name of remote host[]? 192.168.1.2
Source filename []? asdm-647.bin
Destination filename [asdm-647.bin]?
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ciscoasa(config)#asdm image flash:asdm-647.bin
ciscoasa(config)#wr mem

Step 1: Go to IE Browser
Step 2: Type https://192.168.1.1
Step 3: I Enter username and password
Step 4: I install Run the Asdm
Step 5: i Enter firewall ip, username and password in asdm launcher
Step 6: i have one Error unable to launch device manager from 192.168.1.1
Step 7: how to solve this error.
1.
Phi
February 7, 2014 at 4:11 pm (UTC 1)
Reply
Java version 7 is incompatible with asdm-launcher.
2 Solutions:
1. Downgrade to java 6 if you want to use the launcher
2. Dont use the install option just click on Run ASDM (the web asdm should work,
confirmed working with asdm-715)
2/20/2014 ASA 8.4 with ASDM on GNS3 - Step by Step Guide - XeruNetworks
http://www.xerunetworks.com/2012/03/asa-84-asdm-on-gns3-step-by-step-guide/ 7/10
1.
Chandan Dey
February 17, 2014 at 11:09 am (UTC 1)
Reply
I have same problem. Please suggest which java 6 version is needed. Coz in
java.com there are lots of java 6 exe based on different version.
2.
Zi a
January 18, 2014 at 10:10 am (UTC 1)
Reply
Hi all,
I connected an ethernet sw from asa port gi 0 and one loop back adptor to sw. this the config on
g0 on ASa
interface GigabitEthernet0
nameif management
security-level 100
ip address 111.111.111.1 255.255.255.0
loopback ip is 111.111.111.10/24 and gateway is 111.111.111.1
but i am not able to ping g0 interface from laptop and asa to loopback intface. Please help
if i connect router indtead of asa i am able to ping?
Previous 1 7 8 9
1. Confi guri ng Ci sco ASA wi th ASDM | Mi ftah Rahman (Go)-Bl og
January 19, 2014 at 6:07 am (UTC 1) Link to this comment
Reply
[] (cara setting pake GNS) []
2. Confi g i n GNS3 to run ASA 8.4 | Network Gui de
September 23, 2013 at 9:25 pm (UTC 1) Link to this comment
Reply
[] http://www.xerunetworks.com/2012/03/asa-84-asdm-on-gns3-step-by-step-guide/ []
3. ASA GNS i Ci sco
July 25, 2013 at 9:48 am (UTC 1) Link to this comment
Reply
[...] ASDM: http://www.xerunetworks.com/2012/03/asa-84-asdm-on-gns3-step-by-
step-guide/ [...]
4. Instal ar Fi rewal l Ci sco ASA 8.4(2) y ASDM 6.4(7) en GNS3 0.8.3.1 | El Camel l o, el Len y el ni o. O l a
evol uci n del perro al l obo
2/20/2014 ASA 8.4 with ASDM on GNS3 - Step by Step Guide - XeruNetworks
http://www.xerunetworks.com/2012/03/asa-84-asdm-on-gns3-step-by-step-guide/ 8/10
June 8, 2013 at 7:08 pm (UTC 1) Link to this comment
Reply
[...] http://www.xerunetworks.com/2012/03/asa-84-asdm-on-gns3-step-by-step-guide/ [...]
5. Ci sco ASA 8.4 on GNS3 | IPv6 Freel y
May 21, 2013 at 10:24 am (UTC 1) Link to this comment
Reply
[...] http://www.xerunetworks.com/2012/03/asa-84-asdm-on-gns3-step-by-step-guide/ [...]
6. Setup ASA i n GNS3 for capture and export to Wi reshark | CCNP Gubbi ns
March 22, 2013 at 6:34 pm (UTC 1) Link to this comment
Reply
[...] = Setup ASA in GNS3 http://www.xerunetworks.com/2012/03/asa-84-asdm-on-gns3-step-
by-step-guide/ = setup ASA with ASDM http://m.youtube.com/watch?v=VQ0YvL2F7yU = basic
ASA [...]
7. Connect GNS3 Network to Real Networks / Other GNS3 Network - My Tech Worl d My Tech Worl d
March 18, 2012 at 2:15 am (UTC 1) Link to this comment
Reply
[...] http://www.xerunetworks.com/2012/03/asa-84-asdm-on-gns3-step-by-step-guide/ [...]
8. Ci sco ASA 8.4 on GNS3 My Tech Worl d
March 12, 2012 at 9:32 pm (UTC 1) Link to this comment
Reply
[...] you have ASA running in GNS and want to play with ASDM, here is the guide to follow
http://www.xerunetworks.com/2012/03/asa-84-asdm-on-gns3-step-by-step-guide/ I have
posted a LAB Guide for migrating NAT from 8.2 to 8.3/8.4 Version, which is still work in [...]
Leave a Reply
Enter your comment here...
Search Search
Recent Posts
Converting Prompts for UCCX 7
Duplex Mismatch How varying
Duplex/Speed settings can effect
connectivity?
Dont span high volume traffic to WS-
X6548-GE-TX or WS-X6148-GE-TX
oversubscribed line cards
Outlook.com Dont change your
primary email address and how to
revert back if you already did
2/20/2014 ASA 8.4 with ASDM on GNS3 - Step by Step Guide - XeruNetworks
http://www.xerunetworks.com/2012/03/asa-84-asdm-on-gns3-step-by-step-guide/ 9/10
Best Email App for Android ICS
Popular Posts
Cisco ASA 8.4 on GNS3 756, 009 v i ew s
ASA 8.4 with ASDM on GNS3
Step by Step Guide 416, 728 v i ew s
Connect GNS3 Network to Real
Networks / Other GNS3 Network 108, 391
v i ew s
Outlook.com Don't change your
primary email address and how to
revert back if you already did 92, 935 v i ew s
Cisco 5508 WLC Configuration LAB
WPA2, Guest Access, FlexConnect
(aka H-REAP) 91, 083 v i ew s
Sponsored Links
Categories
ASA
CME
EIGRP
GNS3
Licencing
Routing & Switching
Security
Stackwise
Tips
Uncategorized
Voice
VPN
Wireless
Archives
November 2012
August 2012
June 2012
May 2012
March 2012
February 2012
January 2012
December 2011
September 2011
2/20/2014 ASA 8.4 with ASDM on GNS3 - Step by Step Guide - XeruNetworks
http://www.xerunetworks.com/2012/03/asa-84-asdm-on-gns3-step-by-step-guide/ 10/10
August 2011
June 2011
March 2011
February 2011
November 2010
October 2010
July 2010
June 2010
May 2010
Recent Comments
Chandan Dey on ASA 8.4 with ASDM
on GNS3 Step by Step Guide
Paul Prijs on Call center calculator
Phi on ASA 8.4 with ASDM on GNS3
Step by Step Guide
Namasivayam on ASA 8.4 with ASDM
on GNS3 Step by Step Guide
Namasivayam on Cisco ASA 8.4 on
GNS3
Blog Calendar
March 2012
M T W T F S S
Feb May
1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30 31
Meta
Log in
Entries RSS
Comments RSS
WordPress.org
Subscribe to Blog via Email
Enter your email address to subscribe to this
blog and receive notifications of new posts
by email.
Email Address
Subscribe
Copyright
2014 XeruNetworks.
Return to top
Powered by WordPress and the Graphene Theme.