Anda di halaman 1dari 2

9.

Realizar un programa que permita simular el juego de Dados, el algoritmo


debe
permitir ingresar los nombres de los jugadores (2) y la cantidad de dinero a
apostar (ejemplo $ 2000 por jugador), teniendo en cuenta que en cada jugada
puede ganar o perder $500. Se permite el lanzamiento jugador 1 generando el
numero aleatorios (1..6), luego jugador 2. El algoritmo lleva el acumulado de
ganancia por cada uno de los jugadores. El programa termina cuando uno de los
jugadores ha quedado en Banca Rota o decidan no continuar.


Proceso adivinarnumero
//Adivinar un numero entre 0 y max
max<-1000;

//El numero a adivinar es
n<-1+azar(max);

proximidad<-6;
Dimension proximidades[proximidad];
proximidades[1]<-"Muy muy cerca";
proximidades[2]<-"Muy cerca";
proximidades[3]<-"Cerca";
proximidades[4]<-"Lejos";
proximidades[5]<-"Muy lejos";
proximidades[6]<-"Muy muy lejos";

intentos<-0;
Repetir
Escribir "";
Escribir "Que numero piensa?"
Leer pensado;

intentos<-intentos+1;

distancia<-abs(n-pensado);

Si distancia>0 Entonces
calcular<-1+trunc(ln(distancia/(max/exp(proximidad))));
Escribir pensado, " esta " ,proximidades[calcular];
Sino
Escribir "Ha adivinado el numero ",n, " despues de
",intentos," intentos";
FinSi

Hasta Que pensado=n;

FinProceso