Anda di halaman 1dari 16

3

UNIVERSIDAD NACIONAL DEL ALTIPLANO


Centro de Cmputo e Informtica
Ing. Lenin Huayta Flores


1. USO DEL CUADRO DE CONTROLES PARA APLICACIONES
Para poder trabajar con controles para aplicaciones habilitamos primeramente la pestaa o ficha
llamada DESARROLLADOR:

ARCHIVO Opciones Personalizar cinta de opciones

Habilitamos Desarrollador de la siguiente forma:



Luego pulsamos el botn de comando Aceptar, de tal manera que quede as:



Crear una nueva hoja de clculo llamado: Sesin 01, ingresar datos desde H1:H20 tal como se muestra
a continuacin:




4

UNIVERSIDAD NACIONAL DEL ALTIPLANO
Centro de Cmputo e Informtica
Ing. Lenin Huayta Flores

Seleccionamos toda la hoja Botn y vamos a DESARROLLADOR Cdigo - Grabar Macro.

- Nombre a la macro: Formato
- Tecla de mtodo abreviado: C
- Guardar macro en: Este Libro
- Descripcin: Macro grabada el 16/11/2013 por Lenin Huayta Flores

Pulse el botn de comando Aceptar.



Cambiamos el formato de fuente en la pestaa INICIO
- Fuente: Garamond
- Tamao: 16
- Color: Verde




5

UNIVERSIDAD NACIONAL DEL ALTIPLANO
Centro de Cmputo e Informtica
Ing. Lenin Huayta Flores
- Negrita, Cursiva y Subrayado.



Detener el grabado de la macro en la pestaa DESARROLLADOR Cdigo Detener grabacin.

Veamos el cdigo generado en DESARROLLADOR Cdigo Visual Basic Mdulo 1.

Otra manera de acceder es pulsando la combinacin de teclas ALT + F11.


Seleccionamos la hoja Botn e ir a INICIO Modificar Borrar Borrar formatos





6

UNIVERSIDAD NACIONAL DEL ALTIPLANO
Centro de Cmputo e Informtica
Ing. Lenin Huayta Flores


Guardar el archivo con el Nombre Sesin 01, activando el Tipo: Libro de Excel habilitado para macros
Guardar.



Luego escriba su nombre y apellidos en cualquier celda de la hoja Botn, e ir a DESARROLLADOR
Macros - Ver macros




7

UNIVERSIDAD NACIONAL DEL ALTIPLANO
Centro de Cmputo e Informtica
Ing. Lenin Huayta Flores


Seleccionamos la macro Formato y hacemos clic en Ejecutar.


Seleccionar las celdas e ir a INICIO Modificar Borrar Borrar formatos.

Inserte un botn: DESARROLLADOR Insertar Controles de formulario Botn


Dibuje el botn y seleccione la macro Formato y haga clic en el botn de comando Aceptar:




8

UNIVERSIDAD NACIONAL DEL ALTIPLANO
Centro de Cmputo e Informtica
Ing. Lenin Huayta Flores


Cambiar el texto del botn haciendo clic derecho sobre el botn y seleccione Modificar texto:


Cambiamos el nombre del botn a Formato, hacer clic fuera del botn.

Escriba un texto en la hoja y presione el botn de comando Formato.


Activar la hoja Cuadro combinado e ir a: DESARROLLADOR Insertar Cuadro combinado




9

UNIVERSIDAD NACIONAL DEL ALTIPLANO
Centro de Cmputo e Informtica
Ing. Lenin Huayta Flores


Dibujar el cuadro combinado en la hoja, haga clic derecho encima del cuadro combinado y seleccionar Formato
de control.
Rango de entrada: (Seleccione el rango de entrada en la hoja Datos desde H1:H20)
Vincular con la celda: A1



De manera que, quede as:


Activar la hoja Casilla e ir a: DESARROLLADOR Insertar Casilla




10

UNIVERSIDAD NACIONAL DEL ALTIPLANO
Centro de Cmputo e Informtica
Ing. Lenin Huayta Flores


Dibujar 3 casillas en la hoja, cambie los nombres de las casillas:


Haga clic derecho encima las casillas e ir a Formato de control.


Vincular con la celda: A1 (Bsico), A2 (Intermedio) y A3 (Avanzado) respectivamente.

Veamos el comportamiento de las casillas:







11

UNIVERSIDAD NACIONAL DEL ALTIPLANO
Centro de Cmputo e Informtica
Ing. Lenin Huayta Flores
Activar la hoja Control de Nmero e ir a: DESARROLLADOR Insertar Control de nmero


Dibujar el control de nmero en la hoja, haga clic derecho encima del control y seleccionar Formato de control.


Valor actual: 1
Valor mnimo: 1
Valor mximo: 100
Incremento: 1
Vincular con la celda: A1

Veamos el comportamiento del control de nmero:








12

UNIVERSIDAD NACIONAL DEL ALTIPLANO
Centro de Cmputo e Informtica
Ing. Lenin Huayta Flores
Activar la hoja Cuadro de lista e ir a: DESARROLLADOR Insertar Cuadro de lista


Dibujar el cuadro de lista en la hoja, haga clic derecho encima del control y seleccionar Formato de control.
Rango de entrada: (Seleccione el rango de entrada en la hoja Datos desde H1:H20)
Vincular con la celda: A1



Presionamos el botn de comando Aceptar.
De manera que, quede as:










13

UNIVERSIDAD NACIONAL DEL ALTIPLANO
Centro de Cmputo e Informtica
Ing. Lenin Huayta Flores
Activar la hoja Botn de opcin e ir a: DESARROLLADOR Insertar Botn de opcin


Dibujar 2 botones de opcin en la hoja, cambie los nombres de los botones:


Haga clic derecho encima del botn de opcin Masculino e ir a Formato de control.


Vincular con la celda: A1 (Masculino) y A1 (Femenino).

Veamos el comportamiento de los botones de opcin:






14

UNIVERSIDAD NACIONAL DEL ALTIPLANO
Centro de Cmputo e Informtica
Ing. Lenin Huayta Flores
Activar la hoja Cuadro de grupo y Etiqueta e ir a: DESARROLLADOR Insertar Cuadro de grupo e
insertar Etiqueta


Dibujar un Cuadro de grupo y una Etiqueta2 botones de opcin en la hoja, cambie los nombres de los botones:


Estos controles son utilizados para el diseo de nuestros formularios.



























15

UNIVERSIDAD NACIONAL DEL ALTIPLANO
Centro de Cmputo e Informtica
Ing. Lenin Huayta Flores
Activar la hoja Barra de desplazamiento e ir a: DESARROLLADOR Insertar Barra de desplazamiento


Dibujar la barra de desplazamiento en la hoja, haga clic derecho encima del control y seleccionar Formato de
control.
Valor actual: 1
Valor mnimo: 0
Valor mximo: 100
Incremento: 5
Cambio de pgina: 10
Vincular con la celda: A1

Presionamos el botn de comando Aceptar.


Veamos el comportamiento de la barra de desplazamiento:












16

UNIVERSIDAD NACIONAL DEL ALTIPLANO
Centro de Cmputo e Informtica
Ing. Lenin Huayta Flores
1.1. PRCTICA 01
Abrir el archivo Prctica 01.xlsx, en activamos la hoja Registro y realizamos el siguiente formulario


Valores de las celdas:
D6: =HOY()

B14: Clic derecho en el Cuadro combinado Formato de control


B16: Clic derecho en el Cuadro combinado Formato de control


B18: =BUSCARV(C16,Datos!A15:C19,3,FALSO)






17

UNIVERSIDAD NACIONAL DEL ALTIPLANO
Centro de Cmputo e Informtica
Ing. Lenin Huayta Flores
Botones de opcin: Contratado y Nombrado




Guardar como archivo macro Prctica 01.xlsm (ARCHIVO Guardar como Equipo Examinar)


Presione el botn de comando Aceptar.

Ir a la pestaa o ficha DESARROLLADOR Visual Basic o puede tambin realizando la combinacin de
teclas ALT + F11, creamos un Mdulo1 (clic derecho en VBAProject (Prctica 01.xlsm) Insertar
Mdulo).






18

UNIVERSIDAD NACIONAL DEL ALTIPLANO
Centro de Cmputo e Informtica
Ing. Lenin Huayta Flores
En Mdulo 1 crear el procedimiento Registro() y realizar el cdigo siguiente:
Sub Registro()
Dim HojaPlanilla As Worksheet
Dim HojaRegistro As Worksheet
Set HojaPlanilla = Worksheets(3)
Set HojaRegistro = Worksheets(2)
Dim i As Integer
i = HojaRegistro.Range("c23")
HojaPlanilla.Cells(i, 1).Value = HojaRegistro.Cells(8, 2).Value
HojaPlanilla.Cells(i, 2).Value = HojaRegistro.Cells(10, 2).Value
HojaPlanilla.Cells(i, 3).Value = HojaRegistro.Cells(12, 2).Value
HojaPlanilla.Cells(i, 4).Value = HojaRegistro.Cells(14, 3).Value
HojaPlanilla.Cells(i, 6).Value = HojaRegistro.Cells(16, 3).Value
HojaPlanilla.Cells(i, 8).Value = HojaRegistro.Cells(18, 2).Value
HojaPlanilla.Cells(i, 9).Value = HojaRegistro.Cells(21, 3).Value
HojaPlanilla.Cells(i, 11).Value = HojaRegistro.Cells(6, 4).Value

HojaRegistro.Range("c23").Value = HojaRegistro.Range("c23").Value + 1
End Sub

Al Botn de comando Registrar se le asigna la macro Registro


Activar la hoja Planilla y realice lo siguiente:
Valores de celdas:
E6: =SI(D6>0,BUSCARV(Planilla!D6,Datos!$A$2:$B$6,2,FALSO),"")
G6: =SI(F6>0,BUSCARV(F6,Datos!$A$15:$C$19,2,FALSO),"")
J6: =SI(I6=1,"Contratado",SI(I6=2,"Nombrado",""))

Activar la hoja Constancia, realice lo siguiente:
Valores de celdas:
B11: =BUSCARV(B9,Planilla!A6:K19,2)
B13: =BUSCARV(B9,Planilla!A6:K19,3)
B15: =BUSCARV(B9,Planilla!A6:K19,5)
B17: =BUSCARV(B9,Planilla!A6:K19,7)
B19: =BUSCARV(B9,Planilla!A6:K19,8)
H9: =BUSCARV(B9,Planilla!A6:K19,11)
H13: =BUSCARV(B9,Planilla!A6:K19,10)
H26: =AHORA()

Guarde los cambios e ingrese datos.