Anda di halaman 1dari 16

SIMULASI FRAME-MODE MPLS

BY:DAYWALKER@DATAKOM-C223
http://www.ittelkom.ac.id/pinguin
http://iwing.wordpress.com

MPLS (Multi Protocol Label Switching) adalah suatu metode forwarding paket yang melalui
suatu jaringan dengan menggunakan informasi label yang dilekatkan pada paket IP. MPLS
menggabungkan teknologi switching/forwarding layer 2 dengan teknologi routing layer 3 pada
standar OSI. Pada dasarnya sebuah jaringan MPLS melakukan operasi-operasi sebagai berikut :

1. Penciptaan label dan distribusi


2. Penciptaan table forwarding pada setiap router
3. Penciptaan LSP
4. Pemasukan/pencarian didalam table
5. Packet Forwarding

Domain MPLS dapat dibagi menjadi MPLS Core dan MPLS Edge. Setiap node didalam jaringan MPLS
sering disebut sebagai LSRs (Label Switch Routers), node didomain core disebut LSR transit
sedangkan node pada MPLS edge disebut LERs (Label Edge Routers).

Gambar 1

Gambaran umum bagaimana mekanisme forwarding packet dari jaringan MPLS terlihat pada gambar
(1), penjelasanya adalah sebagai berikut :

1. Ketika jaringan beroperasi, langsung secara otomatis membangun table routing seperti
layaknya router dengan menggunakan suatu IGP (interior gateway protocol) seperti
misalnya OSPF atau IS-IS. Label Distribution Protocol (LDP) menggunakan topologi
routing didalam table untuk menentukan nilai label antara piranti yang bertetanggaan dan
mendistribusikannya
2. Ketika sebuah paket memasuki ingress LSR untuk menentukan LSP dan servis layer 3
yang dibutuhkan. Berdasarkan persyaratan routing dan kebijakan, LER memilih dan
menerapkan sebuah label kepada header paket kemudian melewatkan paket.
3. LSR di core jaringan membaca label pada setiap paket, menggantinya dengan yang baru
seperti yang terdaftar pada table LFIB, dan melewatkan paket.
4. LER engress mencopot label, membaca header paket dan meneruskan paket ke tujuan
akhir.

Nah Simulasi yang saya akan lakukan kurang lebih akan seperti yang dipaparkan sebelum nya hi3,
langsung saja ya:

Topology yang saya gunakan adalah seperti gambar 2 dibawah ini

Gambar 2

Konfigurasi umum untuk mengaktifkan basic mpls adalah sebagai berikut :

a) Enable CEF
b) Configure IGP Routing Protocol (pada simulasi ini saya menggunakan OSPF)
c) (Optional) Define LDP
d) (Optional) Assign LDP Router-ID
e) Configure MPLS or Label Forwarding on the Interface
Konfigurasi di tiap router adalah sebagai berikut :

#######################################################
hostname cnc1
!
no ip domain lookup
!
ip cef
mpls label protocol ldp
!
interface Loopback0
ip address 10.10.10.101 255.255.255.255
!
interface GigabitEthernet1/0
ip address 10.10.10.1 255.255.255.252
negotiation auto
mpls ip
!
interface Serial4/0
ip address 172.16.1.1 255.255.255.252
serial restart-delay 0
clock rate 64000
!
router ospf 1
log-adjacency-changes
network 10.10.10.0 0.0.0.255 area 0
network 172.16.1.0 0.0.0.3 area 0

mpls ldp router-id Loopback0


#######################################################

#######################################################

hostname cnc2
!
ip cef
!
no ip domain lookup
!
mpls label protocol ldp
!
interface Loopback0
ip address 10.10.10.102 255.255.255.255
!
interface GigabitEthernet1/0
ip address 10.10.10.2 255.255.255.252
negotiation auto
mpls ip
!
interface GigabitEthernet2/0
ip address 10.10.10.5 255.255.255.252
negotiation auto
mpls ip
!
router ospf 1
network 10.10.10.0 0.0.0.255 area 0
!
mpls ldp router-id Loopback0
#######################################################

#######################################################

hostname cnc3
!
ip cef
!
no ip domain lookup
!
mpls label protocol ldp
!
interface Loopback0
ip address 10.10.10.103 255.255.255.255
!
interface GigabitEthernet1/0
ip address 10.10.10.6 255.255.255.252
negotiation auto
mpls ip
!
interface GigabitEthernet2/0
ip address 10.10.10.9 255.255.255.252
negotiation auto
mpls ip
!
router ospf 1
network 10.10.10.0 0.0.0.255 area 0
!
mpls ldp router-id Loopback0
#######################################################

#######################################################
hostname cnc4
!
ip cef
!
no ip domain lookup
!
mpls label protocol ldp
!
interface Loopback0
ip address 10.10.10.104 255.255.255.255
!
interface GigabitEthernet1/0
ip address 10.10.10.10 255.255.255.252
negotiation auto
mpls ip
!
interface Serial4/0
ip address 172.16.2.1 255.255.255.252
serial restart-delay 0
clock rate 64000
!
router ospf 1
network 10.10.10.0 0.0.0.255 area 0
network 172.16.2.0 0.0.0.3 area 0
!
mpls ldp router-id Loopback0
!
#######################################################

#######################################################
hostname CustA
!
interface Serial0/0
ip address 172.16.1.2 255.255.255.252
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 172.16.1.0 0.0.0.3 area 0
#######################################################

#######################################################
hostname CustB
!
interface Serial0/0
ip address 172.16.2.2 255.255.255.252
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 172.16.2.0 0.0.0.3 area 0
#######################################################

Setelah Router dikonfigurasi, saatnya pengetesan @_@


Dari CustA traceroute ke cnc4 (Seperti gambar 3) dan dari CustB ke cnc1 (Seperti Gambar
5)

Gambar 3
Gambar 4

Gambar 5-8 menunjukkan interface yang di konfigurasi dengan mpls

Gambar 5

Gambar 6

Gambar 7

Gambar 8
Gambar 9
Gambar 10
Gambar 11
Gambar 12
Nah sekarang pengujian MPLS nya, sesuai dengan referensi no [2], cara pengujian MPLS
dengan ping atau traceroute commandnya berbeda dengan biasanya (seperti pada gambar 13-
16). Nah untuk lebih jelasnya silahkan mengacu kepada referensi tersebut ^_^.

Gambar 13

Gambar 14
Gambar 15

Gambar 16
Sekarang kita belajar bagaimana fordwarding paket bekerja @_@ hi3.
Ceritanya kita ingin mengetahui bagaimana paket mengalir dari cnc1 ke cnc 4, caranya kita
menggunakan bantuan command show mpls forwarding-table
Lihat di router cnc1 network 10.10.10.104/32 lalu lihat outgoing Label maka menurut gambar
17 label yang akan digunakan adalah label 20

Gambar 17

Sekarang lihat router cnc2, lihat network 10.10.10.104/32, lihat local label “label 20”,
menurut gambar (18), label 20 akan di ganti dengan “label 20” (lihat outgoing label).

Gambar 18
Sekarang lihat router cnc3, lihat network 10.10.10.104/32, lihat local label “label 20”,
menurut gambar (19), label 20 akan di buang (Pop Label ) paket menuju router selanjutnya
tidak akan diberi label (lihat outgoing label)

Gambar 19

Gambar 20

Kita coba lagi, sekarang dari cnc4 ke network 172.16.1.0/30


Lihat di router cnc4 network 172.16.1.0/30 lalu lihat outgoing Label maka menurut gambar
(21) label yang akan digunakan adalah label 18

Gambar 21
Sekarang lihat router cnc3, lihat network 172.16.1.0/30 , lihat local label “label 18”, menurut
gambar (22), label 18 akan di ganti dengan “label 17” (lihat outgoing label).

Gambar 22

Sekarang lihat router cnc3, lihat network 172.16.1.0/30 , lihat local label “label 17”, menurut
gambar (23), label 20 akan di buang (Pop Label ) paket menuju router selanjutnya tidak akan
diberi label (lihat outgoing label)

Gambar 23

Gambar 24
Nb: Akan tetapi mengapa dari 2 kali percobaan label yang dihilangkan tidak terjadi diedge router
(cnc1 atau cnc4), permasalah ini muncul karena adanya Penultimate Hop Popping (PHP), saya mau
belajar dulu mengenai hal ini hi2, sekian dulu teman2 “wassalam”

######################Semoga bermanfaat######################

Referensi:
[1]. Cisco Documentation.2005. Configuring Basic MPLS Using OSPF (Document ID 13736). USA:
http://www.cisco.com
[2].Cisco Documentation.2004. MPLS OAM Tools for Troubleshooting MPLS Networks. USA :
http://www.cisco.com
[3]. Doniarto.2006.Tugas Akhir: Performances Comparison of Frame Relay with IP MPLS Network
Case Study at PT.Aplikanusa Lintasarta,Jakarta:STT Telkom
[4]. www.gns3.net