Anda di halaman 1dari 14

Belajar Mensetting Multicast Routing di Router Cisco

BY:Daywalker@Datakom-C223
http://www.ittelkom.ac.id/pinguin
http://iwing.wordpress.com

Pada kesempatan ini kita akan belajar bagaimana mensetting multicast routing di
router cisco menggunakan pim sparse-dense-mode, untuk teori silahkan googling karena
disini kita hanya akan membahas bagaimana cara untuk settingnya saja pada router dengan
vendor cisco, untuk pengujian kita akan menggunakan VLC, pada simulasi ini saya
menggunakan 3 buah router, topologi yang digunakan seperti pada gambar 1 dibawah ini.

Gambar 1
Langkah-langkahnya yaitu:

1.Configure physical and Loopback interfaces

cnc1(config)# interface FastEthernet0/0


cnc1(config-if)# ip address 192.168.10.65 255.255.255.252
cnc1(config-if)# no shutdown
cnc1(config-if)# interface FastEthernet0/1
cnc1(config-if)# ip address 192.168.10.1 255.255.255.224
cnc1(config-if)# no shutdown
cnc1(config-if)# interface Loopback0
cnc1(config-if)# ip address 10.10.10.1 255.255.255.0

cnc2(config)# interface FastEthernet0/0


cnc2(config-if)# ip address 192.168.10.66 255.255.255.252
cnc2(config-if)# no shutdown
cnc2(config-if)# interface FastEthernet0/1
cnc2(config-if)# ip address 192.168.10.69 255.255.255.252
cnc2(config-if)# no shutdown
cnc2(config-if)# interface Loopback0
cnc2(config-if)# ip address 10.10.10.2 255.255.255.0

cnc3(config)# interface FastEthernet0/0


cnc3(config-if)# ip address 192.168.10.70 255.255.255.252
cnc3(config-if)# no shutdown
cnc3(config-if)# interface FastEthernet0/1
cnc3(config-if)# ip address 192.168.10.33 255.255.255.224
cnc3(config-if)# no shutdown
cnc3(config-if)# interface Loopback0
cnc3(config-if)# ip address 10.10.10.3 255.255.255.0

2. Configure Routing protocol, pada simulasi ini kita akan menggunakan protocol OSPF
dengan proses id 1

cnc1(config)# router ospf 1


cnc1(config-router)# network 10.10.10.0 0.0.0.255 area 0
cnc1(config-router)# network 192.168.10.0 0.0.0.31 area 0
cnc1(config-router)# network 192.168.10.64 0.0.0.3 area 0

cnc2(config)# router ospf 1


cnc2(config-router)# network 10.10.10.0 0.0.0.255 area 0
cnc2(config-router)# network 192.168.10.64 0.0.0.3 area 0
cnc2(config-router)# network 192.168.10.68 0.0.0.3 area 0

cnc3(config)# router ospf 1


cnc3(config-router)# network 10.10.10.0 0.0.0.255 area 0
cnc3(config-router)# network 192.168.10.32 0.0.0.31 area 0
cnc3(config-router)# network 192.168.10.68 0.0.0.3 area 0
3. Configuring Multicast, langkah-langkah umumnya adalah sebagai berikut :

cnc1(config)# ip multicast-routing (Enables IP multicast routing)


cnc1(config)# interface FastEthernet0/0
cnc1(config-if)# ip pim sparse-dense-mode (Enables PIM Sparse-Dense mode)
cnc1(config-if)# interface FastEthernet0/1
cnc1(config-if)# ip pim sparse-dense-mode (Enables PIM Sparse-Dense mode)
cnc1(config-if)# ip igmp join-group 227.1.1.1 (Allows the router to join the multicast
group identified by the group address of 227.1.1.1)

cnc2(config)# ip multicast-routing (Enables IP multicast routing)


cnc2(config)# interface FastEthernet0/0
cnc2(config-if)# ip pim sparse-dense-mode (Enables PIM Sparse-Dense mode)
cnc2(config-if)# interface FastEthernet0/1
cnc2(config-if)# ip pim sparse-dense-mode (Enables PIM Sparse-Dense mode)

cnc3(config)# ip multicast-routing (Enables IP multicast routing)


cnc3(config)# interface FastEthernet0/0
cnc3(config-if)# ip pim sparse-dense-mode (Enables PIM Sparse-Dense mode)
cnc3(config-if)# interfaceFastEthernet0/1
cnc3(config-if)# ip pim sparse-dense-mode (Enables PIM Sparse-Dense mode)
4. Verifikasi konfigurasi yang kita buat

Gambar 2

Gambar 3
Gambar 4

Gambar 5
Gambar 6

Gambar 7
Gambar 8

Gambar 9
Gambar 10

Gambar 11
Gambar 12

Gambar 13
5. Untuk Pengujian kita siapkan Multicast Server menggunakan VLC yang akan mengirimkam
ke multicast group 227.1.1.1, langkah-langkahnya yaitu :

a) Pada server, buka VLC media palyer


Buka file open file

Gambar 14

Browse file yang akan distreaming


Pada bagian Advanced Options Centang Stream/Save
Klik Settings, sehingga muncul stream output seperti pada gambar 14
Gambar 15

Pada bagian output centang Play localy, lalu centang UDP lalu masukkan address
group multicast, pada simulasi ini adalah 227.1.1.1 dengan port 1234
b) Pada Client
Buka file  open network stream

Gambar 16

Centang UDP/RTP Multicast dengan Address 227.1.1.1 dengan port 1234


Klik ok
c) Selanjutnya kita menunggu proses streaming berlangsung ^_^
Gambar 17 menunjukkan video disisi server
Gambar 18 menunjukkan video disisi client
Gambar 17

Gambar 18
Gambar 19

Untuk sekarang percobaan alakadarnya saja yang penting konfigurasi jalan dulu (what?),
teori nya menyusul hi3, mau belajar dahulu teori cara kerja pim sparse, pim dense dan pim
sparse dense mode dan lain-lain. “kabur…..” zzzzzzzz……..(saya termasuk orang yang suka
learning by doing and trail error hi3 skip baca teori langsung praktek dan hasilnya error
hi3).

Ref:
http://www.cisco.com
http://www.videolan.org

############Sekian dulu teman-teman semoga bermanfaat############