Anda di halaman 1dari 7

Frame Relay Lab

Hub and Spoke: Multipoint



Frame Relay
Network
Headquarters
Hub City
Satellite Office 1
Spokane
Satellite Office 2
Spokomo
172.25.1.2 172.25.1.3
172.25.1.1
DLCI 100
DLCI 101
DLCI 200
DLCI 201
172.25.10.1
172.25.20.1 172.25.30.1
172.25.0.0/24

S0
S1 S2
Frame Switch
Interfaces
Multipoint
subinterface
Point-to-point
subinterfaces


Note: If not using Cisco IOS 11.2 or later, be sure to configure the LMI type on each
serial interface.

Multipoint subinterfaces on the HubCity router:
Multipoint interface on the hub router is used when hub and spoke routers are on the
same subnet.
Spoke routers must use point-to-point subinterfaces, as there will be no way to map
routes in the routing table with dlcis.
Without point-to-point subinterfaces, all networks will show in the spoke routers
routing tables, but they will not be able to ping interfaces on those networks.
Split Horizon must be disabled on the Hub router.


Router HubCity (DTE)

version 12.0
!
hostname HubCity
!
interface Serial0
no ip address
encapsulation frame-relay
no frame-relay inverse-arp
!
interface Serial0.1 multipoint
ip address 172.25.1.1 255.255.255.0
no ip split-horizon
frame-relay interface-dlci 100
frame-relay interface-dlci 200
!
interface FastEthernet0
ip address 172.25.10.1 255.255.255.0
no ip directed-broadcast
no keepalive
!
router rip
network 172.25.0.0
!

Router Spokane (DTE)

version 12.0
!
hostname Spokane
!
interface Serial0
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
ip address 172.25.1.2 255.255.255.0
no ip directed-broadcast
frame-relay interface-dlci 101
!
interface FastEthernet0
ip address 172.25.20.1 255.255.255.0
no ip directed-broadcast
no keepalive
!
router rip
network 172.25.0.0
!
Router Spokomo (DTE)

version 12.0
!
hostname Spokomo
!
interface Serial0
no ip address
encapsulation frame-relay
!
interface Serial0.1 point-to-point
ip address 172.25.1.3 255.255.255.0
frame-relay interface-dlci 201
!
interface FastEthernet0
ip address 172.25.30.1 255.255.255.0
no ip directed-broadcast
no keepalive
!
router rip
network 172.25.0.0
!

Frame Relay Switch (DCE)

version 12.0
!
hostname FrameSwitchE
!
frame-relay switching
!
interface Serial0
no ip address
encapsulation frame-relay
clockrate 56000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 100 interface Serial1 101
frame-relay route 200 interface Serial2 201
!
interface Serial1
no ip address
encapsulation frame-relay
clockrate 56000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 101 interface Serial0 100
!
Frame Relay Switch (continued)

interface Serial2
no ip address
encapsulation frame-relay
clockrate 56000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 201 interface Serial0 200


Notes:
1. A router is not normally used as a Frame Relay switch. This feature is typically sued
in test and demonstration situations.
2. Loopback interface can be used to simulate actual physical interfaces.
3. The Frame Relay switch is acting as the DCE device, which would be a normal
situation.


1. Examine the FrameSwith router:

Fr ameSwi t chE#show f r ame- r el ay r out e
I nput I nt f I nput Dl ci Out put I nt f Out put Dl ci St at us
Ser i al 0 100 Ser i al 1 101 act i ve
Ser i al 0 200 Ser i al 2 201 act i ve
Ser i al 1 101 Ser i al 0 100 act i ve
Ser i al 2 201 Ser i al 0 200 act i ve



2. Each router should see every network and be able to ping each network. On each of
the routers perform the following commands:


HubCity

HubCi t y#show frame-relay map
Ser i al 0. 1 ( up) : i p 172. 25. 1. 2 dl ci 100( 0x64, 0x1840) , dynami c,
br oadcast , , st at us def i ned, act i ve
Ser i al 0. 1 ( up) : i p 172. 25. 1. 3 dl ci 200( 0xC8, 0x3080) , dynami c,
br oadcast , , st at us def i ned, act i ve

HubCi t y#show frame-relay pvc

PVC St at i st i cs f or i nt er f ace Ser i al 0 ( Fr ame Rel ay DTE)

Act i ve I nact i ve Del et ed St at i c
Local 2 0 0 0
Swi t ched 0 0 0 0
Unused 0 0 0 0

DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = ACTI VE, I NTERFACE =
Ser i al 0. 1

i nput pkt s 140 out put pkt s 77 i n byt es 24656
out byt es 7774 dr opped pkt s 0 i n FECN pkt s 0
i n BECN pkt s 0 out FECN pkt s 0 out BECN pkt s 0
i n DE pkt s 0 out DE pkt s 0
out bcast pkt s 69 out bcast byt es 7038
pvc cr eat e t i me 00: 31: 06, l ast t i me pvc st at us changed 00: 30: 36

DLCI = 200, DLCI USAGE = LOCAL, PVC STATUS = ACTI VE, I NTERFACE =
Ser i al 0. 1

i nput pkt s 128 out put pkt s 103 i n byt es 18760
out byt es 11810 dr opped pkt s 0 i n FECN pkt s 0
i n BECN pkt s 0 out FECN pkt s 0 out BECN pkt s 0
i n DE pkt s 0 out DE pkt s 0
out bcast pkt s 72 out bcast byt es 8594
pvc cr eat e t i me 00: 31: 07, l ast t i me pvc st at us changed 00: 30: 37

HubCi t y#show ip route
Codes: C - connect ed, S - st at i c, I - I GRP, R - RI P

Gat eway of l ast r esor t i s not set

172. 25. 0. 0/ 24 i s subnet t ed, 4 subnet s
R 172. 25. 20. 0 [ 120/ 1] vi a 172. 25. 1. 2, 00: 00: 06, Ser i al 0. 1
R 172. 25. 30. 0 [ 120/ 1] vi a 172. 25. 1. 3, 00: 00: 02, Ser i al 0. 1
C 172. 25. 1. 0 i s di r ect l y connect ed, Ser i al 0. 1
C 172. 25. 10. 0 i s di r ect l y connect ed, Fast Et her net 0

HubCi t y#ping 172.25.20.1
Sendi ng 5, 100- byt e I CMP Echos t o 172. 25. 20. 1, t i meout i s 2 seconds:
! ! ! ! !

HubCi t y#ping 172.25.30.1
Sendi ng 5, 100- byt e I CMP Echos t o 172. 25. 30. 1, t i meout i s 2 seconds:
! ! ! ! !


Spokane

Spokane#show frame-relay map
Ser i al 0. 1 ( up) : poi nt - t o- poi nt dl ci , dl ci 101( 0x65, 0x1850) , br oadcast
st at us def i ned, act i ve

Spokane#show frame-relay pvc

PVC St at i st i cs f or i nt er f ace Ser i al 0 ( Fr ame Rel ay DTE)

Act i ve I nact i ve Del et ed St at i c
Local 1 0 0 0
Swi t ched 0 0 0 0
Unused 0 0 0 0

DLCI = 101, DLCI USAGE = LOCAL, PVC STATUS = ACTI VE, I NTERFACE =
Ser i al 0. 1

i nput pkt s 58 out put pkt s 65 i n byt es 6252
out byt es 9602 dr opped pkt s 0 i n FECN pkt s 0
i n BECN pkt s 0 out FECN pkt s 0 out BECN pkt s 0
i n DE pkt s 0 out DE pkt s 0
out bcast pkt s 55 out bcast byt es 8562
pvc cr eat e t i me 00: 20: 34, l ast t i me pvc st at us changed 00: 20: 34

Spokane#show ip route
Codes: C - connect ed, S - st at i c, I - I GRP, R - RI P,

Gat eway of l ast r esor t i s not set

172. 25. 0. 0/ 24 i s subnet t ed, 4 subnet s
C 172. 25. 20. 0 i s di r ect l y connect ed, Fast Et her net 0
R 172. 25. 30. 0 [ 120/ 2] vi a 172. 25. 1. 1, 00: 00: 05, Ser i al 0. 1
C 172. 25. 1. 0 i s di r ect l y connect ed, Ser i al 0. 1
R 172. 25. 10. 0 [ 120/ 1] vi a 172. 25. 1. 1, 00: 00: 05, Ser i al 0. 1

Spokane#ping 172.25.10.1
Sendi ng 5, 100- byt e I CMP Echos t o 172. 25. 10. 1, t i meout i s 2 seconds:
! ! ! ! !

Spokane#ping 172.25.30.1
Sendi ng 5, 100- byt e I CMP Echos t o 172. 25. 30. 1, t i meout i s 2 seconds:
! ! ! ! !

Spokomo

Spokomo#show frame-relay map
Ser i al 0. 1 ( up) : poi nt - t o- poi nt dl ci , dl ci 201( 0xC9, 0x3090) , br oadcast
st at us def i ned, act i ve

Spokomo#show frame-relay pvc

PVC St at i st i cs f or i nt er f ace Ser i al 0 ( Fr ame Rel ay DTE)

Act i ve I nact i ve Del et ed St at i c
Local 1 0 0 0
Swi t ched 0 0 0 0
Unused 0 0 0 0

DLCI = 201, DLCI USAGE = LOCAL, PVC STATUS = ACTI VE, I NTERFACE =
Ser i al 0. 1

i nput pkt s 59 out put pkt s 78 i n byt es 6484
out byt es 9496 dr opped pkt s 0 i n FECN pkt s 0
i n BECN pkt s 0 out FECN pkt s 0 out BECN pkt s 0
i n DE pkt s 0 out DE pkt s 0
out bcast pkt s 63 out bcast byt es 7936
pvc cr eat e t i me 00: 19: 30, l ast t i me pvc st at us changed 00: 19: 30

Spokomo#show ip route
Codes: C - connect ed, S - st at i c, I - I GRP, R - RI P

Gat eway of l ast r esor t i s not set

172. 25. 0. 0/ 24 i s subnet t ed, 4 subnet s
R 172. 25. 20. 0 [ 120/ 2] vi a 172. 25. 1. 1, 00: 00: 18, Ser i al 0. 1
C 172. 25. 30. 0 i s di r ect l y connect ed, Fast Et her net 0
C 172. 25. 1. 0 i s di r ect l y connect ed, Ser i al 0. 1
R 172. 25. 10. 0 [ 120/ 1] vi a 172. 25. 1. 1, 00: 00: 18, Ser i al 0. 1

Spokomo#ping 172.25.10.1
Sendi ng 5, 100- byt e I CMP Echos t o 172. 25. 10. 1, t i meout i s 2 seconds:
! ! ! ! !

Spokomo#ping 172.25.20.1
Sendi ng 5, 100- byt e I CMP Echos t o 172. 25. 20. 1, t i meout i s 2 seconds:
! ! ! ! !

Anda mungkin juga menyukai