Anda di halaman 1dari 9

Belajar Mengkonfigurasi virtual link dalam OSPF pada perangkat Cisco Router

By:Daywalker@Datakom-C223
http://www.ittelkom.ac.id/pinguin
http://iwing.wordpress.com

Pada saat belajar Routing Protocol, khusus nya OSPF kita pasti akan dihadapkan
dengan konsep Area, dimana setiap area harus terhubung secara fisik dengan area 0
(backbone area) terlihat seperti gambar topology 1 dibawah. Akan tetapi bagaimana jika
suatu area tidak dapat terhubung langsung dengan area 0 seperti gambar topology 2
dibawah ini.

Gambar 1

Gambar 2
Pada kesempatan ini kita akan belajar bagaimana cara mengatasi masalah tersebut dengan
menggunakan virtual link.

Nb: virtual links are a design nightmare and are best avoided.

Konfigurasi di tiap router :

################################################
cnc1#
!
hostname cnc1
!
ip subnet-zero
ip cef
!
interface Loopback0
ip address 10.10.10.1 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.10.65 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.10.6 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
area 1 virtual-link 10.10.10.2
network 10.10.10.1 0.0.0.0 area 1
network 192.168.10.4 0.0.0.3 area 2
network 192.168.10.64 0.0.0.3 area 1
!
cnc1#
################################################
################################################
cnc2#
!
hostname cnc2
!
ip subnet-zero
!
ip cef
!
interface Loopback0
ip address 10.10.10.2 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.10.66 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.10.69 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
duplex auto
speed auto
!
interface FastEthernet2/0.1
encapsulation dot1Q 1 native
ip address 192.168.10.97 255.255.255.224
!
interface FastEthernet2/0.10
encapsulation dot1Q 10
ip address 192.168.10.129 255.255.255.224
!
interface FastEthernet2/0.20
encapsulation dot1Q 20
ip address 192.168.10.161 255.255.255.224
!
interface FastEthernet2/0.30
encapsulation dot1Q 30
ip address 192.168.10.193 255.255.255.224
!
interface FastEthernet2/0.40
encapsulation dot1Q 40
ip address 192.168.10.225 255.255.255.224
!
router ospf 1
log-adjacency-changes
area 1 virtual-link 10.10.10.1
network 10.10.10.2 0.0.0.0 area 1
network 192.168.10.64 0.0.0.3 area 1
network 192.168.10.68 0.0.0.3 area 0
network 192.168.10.96 0.0.0.31 area 0
network 192.168.10.128 0.0.0.31 area 0
network 192.168.10.160 0.0.0.31 area 0
network 192.168.10.192 0.0.0.31 area 0
network 192.168.10.224 0.0.0.31 area 0

cnc2#
################################################
################################################
cnc3#
!
hostname cnc3
!
ip cef
!
interface Loopback0
ip address 10.10.10.3 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.10.70 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.10.33 255.255.255.224
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 10.10.10.3 0.0.0.0 area 0
network 192.168.10.32 0.0.0.31 area 0
network 192.168.10.68 0.0.0.3 area 0

cnc3#
################################################
################################################
cnc4#
!
ip subnet-zero
!
interface Loopback0
ip address 10.10.10.4 255.255.255.255
!
interface FastEthernet0
ip address 192.168.10.5 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 10.10.10.4 0.0.0.0 area 2
network 192.168.10.4 0.0.0.3 area 2
!
cnc4#
################################################

Untuk mengkonfigurasi Virtual link konfigurasi umumnya adalah :

Router(config-router)#router ospf process-id


Router(config-router)# area area-id virtual-link router-id
(Dimana, area-id adalah transit area, router-id adalah RID dari Router ABR)

Dalam kasus saya konfigurasinya menjadi :

cnc1(config-router)#router ospf 1
cnc1(config-router)#area 1 virtual-link 10.10.10.2

cnc2(config-router)#router ospf 1
cnc2(config-router)#area 1 virtual-link 10.10.10.1
Untuk pengujian :

Gambar 3

Gambar 4

Gamabar 5
Gambar 6

Gambar 7
Gambar 8
Gambar 9

Gambar 10
Alhamdullilah percobaan kita berjalan dengan lancar b^_^d

Ref:
http://www.cisco.com

############Sekian dulu teman-teman semoga bermanfaat############