Anda di halaman 1dari 38

MPLS/VPLS para ISP

poniente Alfredo Giordano


05/09/2014 1.30PM
MUM MEI!" 2014
Alfredo Giordano
Grad#ado en In$enier%a ele&tr'ni&a en Polit(&ni&o
de )orino *Italia+ , UI! de !-i&a$o. Illinoi/ *USA+
!on/#ltor , )rainer &ertifi&ado por Mi0ro)i0
!on/#ltor &ertifi&ado por !i/&o , otro/
)ra1a2ando en )ele&o3#ni&a&ione/ de/de el 2001
Mie31ro a&ti4o de 5IPE67!!
*5(/ea#8 IP E#rop(en/ 7et9or0 !oordination !entre+
!arrier ISP !E" , de/i$ner
E/pe&iali:ado en 5o#tin$. ;oS. <A7 a&&e//.
9irele//
2
"12eti4o/
3
!on/tr#&&i'n de #na red de tran/porte ,
a&&e/o para ISP perfor3ante. 3od#lar ,
e/&ala1le
5a&ionali:ar el #/o de lo/ re&#r/o/ IP
Mini3i:ar lo/ po/i1le/ pro1le3a/ de
/e$#ridad
"pti3i:ar la $e/ti'n de #/#ario/ por 3edio de
#n =ni&o p#nto de a#tenti&a&i'n , 3ane2o de
&#enta/
"12eti4o/ > ?ia$ra3a de red
4
@erra3ienta/A
5
!ere1ro
Modelo "SI
Mi0ro)i0
"SPB
MPLS
VPLS
PPPoE
"SPB
"pen S-orte/t Pat- Bir/t
C
PanorD3i&a "SPB
"SPB e/ #n proto&olo de ro#tin$ *IGP+ dinD3i&o
1a/ado en el e/tado del lin0 *LSA+
"SPB dete&ta lo/ &a31io/ en la topolo$%a de la
red &o3o la &a%da de #n lin0 o de #n n#do. ,
&on4er$e *&#ando po/i1le+ en #na n#e4a r#ta de
red en #no/ /e$#ndo/
7o #/a )!P/IP para tran/portar la infor3a&i'n del
proto&olo *#/a proto&olo IP E9+
Soporta FerarG#%a/ 3(tri&a , a$re$a&i'n de r#ta/
H
PanorD3i&a "SPB
E
!#ando a&ti4a3o/ "SPB n#e/tro ro#ter e3pie:a a
en4iar paG#ete/ de @ello.
Un paG#ete de @ello e/ &o3o #n 3ail G#e &ontieneA
o5o#terI?
oInter4alo de @ello
oVe&ino/ *7ei$-1or/+
oPrioridad del ro#ter
oInfor3a&i'n de a#tenti&a&i'n
Si ta31i(n /e re&i1e #n paG#ete de @ello &o3pati1le de/de
otro ro#ter /e 4#el4en 4e&ino/ , p#eden inter&a31iar
infor3a&i'n de LSA
PanorD3i&a "SPB
9
En pra&ti&a "SPB para deter3inar la ta1la de ro#tin$ /e 1a/a
/o1re el e/tado de lo/ enla&e/ de &ada ro#ter. ?i&-o e/tado e/
&o3#ni&ado a lo/ de3D/ ro#ter/ del AS
A/% &o3o en #n
ro3pe&a1e:a/ toda/ lo/ LSA
&on/tit#,en el LS?I
Si no /e e/pe&ifi&a Mi0ro)i0
#/a &o3o 5o#terI? la IP de
4alor 3a/ 1a2o en el /i/te3a
E/ 1#ena &o/t#31re a/i$nar
#na IP a #na interfa: 4irt#al ,
#/ar di&-a dire&&i'n &o3o
5o#terI?
Venta2a/ de "SPB
5Dpido de i3ple3entar , fD&il de dep#rar
Ma/ de 50 ro#ter/ por Drea
Pro4ee red#ndan&ia
7o/ per3ite dar preferen&ia a #n enla&e &on
re/pe&to a otro
P#ede pro4eer load 1alan&in$
P#ede /er #/ado para ro#tin$ a/i3(tri&o
10
MPLS
M#lti Proto&ol La1el S9it&-in$
11
PanorD3i&a MPLS
MPLS no e/ #n proto&olo de ro#tin$ porG#e la de&i/i'n para
Jfor9ardearK el paG#ete no /e to3a en 1a/e al en&a1e:ado IP.
La de&i/i'n /e to3a en 1a/e a #na etiG#eta G#e e/ta apli&ada
al paG#ete.
?e/de el p#nto de 4i/ta del f#n&iona3iento MPLS e/ 3#&-o
3a/ /i3ilar a VLA7 G#e a #n proto&olo de ro#tin$
12
A 4e&e/ /e define #n
proto&olo de &apa 2.5
porG#e la/ etiG#eta/
MPLS /e po/i&ionan
entre el en&a1e:ado
L2 , L3
PanorD3i&a MPLS
En MPLS &ada ro#ter a/i$na /#/ propia/ etiG#eta/
por &ada prefi2o en la ta1la de r#teo
Por 3edio de L?P *La1el ?i/tri1#tion Proto&ol+ la/
etiG#eta/ MPLS p#eden /er di/tri1#ida/ Ja#to6
3D$i&a3enteK
?e e/ta for3a &ada ro#ter e/ta infor3ado de la/
a/i$na&ione/ de lo/ de3D/
L!UI?A?"M L?P reG#iere de &one&ti4idad )!P/IP
E/ de&ir ne&e/ita3o/ G#e n#e/tra red L3 /ea
&o3pleta3ente opera&ional para i3ple3entar L?P
13
En MPLS #n ro#ter &#ando re&i1e #n paG#ete p#ede to3ar tre/ a&&ione/A
o In/ertar #na etiG#eta
o !a31iar #na etiG#eta
o ;#itar la etiG#eta
Lo/ LE5 *La1el Ed$e 5o#ter+ P#eden in/ertar o G#itar #na etiG#eta
Lo/ LS5 *La1el S9it&- 5o#ter+ /olo &a31ian la etiG#eta
7otaA a /e$#nda del &a3ino el 3i/3o ro#ter p#ede a&t#ar &o3o LE5 o LS5
14
PanorD3i&a MPLS
PanorD3i&a MPLS
El trafi&o MPLS en lo/ LS5 e/ /9it&-edM
Enton&e/A
7o pa/a por el fire9all , 3eno/ por 3an$le
7o pa/a por 7A)
7o pa/a por ;oS
7otaA En lo/ LE5 /i pa/a por el /i/te3a de
ro#tin$
15
PanorD3i&a MPLS 6 P@P
P@P *Pen#lti3ate @op Poppin$+ e/ la
&ara&ter%/ti&a de MPLS G#e le per3ite a #n LS5 de
re3o4er la/ etiG#eta/ &#ando /a1e G#e el
/i$#iente /9it&- MPLS no ne&e/itara di&-a
infor3a&i'n
MPLS P@P
El P@P /e i3ple3enta por ra:one/ de rapide:
/in P@P lo/ LE5 /ie3pre tendr%an G#e &-e&ar 2
ta1la/ *ta1la MPLS , ta1la de IP ro#tin$+
1C
1H
Venta2a/ de MPLS
Prin&ipal 1enefi&ioA efi&ien&ia del pro&e/o de for9ardin$
Soporta tran/porte de ;oS
Po/i1ilidad de )=nele/ VP7 fD&il3ente e/&ala1le/
Po/i1ilidad de e/&onder la topolo$%a de red
N 3a/...
VPLS
Virt#al Pri4ate Lan Ser4i&e
1E
PanorD3i&a de VPLS
VPLS e/ #n 3(todo para &rear t=nele/
tran/parente/ L2 1a/ado/ en MPLS.
Un t=nel VPLS /e pre/enta al ro#ter &o3o #na
interfa: /eparada *e8a&ta3ente &o3o /#&ede
para EoIP+
Un t=nel VPLS a$re$a #na etiG#eta adi&ional al
fra3e MPLS
19
PanorD3i&a de VPLS
20
VPLS /e p#ede &on/iderar
#n tipo de VP7 *5ed
Pri4ada Virt#al+ 1a/ada en
el pro4eedor en l#$ar G#e
en el #/#ario final.
)odo el tra1a2o de
net9or0in$ /#&ede en el
interior de la red del ISP.
Ade3D/ de poder /er
#/ado para la red de
a&&e/o ta31i(n /e p#ede
#/ar para tran/portar
/e$3ento/ Et-ernet
di/tante/.
Venta2a/ de VPLS
VPLS e/ 3#, rDpido porG#e no en&ripta ni
en&ap/#la
/i to3a3o/ n#e/tra/ pre&a#&ione/ ta3po&o
fra$3enta
Solo a$re$a al fra3e Et-ernet 2 etiG#eta/
!ada n#e4o /itio /olo ne&e/ita la &onfi$#ra&i'n
del ro#ter
Al3eno el C0O 3a/ rDpido G#e EoIP
21
PPPoE
Point to Point Proto&ol o4er
Et-ernet
22
PanorD3i&a de PPPoE
El proto&olo PPPoE *Point to Point Proto&ol o4er
Et-ernet+ en&ap/#la lo/ fra3e/ PPP a dentro de
#n fra3e Et-ernet.
PPPoE &on/tr#,e #n t=nel p#nto a p#nto entre 2
di/po/iti4o/ de red Et-ernet
PPPoE A&t#al3ente e/ prin&ipal3ente #/ado en
lo/ ISP/ para &ontrolar la &one8i'n del &liente
para 8?SL. !a1le. <irele// , &#alG#ier red
Et-ernet G#e ne&e/ite tra1a2ar &on
A#t-enti&ation. At-ori:ation and A&&o#ntin$
*AAA+ a tra4(/ de #n /er4er 5A?IUS.
23
PPPoE ne&e/ita &one8i'n
dire&ta &on entre el
!on&entrador de A&&e/o/
, el &liente *3i/3o
do3inio de 1road&a/t+
En rede/ peG#ePa/ e/to no
&on/tit#,e #n pro1le3a.
24
PanorD3i&a de PPPoE
En rede/ #n po&o 3a/ de/arrollada/ #n =ni&o
do3inio de 1road&a/t no e/ #na /ol#&i'n
4ia1le
5o#$#e ?@!P /er4er/
MA! /poofin$
Anillo/ *loop/+ L2
E8&e/o de trafi&o 1road&a/t
25
PanorD3i&a de PPPoE
Venta2a/ de PPPoE
La/ 3a,ore/ 4enta2a/ G#e lo/ ISP/ re&i1en
de/de PPPoE /on li$ada/ al proto&olo PPP , al
fa&il 3ane2o de AAA
"tra nota1le 4enta2a e/ G#e PPPoE per3ite
G#e &ada &liente /e en&#entre en /# propio
/e$3ento de 1road&a/t
2C
?ia$ra3a de red 6 )#nele/
2H
I3ple3enta&i'n 5*n+
General
/system identity set name=R1
/interface bridge add name=lo
/ip address add address=10.0.0.1/32 interface=lo comment=routerID
/ip address add address=172.16.100.1/30 interface=ehter1
comment=R1_R2
/ip address add address=172.16.100.5/30 interface=ehter1
comment=R1_R3
OSPF
/routing ospf instance set 0 distribute-default=always-as-type-1
redistribute-connected=as-type-1 router-id=10.0.0.1
/routing ospf interface add interface=ether1 network-type=point-
to-point
/routing ospf interface add interface=ether2 network-type=point-
to-point
/routing ospf interface add add network-type=broadcast
passive=yes
/routing ospf network add area=backbone network=172.16.100.0/24
2E
I3ple3enta&i'n 5*n+
MPLS
/mpls set dynamic-label-range=1000-0
/mpls interface set 0 mpls-mtu=1596
/mpls ldp set enabled=yes lsr-id=10.0.0.1 transport-
address=10.0.0.1
/mpls ldp interface add interface=ether1
/mpls ldp interface add interface=ether2
29
I3ple3enta&i'n 5*1+
VPLS
/interface vpls add disabled=no l2mtu=1508 name=R2_CUSTOMERS
remote-peer=10.0.0.2 vpls-id=1:2
....
/interface vpls add disabled=no l2mtu=1508 name=R8_CUSTOMERS
remote-peer=10.0.0.8 vpls-id=1:8
PPPoE
/interface pppoe-server server add disabled=no
interface=R2_CUSTOMERS keepalive-timeout=35 max-mru=1500 max-
mtu=1500 one-session-per-host=yes
....
/interface pppoe-server server add disabled=no
interface=R8_CUSTOMERS keepalive-timeout=35 max-mru=1500 max-
mtu=1500 one-session-per-host=yes
30
I3ple3enta&i'n 5*1+
PPPoE (Cont.)
/ppp profile set 0 dns-server=8.8.8.8,8.8.4.4 local-
address=10.10.10.1 only-one=yes queue-type=default-small rate-
limit=512k/7M remote-address=customers-pool use-vj-compression=no
/ip pool add name=customers-pool ranges=192.168.0.1-192.168.3.254
/ppp aaa accounting=yes interim-update=60 use-radius=yes
Radius
/radius add address=172.16.1.1 secret=xxxxxx service=ppp src-
address=10.0.0.1 timeout=5s
Upstream Provider: default route, nat, et...
/import file-name=upstream_isp.rsc
31
32
PPPoE /olo ne&e/ita &one&ti4idad L2 entre el A! ,
el &liente.
Para prote$er lo/ &liente/
de/de ello/ 3i/3o/ e/
1#ena idea G#e e/t(n
ai/lado/ , /olo p#edan
&o3#ni&ar en L2 &on el A!.
En #n lin0 9irele// e/to /e
o1tiene fD&il3ente
G#itando la palo3ita a
!default"for#ard$.
!on/idera&ione/ L2
33
Ia/i&a3ente lo G#e /#&ede &on #n t#nel VPLS e/ G#e
e/ta3o/ &aptando #n fa3e et-ernet tal &#al *ra9+ , le
e/ta3o/ a$re$ando #na etiG#eta. Por lo tanto &#ando
&on/idela3o/ el M)U de4ere3o/ pen/ar en todo el fra3e
L2. A/i G#e tendre3o/A
1500 1,te dato/ Q E PPPoE Q 14 Et-ernetQ 4 MPLS Q 4 VPLS
R )otal 1530
!on/idera&ione/ L2
Pro1le3a/ > L2M)U
)oda la &adena de tran/porte *AP. /9it&-. ro#ter
enla&e/ dor/ale/+ tiene G#e /oportar la L2M)U de
1530. ?e lo &ontrario -a, G#e di/3in#ir el M)U
en PPPoE.
La 3a,or%a de lo/ /9it&-e/ 1arato/ /olo /oporta
3a8 L2M)U de 1514.
En al$#no/ pode3o/ -a1ilitar JF#31o Bra3e/K
para tener L2M)U 3a,or de 1514
Si en al$=n lado el L2M)U e/ 3a/ &-i&o de lo G#e
/e ne&e/ita lo/ fra3e/ MPLS /e de/&artaran
/ilen&io/a3ente -a&iendo dif%&il la dep#ra&i'n.
34
Pro1le3a/ > I!MP
Lo/ LS5 p#eden /er eG#ipo/ de /9it&-in$ G#e ni
/iG#iera &ono&en I!MP
Por e/ta ra:'n /i -a, #na falla en el &a3ino LS no
pode3o/ #/ar tra&ero#te para deter3inarla.
Por lo 3i/3o en tra&ero#te /olo reporta el ro#nd6
trip de todo el &a3ino LS.
35
!on&l#/ione/
MPLS , VPLS /on 3#, podero/o/ , /en&illo/ de
&onfi$#rar pero p#ede /er 3#, dif%&il de
dep#rarlo/ /i no /e &ono&e la for3a de &o3o
tra1a2an.
Si -a, al$=n pro1le3a al 99O e/ al$=n eG#ipo de
la &o3peten&ia G#e no /oporta #n L2M)U
/#fi&iente.
La /ol#&i'n prop#e/ta e/ la idea de 1a/e.
BD&il3ente e/ po/i1le 3e2orar a#n la red#ndan&ia
, la/ pre/ta&ione/.
3C
B#ente/
Mi0ro)i0 9i0i
Pre/enta&i'n MPLS de Fani/
I3D$ene/ &orte/%a de netle//on/
)eor%a de MPLS
3H
LGra&ia/M
Pre$#nta/ !o3entario/ , /#$eren&ia/
6 Alfredo Giordano *alfredoSti0train.&o3+
3E