Anda di halaman 1dari 49

Look deep , think and solve

CCIE SP Troubleshooting
Practice Lab






Mohammad Khalil
CCIE #35484 (R&S,SP)



1

About the Author

This practice lab was prepared by Mohammad Khalil
Mohammad holds double CCIE in Routing and switching and in Service Provider
He holds BSc in Telecommunications engineering and has more than 8 years
experience in networks field
Mohammad has worked for 4 main Internet Service Providers across the MENA
region
Moreover , he worked as an instructor for CCNP at multiple Cisco partners training
centers in Jordan

Lab goal

The goal of this lab document for sure it to troubleshoot and find the errors injected , but
the main focus of this lab is that error places are not highlighted , the main focus is the
understanding of technologies and implementations within the CCIE service provider
track
As well , after solving the faults the lab itself will give you a good example on the various
routing protocols used and demonstrates the MPLS VPN connections in place

Lab highlights

Diagram 2 shows the routing protocols used within the network and between Ps , PEs
and CEs in addition to the Cs as well , below are the highlights that will guide you
through this practice lab

AToM has been configured in order to achive connectivity between R12 and R13
via both IPv4 and IPv6
MPLS L3VPNs have been configured to achive connectivity between CEs
located in AS 100 (R8,R9) and CEs located in AS 200 (R10,R11) via both IPv4
and IPv6 , the routing protocols configured as denoted in Diagram #2
Carrier supporting Carrier has been implemented in order to achieve connectivity
between Cs located in AS 300 (R14,R15,R16 and R17) via IPv4
Only R15 and R16 needs to communicate via IPv6 as well
MPLS TE has been configured in AS 100 in order to force communication
between R1 and R18 loopback 2 networks via the explicit path called
INTER_AREA
R1 is the RR for IPv4 , VPNv4
R2 is the RR for IPv4 , IPv6 , VPNv6
R3 is the RR for IPv4 , IPv6 , VPNv4 , VPNv6
Loopback 1 networks on R4 , R5 , R6 and R7 is treated as CEs and should be
included in testing communications

2

Network Diagrams


R1
R4
R5
R2
R3
R6
R7
R10
R11
R8
R9
R12 R16
R17
R13
R14
R15
R18

Diagram 1

3

R1
R4
R5
R2
R3
R6
R7
R10
R11
R8
R9
R12
R16
R17
R13
R14
R15
R18
Named
EIGRP
AS 123
Named
EIGRP
AS 123
O2 A0
O3 A0
O2 A0
O3 A0
i4 A49.0001
i6 A49.0001
i4 A49.0001
i6 A49.0001
i4 A49.0001
i6 A49.0001
BGP (4,6)
BGP (4,6)
O2 A0
O3 A0
O2 A0
O3 A0
RIPv2
O3 (PID 159)
O2 A0
RIPng
RIPv2
O3 (PID 106)
RIPv2
RIPv2
EIGRP
AS300
i4 A49.1117
O2 A1
O3 A1
O2 A1
O3 A1
BGP (4,6)
BGP 4
AS100 AS200
R1,R2,R4,R5,R18
R3,R6,R7



Diagram 2








4

Physical Connections

Router Hostname Interface Router Hostname Interface
R1 Pos1/0 R3 Pos1/0
FastEthernet2/0 R2 FastEthernet 2/0
FastEthernet2/1 R4 FastEthernet 1/0
FastEthernet3/0 R5 FastEthernet 1/0
R2 Pos1/0 R3 Pos2/0
FastEthernet 2/0 R1 FastEthernet 2/0
FastEthernet 2/1 R5 FastEthernet 1/1
R3 Pos1/0 R1 Pos1/0
Pos2/0 R2 Pos1/0
FastEthernet 3/0 R6 FastEthernet 1/0
FastEthernet 3/1 R7 FastEthernet 1/0
R4 FastEthernet 1/0 R1 FastEthernet 2/1
FastEthernet 1/1 R5 FastEthernet 2/0
FastEthernet 2/0 R18 FastEthernet 1/0
FastEthernet 2/1 R8 FastEthernet 1/0
S3/0 R14 S1/0
R5 FastEthernet 1/0 R1 FastEthernet 3/0
FastEthernet 1/1 R2 FastEthernet 2/1
FastEthernet 2/0 R4 FastEthernet 1/1
FastEthernet 2/1 R18 FastEthernet 1/1
FastEthernet 3/0 R9 FastEthernet 1/0
S4/0 R13 S1/0
R6 FastEthernet 1/0 R3 FastEthernet 3/0
FastEthernet 1/1 R7 FastEthernet 1/1
FastEthernet 2/0 R10 FastEthernet 1/0
S3/0 R12 S1/0
R7 FastEthernet 1/0 R3 FastEthernet 3/1
FastEthernet 1/1 R6 FastEthernet 1/1
FastEthernet 2/0 R11 FastEthernet 1/0
R8 FastEthernet 1/0 R4 FastEthernet 2/1
FastEthernet 1/1 R14 FastEthernet 1/0
FastEthernet 2/0 R9 FastEthernet 2/0
R9 FastEthernet 1/0 R5 FastEthernet 3/0
FastEthernet 1/1 R15 FastEthernet 1/0
FastEthernet 2/0 R8 FastEthernet 2/0
FastEthernet 2/1 R14 FastEthernet 1/1
R10 FastEthernet 1/0 R6 FastEthernet 2/0
FastEthernet 1/1 R11 FastEthernet 1/1
FastEthernet 2/0 R16 FastEthernet 1/0
R11 FastEthernet 1/0 R7 FastEthernet 2/0

5

FastEthernet 1/1 R10 FastEthernet 1/1
FastEthernet 2/0 R10 FastEthernet 2/0
R12 S1/0 R6 S3/0
R13 S1/0 R5 S4/0
R14 FastEthernet 1/0 R8 FastEthernet 1/1
FastEthernet 1/1 R9 FastEthernet 2/1
R15 FastEthernet 1/0 R9 FastEthernet 1/1
R16 FastEthernet 1/0 R10 FastEthernet 2/0
R17 FastEthernet 1/0 R11 FastEthernet 2/0
R18 FastEthernet 1/0 R4 FastEthernet 2/0
FastEthernet 1/1 R5 FastEthernet 2/1

















6

Net File

autostart = False
[127.0.0.1:7200]
workingdir = /tmp
udp = 10001
[[7200]]
image = INE/c7200-adventerprisek9-mz.152-4.S2.bin
idlepc = 0x60a5b940
ghostios = True
[[ROUTER R4]]
console = 2004
slot1 = PA-2FE-TX
f1/0 = R1 f2/1
f1/1 = R5 f2/0
slot2 = PA-2FE-TX
f2/0 = R18 f1/0
f2/1 = R8 f1/0
x = -243.0
y = -62.0
[[ROUTER R5]]
console = 2005
slot1 = PA-2FE-TX
f1/0 = R1 f3/0
f1/1 = R2 f2/1
slot2 = PA-2FE-TX
f2/0 = R4 f1/1
f2/1 = R18 f1/1
slot3 = PA-2FE-TX
f3/0 = R9 f1/0
slot4 = PA-8T
s4/0 = R13 s1/0
x = -232.0
y = 40.0
[[ROUTER R6]]
console = 2006
slot1 = PA-2FE-TX
f1/0 = R3 f3/0
f1/1 = R7 f1/1
slot2 = PA-2FE-TX
f2/0 = R10 f1/0
slot3 = PA-8T
s3/0 = R12 s1/0
x = 87.0
y = -69.0

7

[[ROUTER R7]]
console = 2007
slot1 = PA-2FE-TX
f1/0 = R3 f3/1
f1/1 = R6 f1/1
slot2 = PA-2FE-TX
f2/0 = R11 f1/0
x = 85.0
y = 38.0
[[ROUTER R12]]
console = 2012
slot1 = PA-8T
s1/0 = R6 s3/0
x = 43.0
y = -128.0
[[ROUTER R1]]
console = 2001
slot1 = PA-POS-OC3
p1/0 = R3 p1/0
slot2 = PA-2FE-TX
f2/0 = R2 f2/0
f2/1 = R4 f1/0
slot3 = PA-2FE-TX
f3/0 = R5 f1/0
x = -132.0
y = -63.0
[[ROUTER R2]]
console = 2002
slot1 = PA-POS-OC3
p1/0 = R3 p2/0
slot2 = PA-2FE-TX
f2/0 = R1 f2/0
f2/1 = R5 f1/1
x = -127.0
y = 27.5857864376
[[ROUTER R3]]
console = 2003
slot1 = PA-POS-OC3
p1/0 = R1 p1/0
slot2 = PA-POS-OC3
p2/0 = R2 p1/0
slot3 = PA-2FE-TX
f3/0 = R6 f1/0
f3/1 = R7 f1/0
x = -14.0

8

y = -24.0
[[ROUTER R11]]
console = 2011
slot1 = PA-2FE-TX
f1/0 = R7 f2/0
f1/1 = R10 f1/1
slot2 = PA-2FE-TX
f2/0 = R17 f1/0
x = 187.0
y = 109.585786438
[[ROUTER R8]]
console = 2008
slot1 = PA-2FE-TX
f1/0 = R4 f2/1
f1/1 = R14 f1/0
slot2 = PA-2FE-TX
f2/0 = R9 f2/0
x = -285.0
y = -119.0
[[ROUTER R9]]
console = 2009
slot1 = PA-2FE-TX
f1/0 = R5 f3/0
f1/1 = R15 f1/0
slot2 = PA-2FE-TX
f2/0 = R8 f2/0
f2/1 = R14 f1/1
x = -296.0
y = 107.0
[[ROUTER R10]]
console = 2010
slot1 = PA-2FE-TX
f1/0 = R6 f2/0
f1/1 = R11 f1/1
slot2 = PA-2FE-TX
f2/0 = R16 f1/0
x = 164.0
y = -110.0
[[ROUTER R15]]
console = 2015
slot1 = PA-2FE-TX
f1/0 = R9 f1/1
x = -224.0
y = 149.0
[[ROUTER R14]]

9

console = 2014
slot1 = PA-2FE-TX
f1/0 = R8 f1/1
f1/1 = R9 f2/1
x = -381.220346111
y = -212.74011537
[[ROUTER R13]]
console = 2013
slot1 = PA-8T
s1/0 = R5 s4/0
x = -158.0
y = 108.0
[127.0.0.1:7201]
workingdir = /tmp
udp = 10101
[[7200]]
image = INE/c7200-adventerprisek9-mz.152-4.S2.bin
idlepc = 0x60a5b940
ghostios = True
[[ROUTER R18]]
console = 2018
slot1 = PA-2FE-TX
f1/0 = R4 f2/0
f1/1 = R5 f2/1
x = -453.021428025
y = -17.7573593129
[[ROUTER R17]]
console = 2017
slot1 = PA-2FE-TX
f1/0 = R11 f2/0
x = 278.126983722
y = 149.119841047
[[ROUTER R16]]
console = 2016
slot1 = PA-2FE-TX
f1/0 = R10 f2/0
x = 263.984848098
y = -203.019335984
[GNS3-DATA]
m11 = 0.707106781187
m22 = 0.707106781187

10

Initial Configuration Files

R1
hostname R1
no logging console

ip cef
ipv6 unicast-routing
ipv6 cef

mpls label protocol ldp
mpls traffic-eng tunnels

interface Loopback0
ip address 1.1.1.1 255.255.255.255
ipv6 address 2001::1/128
ipv6 ospf 1 area 0

interface Loopback2
ip address 1.18.1.1 255.255.255.255

interface Tunnel181
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 18.18.18.18
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng path-option 1 explicit name INTER_AREA

interface POS1/0
ip address 192.168.13.1 255.255.255.0
encapsulation ppp
mpls bgp forwarding
no shut

interface FastEthernet2/0
ip address 192.168.12.1 255.255.255.0
ip ospf network point-to-point
speed 100
duplex full
ipv6 address 2001:192:12::1/64
mpls ip
mpls traffic-eng tunnels
ipv6 ospf 1 area 0

11

ip rsvp bandwidth
no shut

interface FastEthernet2/1
ip address 192.168.14.1 255.255.255.0
ip ospf network point-to-point
speed 100
duplex full
ipv6 address 2001:192:14::1/64
mpls ip
mpls traffic-eng tunnels
ipv6 ospf 1 area 0
ip rsvp bandwidth
no shut

interface FastEthernet3/0
ip address 192.168.15.1 255.255.255.0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
ip ospf network point-to-point
speed 100
duplex full
ipv6 address 2001:192:15::1/64
mpls ip
mpls traffic-eng tunnels
ipv6 ospf 1 area 0
ip rsvp bandwidth
no shut

router ospf 1
router-id 1.1.1.1
redistribute bgp 100 subnets route-map R6LOOP_MAP
network 1.1.1.1 0.0.0.0 area 0
network 192.168.12.1 0.0.0.0 area 0
network 192.168.14.1 0.0.0.0 area 0
network 192.168.15.1 0.0.0.0 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0

router bgp 100
bgp log-neighbor-changes
no bgp default ipv4-unicast
no bgp default route-target filter
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 password cisc0

12

neighbor 2.2.2.2 update-source Loopback0
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0
neighbor 5.5.5.5 remote-as 100
neighbor 5.5.5.5 update-source Loopback0
neighbor 18.18.18.18 remote-as 100
neighbor 18.18.18.18 update-source Loopback0
neighbor 2001::2 remote-as 100
neighbor 2001::2 update-source Loopback0
neighbor 192.168.13.3 remote-as 200

address-family ipv4
network 1.1.1.1 mask 255.255.255.255
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 route-reflector-client
neighbor 2.2.2.2 next-hop-self
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 route-reflector-client
neighbor 4.4.4.4 next-hop-self
neighbor 5.5.5.5 activate
neighbor 5.5.5.5 route-reflector-client
neighbor 5.5.5.5 next-hop-self
neighbor 18.18.18.18 activate
neighbor 18.18.18.18 route-reflector-client
neighbor 18.18.18.18 next-hop-self
neighbor 192.168.13.3 activate
neighbor 192.168.13.3 send-label
exit-address-family

address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 2.2.2.2 route-reflector-client
neighbor 2.2.2.2 next-hop-self
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community both
neighbor 4.4.4.4 route-reflector-client
neighbor 5.5.5.5 activate
neighbor 5.5.5.5 send-community both
neighbor 5.5.5.5 next-hop-self
neighbor 18.18.18.18 activate
neighbor 18.18.18.18 send-community both
neighbor 18.18.18.18 route-reflector-client
neighbor 18.18.18.18 next-hop-self
neighbor 192.168.13.3 activate

13

neighbor 192.168.13.3 send-community both
exit-address-family

address-family ipv6
network 2001::1/128
neighbor 2001::2 activate
exit-address-family

ip route 1.18.1.18 255.255.255.255 Tunnel181

ip explicit-path name INTER_AREA enable
next-address loose 5.5.5.5

ip prefix-list R6LOOP seq 5 permit 6.6.6.6/32
ipv6 router ospf 1
router-id 1.1.1.1

route-map R6LOOP_MAP permit 10
match ip address prefix-list R6LOOP

mpls ldp router-id Loopback0 force

R2
hostname R2

no logging console

ip cef
ipv6 unicast-routing
ipv6 cef

mpls label protocol ldp

interface Loopback0
ip address 2.2.2.2 255.255.255.255
ipv6 address 2001::2/128
ipv6 ospf 1 area 0

interface POS1/0
ip address 192.168.23.2 255.255.255.0
encapsulation ppp
ipv6 address 2001:192:23::2/64
mpls bgp forwarding
no shut


14

interface FastEthernet2/0
ip address 192.168.12.2 255.255.255.0
ip ospf network point-to-point
speed 100
duplex full
ipv6 address 2001:192:12::2/64
mpls ip
mpls traffic-eng tunnels
ipv6 ospf 1 area 0
ip rsvp bandwidth
no shut

interface FastEthernet2/1
ip address 192.168.25.2 255.255.255.0
ip ospf network point-to-point
speed 100
duplex full
ipv6 address 2001:192:25::2/64
mpls ip
mpls traffic-eng tunnels
ipv6 ospf 1 area 0
ip rsvp bandwidth
no shut

router ospf 1
router-id 2.2.2.2
network 2.2.2.2 0.0.0.0 area 0
network 192.168.12.2 0.0.0.0 area 0
network 192.168.25.2 0.0.0.0 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0

router bgp 100
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 password cisco
neighbor 1.1.1.1 update-source Loopback0
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0
neighbor 5.5.5.5 remote-as 100
neighbor 5.5.5.5 update-source Loopback0
neighbor 18.18.18.18 remote-as 100
neighbor 18.18.18.18 update-source Loopback0
neighbor 2001::1 remote-as 100

15

neighbor 2001::1 update-source Loopback0
neighbor 2001::4 remote-as 100
neighbor 2001::4 update-source Loopback0
neighbor 2001::5 remote-as 100
neighbor 2001::5 update-source Loopback0
neighbor 2001::18 remote-as 100
neighbor 2001::18 update-source Loopback0
neighbor 2001:192:23::3 remote-as 200
neighbor 192.168.23.3 remote-as 200

address-family ipv4
network 2.2.2.2 mask 255.255.255.255
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 route-reflector-client
neighbor 1.1.1.1 next-hop-self
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 route-reflector-client
neighbor 4.4.4.4 next-hop-self
neighbor 5.5.5.5 activate
neighbor 5.5.5.5 route-reflector-client
neighbor 5.5.5.5 next-hop-self
neighbor 18.18.18.18 activate
neighbor 18.18.18.18 route-reflector-client
neighbor 18.18.18.18 next-hop-self
neighbor 192.168.23.3 activate
exit-address-family

address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
exit-address-family

address-family ipv6
network 2001::2/128
neighbor 2001::1 activate
neighbor 2001::1 route-reflector-client
neighbor 2001::1 next-hop-self
neighbor 2001::4 activate
neighbor 2001::4 route-reflector-client
neighbor 2001::4 next-hop-self
neighbor 2001::5 activate
neighbor 2001::5 route-reflector-client
neighbor 2001::5 next-hop-self
neighbor 2001::18 activate
neighbor 2001::18 route-reflector-client

16

neighbor 2001::18 next-hop-self
neighbor 2001:192:23::3 activate
exit-address-family

address-family vpnv6
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community both
neighbor 4.4.4.4 route-reflector-client
neighbor 4.4.4.4 next-hop-self
neighbor 5.5.5.5 activate
neighbor 5.5.5.5 send-community both
neighbor 5.5.5.5 route-reflector-client
neighbor 5.5.5.5 next-hop-self
neighbor 18.18.18.18 activate
neighbor 18.18.18.18 route-reflector-client
neighbor 18.18.18.18 next-hop-self
neighbor 192.168.23.3 activate
neighbor 192.168.23.3 send-community both
exit-address-family

ipv6 router ospf 1
router-id 2.2.2.2

mpls ldp router-id Loopback0 force

R3
hostname R3

no logging console

ip cef
ipv6 unicast-routing
ipv6 cef

mpls label protocol ldp

interface Loopback0
ip address 3.3.3.3 255.255.255.255
ip router isis 1
ipv6 address 2001::3/128
ipv6 router isis 1

interface POS1/0
ip address 192.168.13.3 255.255.255.0
encapsulation ppp

17

mpls bgp forwarding
no shut

interface POS2/0
ip address 192.168.23.3 255.255.255.0
encapsulation ppp
ipv6 address 2001:192:23::3/64
mpls bgp forwarding
no shut

interface FastEthernet3/0
ip address 192.168.36.3 255.255.255.0
ip router isis 1
speed 100
duplex full
ipv6 address 2001:192:36::3/64
ipv6 router isis 1
mpls ip
no shut

interface FastEthernet3/1
ip address 192.168.37.3 255.255.255.0
ip router isis 1
speed 100
duplex full
ipv6 address 2001:192:37::3/64
ipv6 router isis 1
mpls ip
no shut

router isis 1
net 49.0001.0000.0000.0003.00
is-type level-2-only
redistribute bgp 200 route-map R5LOOP_MAP level-1

router bgp 200
bgp log-neighbor-changes
no bgp default ipv4-unicast
no bgp default route-target filter
neighbor 6.6.6.6 remote-as 200
neighbor 6.6.6.6 update-source Loopback0
neighbor 7.7.7.7 remote-as 200
neighbor 7.7.7.7 update-source Loopback0
neighbor 2001::6 remote-as 200
neighbor 2001::6 update-source Loopback0

18

neighbor 2001::7 remote-as 200
neighbor 2001::7 update-source Loopback0
neighbor 2001:192:23::2 remote-as 100
neighbor 192.168.13.1 remote-as 100
neighbor 192.168.23.2 remote-as 100

address-family ipv4
network 3.3.3.3 mask 255.255.255.255
neighbor 6.6.6.6 activate
neighbor 6.6.6.6 route-reflector-client
neighbor 6.6.6.6 next-hop-self
neighbor 7.7.7.7 activate
neighbor 7.7.7.7 route-reflector-client
neighbor 7.7.7.7 next-hop-self
neighbor 192.168.13.1 activate
neighbor 192.168.13.1 send-label
neighbor 192.168.23.2 activate
exit-address-family

address-family vpnv4
neighbor 6.6.6.6 activate
neighbor 6.6.6.6 send-community both
neighbor 6.6.6.6 route-reflector-client
neighbor 6.6.6.6 next-hop-self
neighbor 7.7.7.7 activate
neighbor 7.7.7.7 send-community both
neighbor 7.7.7.7 route-reflector-client
neighbor 7.7.7.7 next-hop-self
neighbor 192.168.13.1 activate
neighbor 192.168.13.1 send-community both
exit-address-family

address-family ipv6
network 2001::3/128
neighbor 2001::6 activate
neighbor 2001::6 route-reflector-client
neighbor 2001::6 next-hop-self
neighbor 2001::7 activate
neighbor 2001::7 route-reflector-client
neighbor 2001::7 next-hop-self
neighbor 2001:192:23::2 activate
exit-address-family

address-family vpnv6
neighbor 6.6.6.6 activate

19

neighbor 6.6.6.6 send-community both
neighbor 6.6.6.6 route-reflector-client
neighbor 6.6.6.6 next-hop-self
neighbor 7.7.7.7 activate
neighbor 7.7.7.7 send-community both
neighbor 7.7.7.7 route-reflector-client
neighbor 7.7.7.7 next-hop-self
neighbor 192.168.23.2 activate
neighbor 192.168.23.2 send-community both
exit-address-family

ip prefix-list R5LOOP seq 5 deny 5.5.5.5/32

access-list 16 permit 6.6.6.6
access-list 16 permit 7.7.7.0 0.0.0.255

route-map R5LOOP_MAP permit 10
match ip address prefix-list R5LOOP

mpls ldp router-id Loopback0 force

R4
hostname R4

vrf definition MSSK
rd 100:1

address-family ipv4
route-target export 100:1
route-target import 100:1
exit-address-family

address-family ipv6
route-target export 100:1
route-target import 100:1
route-target import 200:1
exit-address-family

no logging console

ip cef
ipv6 unicast-routing
ipv6 cef

mpls label protocol ldp

20

mpls traffic-eng tunnels
mpls ldp advertise-labels for 1

interface Loopback0
ip address 4.4.4.4 255.255.255.255
ipv6 address 2001::4/128
ipv6 ospf 1 area 0

interface Loopback1
vrf forwarding MSSK
ip address 172.16.4.4 255.255.255.255
ipv6 address 2001:DB8::4/128

interface FastEthernet1/0
ip address 192.168.14.4 255.255.255.0
ip ospf network point-to-point
speed 100
duplex full
ipv6 address 2001:192:14::4/64
mpls ip
mpls traffic-eng tunnels
ipv6 ospf 1 area 0
ip rsvp bandwidth
no shut

interface FastEthernet1/1
ip address 192.168.45.4 255.255.255.0
ip ospf network point-to-point
speed 100
duplex full
ipv6 address 2001:192:45::4/64
mpls ip
mpls traffic-eng tunnels
ipv6 ospf 1 area 0
ipv6 ospf hello-interval 11
ip rsvp bandwidth
no shut

interface FastEthernet2/0
ip address 192.168.184.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 2
speed 100
duplex full
ipv6 address 2001:192:184::4/64

21

mpls ip
mpls traffic-eng tunnels
ipv6 ospf 1 area 1
ip rsvp bandwidth
no shut

interface FastEthernet2/1
vrf forwarding MSSK
ip address 172.16.48.4 255.255.255.0
speed 100
duplex full
ipv6 address 2001:172:48::4/64
mpls bgp forwarding
no shut

router ospf 1
router-id 4.4.4.4
network 4.4.4.4 0.0.0.0 area 0
network 192.168.14.4 0.0.0.0 area 0
network 192.168.45.4 0.0.0.0 area 0
network 192.168.184.4 0.0.0.0 area 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng area 1

router bgp 100
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback0
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
neighbor 2001::2 remote-as 100
neighbor 2001::2 update-source Loopback0

address-family ipv4
network 4.4.4.4 mask 255.255.255.255
neighbor 1.1.1.1 activate
neighbor 2.2.2.2 activate
exit-address-family

address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
exit-address-family

22


address-family ipv6
network 2001::4/128
neighbor 2001::2 activate
exit-address-family

address-family vpnv6
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family

address-family ipv4 vrf MSSK
network 172.16.4.4 mask 255.255.255.255
neighbor 172.16.48.8 remote-as 300
neighbor 172.16.48.8 activate
neighbor 172.16.48.8 as-override
neighbor 172.16.48.8 send-label
exit-address-family

address-family ipv6 vrf MSSK
network 2001:DB8::4/128
exit-address-family

ipv6 router ospf 1
router-id 18.18.18.18

mpls ldp router-id Loopback0 force

access-list 1 deny 4.4.4.4 0.0.0.0
access-list 1 permit any

R5
hostname R5

vrf definition MSSK
rd 100:1

address-family ipv4
route-target export 100:1
route-target import 100:1
route-target import 200:1
exit-address-family

address-family ipv6
route-target import 100:1

23

route-target import 200:1
exit-address-family

no logging console

ip cef
ipv6 unicast-routing
ipv6 cef

mpls label protocol ldp
mpls traffic-eng tunnels

pseudowire-class XCONNECT
encapsulation mpls

interface Loopback0
ip address 5.5.5.5 255.255.255.255
ipv6 address 2001::5/128
ipv6 ospf 1 area 0

interface Loopback1
vrf forwarding MSSK
ip address 172.16.5.5 255.255.255.255
ipv6 address 2001:DB8::5/128

interface FastEthernet1/0
ip address 192.168.15.5 255.255.255.0
ip ospf authentication message-digest
ip ospf message-digest-key 2 md5 cisco
ip ospf network point-to-point
speed 100
duplex full
ipv6 address 2001:192:15::5/64
mpls ip
mpls traffic-eng tunnels
ipv6 ospf 1 area 0
ip rsvp bandwidth
no shut

interface FastEthernet1/1
ip address 192.168.25.5 255.255.255.0
ip ospf network point-to-point
speed 100
duplex full
ipv6 address 2001:192:25::5/64

24

mpls ip
mpls traffic-eng tunnels
ipv6 ospf 1 area 0
ip rsvp bandwidth
no shut

interface FastEthernet2/0
ip address 192.168.45.5 255.255.255.0
ip ospf network point-to-point
speed 100
duplex full
ipv6 address 2001:192:45::5/64
mpls ip
ipv6 ospf 1 area 0
ip rsvp bandwidth
no shut

interface FastEthernet2/1
ip address 192.168.185.5 255.255.255.0
ip ospf network point-to-point
speed 100
duplex full
ipv6 address 2001:192:185::5/64
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth
no shut

interface FastEthernet3/0
vrf forwarding MSSK
ip address 172.16.59.5 255.255.255.0
speed 100
duplex full
ipv6 address 2001:172:59::5/64
mpls bgp forwarding
no shut

interface Serial4/0
no ip address
no keepalive
serial restart-delay 0
xconnect 6.6.6.6 123 encapsulation mpls pw-class XCONNECT
no shut

router ospf 1

25

router-id 5.5.5.5
network 5.5.5.5 0.0.0.0 area 0
network 192.168.15.5 0.0.0.0 area 0
network 192.168.25.5 0.0.0.0 area 0
network 192.168.45.5 0.0.0.0 area 0
network 192.168.185.5 0.0.0.0 area 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng area 1

router bgp 100
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback0
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
neighbor 2001::2 remote-as 100
neighbor 2001::2 update-source Loopback0

address-family ipv4
network 5.5.5.5 mask 255.255.255.255
neighbor 1.1.1.1 activate
neighbor 2.2.2.2 activate
exit-address-family

address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
exit-address-family

address-family ipv6
network 2001::5/128
neighbor 2001::2 activate
exit-address-family

address-family vpnv6
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family

address-family ipv4 vrf MSSK
network 172.16.5.5 mask 255.255.255.255
neighbor 172.16.59.9 remote-as 300
neighbor 172.16.59.9 activate

26

neighbor 172.16.59.9 as-override
neighbor 172.16.59.9 send-label
exit-address-family

address-family ipv6 vrf MSSK
network 2001:DB8::5/128
neighbor 2001:172:59::9 remote-as 300
neighbor 2001:172:59::9 activate
neighbor 2001:172:59::9 as-override
exit-address-family

ipv6 router ospf 1
router-id 5.5.5.5

mpls ldp router-id Loopback0 force

R6
hostname R6

vrf definition MSSK
rd 200:1

address-family ipv4
route-target export 200:1
route-target import 200:1
route-target import 100:1
exit-address-family

address-family ipv6
route-target export 200:1
route-target import 200:1
route-target import 100:1
exit-address-family

no logging console

ip cef
ipv6 unicast-routing
ipv6 cef

mpls label protocol ldp
mpls ldp neighbor 3.3.3.3 password ldppassword
mpls ldp label
allocate global prefix-list R5LOOP


27

pseudowire-class XCONNECT
encapsulation mpls

interface Loopback0
ip address 6.6.6.6 255.255.255.255
ip router isis 1
ipv6 address 2001::6/128
ipv6 router isis 1

interface Loopback1
vrf forwarding MSSK
ip address 172.16.6.6 255.255.255.255
ipv6 address 2001:DB8::6/128

interface FastEthernet1/0
ip address 192.168.36.6 255.255.255.0
ip router isis 1
speed 100
duplex full
ipv6 address 2001:192:36::6/64
ipv6 router isis 1
no shut

interface FastEthernet1/1
ip address 192.168.67.6 255.255.255.0
ip router isis 1
speed 100
duplex full
ipv6 address 2001:192:67::6/64
ipv6 router isis 1
mpls ip
no shut

interface FastEthernet2/0
vrf forwarding MSSK
ip address 172.16.106.6 255.255.255.0
speed 100
duplex full
ipv6 address 2001:172:106::6/64
mpls bgp forwarding
no shut

interface Serial3/0
no ip address
no keepalive

28

serial restart-delay 0
xconnect 5.5.5.5 123 encapsulation mpls pw-class XCONNECT
no shut

router isis 1
net 49.0001.0000.0000.0006.00
is-type level-2-only

router bgp 200
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 3.3.3.3 remote-as 200
neighbor 3.3.3.3 update-source Loopback0
neighbor 2001::3 remote-as 200
neighbor 2001::3 update-source Loopback1

address-family ipv4
network 6.6.6.6 mask 255.255.255.255
neighbor 3.3.3.3 activate
exit-address-family

address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family

address-family ipv6
network 2001::6/128
neighbor 2001::3 activate
exit-address-family

address-family vpnv6
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family

address-family ipv4 vrf MSSK
network 172.16.6.6 mask 255.255.255.255
neighbor 172.16.106.10 remote-as 300
neighbor 172.16.106.10 activate
neighbor 172.16.106.10 as-override
neighbor 172.16.106.10 send-label
exit-address-family

address-family ipv6 vrf MSSK

29

network 2001:DB8::6/128
neighbor 2001:172:106::10 remote-as 300
neighbor 2001:172:106::10 activate
neighbor 2001:172:106::10 as-override
exit-address-family


ip prefix-list R5LOOP seq 5 deny 5.5.5.5/32
ip prefix-list R5LOOP seq 10 permit 0.0.0.0/0 le 32

mpls ldp router-id Loopback0 force

R7
hostname R7

vrf definition MSSK
rd 200:1

address-family ipv4
route-target export 200:1
route-target import 200:1
route-target import 100:1
exit-address-family

address-family ipv6
route-target export 200:1
route-target import 200:1
route-target import 100:1
exit-address-family

no logging console

ip cef
ipv6 unicast-routing
ipv6 cef

mpls label protocol tdp
mpls ldp neighbor 3.3.3.3 password ldppasword

interface Loopback0
ip address 7.7.7.7 255.255.255.255
ip router isis 1
ipv6 address 2001::7/128
ipv6 router isis 1


30

interface Loopback1
vrf forwarding MSSK
ip address 172.16.7.7 255.255.255.255
ipv6 address 2001:DB8::7/128

interface FastEthernet1/0
ip address 192.168.37.7 255.255.255.0
ip router isis 1
speed 100
duplex full
ipv6 address 2001:192:37::7/64
ipv6 router isis 1
mpls ip
isis circuit-type level-1
no shut

interface FastEthernet1/1
ip address 192.168.67.7 255.255.255.0
ip router isis 1
speed 100
duplex full
ipv6 address 2001:192:67::7/64
ipv6 router isis 1
mpls ip
no shut

interface FastEthernet2/0
vrf forwarding MSSK
ip address 172.16.117.7 255.255.255.0
speed 100
duplex full
ipv6 address 2001:172:117::7/64
mpls ip
no shut

router ospf 300 vrf MSSK
router-id 172.16.7.7
network 172.16.117.7 0.0.0.0 area 0
distribute-list route-map DENY_TAG out

router isis 1
net 49.0001.0000.0000.0007.00
is-type level-2-only

router bgp 200

31

bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 3.3.3.3 remote-as 200
neighbor 3.3.3.3 update-source Loopback0
neighbor 2001::3 remote-as 200
neighbor 2001::3 update-source Loopback0

address-family ipv4
network 7.7.7.7 mask 255.255.255.255
neighbor 3.3.3.3 activate
exit-address-family

address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family

address-family ipv6
network 2001::7/128
neighbor 2001::3 activate
exit-address-family

address-family vpnv6
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family

address-family ipv4 vrf MSSK
network 172.16.7.7 mask 255.255.255.255
exit-address-family

address-family ipv6 vrf MSSK
network 2001:DB8::7/128
exit-address-family

mpls ldp router-id Loopback0 force

route-map DENY_TAG deny 10
match tag 300

R8
hostname R8

vrf definition ABC
rd 300:1

32


address-family ipv4
route-target export 300:1
route-target import 300:1
exit-address-family

address-family ipv6
route-target export 300:1
route-target import 300:1
exit-address-family

no logging console

ip cef
ipv6 unicast-routing
no ipv6 cef

interface Loopback0
ip address 172.16.8.8 255.255.255.255
ipv6 address 2001:DB8::8/128
ipv6 eigrp 300

interface FastEthernet1/0
ip address 172.16.48.8 255.255.255.0
speed 100
duplex full
ipv6 address 2001:172:48::8/64
mpls bgp forwarding
no shut

interface FastEthernet1/1
vrf forwarding ABC
ip address 10.10.148.8 255.255.255.0
speed 100
duplex full
ipv6 address 2001:10:148::8/64
no shut

interface FastEthernet2/0
ip address 172.16.89.8 255.255.255.0
speed 100
duplex full
ipv6 address 2001:172:89::8/64
ipv6 eigrp 300
mpls ip

33

no shut

router ospf 300
router-id 172.16.8.8
network 172.16.8.8 0.0.0.0 area 0
network 172.16.89.8 0.0.0.0 area 0

router rip

address-family ipv4 vrf ABC
redistribute bgp 300 metric 15
network 10.0.0.0
no auto-summary
version 2
exit-address-family

router bgp 300
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 172.16.10.10 remote-as 300
neighbor 172.16.10.10 update-source Loopback0
neighbor 172.16.48.4 remote-as 100

address-family ipv4
network 172.16.8.8 mask 255.255.255.255
neighbor 172.16.48.4 activate
neighbor 172.16.48.4 send-label
exit-address-family

address-family vpnv4
neighbor 172.16.10.10 activate
neighbor 172.16.10.10 send-community both
exit-address-family

address-family ipv4 vrf ABC
redistribute rip
exit-address-family

ipv6 router eigrp 300
shutdown

R9
hostname R9

vrf definition ABC

34

rd 300:1

address-family ipv4
route-target export 300:1
route-target import 300:1
exit-address-family

address-family ipv6
route-target export 300:1
route-target import 300:1
exit-address-family

no logging console

ip cef
ipv6 unicast-routing
ipv6 cef

interface Loopback0
ip address 172.16.9.9 255.255.255.255
ipv6 address 2001:DB8::9/128

interface FastEthernet1/0
ip address 172.16.59.9 255.255.255.0
speed 100
duplex full
ipv6 address 2001:172:59::9/64
mpls bgp forwarding
no shut

interface FastEthernet1/1
vrf forwarding ABC
ip address 10.10.159.9 255.255.255.0
speed 100
duplex full
ipv6 address 2001:10:159::9/64
ospfv3 159 ipv6 area 1
no shut

interface FastEthernet2/0
ip address 172.16.89.9 255.255.255.0
speed 100
duplex full
ipv6 address 2001:172:89::9/64
ipv6 eigrp 300

35

mpls ip
no shut

interface FastEthernet2/1
vrf forwarding ABC
ip address 10.10.149.9 255.255.255.0
speed 100
duplex full
ipv6 address 2001:10:149::9/64
no shut

router ospfv3 159

address-family ipv6 unicast vrf ABC
redistribute bgp 300
router-id 172.16.9.9
exit-address-family

router ospf 300
router-id 172.16.9.9
network 172.16.9.9 0.0.0.0 area 0
network 172.16.89.9 0.0.0.0 area 0

router rip

address-family ipv4 vrf ABC
network 10.0.0.0
no auto-summary
version 2
exit-address-family

router bgp 300
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 2001:172:59::5 remote-as 100
neighbor 172.16.10.10 remote-as 300
neighbor 172.16.10.10 update-source Loopback0
neighbor 172.16.59.5 remote-as 100

address-family ipv4
network 172.16.9.9 mask 255.255.255.255
neighbor 172.16.59.5 activate
neighbor 172.16.59.5 send-label
exit-address-family


36

address-family ipv6
redistribute connected
redistribute eigrp 300 include-connected
neighbor 2001:172:59::5 activate
exit-address-family

address-family vpnv6
neighbor 172.16.10.10 activate
neighbor 172.16.10.10 send-community both
exit-address-family

address-family ipv6 vrf ABC
redistribute ospf 159 include-connected
exit-address-family

ipv6 router eigrp 300
redistribute bgp 300 metric 1000 1000 255 1 1500
redistribute connected

R10
hostname R10

vrf definition ABC
rd 300:1

address-family ipv4
route-target export 300:1
route-target import 300:1
exit-address-family

address-family ipv6
route-target export 300:1
route-target import 300:1
exit-address-family

no logging console

no ip cef
ipv6 unicast-routing
ipv6 cef

interface Loopback0
ip address 172.16.10.10 255.255.255.255
ipv6 address 2001:db8::10/128


37

interface FastEthernet1/0
ip address 172.16.106.10 255.255.255.0
speed 100
duplex full
ipv6 address 2001:172:106::10/64
mpls bgp forwarding
no shut

interface FastEthernet1/1
ip address 172.16.110.10 255.255.255.0
speed 100
duplex full
ipv6 address 2001:172:110::10/64
ipv6 rip RIPng enable
mpls ip
no shut

interface FastEthernet2/0
vrf forwarding ABC
ip address 10.10.106.10 255.255.255.0
speed 100
duplex full
ipv6 address 2001:10:106::10/64
ospfv3 106 ipv6 area 1
no shut

router ospfv3 106

address-family ipv6 unicast vrf ABC
router-id 172.16.10.10
exit-address-family

router ospf 300
router-id 172.16.10.10
network 172.16.10.10 0.0.0.0 area 0
network 172.16.110.10 0.0.0.0 area 0
redistribute bgp 300 subnets route-map TAG

router rip

address-family ipv4 vrf ABC
network 10.0.0.0
no auto-summary
version 2
exit-address-family

38


router bgp 300
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 2001:172:106::6 remote-as 200
neighbor 172.16.8.8 remote-as 300
neighbor 172.16.8.8 update-source Loopback0
neighbor 172.16.9.9 remote-as 300
neighbor 172.16.9.9 update-source Loopback0
neighbor 172.16.11.11 remote-as 300
neighbor 172.16.11.11 update-source Loopback0
neighbor 172.16.106.6 remote-as 200

address-family ipv4
network 172.16.10.10 mask 255.255.255.255
redistribute ospf 300 match internal external 1
neighbor 172.16.106.6 activate
exit-address-family

address-family vpnv4
neighbor 172.16.8.8 activate
neighbor 172.16.8.8 send-community both
neighbor 172.16.8.8 route-reflector-client
neighbor 172.16.11.11 activate
neighbor 172.16.11.11 send-community both
neighbor 172.16.11.11 route-reflector-client
exit-address-family

address-family ipv6
redistribute rip RIPng include-connected
exit-address-family

address-family vpnv6
neighbor 172.16.9.9 activate
neighbor 172.16.9.9 send-community both
exit-address-family

address-family ipv4 vrf ABC
redistribute rip
exit-address-family

address-family ipv6 vrf ABC
redistribute ospf 160 include-connected
exit-address-family


39

ipv6 router rip RIPng
redistribute connected

route-map TAG permit 10
set tag 300

R11
hostname R11

vrf definition ABC
rd 300:1

address-family ipv4
route-target export 300:1
route-target import 300:1
exit-address-family

address-family ipv6
route-target export 300:1
route-target import 300:1
exit-address-family

no logging console

ip cef
ipv6 unicast-routing
ipv6 cef

interface Loopback0
ip address 172.16.11.11 255.255.255.255
ipv6 address 2001:db8::11/128
ipv6 rip RIPng enable

interface FastEthernet1/0
ip address 172.16.117.11 255.255.255.0
speed 100
duplex full
ipv6 address 2001:172:117::11/64
mpls ip
no shut

interface FastEthernet1/1
ip address 172.16.110.11 255.255.255.0
ip access-group DENY_LDP in
speed 100

40

duplex full
ipv6 address 2001:172:110::11/64
ipv6 rip RIPmg enable
mpls ip
no shut

interface FastEthernet2/0
vrf forwarding ABC
ip address 10.10.117.11 255.255.255.0
ip router isis 1
speed 100
duplex full
ipv6 address 2001:10:117::11/64
no shut

router ospf 300
router-id 172.16.11.11
redistribute connected subnets route-map LOOP
network 172.16.110.11 0.0.0.0 area 0
network 172.16.117.11 0.0.0.0 area 0

router isis 1
vrf ABC
net 49.1117.0000.0000.0011.00
is-type level-2-only
redistribute bgp 300

router bgp 300
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 172.16.10.10 remote-as 300
neighbor 172.16.10.10 update-source Loopback0

address-family ipv4
exit-address-family

address-family vpnv4
neighbor 172.16.10.10 activate
neighbor 172.16.10.10 send-community both
exit-address-family

address-family ipv4 vrf ABC
redistribute isis 1 level-2
redistribute isis level-2
exit-address-family

41


ip access-list extended DENY_LDP
permit tcp any any eq 646

ipv6 router rip RIPng

ipv6 router rip RIPmg

route-map LOOP permit 10
match interface Loopback0

R12
hostname R12

no logging console

ip cef
ipv6 unicast-routing
ipv6 cef

interface Loopback0
ip address 10.10.12.12 255.255.255.255
ipv6 address 2001:DB8:10::12/128

interface Serial1/0
ip address 10.10.123.12 255.255.255.0
ipv6 address 2001:10:123::12/64
serial restart-delay 0
no shut

router eigrp MSSK

address-family ipv4 unicast autonomous-system 123

topology base
exit-af-topology
network 10.10.12.12 0.0.0.0
exit-address-family

address-family ipv6 unicast autonomous-system 123

topology base
exit-af-topology
exit-address-family


42

R13
hostname R13

no logging console

ip cef
ipv6 unicast-routing
ipv6 cef

interface Loopback0
ip address 10.10.13.13 255.255.255.255
ipv6 address 2001:DB8:10::13/128

interface Serial1/0
ip address 10.10.123.13 255.255.255.0
ipv6 address 2001:10:132::13/64
serial restart-delay 0
no shut

router eigrp MSSK

address-family ipv4 unicast autonomous-system 123

topology base
exit-af-topology
network 10.10.13.13 0.0.0.0
network 10.10.123.13 0.0.0.0
exit-address-family

address-family ipv6 unicast autonomous-system 123

af-interface Serial1/0
passive-interface
exit-af-interface

topology base
exit-af-topology
exit-address-family

R14
hostname R14

no logging console

ip cef

43

no ipv6 cef

interface Loopback0
ip address 10.10.14.14 255.255.255.255
ipv6 address 2001:DB8:10::14/128

interface FastEthernet1/0
ip address 10.10.148.14 255.255.255.0
shutdown
speed 100
duplex full
ipv6 address 2001:10:148::14/64
ip access-group DENY_RIP in

interface FastEthernet1/1
ip address 10.10.149.14 255.255.255.0
speed 100
duplex full
ipv6 address 2001:10:149::14/64
no shut

router rip
version 2
network 10.0.0.0
no auto-summary

ip access-list extended DENY_RIP
permit ip any any

R15
hostname R15

no logging console

ip cef
ipv6 unicast-routing
ipv6 cef

interface Loopback0
ip address 10.10.15.15 255.255.255.255
ipv6 address 2001:DB8:10::15/128
ospfv3 159 ipv6 area 1

interface FastEthernet1/0
ip address 10.10.159.15 255.255.255.0

44

speed 100
duplex full
ipv6 address 2001:10:159::15/64
ospfv3 159 ipv6 area 1
no shut

router ospfv3 159
router-id 10.10.15.15

address-family ipv6 unicast
passive-interface FastEthernet1/0
exit-address-family

router rip
version 2
network 10.0.0.0
no auto-summary

R16
hostname R16

no logging console

ip cef
ipv6 unicast-routing
ipv6 cef

interface Loopback0
ip address 10.10.16.16 255.255.255.255
ipv6 address 2001:DB8:10::16/64
ospfv3 106 ipv6 area 1

interface FastEthernet1/0
ip address 10.10.106.16 255.255.255.0
speed 100
duplex full
ipv6 address 2001:10:106::16/64
ospfv3 106 ipv6 area 1
ipv6 traffic-filter DENY_OSPFv3 in
no shut

router ospfv3 106
router-id 10.10.16.16

address-family ipv6 unicast

45

exit-address-family

router rip
network 10.0.0.0
no auto-summary

ipv6 access-list DENY_OSPFv3
sequence 5 deny ipv6 any host FF02::5
sequence 10 permit ipv6 any any

R17
hostname R17

no logging console

ip cef
ipv6 unicast-routing
ipv6 cef

interface Loopback0
ip address 10.10.17.17 255.255.255.255
ip router isis 1
ipv6 address 2001:DB8:10::17/128

interface FastEthernet1/0
ip address 10.10.117.17 255.255.255.0
ip router isis 1
speed 100
duplex full
ipv6 address 2001:10:117::17/64
isis network point-to-point
no shut

router isis 1
net 49.1117.0000.0000.0017.00
is-type level-2-only

R18
hostname R18

vrf definition MSSK
rd 100:1

address-family ipv4
route-target export 100:1

46

route-target import 100:1
route-target import 200:1
exit-address-family
address-family ipv6
route-target export 100:1
route-target import 100:1
route-target import 200:1
exit-address-family

no logging console

ip cef
ipv6 unicast-routing
ipv6 cef

mpls label protocol ldp
mpls traffic-eng tunnels

interface Loopback0
ip address 18.18.18.18 255.255.255.255
ipv6 address 2001::18/128
ipv6 ospf 1 area 1

interface Loopback1
vrf forwarding MSSK
ip address 172.16.18.18 255.255.255.255
ipv6 address 2001:DB8::18/128

interface Loopback2
ip address 1.18.1.18 255.255.255.255

interface Tunnel181
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 1.1.1.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng path-option 1 explicit name INTER_AREa

interface FastEthernet1/0
ip address 192.168.184.18 255.255.255.0
ip ospf network point-to-point
speed 100
duplex full
ipv6 address 2001:192:184::18/64
mpls ip

47

mpls traffic-eng tunnels
ipv6 ospf 1 area 1
ip rsvp bandwidth
no shut

interface FastEthernet1/1
ip address 192.168.185.18 255.255.255.0
ip ospf network point-to-point
speed 100
duplex full
ipv6 address 2001:192:185::18/64
mpls ip
mpls traffic-eng tunnels
ipv6 ospf 1 area 1
no shut

router ospf 1
router-id 18.18.18.18
network 18.18.18.18 0.0.0.0 area 1
network 192.168.184.18 0.0.0.0 area 1
network 192.168.185.18 0.0.0.0 area 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 1

router bgp 100
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback0
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
neighbor 2001::2 remote-as 100
neighbor 2001::2 update-source Loopback0

address-family ipv4
network 18.18.18.18 mask 255.255.255.255
neighbor 1.1.1.1 activate
neighbor 2.2.2.2 activate
exit-address-family

address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
exit-address-family


48

address-family ipv6
network 2001::18/128
neighbor 2001::2 activate
exit-address-family

address-family vpnv6
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family

address-family ipv4 vrf MSSK
network 172.16.18.18 mask 255.255.255.255
exit-address-family

address-family ipv6 vrf MSSK
network 2001:DB8::18/127
exit-address-family

ip route 1.18.1.1 255.255.255.255 Tunnel181

ip explicit-path name INTER_AREA enable
next-address loose 4.4.4.4

ipv6 router ospf 1
router-id 18.18.18.18

mpls ldp router-id Loopback0 force