Anda di halaman 1dari 9

1

SISTEMA DE ENSINO PRESENCIAL CONECTADO


NOME DO CURSO
TALES GOULART

ALGORITMOS

SETE LAGOAS
2013

TALES GOULART

ALGORITMOS

Trabalho de ........ apresentado Universidade Norte do


Paran - UNOPAR, como requisito parcial para a
obteno de mdia bimestral na disciplina de algoritmos .

SETE LAGOAS
2013

SUMRIO

1 INTRODUO..........................................................................................................5
2 OBJETIVO................................................................................................................5
3 DESENVOLVIMENTO..............................................................................................5
3.1 CONSTANTES E COMANDO DE ATRIBUIO...................................................5
3.2 OPERADORES ARITMTICOS.............................................................................5
4 CRIAO DE ALGORITMO ASSIM COMO FOI SUGERIDO NO ESCOPO DO
TRABALHO.................................................................................................................6
4.1
SEGUNDO
ALGORTMO
PROPOSTO
PELO
TRABALHO. ..................................................................................................................
....................6
5 CONCLUSO...........................................................................................................8
6 REFERENCIAS BIBILHOGRAFICAS......................................................................9

1 INTRODUO
Este trabalho visa aprimorar os conhecimentos em logica de programao atravs
de exerccios prticos de fixao.

2 OBJETIVO.
Rever o contedo e da disciplina.
3 DESENVOLVIMENTO.
A linguagem que o VISUALG interpreta bem simples: uma
verso portuguesa dos pseudocdigos largamente utilizados nos livros de introduo
programao, conhecida como "Portugol".
3.1 CONSTANTES E COMANDO DE ATRIBUIO.
Numricos: so valores numricos escritos na forma usual das
linguagens de programao. Podem ser inteiros ou reais. Neste ltimo caso, o
separador de decimais o ponto e no a vrgula, independente da configurao
regional do computador onde o VisuAlg est sendo executado. O VisuAlg tambm
no suporta separadores de milhares.
Caracteres: qualquer cadeia de caracteres delimitada por aspas duplas (").
Lgicos: admite os valores VERDADEIRO ou FALSO.
3.2 OPERADORES ARITMTICOS.
Operadores unrios, isto , so aplicados a um nico operando. So
os operadores aritmticos de maior precedncia. Exemplos: -3, +x. Enquanto o
operador unrio - inverte o sinal do seu operando, o operador + no altera o
valor em nada o seu valor.
Operador de diviso inteira. Por exemplo, 5 \ 2 = 2. Tem a mesma
precedncia do operador de diviso tradicional.+,-,*,/ Operadores aritmticos
tradicionais de adio, subtrao, multiplicao e diviso.
Por conveno, * e / tm precedncia sobre + e -. Para modificar a

ordem de avaliao das operaes, necessrio usar parnteses como em


qualquer
expresso aritmtica. % Operador de mdulo (isto , resto da diviso inteira). Por
exemplo, 8 % 3 = 2. Tem a mesma precedncia do operador de diviso tradicional.
^ Operador de potenciao. Por exemplo, 5 ^ 2 = 25.
4 CRIAO DE ALGORITMO ASSIM COMO FOI SUGERIDO NO ESCOPO DO
TRABALHO.
Este algoritmo foi criado para calcular o valor do salario de
funcionrio de acordo com as taxas cobradas pelo INSS.

var
vr1,vr2, sal, inss : real
fun,sal: caractere
inicio
escreval ("Digite O nome do Funcionrio: ")
leia (fun)
escreval ("Digite O salario do funcionrio: ")
leia (sal)
vr<- sal
se (vr>=1000)
vr1<-(1000 -(1000*0.11))
se (vr<=1000)
vr2<-(1000 -(1000*0.09))
fim se
escreval ( O nome do funcionrio :)
escreval (fun)
escreval (O salario do funcionrio bruto :)
escreval (sal)
escreval (O salario do funcionrio com desconto INSS :)
escreval (vr1)
escreval (O salario do funcionrio sem desconto do INSS :)
escreval (vr2)
fimse
fimalgoritmo

4.1 SEGUNDO ALGORTMO PROPOSTO PELO TRABALHO CONTO.


Este algoritmo trata do valor de desconto dado a um cliente de
acordo com valor das compras efetuadas por ele, segue a tabela de descontos.

Var
Vr1, desconto: real
Nome: caractere
Inicio
escreval ( Insira o nome do cliente ;)
Leia(nome);
escreval (Digite o valor da compra;)
Leia(vr1);
Se (vr1 >= 1000)
Desconto <- (1000 -(1000*0.05))
Se (vr1 >= 1000) ou (vr1<= 1500)
Desconto <- (1000 -(1000*0.10))
Se (vr1 > 5000)
Desconto <- (1000 -(1000*0.15))
fimse
escreval (Valor da compra com desconto ;)
escreval (desconto)
fimse

5 CONCLUSO.
Mais uma vez tivemos a oportunidade de rever conceitos e aprimorar
conhecimentos atravs da criao de exerccios de algoritmos que contriburam para
fixao da matria, e aumento do conhecimento atravs da pesquisa e pratica da
matria contriburam para o enriquecimento do contedo.

6 REFERENCIAS BIBILHOGRAFICAS:
A

Linguagem

de

Programao

do

VisuAlg

(1)

Disponivel

em:

<http://www.eletrica.ufpr.br/~rogerio/visualg/Help/linguagem.htm>. Acesso em: 08


out. 2013.
A Wikipdia. Visualg. Disponivel em: <http://pt.wikipedia.org/wiki/Visualg>. Acesso
em: 08 out. 2013.