Anda di halaman 1dari 83

Tutorial Step by step setting mikrotik

MikroTik RouterOS™ adalah sistem operasi linux yang dapat digunakan untuk menjadikan komput
* Monitoring/Accounting - IP traffic accounting, firewall actions logging, statistics graph
1GB di proxy.. * HDD minimal 128MB parallel ATA atau Compact Flash, tidak dianjurkan menggu
1 R ether2 ether 0 0 1500 [admin@Andre-Network] > 6. Memberikan IP address pada interface M
primary-dns: 192.168.0.10 secondary-dns: 192.168.0.11 allow-remote-requests: no cache-size:
4. Lihat status DHCP server [admin@Andre-Network]> ip dhcp-server print Flags: X - disabled
2 ISP IN 1 ROUTER WITH LOADBALANCING
/ ip address add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interfa
add chain=prerouting in-interface=Local connection-state=new nth=1,1,1 \ action=mark-connec
/ ip firewall nat add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.111.0
nat & filter firewall standar_______________ ip firewall nat add action=masquerade chain=sr
queue simple add name=kbu-03 target-addresses=192.168.0.13 queue simple add name=kbu-04 tar
the best anti-ddos rule
/ip firewall filter add action=add-src-to-address-list address-list=black_list \ address-li
limit=25,10 src-address-list=!Safe-List action=add-src-to-address-list address-list=tcp-syn
Anti DDoS di Mikrotik
•Memang mencegah adalah lebih baik dari pada tidak sama sekali. begitu juga
dengan dijaringan asal-asalan di tempat saya mencari makan , dengan bandwith yang sangat te
ip firewall filter add chain=input dst-address-type=broadcast action=accept comment=”Allow
1. bersihin dulu isi route nya , dari winbox pilih ip route, trus di delete deh tuh gateway
jangan lupa nyobainnya ntar malam aja, sambil ngopi n ngudut djarum super ya
Memisahkan bandwith lokal dan internasional menggunakan Mikrotik
Mei 16, 2008
Versi 3 Perubahan dari versi sebelumnya 1.Proses mangle berdasarkan address-list 2.Pemisaha
Gambar 1. skenario jaringan Penjelasan : 1.Mikrotik router dengan 2 network interface card
kita namai. Kelompok ini bisa digunakan sebagai parameter dalam mangle, firewall filter, NA
. dst...
Simpanlah file tersebut ke komputer anda dengan nama nice.rsc, lalu lakukan FTP ke router M
C:\>dir nice.*ftp 192.168.0.1admin********asciiput nice.rscbye Volume in drive C has no lab
150 Opening ASCII mode data connection for '/nice.rsc' 226 ASCII transfer complete ftp: 175
Setelah file di upload, import-lah file tersebut.
[admin@MikroTik] > import nice.rsc Opening script file nice.rsc Script file loaded and exec
Pastikan bahwa proses import telah berlangsung dengan sukses, dengan mengecek Address-List
Pengaturan Mangle Berikut adalah perintah untuk melakukan konfigurasi mangle yang bisa dila
add chain=forward src-address-list=nice action=mark-connection new-connectionmark=mark-con-
Anda juga dapat mengembangkan queue type menggunakan pcq sehingga trafik pada setiap client
Memblokir Situs dengan MikrotikRouterOS
Untuk memblokir suatu situs dengan MikrotikRouterOS maka langkahnya adalah: 1. Aktifkan web
Memanipulasi ToS ICMP & DNS di MikroTik
Tujuan : o Memperkecil delay ping dari sisi klien ke arah Internet. o Mempercepat resolving
> queue tree add name=ICMP parent=INTERNET packet-mark=ICMP-PM priority=1 limit-at=8000 max
Queue dengan SRC-NAT dan WEB-PROXY
Pada penggunaan queue (bandwidth limiter), penentuan CHAIN pada MENGLE sangat menentukan ja
[admin@instaler] ip firewall nat> pr Flags: X - disabled, I - invalid, D - dynamic 0 chain=
dst-address=172.21.1.0/24 action=mark-packet new-packet-mark=test-down passthrough=no Untuk
Blocking Virus di Firewall Mikrotik
1;;; BLOCK SPAMMERS OR INFECTED USERS chain=forward protocol=tcp dst-port=25 src-address-li
add chain=prerouting connection-mark=voip-con action=mark-packet \ new-packet-mark=voip pas
Setting Mikrotik RouterOS PPPoE Client Sebagai Internet Gateway Telkom Speedy
Kmareen nyoba - nyoba gimana seeh dial speedy melalui mikrotik dan apa keuntungannya diband
(Klik Untuk memperbesar) kemudian isi VPI dan VCI dengan 8 dan 81
setelah itu pilih menu bridging dan masukkan nama service nya setelah semua dilakuakan klik
reboot modem maka modem saat ini sudah berfungsi sebagai bridge. Langkah kedua Langkah yang
Isikan nama service lalu pilih interface yang terhubung langsung ke modem.
setelah itu pilih tab Dial Out isikan username yang diberikan telkom beseta passwordnya, bi
lalu tahap akhir klik tombol OK maka secara otomatis mikrotik akan DIAL ke telkom. – END SE
keunggulannya menggunakan mikrotik sebagai modem ketimbang modem ADSL biasa :
•Proses dial nya lebih cepat dibandingkan dengan menggunakan modem adsl biasa,
biasanya mikrotik mendapatkan status connected dalam waktu kurang dari 15 detik, jika modem
Setting Mikrotik RouterOS PPPoE Client Sebagai Internet Gateway Telkom Speedy
Kita mulai setup dari modem adsl nya sebagai brigding protocol mode. Settingnya dapat anda
Selesai setting modem sebagai bridging yang tidak menyimpan password dan user ID anda di mo
Sebetulnya perintah diatas dapat anda lakukan di winbox, jika ingin lebih mudah sambil cek
Setting MIKROTIK SDSL SPEEDY – BANDWITH MANAGEMENT
Sebelumnya saya gambarkan dulu skema jaringannya: LAN —> Mikrotik RouterOS —> Modem ADSL —>
Agar semua komputer yg ada di LAN bisa terhubung ke internet juga, maka Anda perlu menambah
Lalu, jumlah komputer klien yang ada saat ini adalah 10 buah. Jadi harus disiapkan bandwidt
Nanti akan ada pilihan interface apa aja yg ada di router Anda. Coba klik salah satu, maka
Membatasi inetan di kantor........dengan mikrotik..
Lanjut ah, sharing cara membatasi inetan dikantor....lagi-lagi dengan mikrotik. Kantor saya
Lock IP dan MAC address client di Mikrotik....
Mungkin anda pernah mengalami, ada client nakal yang coba-coba memakai ip komputer admin un
4. 5.Isikan nama sesuai keinginan anda asal mudah diingat, kemudian IP client. Prosedur ini
6.
7.Gambar diatas adalah merubah rule/script dari nat-masquerade yang sudah ada, dimana biasa
9. 10.Interface dipilih interface yang ada dimikrotik yang mengarah ke LAN, untuk address r
11. 12.Maka didalam ARP list akan muncul ip dan mac-address dari client. Selanjutnya adalah
13. 14.Pilih interface yang menuju klien, klik kiri dua kali sehingga muncul gambar seperti
Mengamankan web-proxy kita.....
Setelah kita berhasil menggabungkan smoothwall dengan mikrotik. Apabila koneksi kita menggu
2. 3.Ikuti option-option diatas,untuk jenis koneksi selain speedy tinggal menyesuaikan "in-
4.Langkah ke-2 diulang untuk port-port:3128,808 5.Selesai
Setting VPN di mikrotik memakai PPtP...
Pengantar.. Sebenernya agak males untuk menulis masalah setting VPN ini, dikarenakan banyak
3. 4.untuk nama bisa diberikan sesuai dengan keinginan anda, yang penting mudah diingat 5.u
7.Untuk nama silahkan cari yang unik, kemudian local address diisikan dengan ip mikrotik ya
10.Pada bagian ini untuk memberikan akses/username untuk menggunakan atau login ke VPN kita
12. 13.Silahkan diikuti semua option diatas kemudian klik OK, maka telah selesai setting VP
1.
2.
3.
4.
5.
6.
7.
8. Selesai.... Selamat mencoba
Setting Linksys AG241 dan Mikrotik untuk akses speedy
Pengantar... Kenapa yang digunakan adalah Linksys AG241 tidak yang lain? jawabnya simpel, d
1.Modem AG241 dihubungkan dengan PC menggunakan kabel UTP yang sudah disiapkan 2.IP PC diru
6.
7. 8.Setting gambar diatas untuk daerah jakarta tepatnya daerah bekasi, untuk daerah lainny
4.Pada tab general ini yang diisi hanya bagian interface, dipilih WAN 5.pindah ke tab dial
6.Pada tab dial out, yang diisi hanyalah username dan password saja. isikan username dan pa
12.Pilih chain :srcnat, src.address:192.168.0.0/24, out.interface=pppoe-out2, kemudian pind
13.untuk action silahkan pilih: masquerade
Remote Mikrotik bagi pengguna ip public dynamis....
Pengantar... Bagi anda sekalian pengguna ISP Tel**m aka Speeda, yang berlangganan paket opi
Dengan bantuan sebuah website (disini websitenya) kita dapat meremote mikrotik kita tanpa p
:log info "DDNS: Begin" :global ddns-user "YOURUSERID" :global ddns-pass "YOURPASSWORD" :gl
Untuk Mikrotik v3.x.x
# Define User Variables :global ddnsuser "CHANGEIPUSERID" :global ddnspass "CHANGEIPPASSWOR
# Define Global Variables :global ddnsip :global ddnslastip :if ([ :typeof $ddnslastip ] =
Pada bagian On Event, tuliskan nama script yang anda buat tadi. Selesai, selamat mencoba.
Menggabungkan Smoothwall dgn Mikrotik
Pengantar Tidak bisa dipungkiri jika keberadaan webproxy (jika diconfigure dengan baik, dan
tersebut mikrotik mempunyai nilai lebihnya. Skema Jaringan | Inet Cloud |-------| Modem |--
Setelah di ENTER maka akan muncul :
Lalu
Tekan OK, lalu tekan enter dua kali sehingga akan muncul...
Jika anda sebelumnya pernah menginstall smoothwall dan menyimpan backup confignya kedalam f
Jika untuk pertama kali menginstall smoothwall maka cukup tekan tombol No. kemudian pilih k
kemudian masuk ke pemilihan topologi smoothwall
pilih green + red
Kemudian muncul tampilan konfirmasi untuk mengubah config network
klik OK, lakukan probe untuk mendeteksi secara otomatis kartu jaringan anda
Setelah semua kartu jaringan terdeteksi, kemudian kita berikan IP-nya
Untuk kasus saya ini IP untuk GREEN dan RED diisikan IP dalam satu subnet, jadi misalkan un
Isikan DNS dan default gatewaynya, untuk default gateway isikan ip mikrotik yang mengarah k
Dikarenakan akan menggunakan addons advproxy dkk, maka untuk section ini langsung saja klik
Isikan password yang anda inginkan untuk mengakses smoothwall melalui web browser (user: ad
Isikan password yang anda inginkan untuk mengakses smoothwall melalui terminal (user: root)
Installasi telah selesai, Klik OK untuk reboot. silahkan antara mikrotik dan smoothwall sal
mengetik ip_smoothwall:81 di browser, sehingga akan muncul dibrowser anda seperti ini.
Setelah masuk ke configure smoothwall, langsung aja masuk ke tab service-->remote access..
ceklist bagian ssh, kemudian save... Kemudian masuk ke tab maintenance --> updates untuk me
Jika koneksi keinternet anda tidak bermasalah maka akan terdapat updates-updates yang beras
sama, maka akan muncul selain updates terbaru dari website smootwall (jika ada yang baru da
untuk option yang diceklist silahkan melihat gambar diatas, untuk proxyport bisa memakai 80
acl store_rewrite_list url_regex ^http://i(.*?).photobucket.com/albums/(.*?)/(.*?)/(.*?)\?
acl file_terlarang url_regex -i URLDownload.exe acl file_terlarang url_regex -i od-stnd67.e
refresh_pattern -i \.(jpe|tif)$ 10080 90% 43200 override-expire refresh_pattern -i \.(mpe|w
lastmod ignore-reload reload-into-ims refresh_pattern ^http://www.usercash.com/.* 180 100%
refresh_pattern ^http://www.friendster.com/.* 180 100% 4320 override-expire overridelastmod
masuk kedirektory hasil uncompress dan jalankan ./install setelah selesai install, melalui
Untuk update blacklist-nya bisa disini setelah semua option yang diinginkan untuk difilter
masuk kedirektory hasil uncompress dan jalankan ./install Setelah berhasil install maka di
Load Balancing Dual DSL Speedy di Satu Router
Jumat, 7 September 2007M 24 Syaban 1428H •data recovery •Dating •Laura Ashley •HP Compaq RA
Banyak pertanyaan dari teman-teman, terutama para operator warnet, admin jaringan sekolah/k
namun banyak yang merasa kesulitan pada saat diintegrasikan. Penyebab utamanya adalah karen
anda dicegat di persimpangan oleh polisi dan polisi menanyakan “anda dari mana?” dan anda a
online, namun koneksi tetap di satu link Batman & Robin, sehingga pada saat link Batman jat
net.inet.ip.forwarding=1
2. Pastikan konfigurasi interface dan default routing kosong, hanya filename saja
# /etc/hosts.sk0 # /etc/hosts.sk1 # /etc/hostname.sk0 # /etc/hostname.sk1 # /etc/mygate
Script koneksi DSL Speedy, pppoe0 untuk koneksi pertama dan pppoe1 untuk koneksi kedua. Ses
# /etc/ppp/ppp.conf default: set log Phase Chat LCP IPCP CCP tun command set redial 15 0 se
pppoe1: set device "!/usr/sbin/pppoe -i sk1" disable acfcomp protocomp deny acfcomp set mtu
3. Aktifkan interface sk0 dan sk1
# ifconfig sk0 up # ifconfig sk1 up
4. Jalankan PPPoE, Point to Point Protocol over Ethernet.
# ppp -ddial pppoe0 # ppp -ddial pppoe1
5. Jika koneksi Speedy berhasil, IP address dari Speedy akan di-binding di interface tunnel
# ifconfig tun0: flags=8051 mtu 1492 groups: tun egress inet 125.xxx.xxx.113 --> 125.163.72
6. Dan default gateway akan aktif
# netstat -nr |more Routing tables Internet: Destination Gateway default 125.163.72.1
Flags UGS
Refs Use 7 17529
Mtu Interface - tun0
7. Serta konfigurasi resolver DNS pun akan terisi
# cat /etc/resolv.conf lookup file bind nameserver 202.134.2.5 nameserver 203.130.196.5
8. Aktifkan Packet Firewall pf
# /etc/rc.conf pf=”YES”
9. Script Packet Firewall NAT dan balancing dengan round-robin (ganti round-robin dengan lo
# /etc/pf.conf lan_net = "10.0.0.0/8" int_if = "vr0" ext_if1 = "tun0" ext_if2 = "tun1" ext_
10. Aktifkan script yang diperlukan di /etc/rc.local agar setiap reboot langsung bekerja.
ifconfig sk0 up ifconfig sk1 up # aktifkan speedy ppp -ddial pppoe0 ppp -ddial pppoe1
PF akan langsung bekerja membaca /etc/pf.conf. Jika harus me-restart koneksi DSL Speedy, pa
# pkill ppp
Jika tidak, maka ppp akan membuat tunneling baru menjadi tun2, tun3 dan seterusnya. 11. Unt
Jika anda mengoptimasikan koneksi jaringan juga dengan menggunakan proxy, misalnya Squid, m
Memisahkan Bandwidth Lokal dan International menggunakan Mikrotik
From SpeedyWiki
Jump to: navigation, search
Written by harijanto@datautama.net.id http://www.datautama.net.id Wednesday, 08 November 20
Versi 3 Perubahan dari versi sebelumnya: 1.Proses mangle berdasarkan address-list 2.Pemisah
Gambar 1. Skenario Jaringan Penjelasan: 1.Mikrotik Router dengan 2 Network Interface Card (
http://203.89.24.3/cgi-bin/lg.cgi
Pilih Query dengan men-cek-list BGP dan klik Submit
Gambar 2. Hasil Query http://lg.mohonmaaf.com untuk perintah “show ip bgp” Fungsi dari http
semua alamat Network yang diadvertise oleh router-router BGP ISP lokal Indonesia pada BGP r
/ ip firewall address-list add list=nice address=58.65.240.0/23 comment="" disabled=no add
untuk mendapatkan script diatas dapat melalui URL berikut:
http://www.datautama.net.id/harijanto/mikrotik/datautama-nice.php
URL diatas secara online akan melakukan query ke router NICE dari http://lg.mohonmaaf.com C
http://ixp.mikrotik.co.id/download/nice.rsc
atau dari
http://www.datautama.net.id/harijanto/mikrotik/datautama-nice.php
yang datanya dari looking glass DatautamaNet dari hasil URL diatas copy lalu paste ke mikro
\... add address=222.124.64.0/23 list="nice" [datautama@router-01-jkt] > /ip firewall addre
dimana 222.124.64.0/21 adalah supernet dari 222.124.64.0/23 artinya diantara dua blok ip te
Selanjutnya pada /ip firewall mangle perlu dilakukan konfigurasi sbb:
/ ip firewall mangle add chain=forward src-address-list=nice action=mark-connection \ new-c
Langkah selanjutnya adalah mengatur bandwidth melalui queue simple, untuk mengatur bandwidt
/ queue simple add name="harijant-indonesia" target-addresses=192.168.2.4/32 \ dst-address=
Script diatas berarti hanya komputer dengan IP 192.168.2.4 saja yang di batasi bandwidthnya
Gambar 3. simple queue untuk komputer 192.168.2.4 Dengan demikian maka komputer 192.168.2.4
Gambar 4. Hasil bandwidth meter komputer 192.168.2.4 ke lokal ISP
Gambar 5. Hasil bandwidth meter ke ISP internasional Dengan demikian berarti Mikrotik telah
packet-mark=!indonesia artinya “packet-mark=bukan paket Indonesia”, padahal “bukan paket In
http://www.mikrotik.com/docs/ros/2.9/RouterOS_Reference_Manual_v2.9.pdf
Script diatas dapat diimplementasikan pada Mikrotik Versi 2.9.27 , untuk versi mikrotik seb
Load Balancing Sederhana Pakai Mikrotik
From SpeedyWiki
Jump to: navigation, search Sumber abdi_wae http://opensource.telkomspeedy.com/forum/viewto
modem1 --+--- eth0 mikrotik --- eth2 LAN +--- eth1 modem2 ---
manualnya ada disini : http://www.mikrotik.com/testdocs/ros/2.9/ip/route.php
Load Balancing over Multiple Gateways
From MikroTik Wiki
Jump to: navigation, search The typical situation where you got one router and want to conn
Of course, you want to do load balancing! There are several ways how to do it. Depending on
Policy Routing based on Client IP Address
If you have a number of hosts, you may group them by IP addresses. Then, depending on the s
•192.168.100.1-127 are used for Group A workstations •192.168.100.128-253 are used for Grou
All workstations have IP configuration with the IP address from the relevant group, they al
•Group A is 192.168.100.0/25, i.e., addresses 192.168.100.0-127 •Group B is 192.168.100.128
We need to add two IP Firewall Mangle rules to mark the packets originated from Group A or
•Chain prerouting and Src. Address 192.168.100.0/25 •Action mark routing and New Routing Ma
It is a good practice to add a comment as well. Your mangle rules might be interesting for
•Chain prerouting and Src. Address 192.168.100.128/25 •Action mark routing and New Routing
All IP traffic coming from workstations is marked with the routing marks GroupA or GroupB.
This thing is not going to work, unless you do masquerading for your LAN! The simplest way
Test the setup by tracing the route to some IP address on the Internet! From a workstation
C:\>tracert -d 8.8.8.8 Tracing route to 8.8.8.8 over a maximum of 30 hops 1 2 ms 2 10 ms ..
From a workstation of Group B, it should go like this:
C:\>tracert -d 8.8.8.8 Tracing route to 8.8.8.8 over a maximum of 30 hops 1 2 ms 2 10 ms ..
You can specify the DNS server for workstations quite freely, j Articles
Load Balancing dan Fail Over [Group] pada Mikrotik
Pending Written on Aug-19-08 3:08pm/19/2008 8:08 GMT - Not yet published to a wikizine
From: mellasaeblog.blogspot.com
Load Balancing dan Fail Over [Group] pada Mikrotik
April 27th, 2008 by admin
Load Balancing dan Fail Over [Group] 2 Speedy [atau lebih ] dibawah ini akan di bahas tekhn
Tutorial bisa di Download Disini
Seumpama kita mempunyai address seperti ini :
IP Modem satu adalah 192.168.110.1 dengan interface ”Wanatas” dan IP Modem yang satunya ada
Masuk ke IP >> Firewall Dan pilih tab Addess Lists dan Add
Seperti contoh diatas saya bikin Group A dan B dan dibawah adalah tampilan ketika tombol ad
Jika sudah menentuka blok IP berdasarkan group maka kita lanjut ke sesi berikutnya yaitu :
Tetap pada Window Firewall tapi pindah ke Tab Mangel yang seperti saya lingkari berwarna me
Maka akan muncul Window seperti dibawah ini :
Chain pilih prerouting kemudian pilih tab Advance Jika sudah pilih Src Address List , jika
Jika sudah pilih Tab Action maka akan muncul Window seperti di bawah ini :
Pilih action menjadi mark routing dan isikan New Routing Mark sesuai nama dari Group IP , s
IP >> Route : maka akan muncul Window Route List
pilih Add dan akan muncul Window dibawah ini :
isikan gatheway dengan IP modem pertama , yaitu 192.168.110.1 kemudian agar Fail Over maka
agar dapat menambahkan lebih dari satu gatheway, klik panah yang mengarah kebawah
yang sejajar dengan text box dari Gathway. Jika sudah Setelah tekan Tombol Apply pastikan I