Anda di halaman 1dari 3

FACULTAD DE INGENIERIA

TECNICAS DE PROGRAMACION

EPIE

SESION 03 PSEUDOCODIGO - EJEMPLOS


1. Realizar el pseudocdigo de un problema que permita calcular el rea de un
rectngulo. Se debe introducir la base y la altura para poder realizar el clculo.
INICIO
DATOS
VARIABLES
BASE, ALTURA, AREA son nmero enteros
ALGORITMO
escribir Introduzca la base y la altura
leer BASE, ALTURA
calcular AREA = BASE * ALTURA
escribir El rea del rectngulo es AREA
FIN
2. Realizar el pseudocdigo que permita al usuario introducir por teclado dos notas,
calculando la suma y el producto de las notas.
INICIO
DATOS
VARIABLES
NOTA1,NOTA2,SUMA,PRODUCTO son nmeros enteros
ALGORITMO
escribir Introduzca las notas
leer NOTA1,NOTA2
calcular SUMA = NOTA1 + NOTA2
calcular PRODUCTO = NOTA1 * NOTA2
escribir La suma de las dos notas es: SUMA
escribir El producto de las dos notas es :PRODUCTO
FIN
3. Disear e l pseudocdigo correspondiente a un programa que lea el valor
correspondiente a una distancia en millas marinas y las escriba expresadas en
metros. Sabiendo que 1 milla marina equivale a 1852 metros.
INICIO
DATOS
CONSTANTES
MILL_METR Numrico Entero = 1852
VARIABLES
Dmillas
Numrico Entero
Dmetros
Numrico Entero
ALGORITMO:
Escribir Distancia en millas:
Leer Dmillas
Calcular Dmetros = Dmillas * MILL_METR
Escribir Distancia en metros:, Dmetros
FIN

4. Disear el pseudocdigo correspondiente a un programa que con dos nmeros


enteros y muestre su suma, resta, multiplicacin, divisin y el resto (mdulo) de la
_________________________________________________________________________________________
Ing. Edwin Valencia

e-mail: evalencia_01@hotmail.com

Pg.1

FACULTAD DE INGENIERIA
TECNICAS DE PROGRAMACION

EPIE

divisin. Si la operacin no es conmutativa, tambin se mostrar el resultado


invirtiendo los operadores
INICIO
DATOS
VARIABLES
num1 Numrico Entero
num2 Numrico Entero
ALGORITMO:
Leer num1, num2
Escribir n1 + n2 = , num1+num2
Escribir n1 - n2 = , num1-num2
Escribir n2 - n1 = , num2-num1
Escribir n1 * n2 = , num1*num2
Escribir n1 / n2 = , num1/num2
Escribir n2 / n1 = , num2/num1
Escribir n1 mod n2 = , num1 mod num2
Escribir n2 mod n1 = , num2 mod num1
FIN
5. Disear el pseudocdigo de un problema que obtiene la ltima cifra de un nmero
dado
INICIO
DATOS
VARIABLES
num Numrico Entero
ALGORITMO:
Escribir Introduzca nmero:
Leer num
Escribir ltima cifra: , num mod 10
FIN
6. Disear pseudocdigo correspondiente a un programa que calcule el rea y el
permetro de un tringulo rectngulo dada la base y la altura.
INICIO
DATOS
VARIABLES
base
Numrico Entero
altura
Numrico Entero
area
Numrico Real
hipotenusa Numrico Real
perimetro Numrico Real
ALGORITMO
Leer base, altura
area = base * altura / 2
hipotenusa = Raiz (base^2 + altura^2)
perimetro = base + altura + hipotenusa
Escribir rea = , area
Escribir Permetro = , permetro
FIN
7. Disear e l pseudocdigo correspondiente a un problema que permita saber el
mayor de dos nmeros enteros daos.
_________________________________________________________________________________________
Ing. Edwin Valencia

e-mail: evalencia_01@hotmail.com

Pg.2

FACULTAD DE INGENIERIA
TECNICAS DE PROGRAMACION

EPIE

INICIO
DATOS
VARIABLES
Num1
Entero
Num2
Entero
ALGORITMO:
Escribir Ingrese dos nmeros enteros:
Leer Num1, Num2
SI Num1 > Num2 ENTONCES
Escribir Num1 es el mayor
SINO
Escribir Num2 es el mayor
FIN SI
FIN
8. Realizar el pseudocdigo de un programa que permita saber si un nmero es mayor,
menor o igual a cero.
INICIO
DATOS
VARIABLES
NUMERO nmero entero
ALGORITMO
Escribir Introduzca un nmero
Leer NUMERO
SI NUMERO>0 ENTONCES
Escribir El nmero introducido es positivo
SI NO
SI NUMERO<0 ENTONCES
Escribir El nmero introducido es negativo
SI NO
Escribir El nmero es cero
FIN SI
FIN SI
FIN

_________________________________________________________________________________________
Ing. Edwin Valencia

e-mail: evalencia_01@hotmail.com

Pg.3