Anda di halaman 1dari 4

How to Configure BGP Local

Preference Attribute
BGP attribute local preference is the second BGP attribute and it can be used
to choose the exit path for an autonomous system. Here are the details:

Local preference is the second BGP attribute.

You can use local preference to choose the outbound external BGP
path.

Local preference is sent to all internal BGP routers in your


autonomous system.

Not exchanged between external BGP routers.

Local preference is a well-known and discretionary BGP attribute.

Default value is 100.

The path with the highest local preference is preferred

Let me show you an example:

You can use local preference to configure your autonomous system to select
a certain exit point. Instead of configuring weight on each router you can use
local preference because it is exchanged on all internal BGP routers. By
increasing the local preference to 800 we can make AS 1 send all traffic
towards AS 2.
A well-known discretionary BGP attribute must be recognized by all BGP
routers per RFC but its presence in a BGP update is optional.
Now let me show you how to configure local preference, here is the topology
that we will use:

In the picture above we have two autonomous systems. Router James will
advertise network 1.1.1.0/24 towards AS 2 and router Jack will have to make
a choice when it wants to reach this network. It can go through router Jim or
Jack, well see how local preference influence this.
James(config)#router bgp 1
James(config-router)#neighbor 192.168.12.2 remote-as 2
James(config-router)#neighbor 192.168.13.3 remote-as 2
James(config-router)#network 1.1.1.0 mask 255.255.255.0

This is the configuration of router Jack, nothing spectacular here.


Jim(config)#interface loopback 0
Jim(config-if)#ip address 2.2.2.2 255.255.255.0
Jim(config)#router ospf 1

Jim(config-router)#network 192.168.24.0 0.0.0.255 area 0


Jim(config-router)#network 2.2.2.0 0.0.0.255 area 0
John(config)#interface loopback 0
John(config-if)#ip address 3.3.3.3 255.255.255.0
John(config)#router ospf 1
John(config-router)#network 192.168.34.0 0.0.0.255 area 0
John(config-router)#network 3.3.3.0 0.0.0.255 area 0
Jack(config)#interface loopback 0
Jack(config-if)#ip address 4.4.4.4 255.255.255.0
Jack(config)#router ospf 1
Jack(config-router)#network 192.168.24.0 0.0.0.255 area 0
Jack(config-router)#network 192.168.34.0 0.0.0.255 area 0
Jack(config-router)#network 4.4.4.0 0.0.0.255 area 0

Ill configure OSPF within AS2 to prepare it for IBGP.


John(config)#router bgp 2
John(config-router)#neighbor 192.168.13.1 remote-as 1
John(config-router)#neighbor 2.2.2.2 remote-as 2
John(config-router)#neighbor 2.2.2.2 update-source loopback0
John(config-router)#neighbor 4.4.4.4 remote-as 2
John(config-router)#neighbor 4.4.4.4 update-source loopback0
John(config-router)#neighbor 4.4.4.4 next-hop-self
Jim(config)#router bgp 2
Jim(config-router)#neighbor 192.168.12.1 remote-as 1
Jim(config-router)#neighbor 3.3.3.3 remote-as 2
Jim(config-router)#neighbor 3.3.3.3 update-source loopback0
Jim(config-router)#neighbor 4.4.4.4 remote-as 2
Jim(config-router)#neighbor 4.4.4.4 update-source loopback0
Jim(config-router)#neighbor 4.4.4.4 next-hop-self
Jack(config)#router bgp 2
Jack(config-router)#neighbor 2.2.2.2 remote-as 2
Jack(config-router)#neighbor 2.2.2.2 update-source loopback 0
Jack(config-router)#neighbor 3.3.3.3 remote-as 2
Jack(config-router)#neighbor 3.3.3.3 update-source loopback 0

And above you can see the BGP configurations.


Now lets find out what path router Jack will use to reach network 1.1.1.0/24:

Anda mungkin juga menyukai