Anda di halaman 1dari 13

Task 1: Configure a VLAN

Step 1:
Enter this sequence of commands on SW1:

SW2#configure terminal
SW2(config)#interface vlan 1
SW2(config-if)#ip address 10.1.1.12 255.255.255.0
SW2(config-if)#no shutdown

Step 2:

SW1#configure terminal
SW1(config)#interface Ethernet 1/1
SW1(config-if)#no shutdown

Step 3:
The ping should be successful, because ports on both PCs are access ports belonging to VLAN1.

PC1#ping 10.1.1.101
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.101, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/4 ms

Step 4:

Enter this sequence of commands on SW1:

SW1#configure terminal
SW1(config)#vlan 10
SW1(config)-vlan)#vlan 20
Enter this sequence of commands on SW2:

SW2#configure terminal
SW2(config)#vlan 10
SW2(config)-vlan)#vlan 20

Step 5:
Enter this sequence of commands on SW1:

SW1(config)#interface Ethernet0/1
SW1(config-if)#switchport access vlan 10
SW1(config-if)#exit
SW1(config)#ip route 0.0.0.0 0.0.0.0 10.1.1.1
Enter this sequence of commands on SW2:

SW2(config)#interface Ethernet0/1
SW2(config-if)#switchport access vlan 20
SW2(config-if)#exit
SW2(config)#ip route 0.0.0.0 0.0.0.0 10.1.1.1

Step 6:

Enter the following commands on the SW1 switch.

SW1#copy running-config startup-config


Destination filename [startup-config]? <Enter>
Building configuration...
[OK]
Enter the following commands on the SW2 switch.

SW2#copy running-config startup-config


Destination filename [startup-config]? <Enter>
Building configuration...
[OK]

Step 7:
This step provides PC1 addressing in accordance with its VLAN assignment.

PC1(config)#interface Ethernet0/0
PC1(config-if)#ip address 10.1.10.100 255.255.255.0
PC1(config-if)#exit
PC1(config)#ip default-gateway 10.1.10.1

Step 8:
This step provides PC2 addressing in accordance with its VLAN assignment.

PC2(config)#interface Ethernet0/0
PC2(config-if)#ip address 10.1.20.100 255.255.255.0

PC2(config-if)#exit
PC2(config)#ip default-gateway 10.1.20.1

Step 9:
SW1 should have Ethernet0/1 belonging to VLAN10, and SW2 should have Ethernet0/1 belonging to VLAN20.

SW1#show vlan
VLAN Name

Status

Ports

---- -------------------------------- --------------------------------------1

default

active

Et0/0, Et0/2, Et0/3, Et1/0


Et1/2, Et1/3, Et2/0, Et2/1
Et2/2, Et2/3, Et3/0, Et3/1
Et3/2, Et3/3, Et4/0, Et4/1
Et4/2, Et4/3, Et5/0, Et5/1
Et5/2, Et5/3

10

VLAN0010

active

20

VLAN0020

active

1002 fddi-default

act/unsup

1003 token-ring-default

act/unsup

1004 fddinet-default

act/unsup

Et0/1

1005 trnet-default

act/unsup

<output omitted>
SW2#show vlan
VLAN Name

Status

Ports

---- -------------------------------- --------------------------------------1

default

active

Et0/0, Et0/2, Et0/3, Et1/1


Et1/2, Et1/3, Et2/0, Et2/1
Et2/2, Et2/3, Et3/0, Et3/1
Et3/2, Et3/3, Et4/0, Et4/1
Et4/2, Et4/3, Et5/0, Et5/1
Et5/2, Et5/3

10

VLAN0010

active

20

VLAN0020

active

1002 fddi-default

act/unsup

1003 token-ring-default

act/unsup

1004 fddinet-default

act/unsup

1005 trnet-default

act/unsup

<output omitted>

Et0/1

Step 10:
The connectivity test should not be successful. You first need to configure a trunk between switches that will
carry traffic from both VLANs and then configure a Layer 3 device that will route between those two VLANs.

PC1#ping 10.1.20.100
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.20.100, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Task 2: Configure the Link Between Switches as a Trunk

Step 1:
Enter this sequence of commands on the SW1 switch:

SW1(config)#interface Ethernet 1/1


SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport trunk allowed vlan 1,10,20
SW1(config-if)#switchport mode trunk
Enter this sequence of commands on the SW2 switch:

SW2(config)#interface Ethernet 1/0


SW2(config-if)#switchport trunk encapsulation dot1q
SW2(config-if)#switchport trunk allowed vlan 1,10,20
SW2(config-if)#switchport mode trunk

Step 2:

Enter the following commands on the SW1 switch.

SW1#copy running-config startup-config


Destination filename [startup-config]? <Enter>
Building configuration...
[OK]
Enter the following commands on the SW2 switch.

SW2#copy running-config startup-config


Destination filename [startup-config]? <Enter>
Building configuration...
[OK]

Step 3:

SW1#show interfaces trunk


Port

Mode

Encapsulation

Status

Native vlan

Et1/1

on

802.1q

trunking

Port

Vlans allowed on trunk

Et1/1

1,10,20

<output omitted>

On switch SW2, verify that the link toward SW1 is trunking and that VLANs 1,10, and 20 are the only VLANs
that are allowed.

SW2#show interfaces trunk


Port

Mode

Encapsulation

Status

Native vlan

Et1/0

on

802.1q

trunking

Port

Vlans allowed on trunk

Et1/0

1,10,20

<output omitted>

Step 4:
The connectivity test will not be successful. You need to configure a Layer 3 device that will route between
those two VLANs.
From PC1, ping PC2 (10.1.20.100).

PC1#ping 10.1.20.100
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.20.100, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Task 3: Configure Trunk Link on the Router

Step 1:
Enter this sequence of commands on the SW1 switch:

SW1(config)#interface Ethernet 1/0


SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport trunk allowed vlan 1,10,20
SW1(config-if)#switchport mode trunk

Step 2:
Enter the following commands on the SW1 switch.

SW1#copy running-config startup-config


Destination filename [startup-config]? <Enter>
Building configuration...
[OK]

Step 3:
Enter the following commands on the Branch router.

Branch#configure terminal
Branch(config)#interface Ethernet0/0
Branch(config-if)#no ip address

Step 4:
Enter the following commands on the Branch router.

Branch(config)#interface Ethernet 0/0.1

Branch(config-if)#encapsulation dot1q 1
Branch(config-if)#ip address 10.1.1.1 255.255.255.0
Branch(config-if)#exit
Branch(config)#interface Ethernet 0/0.10
Branch(config-if)#encapsulation dot1q 10
Branch(config-if)#ip address 10.1.10.1 255.255.255.0
Branch(config-if)#exit
Branch(config)#interface Ethernet 0/0.20
Branch(config-if)#encapsulation dot1q 20
Branch(config-if)#ip address 10.1.20.1 255.255.255.0

Step 5:
Enter the following commands on the Branch router.

Branch#copy running-config startup-config


Destination filename [startup-config]? <Enter>
Building configuration...
[OK]

Step 6:

Branch#show vlans
Virtual LAN ID:

1 (IEEE 802.1Q Encapsulation)

vLAN Trunk Interface:

Ethernet0/0.1

This is configured as native Vlan for the following interface(s) :


Ethernet0/0
Protocols Configured:
Transmitted:

Address:

IP

10.1.1.1

Received:
0

0
Other

4
119 packets, 7992 bytes input
4 packets, 1170 bytes output
Virtual LAN ID:

10 (IEEE 802.1Q Encapsulation)

vLAN Trunk Interface:

Ethernet0/0.10

Protocols Configured:
Transmitted:

Address:

IP

10.1.10.1

Received:
0

0
Other

1
56 packets, 3808 bytes input
1 packets, 46 bytes output
Virtual LAN ID:

20 (IEEE 802.1Q Encapsulation)

vLAN Trunk Interface:

Ethernet0/0.20

Protocols Configured:
Transmitted:

Address:

IP

10.1.20.1

Received:
0

0
Other

1
42 packets, 2856 bytes input
1 packets, 46 bytes output

Step 7:
The attempt should be successful. The first ping or first few pings might fail due to the ARP resolution process.

PC1>ping 10.1.20.100
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.20.100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/12 ms

Step 8:
Notice that the traffic goes through the Branch router.

PC1>traceroute 10.1.20.100
Type escape sequence to abort.
Tracing the route to 10.1.20.100
VRF info: (vrf in name/id, vrf out name/id)
1 10.1.10.1 4 msec 0 msec 0 msec
2 10.1.20.100 0 msec *

4 msec

Anda mungkin juga menyukai