Anda di halaman 1dari 8

Questo 1/5

Para manipulao de dados dentro de nossos algoritmos utilizamos quais elementos?


Explique cada um.
RESPOSTA:
Variveis e Constantes. Variveis que so alteradas constantemente no decorrer
do tempo de execuo dos algoritmos e constantes, que no sofrem variao no
decorrer do tempo de execuo do algoritmo.
Contedo da Aula 3, Slide 6.

Questo 2/5
Faa um algoritmo que exiba um relatrio de Totais e % por faixa-etria e sexo no
seguinte formato:
"*** Totais por faixa-etria e sexo ***
Nmero de meninas:
Nmero de mulheres:
Nmero de meninos:
Nmero de homens:
Total geral:
% de meninas:
% de mulheres:
% de meninos:
% de homens:
RESPOSTA:

algoritmo "estat"
var
x, idade,qt,fem_maior, fem_menor,masc_maior, masc_menor: inteiro
sexo:caracter

inicio

// Seo de Comandos
escreval("Digite a quantidade de entradas:")
leia(qt)
enquanto x < qt faca

escreva("Digite uma idade: ")


leia(idade)
escreva("Digite o sexo (f/m): ")
leia(sexo)

se (idade<18) e (sexo="f") entao


fem_menor<-fem_menor+1
fimse

se (idade<18) e (sexo="m") entao


masc_menor<-masc_menor+1
fimse

se (idade>=18) e (sexo="f") entao


fem_maior<-fem_maior+1
fimse

se (idade>=18) e (sexo="m") entao

masc_maior<-masc_maior+1
fimse

x<-x+1
fimenquanto

escreval("*** Totais por faixa-etria e sexo ***")


escreval("Nmero de meninas: ",fem_menor)
escreval("Nmero de mulheres: ",fem_maior)
escreval("Nmero de meninos: ",masc_menor)
escreval("Nmero de homens: ",masc_maior)
escreval("Total geral:",qt)

escreval("% de meninas: ",fem_menor*100/qt," %")


escreval("% de mulheres: ",fem_maior*100/qt," %")
escreval("% de meninos: ",masc_menor*100/qt," %")
escreval("% de homens: ",masc_maior*100/qt," %")

fimalgoritmo
Contedo das Aulas 9 e 10.

Questo 3/5

Faa um algoritmo que leia trs valores e descubra qual o menor valor.
RESPOSTA:
algoritmo "Menor3"
// Funo : Verificar o menor de tres numeros e ordem decrescente)
// Seo de Declaraes
var
n1,n2,n3: real

inicio
// Seo de Comandos
escreval("Digite tres nmeros quaisquer: ")
leia(n1)
leia(n2)
leia(n3)

se (n1=n2) e (n2=n3) entao


escreva ("Os tres numeros sao iguais :", n1, n2, n3)
senao
se (n1=n2) ou (n2=n3) ou (n1=n3) entao
escreva ("Ha numeros iguais :", n1, n2 ,n3)
senao

se (n1<n2) e (n1<n3) e (n2<n3) entao

escreva (" n1<n2<n3 ", n1,"<", n2,"<", n3)


fimse

se (n1<n3) e (n1<n2) e (n3<n2) entao


escreva (" n1<n3<n2 ", n1,"<", n3,"<", n2)
fimse

se (n2<n3) e (n2<n1) e (n3<n1) entao


escreva (" n2<n3<n1 ", n2,"<", n3,"<", n1)
fimse

se (n2<n1) e (n2<n3) e (n1<n3) entao


escreva (" n2<n1<n3 ", n2,"<", n1,"<", n3)
fimse

se (n3<n1) e (n3<n2) e (n1<n2) entao


escreva (" n3<n1<n2 ", n3,"<", n1,"<", n2)
fimse

se (n3<n2) e (n3<n1) e (n2<n1) entao


escreva (" n3<n2<n1 ", n3,"<", n2,"<", n1)
fimse
fimse

fimse

fimalgoritmo
Contedo da Aula 5.

Questo 4/5
Faa um algoritmo que escreva os quadrados de todos os nmeros pares entre 1 e 20
(inclusive).
RESPOSTA:
algoritmo "quadrados"
// Seo de Declaraes
var
i:inteiro

inicio
// Seo de Comandos

escreval("Quadrados dos numeros pares entre 1 e 20")


para i de 2 ate 20 passo 2 faca
escreva(i*i)
fimpara

fimalgoritmo
Contedo da Aula 7

Questo 5/5
Faa um algoritmo que crie uma funo de converso de uma temperatura em graus
celsius para uma temperatura em Farenheit.
A frmula para converso :

RESPOSTA:
algoritmo "conversaoCFf"
// Seo de Declaraes
var
far,celsius: real

funcao conv(c:real):real
var res: real
inicio

res<-9/5*c+32;
retorne res
fimfuncao

inicio
// Seo de Comandos

escreval("Informa a temperatura inicial em Graus Celsius:")


leia(celsius)

far<-conv(celsius)

escreval("Temperatura em Farehneit:", far)

fimalgoritmo
Contedo da Aula 8.