Anda di halaman 1dari 4

Balanceo de carga marcando PPPoE cliente

Bueno, salimos un poco de lo tpico, esta vez toca el balanceo de carga con 2 links
de internet marcando PPPoE cliente, ya sea que utilicemos modems ADSL o routers
en modo bridge. Es absolutamente necesario leer esta gua para proceder con este
manualhttp://www.ryohnosuke.com/foros/index.php?threads/1678/

1. Asignando IP's a las interfaces de red


CODE, HTML o PHP Insertado:

/ip address
add address=192.168.5.1/24 interface=ether5
En efecto, slo es necesario agregar el IP que ser el GW de nuestro balanceador,
esta asignada al ether5. Repito, no es necesario colocar un IP aether1 o
a ether2, ya que las verdaderas interfaces WAN sern pppoe-out1 y pppoeout2, cuyas IP se agregarn automticamente en IP -> Addresses

Ya deben de saber que las reglas que se agregan automticamente o


dinmicamente, tienen una D al lado izquierdo.
2. Configurando enmascarado de las interfaces de red WAN

En este caso como nuestras interfaces WAN son pppoe-out1 y pppoe-out2, toca
enmascarar ambas.
CODE, HTML o PHP Insertado:

/ip firewall nat


add chain=srcnat out-interface=pppoe-out1 action=masquerade
add chain=srcnat out-interface=pppoe-out2 action=masquerade
Y como es de esperarse, si tuviramos ms conexiones WAN por PPPoE cliente,
tocara agregar a cada una de ellas.
3. Configurando las rutas, parte 1

Si leyeron ya este manual http://www.ryohnosuke.com/foros/index.php?


threads/1678/ sabrn que en este caso se va a tener que colocar como GW nuestra
propia interfaz WAN, osea, pppoe-out1 y pppoe-out2
CODE, HTML o PHP Insertado:

/ip route
add gateway=pppoe-out1 distance=1
add gateway=pppoe-out2 distance=2
Sobre las distancias, esto ya est explicado en este misma gua y en el manual que
dej. En este caso no es necesario marcar hacer un check-gateway, ya que una
de las ventajas de tener PPPoE cliente, es que cuando uno de estos se desconecta,
automticamente la ruta se "desactiva", y como hablamos de una conexin directa
a internet, el failover es 'gratis'.
4. Configurando mangle, empieza la magia o los problemas para el que no pone
atencin

Es prcticamente lo mismo que la gua para router neutro, as que pasar de largo
la explicacin del proceso

4.1 Primera parte, todo lo que entre por un WAN, debe salir por el mismo
WAN
CODE, HTML o PHP Insertado:

/ip firewall mangle


add chain=prerouting in-interface=pppoe-out1 connection-state=new newconnection-mark=pppoe-out1_conn action=mark-connection passthrough=yes
add chain=prerouting in-interface=pppoe-out2 connection-state=new newconnection-mark=pppoe-out2_conn action=mark-connection passthrough=yes
add chain=output connection-mark=pppoe-out1_conn new-routing-mark=to_pppoeout1 action=mark-routing passthrough=yes
add chain=output connection-mark=pppoe-out2_conn new-routing-mark=to_pppoeout2 action=mark-routing passthrough=yes
4.2 Segunda parte, dividiendo las conexiones de los clientes y formando
grupos
CODE, HTML o PHP Insertado:

/ip firewall mangle


add chain=prerouting in-interface=ether5 connection-state=new dst-addresstype=!local per-connection-classifier=both-addresses:2/0 action=mark-connection
new-connection-mark=pppoe-out1_conn passthrough=yes
add chain=prerouting in-interface=ether5 connection-state=new dst-addresstype=!local per-connection-classifier=both-addresses:2/1 action=mark-connection
new-connection-mark=pppoe-out2_conn passthrough=yes
add chain=prerouting in-interface=ether5 connection-mark=pppoe-out1_conn
action=mark-routing new-routing-mark=to_pppoe-out1 passthrough=yes
add chain=prerouting in-interface=ether5 connection-mark=pppoe-out2_conn
action=mark-routing new-routing-mark=to_pppoe-out2 passthrough=yes
4.3 [Opcional] Tercera parte, accediendo a nuestros routers desde la red
balanceada
Ciertamente pasaremos de largo este opcional, ya que no considero necesario que
alguien quiera entrar a su modem o router modo bridge; una vez configurado como
tal, qu ms se va a querer configurar?

5. Configurando las rutas, parte 2


CODE, HTML o PHP Insertado:

/ip route
add gateway=pppoe-out1 routing-mark=to_pppoe-out1
add gateway=pppoe-out2 routing-mark=to_pppoe-out2