Anda di halaman 1dari 5

TCNICAS DE PROGRAMAO

ALGORTMO
Algoritmo o conjunto de instrues escritas de maneira lgica, ou seja, a soluo de um problema. A etapa
seguinte aps a sua construo a programao, utilizando-se de uma ferramenta de programao, por exemplo
Delphi, Visual Basic, etc.

Itens Fundamentais
Variveis Correspondem a posies de memria cujo o contedo pode variar durante a execuo de um
programa. Para nomear variveis em um algoritmo importante lembrar de algumas regras, tais como:
- Os nomes das variveis so formados por caracteres, sendo que o 1 caracter dever ser uma letra.;
- No pode conter caracteres especiais, exemplo ; : . , < > ? / { [ ! @ # ( - ] [ ) ;
- Deveremos tambm utilizar nomes lgicos para as variveis;
- Os nomes no podem conter espaos em branco;
- Os nomes de variveis devem conter no mximo 255 caracteres;
- No usar palavras reservadas da linguagem de programao que estiver utilizando, como por exemplo: for,
while, end, begin, var, etc.
Constante Uma constante corresponde a uma varivel que no pode ter o seu valor modificado durante a
execuo do algoritmo. Existem constantes numricas, de caractere ou lgica. Exemplos:
- Numrica: 5, 7, -5 ;
- Lgica: Falso (F), Verdadeiro (V), Sim (S), No (N);
- Caractere: Renato, x5, 27 as constantes de caracteres devem ser representadas entre aspas
Expresses Uma expresso pode ser a combinao de uma ou mais constantes, variveis, operadores e/ou
funes. As expresses mais comuns so as aritmticas que contm os operandos (constantes, variveis e/ou
funes) ligadas por um ou mais operadores ( + - * / ). Exemplo:
Valor * 10
Total (total * 0,2)
Sr + nome
Operadores Os operadores so representados por smbolos, funcionando como relacionamento que criam um
nico resultado. Existem os operadores aritmticos, relacionais, lgicos e de strings (cadeia de caracteres).
Operadores Aritmticos Os operadores matemticos a seguir esto em ordem de prioridade (de cima para baixo),
obedecendo a ordem em que so efetuadas as operaes.
Operao
Exponenciao
Multiplicao
Diviso
Adio
Subtrao
Inteiro da diviso
Resto da diviso

Operador
^
*
/
+
Div
Mod

Operadores Relacionais Os operadores relacionais servem para comparar dois valores de um mesmo tipo, e
nesta relao poderemos encontrar constantes, variveis ou expresses. Os operadores relacionais so:
Operao
Igual a
Diferente de
Menor que
Maior que
Menor que ou igual a
Maior que ou igual a
Membro de

Operador
=
<>
<
>
<=
>=
In

Operadores lgicos Os operadores lgicos tambm comparam valores do mesmo tipo para criar uma lgicas
verdadeira ou falsa, sim ou no, utilizando a lgica booleana. Os operadores lgicos so:
Operao

Operador
E
Ou
No
Xou

Conjuno
Disjuno
Negao
Excluso
A hierarquia entre os operadores so:
1 - As expresses que esto dentro do parnteses
2 - Operador de unio
3 - Operadores: *, /, div, mod, ^, and
4 - Operadores +, -, or, xor, not
5 - Operadores e, =, <, >, <=, >=, <>, in
Booleanos:

Not Inverte o resultado de uma expresso lgica


And Somente resultar Verdadeiro (true) se ambos os operandos forem true
Or true quando pelo menos 1 dos operandos for true
Xor exclusivo ou. S true se apenas um dos operandos for true.
Exemplo
T
T
F
F

AND
T
F
T
F

T
F
F
F

T
T
F
F

OR
T
F
T
F

T
T
T
F

T
T
F
F

XOR
T
F
T
F

F
T
T
F

Funes:
Raiz (x) retorna a raiz quadrada de um valor;
Cos (x) retorna o cosseno de um valor;
Trunca(x) retorna a parte inteira de um nmero fracionrio
Hoje retorna a data atual
Arredonda(z) retorna por arredondamento um nmero inteiro do valor fracionrio
Comentrios Todo programador deve ter a preocupao com a clareza do seu algoritmo, ou seja, dar a facilidade
para que outras pessoas possam entender a lgica desenvolvida para a execuo de um problema.
Para acrescentar comentrios no algoritmo, utilize:
{mensagem} ou (*mensagem*) ou //mensagem
Declaraes ou Atribuies essencial que se declare no inicio ou no decorrer do algoritmo todas as variveis
que esto sendo utilizadas, para declara-las deve-se fazer como nos exemplos a seguir:
Ex.1 Declare num1, num2 : numricas
Ex.2 Declare nota1, nota2 : numricas
nome : caracter
Para atribuir valores ou o contedo de uma varivel deve-se seguir os exemplos a seguir:
Ex.1 num1 := 100
Ex.2 Nome := Paula
Ex.3 A := 10
B := 5
C := 1
Verdade := .T.

Instruo de leitura de dados:


Receba usada para leitura das variveis quando o algoritmo estiver sendo executado. Por exemplo, voc quer
que o usurio entre com os valores necessrios para a execuo da conta no seu algoritmo, para isso basta
colocar no seu algoritmo a seguinte instruo:
Receba(num1, num2)
Instruo de Sada de dados
Escreva Funo utilizada para exibir os dados na tela. Por exemplo, voc quer exibir para o usurio o resultado
de uma conta feita pelo seu algoritmo, nesse caso basta colocar no seu algoritmo a seguinte instruo:
Escreva (num1) Ou Escreva (o valor : , num1)

Exerccios
1 Faa um algoritmo que receba 2 notas e imprima a mdia desses valores.
2 Crie um algoritmo que receba 3 valores e escreva apenas a parte inteira referente ao clculo do cosseno dos 3
valores somados
3 Dados 5 nmeros, monte um algoritmo que permita obter como resultado a soma, o produto e a mdia dos
valores recebidos.
4 Crie um algoritmo que calcule e exiba na tela o valor de y a partir do valor de x recebido, para a sentena
matemtica : y = x/3 x + 7
5 Num tringulo retngulo, o quadrado da hipotenusa (a) igual a soma dos quadrados dos catetos (b e c). Num
algoritmo, receba os valores dos catetos e exiba o valor da hipotenusa.
6 Receba 2 valores nas variveis A e B respectivamente. Troque o valor contido na varivel A pelo valor contido
na varivel B. Escreva na tela A e B com os valores trocados.
7 Receba o cdigo, nome e salrio Bruto de um determinado funcionrio. Calcule o salrio lquido, sabendo-se
que ser deduzido 15% de imposto de renda. No final, imprima o nome e o salrio a receber.

Estrutura Condicionais
Se Funo que ir permitir a escolha de opes e estruturas a serem executadas quando determinada condio
for ou no satisfeita.
Sintaxe:
1)

Se (expresso lgica) ento


instruo
Fim se

A := 10
B:=5
Se (A>=B) ento
Escreva( A, maior ou igual)
Fim se

Se (expresso lgica) ento


instruo
seno
instruo
fim se
A := 10
B := 5
Se (A>=B) ento
Escreva( A, maior ou igual)
Seno
Escreva( A, maior ou igual)
Fim se

Exerccios
1 Crie um algoritmo que receba o nome e a nota de um aluno. Caso a nota seja maior ou igual a 7, escreva
Aprovado, em caso negativo escreva Reprovaldo.
2 Faa um algoritmo que aps receber dois valores numricos. Calcule a mdia e escreva o resultado se, o
somente se, for maior que 33.
3 Fazer um algoritmo que aps receber 3 valores, escreva apenas os nmeros pares.
4 Dados 3 valores A, B, C determine e escreva o menor deles.

Estrutura Condicional
Caso a estrutura caso contm uma expresso (o seletor) e uma lista de declaraes, cada declarao
anteposta por uma ou mais constante (chamadas de constante de caso) ou com a palavra seno o seletor deve ser
de um tipo ordinal, ou seja, possua um ordem. Todas as constantes de caso devem ser diferentes e de um tipo
ordinal compatvel com o tipo seletor.
Sintaxe:
Caso (expresso)
Seja valor1 faa instruo
Seja valor2 faa instruo
Seja valor3 faa instruo
Seno
Instruo
Fim caso

Exerccios
1 Escreva um algoritmo que receba 2 nmeros e o nome da operao matemtica desejada entre eles. Exiba o
resultado.
2 A partir da entrada de qualquer nmero, o algoritmo dever informar:
- nmero par se a entrada for um nmero par e menor que 10;
- nmero impar se a entrada for um nmero impar e menor que 10;
- entre 10 e 100 se a entrada for maior que 10 e menor que 100;
- negativo ou maior que 100 caso contrrio.
3 Faa um algoritmo que ao receber 3 valores, verifique se ele pode ser os comprimentos dos lados de um
tringulo. Se no for tringulo escreva uma mensagem.
4 Receba 3 valores diferentes e coloca-los em ordem crescente. No final, escreva-os na nova ordem.
5 Desenvolva um algoritmo que converta valores em graus, entre as escalas termomtricas.
6 Desenvolva um algoritmo que converta valores entre as unidades de medida (m)

Estrutura de Repetio
Para .... at..... faa repete a execuo de uma instruo ou bloco de instruo por um determinado nmero de
vezes. A varivel utilizada nessa estrutura incrementada automaticamente, sempre de um em um. Essa varivel
tem que ser do tipo numrica inteira.
Sintaxe:
Para <varivel> = valor inicial at valor final faa
Instruo
Fim para
Exemplo:
Para i = 1 at 200 faa
S = s + (a^ 1)
Fim para
Enquanto ........ faa contm uma condio que controla a execuo repetidas vezes de uma seqncia de
instrues. A condio que controla a repetio deve ser do tipo Booleana. Ela avaliada antes da seqncia de
comandos a ser executada. A seqncia de comandos ser executada repetidamente, contanto que a condio
seja verdadeira. Se a condio for falsa a seqncia de comandos no ser executada.
Sintaxe:
Enquanto (expresso lgica) faa
Instrues
Fim enquanto
Exemplo
A := 20
Enquanto (a < 20) faa
Escreva (a)
A=a+1
Fim enquanto

Repita .... at que ...... contm uma condio que controla a execuo repetidas vezes de uma seqncia de
comandos. Esta condio tem que produzir um resultado de tipo booleano (verdadeiro ou falso). A seqncia de
comandos ser executada at que a condio seja satisfeita.
Nesse caso a seqncia ser executada pelo menos 1 vez, porque a condio s ser avaliada somente depois da
execuo de cada seqncia de comandos.
Sintaxe
Repita
Instrues
At que (condio booleana)
Exemplo
S := 0
Repita
Ler (A)
S=s+a
At que (s> 19)
Escreva (s = , s)

Exerccios
1 Faa um algoritmo que soma os nmeros compreendidos entre os valores 10 e 100, e no final escreva o valor
total da soma. Usar a repetio Para
2 Crie um algoritmo que receba um nmero inteiro diferente de 0 (zero) e calcule o fatorial desse nmero. Usar a
repetio Para
3 Escreva um algoritmo que repita a soma dos nmeros recebidos at que o total seja maior que 100. Usar a
repetio Para
4 Escreva um algoritmo para mostrar o resultado da seqncia abaixo. Usar a repetio Para
n 200

a
i 1