Anda di halaman 1dari 50

Paper Code:MCA 256

Roll Number :02119104414

Serial
No.

Practical

Page
No.

Study and undersatand the CISCO Simulator


Application Interface.

Router configuration and commands,changing


hostname and working with passwords.

Demonstrate help(?) command and implement


banner MOTD on a router.

Setting up a simple console based peer to peer


network

Setting up a simple Client Server network

Setting up a client server over switche

Show static routing over 3 routers

Show static routing over 4 routers

Setting up a Single Client and Single Server


Network.
Demonstration of a ping.
Demonstration of Web Browser.

10

Setting up a Single Client and Single Server


Network.
Demonstration of a ping.
Demonstrating FTP.

11

Setting up FTP,Web and DNS Servers over a router


based network

12

Setting up DHCP on router

13

Setting up an e-mail Server over a router network

14

Setting up a Client Server Network by Connecting


two networks through RIP
Setting up a Client Server Network by Connecting
two networks through OSPF

15

INDEX
1

Date

Sign

Paper Code:MCA 256


Roll Number :02119104414

Practical no.:1
Study and undersatand the CISCO Simulator
Application Interface.
Packet Tracer is a powerful network simulator that can be utilized in training for CCNA and CCNP
certification exam by allowing students to create networks with an almost unlimited number of
devices and to experience troubleshooting without having to buy real Cisco routers or switches.
The tool is created by Cisco Systems. The purpose of Packet Tracer is to offer students a tool to
learn the principles of networking as well as develop Cisco technology specific skills. However, it
is not be used as a replacement for Routers or Switches.
It includes the following Feature.

Supported
Feature
Protocols

Logical Workspace

Physical Workspace

Real time Mode


Simulation Mode

Local Authoring and


Sharing

Description
1. LAN Ethernet, 802.11wireless, PPPOE. 2. Switching: VLAN,
trucking, VTP, DTP, STP, and RSTP. 3. TCP/IP : HTTPS , DHTPS ,
DHCPv6 , TELNET , SSH ,TFTP ,DNS ,UDP , ICMP ,ICMPv6 , FTP ,
SMTP,VOIP. 4. Routing: Static default, RIPv1, EIGRP single area
and multi area OSPF, BGP, inter VLAN routing. 5. Security :
IPSec ,GRE, ISAKMP , NTP ,AAA,RADIUS, TACACS ,SNMP ,
SSH,SYSLOG ,CBAC ,FIREWALL ,IPS . 6. WAN: HDLC, SLARP, PPP
and Frame Relay.
1. Devices : Generic, Real and modular with customizable
Image
2. Network topology creating
3. Routers, Switches, Hosts, Hubs, Bridges, Wireless access
point, Wireless routers, Cloud and DSL modems.
4. Multiuser remote network
1. Structured Cabling: Create bend point and group point.
2. Hierarchy of device, wiring closet, building, city.
3. Ethernet cable length display and length limitation
connectivity
4. Images for Devices custom and scalable
5. Wireless association management
1. Menu Based Configuration of DHCP, DNS, HTTP, TFTP.
2. Real Time protocol updates
3. Medium fidelity
1. OSI Model , Detailed PDU , Device table views .
2. Packet animation
3. Global event list
1. Easily translated GUI
2. Communication
3. Extensive file saving option
4. Multi level activity wizard for authoring
5. Challenge mode allowing users to make device algorithm
2

Paper Code:MCA 256


Roll Number :02119104414
decisions on packet.

Interface Overview
When we open Packet Tracer, by default we will be presented with the following interface:

Paper Code:MCA 256


Roll Number :02119104414

This interface has following Contains components

Paper Code:MCA 256


Roll Number :02119104414

PRACTICAL NO.:2

Router configuration and commands, changing


hostname and working with passwords.
5

Paper Code:MCA 256


Roll Number :02119104414

Configure the router name

Configure the enable password and secret

Show IP Address

Paper Code:MCA 256


Roll Number :02119104414

Show IP route
The show IP route command is used to show the router's routing table. This is the list of all
networks that the router can reach, their metric (the router's preference for them), and how to
get there.

Show version
The show version command gives you the router's configuration register (essentially, the router's
firmware settings for booting up), the last time the router was booted, the version of the IOS, the
name of the IOS file, the model of the router, and the router's amount of RAM and Flash.

Show running-configuration
7

Paper Code:MCA 256


Roll Number :02119104414
The show running-config command shows the router, switch, or firewall's current configuration.

Practical no.:3
8

Paper Code:MCA 256


Roll Number :02119104414

Demonstrate help(?) command and implement


banner MOTD on a router.

Paper Code:MCA 256


Roll Number :02119104414

Practical no.:4
Setting up a simple console based peer to peer
network
Setting up peer to peer network

10

Paper Code:MCA 256


Roll Number :02119104414

Demonstration of ping

11

Paper Code:MCA 256


Roll Number :02119104414

Sending simple PDU


12

Paper Code:MCA 256


Roll Number :02119104414

13

Paper Code:MCA 256


Roll Number :02119104414

Practical no.:5
Setting up a simple Client Server network
Setting client-server networK

Demonstrating ping

14

Paper Code:MCA 256


Roll Number :02119104414

Sending simple PDU

15

Paper Code:MCA 256


Roll Number :02119104414

Practical no.:6
Setting up a client server network over switch

Demonstrating ping

16

Paper Code:MCA 256


Roll Number :02119104414

17

Paper Code:MCA 256


Roll Number :02119104414

Sending SimplePDU in same network

18

Paper Code:MCA 256


Roll Number :02119104414

Sending packet in different network

19

Paper Code:MCA 256


Roll Number :02119104414

Practical no.:7
Show static routing over 3 routers

Router 0: config
interface FastEthernet0/0
20

Paper Code:MCA 256


Roll Number :02119104414
ip address 192.168.1.254 255.255.255.0
interface FastEthernet0/1
ip address 192.168.2.1 255.255.255.0
ip classless
ip route 192.168.3.0 255.255.255.0 192.168.2.2
ip route 192.168.4.0 255.255.255.0 192.168.2.2
ip route 192.168.5.0 255.255.255.0 192.168.2.2

Router 1: config

interface FastEthernet0/0
ip address 192.168.3.254 255.255.255.0
interface FastEthernet0/1
ip address 192.168.2.2 255.255.255.0
interface FastEthernet1/0
ip address 192.168.4.1 255.255.255.0
ip classless
ip route 192.168.1.0 255.255.255.0 192.168.2.1
ip route 192.168.5.0 255.255.255.0 192.168.4.2

Router 2: config

interface FastEthernet0/0
ip address 192.168.5.254 255.255.255.0
interface FastEthernet0/1
ip address 192.168.4.2 255.255.255.0
ip classless
ip route 192.168.3.0 255.255.255.0 192.168.4.1
ip route 192.168.2.0 255.255.255.0 192.168.4.1
ip route 192.168.1.0 255.255.255.0 192.168.4.1

Demonstrating ping

21

Paper Code:MCA 256


Roll Number :02119104414

22

Paper Code:MCA 256


Roll Number :02119104414

Sending Simple PDU

23

Paper Code:MCA 256


Roll Number :02119104414

Practical no.:8
Show static routing over 4 routers

Router 0: config
interface FastEthernet0/0
ip address 192.168.11.2 255.255.255.0
interface FastEthernet0/1
ip address 192.168.12.1 255.255.255.0
interface FastEthernet1/0
ip address 192.168.13.1 255.255.255.0
ip classless
ip route 192.168.18.0 255.255.255.0 192.168.12.2
ip route 192.168.14.0 255.255.255.0 192.168.13.2
ip route 192.168.17.0 255.255.255.0 192.168.12.2
ip route 192.168.15.0 255.255.255.0 192.168.13.2
ip route 192.168.16.0 255.255.255.0 192.168.13.2
ip route 192.168.16.0 255.255.255.0 192.168.12.2
ip route 192.168.14.0 255.255.255.0 192.168.12.2
ip route 192.168.15.0 255.255.255.0 192.168.12.2
ip route 192.168.17.0 255.255.255.0 192.168.13.2
ip route 192.168.18.0 255.255.255.0 192.168.13.2

24

Paper Code:MCA 256


Roll Number :02119104414

Router 1: config

interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
interface FastEthernet0/1
ip address 192.168.17.2 255.255.255.0
interface FastEthernet1/0
ip address 192.168.18.1 255.255.255.0
ip classless
ip route 192.168.11.0 255.255.255.0 192.168.12.1
ip route 192.168.13.0 255.255.255.0 192.168.12.1
ip route 192.168.14.0 255.255.255.0 192.168.12.1
ip route 192.168.15.0 255.255.255.0 192.168.12.1
ip route 192.168.16.0 255.255.255.0 192.168.17.1
ip route 192.168.16.0 255.255.255.0 192.168.12.1
ip route 192.168.15.0 255.255.255.0 192.168.17.1
ip route 192.168.14.0 255.255.255.0 192.168.17.1
ip route 192.168.13.0 255.255.255.0 192.168.17.1
ip route 192.168.11.0 255.255.255.0 192.168.17.1

Router 2: config

interface FastEthernet0/0
ip address 192.168.13.2 255.255.255.0
interface FastEthernet0/1
ip address 192.168.15.1 255.255.255.0
interface FastEthernet1/0
ip address 192.168.14.1 255.255.255.0
ip classless
ip route 192.168.11.0 255.255.255.0 192.168.13.1
ip route 192.168.12.0 255.255.255.0 192.168.13.1
ip route 192.168.18.0 255.255.255.0 192.168.13.1
ip route 192.168.17.0 255.255.255.0 192.168.13.1
ip route 192.168.16.0 255.255.255.0 192.168.13.1
ip route 192.168.16.0 255.255.255.0 192.168.15.2
ip route 192.168.17.0 255.255.255.0 192.168.15.2
ip route 192.168.18.0 255.255.255.0 192.168.15.2
ip route 192.168.12.0 255.255.255.0 192.168.15.2
ip route 192.168.11.0 255.255.255.0 192.168.15.2

25

Paper Code:MCA 256


Roll Number :02119104414

Router 3: config

interface FastEthernet0/0
ip address 192.168.17.1 255.255.255.0
interface FastEthernet0/1
ip address 192.168.15.2 255.255.255.0
interface FastEthernet1/0
ip address 192.168.16.1 255.255.255.0
ip classless
ip route 192.168.18.0 255.255.255.0 192.168.17.2
ip route 192.168.12.0 255.255.255.0 192.168.17.2
ip route 192.168.11.0 255.255.255.0 192.168.17.2
ip route 192.168.13.0 255.255.255.0 192.168.17.2
ip route 192.168.14.0 255.255.255.0 192.168.17.2
ip route 192.168.14.0 255.255.255.0 192.168.15.1
ip route 192.168.13.0 255.255.255.0 192.168.15.1
ip route 192.168.11.0 255.255.255.0 192.168.15.1
ip route 192.168.12.0 255.255.255.0 192.168.15.1
ip route 192.168.18.0 255.255.255.0 192.168.15.1

Demonstrating ping

26

Paper Code:MCA 256


Roll Number :02119104414

Sending Simple PDU

27

Paper Code:MCA 256


Roll Number :02119104414

Practical no.:9
Setting up a Single Client and Single Server Network.
Demonstration of a ping.
Demonstration of Web Browser.

Demonstrating ping

28

Paper Code:MCA 256


Roll Number :02119104414

Demonstration of web browser

29

Paper Code:MCA 256


Roll Number :02119104414

Practical no.:10
Setting up a Single Client and Single Server Network.
Demonstration of a ping.
Demonstrating FTP.

Demonstrating ping

30

Paper Code:MCA 256


Roll Number :02119104414

Demonstration of FTP

31

Paper Code:MCA 256


Roll Number :02119104414

Practical no.:11
Setting up FTP,Web and DNS Servers over a router
based network

Router 0: config
interface FastEthernet0/0
ip address 192.168.6.1 255.255.255.0
interface FastEthernet0/1
ip address 192.168.5.254 255.255.255.0
ip classless
ip route 192.168.8.0 255.255.255.0 192.168.6.2
ip route 192.168.7.0 255.255.255.0 192.168.6.2
ip route 192.168.9.0 255.255.255.0 192.168.6.2

Router 1: config
32

Paper Code:MCA 256


Roll Number :02119104414
interface FastEthernet0/0
ip address 192.168.6.2 255.255.255.0
interface FastEthernet0/1
ip address 192.168.7.254 255.255.255.0
interface FastEthernet1/0
ip address 192.168.8.1 255.255.255.0
ip classless
ip route 192.168.5.0 255.255.255.0 192.168.6.1
ip route 192.168.9.0 255.255.255.0 192.168.8.2

Router 2: config

interface FastEthernet0/0
ip address 192.168.8.2 255.255.255.0
interface FastEthernet0/1
ip address 192.168.9.254 255.255.255.0
ip classless
ip route 192.168.6.0 255.255.255.0 192.168.8.1
ip route 192.168.7.0 255.255.255.0 192.168.8.1
ip route 192.168.5.0 255.255.255.0 192.168.8.1

Demonstrating ping

33

Paper Code:MCA 256


Roll Number :02119104414

34

Paper Code:MCA 256


Roll Number :02119104414

Demonstration of web browser

Demonstration of FTP

35

Paper Code:MCA 256


Roll Number :02119104414

36

Paper Code:MCA 256


Roll Number :02119104414

Practical no.:12
Setting up DHCP on router

192.155.20.
0

Router 0: config
ip dhcp pool ip10
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
ip dhcp excluded-address 192.168.10.1 192.168.10.10
ip dhcp pool ip20
network 192.155.20.0 255.255.255.0
default-router 192.155.20.1
ip dhcp excluded-address 192.155.20.1 192.155.20.2
interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.0
interface FastEthernet0/1
ip address 192.155.20.1 255.255.255.0

37

Paper Code:MCA 256


Roll Number :02119104414

Demonstrating ping

Addressing through DHCP

38

Paper Code:MCA 256


Roll Number :02119104414

39

Paper Code:MCA 256


Roll Number :02119104414

Practical no.:13
Setting up an e-mail Server over a router network

40

Paper Code:MCA 256


Roll Number :02119104414

Configuration of servers

41

Paper Code:MCA 256


Roll Number :02119104414

Configure mail

42

Paper Code:MCA 256


Roll Number :02119104414

Demonstration of E-mail

43

Paper Code:MCA 256


Roll Number :02119104414

Practical no.:14
Setting up a Client Server Network by Connecting
two networks through RIP

Router 2: config
ip dhcp excluded-address 192.168.1.10 192.168.1.12
ip dhcp pool ip1
network 192.168.1.0 255.255.255.0
default-router 192.168.1.10
interface FastEthernet0/0
ip address 192.168.1.10 255.255.255.0
interface Serial2/0
ip address 10.10.0.2 255.0.0.0
clock rate 64000
shutdown
router rip
network 10.0.0.0
network 192.168.1.0

Router 3: config
44

Paper Code:MCA 256


Roll Number :02119104414
ip dhcp excluded-address 156.128.1.10 156.128.1.19
ip dhcp pool ip2
network 156.128.0.0 255.255.0.0
default-router 156.128.1.1
interface FastEthernet0/0
ip address 156.128.1.10 255.255.0.0
interface Serial2/0
ip address 10.10.0.3 255.0.0.0
shutdown
router rip
network 10.0.0.0
network 156.128.0.0

Demonstrating ping

45

Paper Code:MCA 256


Roll Number :02119104414

Sending Simple PDU

46

Paper Code:MCA 256


Roll Number :02119104414

Practical no.:15
Setting up a Client Server Network by Connecting
two networks through OSPF

Router 0: config
interface FastEthernet0/0
ip address 10.0.0.1 255.0.0.0
interface Serial2/0
bandwidth 64
ip address 20.0.0.1 255.0.0.0
clock rate 64000
router ospf 1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
network 20.0.0.0 0.255.255.255 area 0
network 100.0.0.0 0.255.255.255 area 0
network 45.0.0.0 0.255.255.255 area 0
47

Paper Code:MCA 256


Roll Number :02119104414
network 192.168.0.0 0.0.0.255 area 0
network 192.0.0.0 0.255.255.255 area 1

48

Paper Code:MCA 256


Roll Number :02119104414

Router 1: config
interface FastEthernet0/0
ip address 100.0.0.1 255.0.0.0
interface FastEthernet1/0
interface Serial2/0
bandwidth 64
ip address 20.0.0.2 255.0.0.0
interface Serial3/0
bandwidth 64
ip address 45.0.0.1 255.0.0.0
clock rate 64000
router ospf 2
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
network 20.0.0.0 0.255.255.255 area 0
network 100.0.0.0 0.255.255.255 area 0
network 45.0.0.0 0.255.255.255 area 0
network 192.168.0.0 0.0.0.255 area 1

Router 2: config
interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.0
interface Serial2/0
ip address 45.0.0.2 255.0.0.0
router ospf 3
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
network 20.0.0.0 0.255.255.255 area 0
network 100.0.0.0 0.255.255.255 area 0
network 45.0.0.0 0.255.255.255 area 0
network 192.0.0.0 0.255.255.255 area 1

49

Paper Code:MCA 256


Roll Number :02119104414

Demonstrating ping

Sending Simple PDU

50