Anda di halaman 1dari 65

UNIVERSIDAD CATOLICA BOLIVIANA

SAN PABLO

Implementacin de OSFP reas Especiales


Nombres:
Fernndez Iberth
Galarza Edward
Marn Eduardo
Zerna Lesly

Enero 2013

INDICE
Configuracin de reas especiales OSPF............................................................................................................... 2
Descripcin del laboratorio............................................................................................................................... 2
Esquema del laboratorio ................................................................................................................................... 2
Configuracin bsica de interfaces en los Routers ........................................................................................... 3

AREA 0 ................................................................................................................................................... 3

AREA 23 ................................................................................................................................................. 4

AREA 45 ................................................................................................................................................. 5

AREA 67 ................................................................................................................................................. 5

AREA 78 ................................................................................................................................................. 6

OBJETIVOS ......................................................................................................................................................... 6
Objetivo 1. ..................................................................................................................................................... 6
Objetivo 2 .................................................................................................................................................... 20
Objetivo 3 .................................................................................................................................................... 24
Objetivo 4 .................................................................................................................................................... 26
Objetivo 5 .................................................................................................................................................... 29
Objetivo 6 .................................................................................................................................................... 33
Objetivo 7 .................................................................................................................................................... 36
Objetivo 8 .................................................................................................................................................... 41
Comentarios y Conclusiones ........................................................................................................................... 43
ANEXOS ........................................................................................................................................................... 44

Configuracin de reas especiales OSPF


Descripcin del laboratorio
En este laboratorio, se tiene no solo distintas reas de OSPF sino tambin, que el AREA 78 no esta
directamente conectado al CORE, de modo que para que esta rea pueda comunicarse con el AREA 0 es
necesario establecer Enlaces Virtuales (Virtual Links).
Adems segn requerimientos, se utilizara algunas reas de OSPF como Normal Stub Area y Totally Stub;
comprobando que filtran tipos de paquetes LSA, y luego cambiando el rea Stub por un Not-So-Stubby Area,
ya que esa rea en especifico usa EIGRP como protocolo de enrutamiento y solo con un tipo NSSA podr
conocer de las otras rutas OSPF.
Primero se configurara todo el dominio OSPF, desde sus interfaces hasta los requerimientos de los objetivos,
seguidamente se introduce el router R9 cuyo protocolo de enrutamiento es EIGRP que se lo trata por
separado, pero con mecanismo de inyeccin de OSFP a EIGRP, es posible tambin tener conexin desde R9 al
dominio OSPF.

Esquema del laboratorio


La configuracin requerida para el siguiente ejercicio es la siguiente:

Configuracin bsica de interfaces en los Routers


Antes de empezar a describir los objetivos con los respectivos comandos a utilizar, especificamos la
configuracin bsica de funcionamiento en cada router segn su rea correspondiente.

AREA 0

INTERFACES
R1(config)#int f0/0
R1(config-if)#ip address 10.100.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit

R4(config)#int f0/0
R4(config-if)#ip address 10.100.1.4 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit

R2(config)#int f0/0
R2(config-if)#ip address 10.100.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

R6(config)#int f0/0
R6(config-if)#ip address 10.100.1.6 255.255.255.0
R6(config-if)#no shutdown
R6(config-if)#exit

AREA 23

INTERFACES
R3
R3(config)#int s0/0
R3(config-if)#ip address 10.23.1.3 255.255.255.0
R3(config-if)#bandwidth 500
R3(config-if)#no shutdown
R3(config-if)#exit

R3(config)#int loopback 2
R3(config-if)#ip address 172.30.1.1 255.255.255.0
R3(config-if)# ip ospf network point-to-point
R3(config-if)#no shutdown
R3(config-if)#exit

R3(config)#int loopback 1
R3(config-if)#ip address 172.30.0.1 255.255.255.0
R3(config-if)# ip ospf network point-to-point
R3(config-if)#no shutdown
R3(config-if)#exit

R3(config)#int loopback 3
R3(config-if)#ip address 172.30.2.1 255.255.255.0
R3(config-if)# ip ospf network point-to-point
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#int loopback 4
R3(config-if)#ip address 172.30.3.1 255.255.255.0
R3(config-if)# ip ospf network point-to-point
R3(config-if)#no shutdown
R3(config-if)#exit

R2
R2(config)#int s0/0
R2(config-if)#ip address 10.23.1.2 255.255.255.0
R2(config-if)#bandwidth 500
R2(config-if)#clock rate 500000
R2(config-if)#no shutdown
R2(config-if)#exit

AREA 45

INTERFACES
R4(config)#int s0/0
R4(config-if)#ip address 10.45.1.4 255.255.255.0
R4(config-if)#bandwidth 500
R4(config-if)#clock rate 500000
R4(config-if)#no shutdown
R4(config-if)#exit

R5(config)#int s0/0
R5(config-if)#ip address 10.45.1.5 255.255.255.0
R5(config-if)#bandwidth 500
R5(config-if)#no shutdown
R5(config-if)#exit

AREA 67

INTERFACES
R6(config)#int s0/0
R6(config-if)#ip address 10.67.1.6 255.255.255.0
R6(config-if)#bandwidth 500
R6(config-if)#clock rate 500000
R6(config-if)#no shutdown
R6(config-if)#exit

R7(config)#int s0/1
R7(config-if)#ip address 10.67.1.7 255.255.255.0
R7(config-if)#bandwidth 500
R7(config-if)#no shutdown
R7(config-if)#exit

AREA 78

INTERFACES
R7(config)#int s0/0
R7(config-if)#ip address 10.78.1.7 255.255.255.0
R7(config-if)#bandwidth 500
R7(config-if)#clock rate 500000
R7(config-if)#no shutdown
R7(config-if)#exit

R8(config)#int s0/0
R8(config-if)#ip address 10.78.1.8 255.255.255.0
R8(config-if)#bandwidth 500
R8(config-if)#no shutdown
R8(config-if)#exit

OBJETIVOS
Objetivo 1.

Configurar OSPF bsico para el esquema de red mostrado (configurar todos los
routers menos R9). Publicar todas las redes conectadas a cada router en OSPF usando
el mtodo ms simple disponible. Para inyectar redes externas en el dominio OSPF,
redistribuir las rutas estticas en R1. Estas rutas deberan ser marcadas como tipo
E1.
ENRUTAMIENTO DE OSPF en cada ROUTER

AREA 0

R1(config)#ip route 172.31.0.0 255.255.255.0 Null 0


R1(config)#ip route 172.31.1.0 255.255.255.0 Null 0
R1(config)#ip route 172.31.2.0 255.255.255.0 Null 0
R1(config)#ip route 172.31.3.0 255.255.255.0 Null 0
R1(config)#router ospf 1
R1(config-router)#network 10.100.1.0 0.0.0.255 area 0
R1(config-router)#redistribute static subnet metric 50 metric-type 1

Inyectando
redes externas
al dominio OSPF

R1(config-router)#router-id 1.1.1.1

Verificando:
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.31.0.0/24 is subnetted, 4 subnets
S
172.31.3.0 is directly connected, Null0
S
172.31.2.0 is directly connected, Null0
S
172.31.1.0 is directly connected, Null0
S
172.31.0.0 is directly connected, Null0
10.0.0.0/24 is subnetted, 1 subnets
C
10.100.1.0 is directly connected, FastEthernet0/0

R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 10.100.1.0 0.0.0.255 area 0
R2(config-router)#network 10.23.1.0 0.0.0.255 area 23
R2(config-router)#exit
Verificando:
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.31.0.0/24 is subnetted, 4 subnets
O E1 172.31.3.0 [110/60] via 10.100.1.1, 00:01:30, FastEthernet0/0
O E1 172.31.2.0 [110/60] via 10.100.1.1, 00:01:30, FastEthernet0/0
O E1 172.31.1.0 [110/60] via 10.100.1.1, 00:01:30, FastEthernet0/0

Redes externas
al dominio OSPF
redistribuidas
tipo E1

O E1 172.31.0.0 [110/60] via 10.100.1.1, 00:01:30, FastEthernet0/0


10.0.0.0/24 is subnetted, 1 subnets
C
10.100.1.0 is directly connected, FastEthernet0/0

R4(config)#router ospf 1
R4(config-router)#router-id 4.4.4.4
R4(config-router)#network 10.100.1.0 0.0.0.255 area 0
R4(config-router)#network 10.45.1.0 0.0.0.255 area 45
R4(config-router)#exit
Verificando:
R4#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.31.0.0/24 is subnetted, 4 subnets
O E1 172.31.3.0 [110/60] via 10.100.1.1, 00:00:54, FastEthernet0/0
O E1 172.31.2.0 [110/60] via 10.100.1.1, 00:00:54, FastEthernet0/0
O E1 172.31.1.0 [110/60] via 10.100.1.1, 00:00:54, FastEthernet0/0
O E1 172.31.0.0 [110/60] via 10.100.1.1, 00:00:54, FastEthernet0/0
10.0.0.0/24 is subnetted, 1 subnets
C
10.100.1.0 is directly connected, FastEthernet0/0

Redes externas
al dominio OSPF
redistribuidas
tipo E1

R6(config)#router ospf 1
R6(config-router)#router-id 6.6.6.6
R6(config-router)#network 10.100.1.0 0.0.0.255 area 0
R6(config-router)#network 10.67.1.0 0.0.0.255 area 67
R6(config-router)#exit
Verificando:
R6#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
8

E1 - OSPF external type 1, E2 - OSPF external type 2


i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.31.0.0/24 is subnetted, 4 subnets
O E1 172.31.3.0 [110/60] via 10.100.1.1, 00:00:39, FastEthernet0/0
O E1 172.31.2.0 [110/60] via 10.100.1.1, 00:00:39, FastEthernet0/0
O E1 172.31.1.0 [110/60] via 10.100.1.1, 00:00:39, FastEthernet0/0
O E1 172.31.0.0 [110/60] via 10.100.1.1, 00:00:39, FastEthernet0/0
10.0.0.0/24 is subnetted, 1 subnets
C
10.100.1.0 is directly connected, FastEthernet0/0

Redes externas
al dominio OSPF
redistribuidas
tipo E1

- show ip ospf AREA 0


R1#show ip ospf
Routing Process "ospf 1" with ID 1.1.1.1
Start time: 00:02:53.300, Time elapsed: 00:28:56.016
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Es un ASBR
Supports area transit capability
It is an autonomous system boundary router
Redistributing External Routes from,
static with metric mapped to 50, includes subnets in redistribution
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 4. Checksum Sum 0x00A323
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Number of areas transit capable is 0
9

External flood list length 0


Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:04:57.648 ago
SPF algorithm executed 8 times
Area ranges are
Number of LSA 5. Checksum Sum 0x028A9E
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0

R2#show ip ospf
Routing Process "ospf 1" with ID 2.2.2.2
Start time: 00:05:11.500, Time elapsed: 00:25:23.436
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 4. Checksum Sum 0x009B27
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 2. 2 normal 0 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:02:18.224 ago
10

SPF algorithm executed 9 times


Area ranges are
Number of LSA 5. Checksum Sum 0x0282A7
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Area 23
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:02:18.240 ago
SPF algorithm executed 3 times
Area ranges are
Number of LSA 1. Checksum Sum 0x000130
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0

R4#show ip ospf
Routing Process "ospf 1" with ID 4.4.4.4
Start time: 00:18:25.844, Time elapsed: 00:01:05.700
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 4. Checksum Sum 0x009B27
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
11

Number of areas in this router is 2. 2 normal 0 stub 0 nssa


Number of areas transit capable is 0
External flood list length 0
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:00:48.596 ago
SPF algorithm executed 1 times
Area ranges are
Number of LSA 5. Checksum Sum 0x027AB5
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Area 45
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:00:32.680 ago
SPF algorithm executed 1 times
Area ranges are
Number of LSA 1. Checksum Sum 0x006CB6
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0

R6#show ip ospf
Routing Process "ospf 1" with ID 6.6.6.6
Start time: 00:03:00.672, Time elapsed: 00:20:35.164
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
12

LSA group pacing timer 240 secs


Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 4. Checksum Sum 0x009B27
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 2. 2 normal 0 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:01:07.000 ago
SPF algorithm executed 8 times
Area ranges are
Number of LSA 5. Checksum Sum 0x027AB0
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Area 67
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:01:07.000 ago
SPF algorithm executed 3 times
Area ranges are
Number of LSA 1. Checksum Sum 0x00CF41
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0

ENRUTAMIENTO DE OSPF en cada ROUTER

AREA 23
R3(config)#router ospf 1
R3(config-router)#network 10.23.1.0 0.0.0.255 area 23
13

R3(config-router)#router-id 3.3.3.3
R3(config-router)#exit
Verificando:
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.31.0.0/24 is subnetted, 4 subnets
O E1 172.31.3.0 [110/260] via 10.23.1.2, 00:00:28, Serial0/0
O E1 172.31.2.0 [110/260] via 10.23.1.2, 00:00:28, Serial0/0
O E1 172.31.1.0 [110/260] via 10.23.1.2, 00:00:28, Serial0/0
O E1 172.31.0.0 [110/260] via 10.23.1.2, 00:00:28, Serial0/0
172.30.0.0/24 is subnetted, 4 subnets
C
172.30.2.0 is directly connected, Loopback3
C
172.30.3.0 is directly connected, Loopback4
C
172.30.0.0 is directly connected, Loopback1
C
172.30.1.0 is directly connected, Loopback2
10.0.0.0/24 is subnetted, 3 subnets
C
10.23.1.0 is directly connected, Serial0/0
O IA 10.45.1.0 [110/410] via 10.23.1.2, 00:00:35, Serial0/0
O IA 10.100.1.0 [110/210] via 10.23.1.2, 00:03:33, Serial0/0

AREA 45
R5(config)#router ospf 1
R5(config-router)#router-id 5.5.5.5
R5(config-router)#network 10.45.1.0 0.0.0.255 area 45
R5(config-router)#exit

Verificando:
R5#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
14

ia - IS-IS inter area, * - candidate default, U - per-user static route


o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.31.0.0/24 is subnetted, 4 subnets
O E1 172.31.3.0 [110/260] via 10.45.1.4, 00:01:11, Serial0/0
O E1 172.31.2.0 [110/260] via 10.45.1.4, 00:01:11, Serial0/0
O E1 172.31.1.0 [110/260] via 10.45.1.4, 00:01:11, Serial0/0
O E1 172.31.0.0 [110/260] via 10.45.1.4, 00:01:11, Serial0/0
10.0.0.0/24 is subnetted, 3 subnets
O IA 10.23.1.0 [110/410] via 10.45.1.4, 00:01:11, Serial0/0
C
10.45.1.0 is directly connected, Serial0/0
O IA 10.100.1.0 [110/210] via 10.45.1.4, 00:01:17, Serial0/0

AREA 67
R7(config)#router ospf 1
R7(config-router)#router-id 7.7.7.7
R7(config-router)#network 10.67.1.0 0.0.0.255 area 67
R7(config-router)#network 10.78.1.0 0.0.0.255 area 78
R7(config-router)#^Z

Verificando:
R7#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.31.0.0/24 is subnetted, 4 subnets
O E1 172.31.3.0 [110/260] via 10.67.1.6, 00:01:00, Serial0/1
O E1 172.31.2.0 [110/260] via 10.67.1.6, 00:01:00, Serial0/1
O E1 172.31.1.0 [110/260] via 10.67.1.6, 00:01:00, Serial0/1
O E1 172.31.0.0 [110/260] via 10.67.1.6, 00:01:00, Serial0/1
10.0.0.0/24 is subnetted, 4 subnets
O IA 10.23.1.0 [110/410] via 10.67.1.6, 00:01:01, Serial0/1
15

O IA 10.45.1.0 [110/410] via 10.67.1.6, 00:01:01, Serial0/1


C
10.67.1.0 is directly connected, Serial0/1
O IA 10.100.1.0 [110/210] via 10.67.1.6, 00:01:17, Serial0/1

AREA 78
R8(config)#router ospf 1
R8(config-router)#router-id 8.8.8.8
R8(config-router)#network 10.78.1.0 0.0.0.255 area 78
R8(config-router)#^Z

Verificando:
R8#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
No esta conectado
10.0.0.0/24 is subnetted, 1 subnets
directamente al CORE. No
C
10.78.1.0 is directly connected, Serial0/0
conoce mas redes OSPF.

Como vemos, R8 no conoce dems rutas OSPF, asi que NO puede hacer ping a ningn IP en el CORE.
R8#ping 10.100.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.100.1.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Si analizamos la base de Datos de OSPF para este router vemos:


R8#show ip ospf database
OSPF Router with ID (8.8.8.8) (Process ID 1)
Router Link States (Area 78)
Link ID
ADV Router Age
Seq#
Checksum Link count
7.7.7.7
7.7.7.7
341
0x80000005 0x004E2F 2
8.8.8.8
8.8.8.8
340
0x80000003 0x00F188 2
16

Type-5 AS External Link States


Link ID
ADV Router Age
Seq#
Checksum Tag
172.31.0.0 1.1.1.1
1876
0x80000003 0x0035FB 0
172.31.1.0 1.1.1.1
1876
0x80000003 0x002A06 0
172.31.2.0 1.1.1.1
1876
0x80000003 0x001F10 0
172.31.3.0 1.1.1.1
1876
0x80000003 0x00141A 0

Es necesario crear una RUTA VIRTUAL entre R7 y R6 para que R8 pueda acceder a la red completa OSPF.
R6(config)#router ospf 1
R6(config-router)#area 67 v
R6(config-router)#area 67 virtual-link 7.7.7.7
R6(config-router)#exit

R7(config)#router ospf 1
R7(config-router)#area 67 v
R7(config-router)#area 67 virtual-link 6.6.6.6
R7(config-router)#exit

Verificando:
R8#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 2 subnets
C
10.78.1.0 is directly connected, Serial0/0
O IA 10.67.1.0 [110/400] via 10.78.1.7, 00:00:09, Serial0/0
Probando Ping:
R8#ping 10.100.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.100.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/44/68 ms

17

Conociendo la base de Datos para OSPF en R8:


R8#show ip ospf database
OSPF Router with ID (8.8.8.8) (Process ID 1)
Router Link States (Area 78)
Link ID
ADV Router Age
Seq#
Checksum Link count
7.7.7.7
7.7.7.7
52
0x80000006 0x004F2C 2
8.8.8.8
8.8.8.8
476
0x80000003 0x00F188 2
Summary Net Link States (Area 78)
Link ID
ADV Router Age
Seq#
Checksum
10.23.1.0
7.7.7.7
37
0x80000001 0x00273C
10.45.1.0
7.7.7.7
37
0x80000001 0x001E2F
10.67.1.0
7.7.7.7
52
0x80000001 0x00D930
10.100.1.0 7.7.7.7
37
0x80000001 0x00B02E
172.30.0.1 7.7.7.7
37
0x80000001 0x009B1D
172.30.1.1 7.7.7.7
37
0x80000001 0x009027
172.30.2.1 7.7.7.7
37
0x80000001 0x008531
172.30.3.1 7.7.7.7
37
0x80000001 0x007A3B
Summary ASB Link States (Area 78)
Link ID
1.1.1.1

ADV Router Age


Seq#
Checksum
7.7.7.7
37
0x80000001 0x00B692
Type-5 AS External Link States

Link ID
ADV Router
172.31.0.0 1.1.1.1
172.31.1.0 1.1.1.1
172.31.2.0 1.1.1.1
172.31.3.0 1.1.1.1

Age
2015
2015
2015
2015

Seq#
Checksum Tag
0x80000003 0x0035FB 0
0x80000003 0x002A06 0
0x80000003 0x001F10 0
0x80000003 0x00141A 0

Despus de haber configurado OSPF en todos los routers, la tabla de enrutamiento de R1, luce asi:
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
18

o - ODR, P - periodic downloaded static route


Gateway of last resort is not set
172.31.0.0/24 is subnetted, 4 subnets
S
172.31.3.0 is directly connected, Null0
S
172.31.2.0 is directly connected, Null0
S
172.31.1.0 is directly connected, Null0
S
172.31.0.0 is directly connected, Null0
172.30.0.0/32 is subnetted, 4 subnets
O IA 172.30.3.1 [110/211] via 10.100.1.2, 00:00:50, FastEthernet0/0
O IA 172.30.2.1 [110/211] via 10.100.1.2, 00:00:49, FastEthernet0/0
O IA 172.30.1.1 [110/211] via 10.100.1.2, 00:01:00, FastEthernet0/0
O IA 172.30.0.1 [110/211] via 10.100.1.2, 00:01:01, FastEthernet0/0
10.0.0.0/24 is subnetted, 4 subnets
O IA 10.23.1.0 [110/210] via 10.100.1.2, 00:12:31, FastEthernet0/0
O IA 10.45.1.0 [110/210] via 10.100.1.4, 00:12:31, FastEthernet0/0
O IA 10.67.1.0 [110/210] via 10.100.1.6, 00:12:32, FastEthernet0/0
C
10.100.1.0 is directly connected, FastEthernet0/0
Probando ping:
R1# ping 172.30.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/36/64 ms

19

Objetivo 2

OSPF nunca debera formar relaciones de vecindario en cualqui er interfaz donde


otros routers OSPF no existen (como se muestra en el diagrama).
Para que OSPF no forme relaciones de vecindario, es necesario poner sus interfaces en MODO PASIVO.

R1(config)#router ospf 1
R1(config-router)#passive-interface default
R1(config-router)#exit

R6(config)#router ospf 1
R6(config-router)#passive-interface default
R6(config-router)#exit

R2(config)#router ospf 1
R2(config-router)#passive-interface default
R2(config-router)#exit

R4(config)#router ospf 1
R4(config-router)#passive-interface default
R4(config-router)#exit

R3(config)#router ospf 1
R3(config-router)#passive-interface default
R3(config-router)#exit

R7(config)#router ospf 1
R7(config-router)#passive-interface default
R7(config-router)#exit

R5(config)#router ospf 1
R5(config-router)#passive-interface default
R5(config-router)#exit

R8(config)#router ospf 1
R8(config-router)#passive-interface default
R8(config-router)#exit

Con esto vemos que no se envan paquetes HELLO, por tanto las rutas OSFP no son publicadas.
R7#show ip route
*Mar 1 00:30:18.315: %SYS-5-CONFIG_I: Configured from console by console
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 2 subnets
C
10.78.1.0 is directly connected, Serial0/0
C
10.67.1.0 is directly connected, Serial0/1

20

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.31.0.0/24 is subnetted, 4 subnets
S
172.31.3.0 is directly connected, Null0
S
172.31.2.0 is directly connected, Null0
S
172.31.1.0 is directly connected, Null0
S
172.31.0.0 is directly connected, Null0
10.0.0.0/24 is subnetted, 1 subnets
C
10.100.1.0 is directly connected, FastEthernet0/0
Hay que volver a reactivar las interfaces, excepto las interfaces loopback de R3, porque stas no necesitan
enviar paquetes HELLO ya que no tienen otros vecinos conectados.

El comando a emplear es la NEGACION del anterior.

R1(config)#router ospf 1
R1(config-router)#no passive-interface default
R1(config-router)#exit

R3(config)#router ospf 1
R3(config-router)#no passive-interface s0/0
R3(config-router)#exit

R2(config)#router ospf 1
R2(config-router)#no passive-interface default
R2(config-router)#exit

R5(config)#router ospf 1
R5(config-router)#no passive-interface default
R5(config-router)# exit

R6(config)#router ospf 1
R6(config-router)#no passive-interface default
R6(config-router)#exit

R7(config)#router ospf 1
R7(config-router)#no passive-interface default
R7(config-router)#exit

R4(config)#router ospf 1
R4(config-router)#no passive-interface default
R4(config-router)#exit

R8(config)#router ospf 1
R8(config-router)#no passive-interface default
R8(config-router)#exit

21

Verificando los cambios:


R7#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.31.0.0/24 is subnetted, 4 subnets
O E1 172.31.3.0 [110/260] via 10.67.1.6, 00:00:31, Serial0/1
O E1 172.31.2.0 [110/260] via 10.67.1.6, 00:00:31, Serial0/1
O E1 172.31.1.0 [110/260] via 10.67.1.6, 00:00:31, Serial0/1
O E1 172.31.0.0 [110/260] via 10.67.1.6, 00:00:31, Serial0/1
172.30.0.0/32 is subnetted, 4 subnets
O IA 172.30.3.1 [110/411] via 10.67.1.6, 00:00:31, Serial0/1
O IA 172.30.2.1 [110/411] via 10.67.1.6, 00:00:31, Serial0/1
O IA 172.30.1.1 [110/411] via 10.67.1.6, 00:00:33, Serial0/1
O IA 172.30.0.1 [110/411] via 10.67.1.6, 00:00:33, Serial0/1
10.0.0.0/24 is subnetted, 5 subnets
O IA 10.23.1.0 [110/410] via 10.67.1.6, 00:00:33, Serial0/1
O IA 10.45.1.0 [110/410] via 10.67.1.6, 00:00:33, Serial0/1
C
10.78.1.0 is directly connected, Serial0/0
C
10.67.1.0 is directly connected, Serial0/1
O IA 10.100.1.0 [110/210] via 10.67.1.6, 00:00:34, Serial0/1

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.31.0.0/24 is subnetted, 4 subnets
S
172.31.3.0 is directly connected, Null0
22

S
S
S

172.31.2.0 is directly connected, Null0


172.31.1.0 is directly connected, Null0
172.31.0.0 is directly connected, Null0
172.30.0.0/32 is subnetted, 4 subnets
O IA 172.30.3.1 [110/211] via 10.100.1.2, 00:01:49, FastEthernet0/0
O IA 172.30.2.1 [110/211] via 10.100.1.2, 00:01:49, FastEthernet0/0
O IA 172.30.1.1 [110/211] via 10.100.1.2, 00:01:49, FastEthernet0/0
O IA 172.30.0.1 [110/211] via 10.100.1.2, 00:01:51, FastEthernet0/0
10.0.0.0/24 is subnetted, 4 subnets
O IA 10.23.1.0 [110/210] via 10.100.1.2, 00:01:51, FastEthernet0/0
O IA 10.45.1.0 [110/210] via 10.100.1.4, 00:01:51, FastEthernet0/0
O IA 10.67.1.0 [110/210] via 10.100.1.6, 00:01:51, FastEthernet0/0
C
10.100.1.0 is directly connected, FastEthernet0/0

23

Objetivo 3

Todos los routers del rea 0 deberan usar autenticacin MD5 con sus vecinos. Los
routers en el rea 23 deberan ser configurados para soportar autenticacin en texto
plano con sus vecinos. Todas las claves deben ser configuradas como cisco.
CONFIGURANDO AUTENTICACION MD5 EN AREA 0
R1(config)#int f0/0
R1(config-if)#ip ospf authentication message-digest
R1(config-if)#ip ospf message-digest-key 1 md5 cisco
R1(config-if)#exit
R2(config)#int f0/0
R2(config-if)#ip ospf authentication message-digest
R2(config-if)#ip ospf message-digest-key 1 md5 cisco
R2(config-if)#exit
R6(config)#int f0/0
R6(config-if)#ip ospf authentication message-digest
R6(config-if)#ip ospf message-digest-key 1 md5 cisco
R6(config-if)#exit
R4(config)#int f0/0
R4(config-if)#ip ospf authentication message-digest
R4(config-if)#ip ospf message-digest-key 1 md5 cisco
R4(config-if)# exit
Usando Wireshark para capturar el mensaje donde se observa la autenticacin MD5.

Password Encriptado

24

CONFIGURANDO AUTENTICACION EN TEXTO PLANO EN AREA 23


R2(config)#int s0/0
R2(config-if)#ip ospf authentication
R2(config-if)#ip ospf authentication-key cisco
R2(config-if)#
R3(config)#int s0/0
R3(config-if)#ip ospf authentication
R3(config-if)#ip ospf authentication-key cisco
R3(config-if)#

Password en Texto Plano

25

Objetivo 4

Los routers del rea 45 estn limitados en su capacidad y no deberan recibir rutas de
redes externas al dominio OSPF. Estos routers deberan alcanzar la red externa
usando una ruta por defecto la cual no puede ser configurada estticamente.
CONFIGURANDO AREA STUB EN EL ROUTER R4 Y R5
R4(config)#router ospf 1
R4(config-router)#area 45 stub
R4(config-router)#exit
R5(config)#router ospf 1
R5(config-router)#area 45 stub
R5(config-router)#exit

VERIFICANDO LOS CAMBIOS


R4#show ip ospf database
OSPF Router with ID (4.4.4.4) (Process ID 1)

Link ID
1.1.1.1
2.2.2.2
4.4.4.4
6.6.6.6
7.7.7.7

Router Link States (Area 0)


ADV Router Age
Seq#
Checksum Link count
1.1.1.1
248
0x8000000A 0x00230E 1
2.2.2.2
248
0x8000000C 0x00DD49 1
4.4.4.4
383
0x8000000B 0x0063B2 1
6.6.6.6
944
0x8000000B 0x00D8E0 2
7.7.7.7
2 (DNA) 0x80000002 0x00D2EE 1

Net Link States (Area 0)


Link ID
ADV Router Age
Seq#
Checksum
10.100.1.6 6.6.6.6
384
0x80000007 0x003D2D
Summary Net Link States (Area 0)
Link ID
ADV Router Age
Seq#
Checksum
10.23.1.0
2.2.2.2
373
0x80000003 0x007EC9
10.45.1.0
4.4.4.4
1869
0x80000002 0x003BEF
10.67.1.0
6.6.6.6
1430
0x80000002 0x00F517
10.67.1.0
7.7.7.7
7 (DNA) 0x80000001 0x00D930
10.78.1.0
7.7.7.7
7 (DNA) 0x80000001 0x0055A9
172.30.0.1 2.2.2.2
1445
0x80000001 0x00F6A8
172.30.1.1 2.2.2.2
1445
0x80000001 0x00EBB2
172.30.2.1 2.2.2.2
1445
0x80000001 0x00E0BC
26

172.30.3.1 2.2.2.2
1445
0x80000001 0x00D5C6
Router Link States (Area 45)
Link ID
ADV Router Age
Seq#
Checksum Link count
4.4.4.4
4.4.4.4
27
0x8000000A 0x00954D 2
5.5.5.5
5.5.5.5
25
0x80000006 0x003AA8 2
Summary Net Link States (Area 45)
Link ID
ADV Router Age
Seq#
Checksum
0.0.0.0
4.4.4.4
38
0x80000001 0x0039F4
10.23.1.0
4.4.4.4
38
0x80000002 0x00C672
10.67.1.0
4.4.4.4
38
0x80000002 0x00B458
10.78.1.0
4.4.4.4
38
0x80000002 0x000732
10.100.1.0 4.4.4.4
38
0x80000006 0x004769
172.30.0.1 4.4.4.4
39
0x80000002 0x003B53
172.30.1.1 4.4.4.4
39
0x80000002 0x00305D
172.30.2.1 4.4.4.4
39
0x80000002 0x002567
172.30.3.1 4.4.4.4
39
0x80000002 0x001A71
Type-5 AS External Link States
Link ID
ADV Router Age
Seq#
Checksum Tag
172.31.0.0 1.1.1.1
888
0x80000004 0x0033FC 0
172.31.1.0 1.1.1.1
888
0x80000004 0x002807 0
172.31.2.0 1.1.1.1
888
0x80000004 0x001D11 0
172.31.3.0 1.1.1.1
888
0x80000004 0x00121B 0

R5#show ip ospf database


OSPF Router with ID (5.5.5.5) (Process ID 1)
Router Link States (Area 45)
Link ID
ADV Router Age
Seq#
Checksum Link count
4.4.4.4
4.4.4.4
43
0x8000000A 0x00954D 2
5.5.5.5
5.5.5.5
39
0x80000006 0x003AA8 2
Summary Net Link States (Area 45)
Link ID
ADV Router Age
Seq#
Checksum
0.0.0.0
4.4.4.4
54
0x80000001 0x0039F4
10.23.1.0
4.4.4.4
54
0x80000002 0x00C672
10.67.1.0
4.4.4.4
54
0x80000002 0x00B458
10.78.1.0
4.4.4.4
54
0x80000002 0x000732
10.100.1.0 4.4.4.4
54
0x80000006 0x004769
27

172.30.0.1 4.4.4.4
54
0x80000002 0x003B53
172.30.1.1 4.4.4.4
54
0x80000002 0x00305D
172.30.2.1 4.4.4.4
54
0x80000002 0x002567
172.30.3.1 4.4.4.4
54
0x80000002 0x001A71
Como vemos en un STUB AREA, no se acepta informacin de rutas externas al sistema autnomo (ninguna
redistribucin), como las rutas desde orgenes no OSPF.
Si los routers necesitan enrutar hacia redes ubicada fuera del sistema autnomo OSPF, utilizan una ruta por
defecto 0.0.0.0/0 que es enviada por el ABR (en este caso R4) hacia los routers internos del rea STUB.
Usualmente, en esta rea no se permiten ASBR (a menos que el ABR sea al mismo tiempo un ASBR).
Configurando el AREA STUB (en AREA 45) los paquetes LSA tipo 5 (E1 y E2) son filtrados de la tabla de
enrutamiento.

CONOCIENDO LA TABLA DE ENRUTAMIENTO EN R5


R5#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.45.1.4 to network 0.0.0.0
172.30.0.0/32 is subnetted, 4 subnets
O IA 172.30.3.1 [110/411] via 10.45.1.4, 00:02:55, Serial0/0
O IA 172.30.2.1 [110/411] via 10.45.1.4, 00:02:55, Serial0/0
O IA 172.30.1.1 [110/411] via 10.45.1.4, 00:02:55, Serial0/0
O IA 172.30.0.1 [110/411] via 10.45.1.4, 00:02:55, Serial0/0
10.0.0.0/24 is subnetted, 5 subnets
O IA 10.23.1.0 [110/410] via 10.45.1.4, 00:02:55, Serial0/0
C
10.45.1.0 is directly connected, Serial0/0
O IA 10.78.1.0 [110/610] via 10.45.1.4, 00:02:56, Serial0/0
No conoce las rutas
O IA 10.67.1.0 [110/410] via 10.45.1.4, 00:02:56, Serial0/0
estticas de R1, pero SI
O IA 10.100.1.0 [110/210] via 10.45.1.4, 00:02:56, Serial0/0
conoce una ruta por
Defecto
O*IA 0.0.0.0/0 [110/201] via 10.45.1.4, 00:02:56, Serial0/0

PROBANDO CONECTIVIDAD
R5#ping 10.100.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.100.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/32/52 ms
28

Objetivo 5

Los routers del rea 23 no deben recibir ningn LSA tipo 3, 4 o 5 del resto de la red
OSPF. Estos routers deberan alcanzar la red externa usando una ruta por defecto con
un costo inicial OSPF de 100.
Para que ningn LSA tipo 3, 4 o 5 sean recibidos en el rea 23, se debe configurar esta rea como un OSPF
TOTALLY SUTB AREA, as se filtraran paquetes LSA tipo 5, tipo 3 IA O, y tipo 4 IA O de la tabla de
enrutamiento.
Esta rea es propietaria de Cisco y no acepta rutas de Sistemas Autnomos externos (redistribucin) o rutas
sumarizadas desde otras reas internas del sistema autnomo. Al igual que en las reas Stub, los ABR envan
una ruta por defecto para todas la rutas externas y sumarizadas (a diferencia del STUB).

TABLA DE ENRUTAMIENTO R3 antes de convertirse en AREA TOTALLY STUB


R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
Conoce rutas
172.31.0.0/24 is subnetted, 4 subnets
externas a
OSPF
O E1 172.31.3.0 [110/260] via 10.23.1.2, 00:10:46, Serial0/0
O E1 172.31.2.0 [110/260] via 10.23.1.2, 00:10:46, Serial0/0
O E1 172.31.1.0 [110/260] via 10.23.1.2, 00:10:46, Serial0/0
O E1 172.31.0.0 [110/260] via 10.23.1.2, 00:10:46, Serial0/0
172.30.0.0/24 is subnetted, 4 subnets
C
172.30.2.0 is directly connected, Loopback3
C
172.30.3.0 is directly connected, Loopback4
C
172.30.0.0 is directly connected, Loopback1
C
172.30.1.0 is directly connected, Loopback2
10.0.0.0/24 is subnetted, 4 subnets
C
10.23.1.0 is directly connected, Serial0/0
O IA 10.45.1.0 [110/410] via 10.23.1.2, 00:17:44, Serial0/0
O IA 10.67.1.0 [110/410] via 10.23.1.2, 00:10:54, Serial0/0
O IA 10.100.1.0 [110/210] via 10.23.1.2, 00:23:52, Serial0/0

CONFIGURANDO AREA TOTALLY STUB


R2(config)#router ospf 1
R2(config-router)#area 23 stub no-summary
R2(config-router)#exit
29

R3(config)#router ospf 1
R3(config-router)#area 23 stub no-summary
R3(config-router)#exit

VERIFICANDO SU ACTUALIZACION
R2#show ip ospf
Routing Process "ospf 1" with ID 2.2.2.2
Start time: 00:05:11.500, Time elapsed: 01:56:00.676
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
It is an area border router
Area BACKBONE(0)
Number of interfaces in this area is 1
Area 23
Number of interfaces in this area is 1
It is a stub area, no summary LSA in this area
generates stub default route with cost 1
R3#show ip ospf
Routing Process "ospf 1" with ID 3.3.3.3
Start time: 00:06:50.188, Time elapsed: 01:17:38.624
Supports only single TOS(TOS0) routes
Area 23
Number of interfaces in this area is 5 (4 loopback)
It is a stub area

VERIFICANDO TABLAS DE ENRUTAMIENTO EN AREA 23


R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.31.0.0/24 is subnetted, 4 subnets
30

O E1 172.31.3.0 [110/60] via 10.100.1.1, 00:04:19, FastEthernet0/0


O E1 172.31.2.0 [110/60] via 10.100.1.1, 00:04:19, FastEthernet0/0
O E1 172.31.1.0 [110/60] via 10.100.1.1, 00:04:19, FastEthernet0/0
O E1 172.31.0.0 [110/60] via 10.100.1.1, 00:04:19, FastEthernet0/0
172.30.0.0/32 is subnetted, 4 subnets
O
172.30.3.1 [110/201] via 10.23.1.3, 00:04:19, Serial0/0
O
172.30.2.1 [110/201] via 10.23.1.3, 00:04:19, Serial0/0
O
172.30.1.1 [110/201] via 10.23.1.3, 00:04:20, Serial0/0
O
172.30.0.1 [110/201] via 10.23.1.3, 00:04:20, Serial0/0
10.0.0.0/24 is subnetted, 5 subnets
C
10.23.1.0 is directly connected, Serial0/0
O IA 10.45.1.0 [110/210] via 10.100.1.4, 00:04:20, FastEthernet0/0
O IA 10.78.1.0 [110/410] via 10.100.1.6, 00:04:22, FastEthernet0/0
O IA 10.67.1.0 [110/210] via 10.100.1.6, 00:04:22, FastEthernet0/0
C
10.100.1.0 is directly connected, FastEthernet0/0

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.23.1.2 to network 0.0.0.0
172.30.0.0/24 is subnetted, 4 subnets
C
172.30.2.0 is directly connected, Loopback3
C
172.30.3.0 is directly connected, Loopback4
C
172.30.0.0 is directly connected, Loopback1
C
172.30.1.0 is directly connected, Loopback2
10.0.0.0/24 is subnetted, 1 subnets
Solo conoce la RUTA
C
10.23.1.0 is directly connected, Serial0/0
POR DEFECTO
O*IA 0.0.0.0/0 [110/201] via 10.23.1.2, 00:04:22, Serial0/0

AGREGANDO COSTO INICIAL OSPF 100 PARA RUTAS POR DEFECTO


R2(config)#router ospf 1
R2(config-router)#area 23 default-cost 100
R2(config-router)#exit

31

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.31.0.0/24 is subnetted, 4 subnets
O E1 172.31.3.0 [110/60] via 10.100.1.1, 00:06:04, FastEthernet0/0
O E1 172.31.2.0 [110/60] via 10.100.1.1, 00:06:04, FastEthernet0/0
O E1 172.31.1.0 [110/60] via 10.100.1.1, 00:06:04, FastEthernet0/0
O E1 172.31.0.0 [110/60] via 10.100.1.1, 00:06:04, FastEthernet0/0
172.30.0.0/32 is subnetted, 4 subnets
O
172.30.3.1 [110/201] via 10.23.1.3, 00:06:04, Serial0/0
O
172.30.2.1 [110/201] via 10.23.1.3, 00:06:04, Serial0/0
O
172.30.1.1 [110/201] via 10.23.1.3, 00:06:05, Serial0/0
O
172.30.0.1 [110/201] via 10.23.1.3, 00:06:05, Serial0/0
10.0.0.0/24 is subnetted, 5 subnets
C
10.23.1.0 is directly connected, Serial0/0
O IA 10.45.1.0 [110/210] via 10.100.1.4, 00:06:05, FastEthernet0/0
O IA 10.78.1.0 [110/410] via 10.100.1.6, 00:06:08, FastEthernet0/0
O IA 10.67.1.0 [110/210] via 10.100.1.6, 00:06:08, FastEthernet0/0
C
10.100.1.0 is directly connected, FastEthernet0/0

R3(config)#router ospf 1
R3(config-router)#area 23 default-cost 100
R3(config-router)#exit
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.23.1.2 to network 0.0.0.0
32

172.30.0.0/24 is subnetted, 4 subnets


C
172.30.2.0 is directly connected, Loopback3
C
172.30.3.0 is directly connected, Loopback4
C
172.30.0.0 is directly connected, Loopback1
C
172.30.1.0 is directly connected, Loopback2
10.0.0.0/24 is subnetted, 1 subnets
C
10.23.1.0 is directly connected, Serial0/0
O*IA 0.0.0.0/0 [110/300] via 10.23.1.2, 00:01:04, Serial0/0

Se incremento su
COSTO INICIAL en 100

Objetivo 6

Todos los routers deberan poder hacer ping a cada ruta en la tabla de enrutamiento
OSPF.
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.31.0.0/24 is subnetted, 4 subnets
S
172.31.3.0 is directly connected, Null0
S
172.31.2.0 is directly connected, Null0
S
172.31.1.0 is directly connected, Null0
S
172.31.0.0 is directly connected, Null0
172.30.0.0/24 is subnetted, 4 subnets
O IA 172.30.2.0 [110/211] via 10.100.1.2, 00:00:47, FastEthernet0/0
O IA 172.30.3.0 [110/211] via 10.100.1.2, 00:00:47, FastEthernet0/0
O IA 172.30.0.0 [110/211] via 10.100.1.2, 00:00:48, FastEthernet0/0
O IA 172.30.1.0 [110/211] via 10.100.1.2, 00:00:48, FastEthernet0/0
10.0.0.0/24 is subnetted, 5 subnets
O IA 10.23.1.0 [110/210] via 10.100.1.2, 00:00:48, FastEthernet0/0
O IA 10.45.1.0 [110/210] via 10.100.1.4, 00:00:49, FastEthernet0/0
O IA 10.78.1.0 [110/410] via 10.100.1.6, 00:00:49, FastEthernet0/0
O IA 10.67.1.0 [110/210] via 10.100.1.6, 00:00:49, FastEthernet0/0
C
10.100.1.0 is directly connected, FastEthernet0/0
O E1 192.168.1.0/24 [110/230] via 10.100.1.4, 00:00:49, FastEthernet0/0

33

R1#ping 10.45.1.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.45.1.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/37/52 ms
R1#ping 10.78.1.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.78.1.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/37/60 ms
R1#ping 10.23.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.23.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/28/52 ms
R1#ping 10.67.1.7
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.67.1.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/41/100 ms

R5#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.45.1.4 to network 0.0.0.0
172.30.0.0/32 is subnetted, 4 subnets
O IA 172.30.3.1 [110/411] via 10.45.1.4, 00:02:55, Serial0/0
O IA 172.30.2.1 [110/411] via 10.45.1.4, 00:02:55, Serial0/0
O IA 172.30.1.1 [110/411] via 10.45.1.4, 00:02:55, Serial0/0
O IA 172.30.0.1 [110/411] via 10.45.1.4, 00:02:55, Serial0/0
34

10.0.0.0/24 is subnetted, 5 subnets


O IA 10.23.1.0 [110/410] via 10.45.1.4, 00:02:55, Serial0/0
C
10.45.1.0 is directly connected, Serial0/0
O IA 10.78.1.0 [110/610] via 10.45.1.4, 00:02:56, Serial0/0
O IA 10.67.1.0 [110/410] via 10.45.1.4, 00:02:56, Serial0/0
O IA 10.100.1.0 [110/210] via 10.45.1.4, 00:02:56, Serial0/0
O*IA 0.0.0.0/0 [110/201] via 10.45.1.4, 00:02:56, Serial0/0

R5#ping 172.30.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/40/76 ms
R5#ping 10.78.1.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.78.1.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/36/52 ms
R5#ping 10.23.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.23.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/35/68 ms
R5#ping 10.100.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.100.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/32/52 ms
R5#ping 10.67.1.7
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.67.1.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/41/68 ms

35

Objetivo 7

Configurar EIGRP en R5 y R9. Publicar en EIGRP todas las loopbacks de R9. Una vez
hecho esto configurar redistribucin mutua entre EIGRP y OSPF en R5. Cambiar el
tipo del rea 45 para que soporte ASBRs, y una vez hecho esto configurar R4 para que
genere la ruta por defecto correspondiente.

CONFIGURANDO R9

INTERFACES

R9

R5

R9(config)#int s0/0
R9(config-if)#ip address 192.168.1.9 255.255.255.0
R9(config-if)#bandwidth 500
R9(config-if)#no shutdown
R9(config-if)#exit

R5(config)#int s0/1
R5(config-if)#ip address 192.168.1.5 255.255.255.0
R5(config-if)#bandwidth 500
R5(config-if)#clock rate 500000
R5(config-if)#no shutdown
R5(config-if)#exit

R9(config)#int loopback 1
R9(config-if)#ip address 172.16.0.1 255.255.255.0
R9(config-if)#no shutdown
R9(config-if)#exit
R9(config)#int loopback 2
R9(config-if)#ip address 172.16.1.1 255.255.255.0
R9(config-if)#no shutdown
R9(config-if)#exit
R9(config)#int loopback 3
R9(config-if)#ip address 172.16.2.1 255.255.255.0
R9(config-if)#no shutdown
R9(config-if)#exit
R9(config)#int loopback 4
R9(config-if)#ip address 172.16.3.1 255.255.255.0
36

R9(config-if)#no shutdown
R9(config-if)#exit

ENRUTAMIENTO EIGPR
R5(config)#router eigrp 100
R5(config-router)#network 192.168.1.0
R5(config-router)# exit

R9(config)#router eigrp 100


R9(config-router)#network 192.168.1.0
R9(config-router)#

VERIFICANDO EIGRP
R5#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.45.1.4 to network 0.0.0.0
172.30.0.0/32 is subnetted, 4 subnets
O IA 172.30.3.1 [110/411] via 10.45.1.4, 00:21:10, Serial0/0
O IA 172.30.2.1 [110/411] via 10.45.1.4, 00:21:10, Serial0/0
O IA 172.30.1.1 [110/411] via 10.45.1.4, 00:21:10, Serial0/0
O IA 172.30.0.1 [110/411] via 10.45.1.4, 00:21:10, Serial0/0
10.0.0.0/24 is subnetted, 5 subnets
O IA 10.23.1.0 [110/410] via 10.45.1.4, 00:27:24, Serial0/0
C
10.45.1.0 is directly connected, Serial0/0
O IA 10.78.1.0 [110/610] via 10.45.1.4, 00:27:26, Serial0/0
O IA 10.67.1.0 [110/410] via 10.45.1.4, 00:27:26, Serial0/0
O IA 10.100.1.0 [110/210] via 10.45.1.4, 00:27:26, Serial0/0
O*IA 0.0.0.0/0 [110/201] via 10.45.1.4, 00:27:26, Serial0/0
R9#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

37

Gateway of last resort is not set

C
C
C
C
C

172.16.0.0/24 is subnetted, 4 subnets


172.16.0.0 is directly connected, Loopback1
172.16.1.0 is directly connected, Loopback2
172.16.2.0 is directly connected, Loopback3
172.16.3.0 is directly connected, Loopback4
192.168.1.0/24 is directly connected, Serial0/0

PUBLICANDO LOOPBACKS DE R9 EN EIGRP


R9(config)#router eigrp 100
R9(config-router)#network 172.16.0.0 0.0.0.255
R9(config-router)#network 172.16.1.0 0.0.0.255
R9(config-router)#network 172.16.2.0 0.0.0.255
R9(config-router)#network 172.16.3.0 0.0.0.255

CAMBIANDO EL AREA 45 DE AREA STUB A NSSA


R5(config)#router ospf 1
R5(config-router)#no area 45 stub
R5(config-router)#are 45 nssa
R4(config)#router ospf 1
R4(config-router)#no area 45 stub
R4(config-router)#area 45 nssa

CONFIGURANDO REDISTRIBUCION ENTRE EIGPR Y OSPF EN R5


R5(config)#router eigrp 100
R5(config-router)#redistribute ospf 1 metric 100 100 100 100 100
R5(config-router)# exit

R5(config)#router ospf 1
R5(config-router)#redistribute eigrp 100 subnets metric-type 1
R5(config-router)# exit

CONFIGURANDO RUTA POR DEFECTO


R5(config)#router ospf 1
R5(config-router)#area 45 nssa default-information-originate
38

R5(config-router)#exit

R9#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
C
172.16.0.0/24 is directly connected, Loopback1
D
172.16.0.0/16 is a summary, 00:01:28, Null0
C
172.16.1.0/24 is directly connected, Loopback2
C
172.16.2.0/24 is directly connected, Loopback3
C
172.16.3.0/24 is directly connected, Loopback4
172.30.0.0/32 is subnetted, 4 subnets
D EX 172.30.3.1 [170/26137600] via 192.168.1.5, 00:01:28, Serial0/0
D EX 172.30.2.1 [170/26137600] via 192.168.1.5, 00:01:28, Serial0/0
D EX 172.30.1.1 [170/26137600] via 192.168.1.5, 00:01:29, Serial0/0
D EX 172.30.0.1 [170/26137600] via 192.168.1.5, 00:01:29, Serial0/0
10.0.0.0/24 is subnetted, 5 subnets
D EX 10.23.1.0 [170/26137600] via 192.168.1.5, 00:01:29, Serial0/0
D EX 10.45.1.0 [170/26137600] via 192.168.1.5, 00:01:30, Serial0/0
D EX 10.78.1.0 [170/26137600] via 192.168.1.5, 00:01:30, Serial0/0
D EX 10.67.1.0 [170/26137600] via 192.168.1.5, 00:01:30, Serial0/0
D EX 10.100.1.0 [170/26137600] via 192.168.1.5, 00:01:30, Serial0/0
C 192.168.1.0/24 is directly connected, Serial0/0

R9#show ip eigrp 100 neighbors


IP-EIGRP neighbors for process 100
H Address
Interface
Hold Uptime SRTT RTO Q Seq
(sec)
(ms)
Cnt Num
0 192.168.1.5
Se0/0
11 00:05:27 67 402 0 3

R9#show ip eigrp 100 topology


IP-EIGRP Topology Table for AS(100)/ID(172.16.3.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
39

r - reply Status, s - sia Status


P 10.23.1.0/24, 1 successors, FD is 26137600
via 192.168.1.5 (26137600/25625600), Serial0/0
P 10.45.1.0/24, 1 successors, FD is 26137600
via 192.168.1.5 (26137600/25625600), Serial0/0
P 10.78.1.0/24, 1 successors, FD is 26137600
via 192.168.1.5 (26137600/25625600), Serial0/0
P 10.67.1.0/24, 1 successors, FD is 26137600
via 192.168.1.5 (26137600/25625600), Serial0/0
P 192.168.1.0/24, 1 successors, FD is 5632000
via Connected, Serial0/0
P 10.100.1.0/24, 1 successors, FD is 26137600
via 192.168.1.5 (26137600/25625600), Serial0/0
P 172.30.3.1/32, 1 successors, FD is 26137600
via 192.168.1.5 (26137600/25625600), Serial0/0
P 172.30.2.1/32, 1 successors, FD is 26137600
via 192.168.1.5 (26137600/25625600), Serial0/0
P 172.30.1.1/32, 1 successors, FD is 26137600
via 192.168.1.5 (26137600/25625600), Serial0/0
P 172.30.0.1/32, 1 successors, FD is 26137600
via 192.168.1.5 (26137600/25625600), Serial0/0
P 172.16.0.0/16, 1 successors, FD is 128256
via Summary (128256/0), Null0
P 172.16.0.0/24, 1 successors, FD is 128256
via Connected, Loopback1
P 172.16.1.0/24, 1 successors, FD is 128256
via Connected, Loopback2
P 172.16.2.0/24, 1 successors, FD is 128256
via Connected, Loopback3
P 172.16.3.0/24, 1 successors, FD is 128256
via Connected, Loopback4

R5#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
40

D 172.16.0.0/16 [90/5760000] via 192.168.1.9, 00:01:12, Serial0/1


172.30.0.0/24 is subnetted, 4 subnets
O IA 172.30.2.0 [110/411] via 10.45.1.4, 00:00:26, Serial0/0
O IA 172.30.3.0 [110/411] via 10.45.1.4, 00:00:26, Serial0/0
O IA 172.30.0.0 [110/411] via 10.45.1.4, 00:00:26, Serial0/0
O IA 172.30.1.0 [110/411] via 10.45.1.4, 00:00:26, Serial0/0
10.0.0.0/24 is subnetted, 5 subnets
O IA 10.23.1.0 [110/410] via 10.45.1.4, 00:00:26, Serial0/0
C
10.45.1.0 is directly connected, Serial0/0
O IA 10.78.1.0 [110/610] via 10.45.1.4, 00:00:28, Serial0/0
O IA 10.67.1.0 [110/410] via 10.45.1.4, 00:00:28, Serial0/0
O IA 10.100.1.0 [110/210] via 10.45.1.4, 00:00:59, Serial0/0
C 192.168.1.0/24 is directly connected, Serial0/1

Objetivo 8

Todos los routers deberan poder hacer ping a cada ruta en la tabla de enrutamiento
atravesando los dominios OSPF y EIGRP.

Desde EIGRP a OSPF


R9#ping 10.67.1.7
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.67.1.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/49/92 ms

R9#ping 10.23.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.23.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/55/96 ms
R9#ping 172.30.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/44/112 ms
R9#ping 172.30.1.1
41

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 172.30.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/40/64 ms
R9#ping 10.78.1.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.78.1.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/51/88 ms

Desde OSPF a EIGRP


R3#ping 192.168.1.9
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.9, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/65/108 ms
R3#ping 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/59/108 ms
R4#ping 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/24/60 ms
R8#ping 192.168.1.9
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.9, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/48/76 ms
R6#ping 172.16.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
!!!!!
42

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/28/72 ms

Comentarios y Conclusiones
-

Cuando es necesario filtrar paquetes LSA tipo 3,4 o 5 se configura los distintos tipos de reas de OSPF
como el STUB AREA, que no acepta informacin acerca de rutas externas al sistema autnomo; el
TOTALLY STUBBY AREA no acepta rutas de sistemas autnomos externos (ninguna redistribucin) o
rutas sumarizadas desde otras reas internas del sistema autnomo, al igual que el STUB los ABR
envan una ruta por defecto para todas las rutas externas. En el rea NSSA existen LSA tipo 7, son
similares al rea STUB porque no aceptan informacin de rutas externas al mundo OSPF, pero la
diferencia esta en que NSSA si acepta un ASBR que se conecte con otros protocolos de enrutamiento
(por ejemplo RIP, EIGRP, etc). El TOTALLY STUBBY NSSA no permite rutas externas ni sumarizadas,
pero si permite un ASBR como en NSSA.
Para verificar el efecto producido por los cambios hechos en los routers, es recomendable usar la
variedad de los comandos de show y otros como show running-config y show ip route.
Cuando se trata de interconectar dos protocolos de enrutamiento distintos, es necesario inyectar las
tablas de ruteo de uno en el otro.

43

ANEXOS
R1#show running-config
Building configuration...
Current configuration : 1057 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
interface FastEthernet0/0
ip address 10.100.1.1 255.255.255.0
Autenticacin MD5
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
Redistribucin Rutas Estticas
redistribute static metric 50 metric-type 1 subnets
network 10.100.1.0 0.0.0.255 area 0
!
44

ip forward-protocol nd
ip route 172.31.0.0 255.255.255.0 Null0
ip route 172.31.1.0 255.255.255.0 Null0
ip route 172.31.2.0 255.255.255.0 Null0
ip route 172.31.3.0 255.255.255.0 Null0
!
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
login
!
!
End

Rutas Estticas Externas

R2#show running-config
Building configuration...
Current configuration : 1150 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
ip cef
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
45

interface FastEthernet0/0
ip address 10.100.1.2 255.255.255.0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
duplex auto
speed auto
!
interface Serial0/0
bandwidth 500
ip address 10.23.1.2 255.255.255.0
ip ospf authentication
ip ospf authentication-key cisco
clock rate 500000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
area 23 stub no-summary
area 23 default-cost 100
network 10.23.1.0 0.0.0.255 area 23
network 10.100.1.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4

Autenticacin MD5

Autenticacin Texto Plano

Totally Stub

46

login
!
!
End

R6#show running-config
Building configuration...
Current configuration : 1070 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
ip cef
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
interface FastEthernet0/0
ip address 10.100.1.6 255.255.255.0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
duplex auto
speed auto
!
interface Serial0/0
bandwidth 500
ip address 10.67.1.6 255.255.255.0
clock rate 500000
!
interface FastEthernet0/1
no ip address
shutdown

Autenticacin MD5

47

duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
router-id 6.6.6.6
log-adjacency-changes
area 67 virtual-link 7.7.7.7
network 10.67.1.0 0.0.0.255 area 67
network 10.100.1.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
login
!
!
End

Virtual Link

R4#show running-config
Building configuration...
Current configuration : 1054 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
48

boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
ip cef
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
interface FastEthernet0/0
ip address 10.100.1.4 255.255.255.0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
duplex auto
speed auto
!
interface Serial0/0
bandwidth 500
ip address 10.45.1.4 255.255.255.0
clock rate 500000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
router-id 4.4.4.4
log-adjacency-changes
area 45 nssa
network 10.45.1.0 0.0.0.255 area 45
network 10.100.1.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!

Autenticacin MD5

rea NSSA

49

ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
login
!
end

R3#show running-config
Building configuration...
Current configuration : 1598 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
ip cef
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
interface Loopback1
ip address 172.30.0.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback2
ip address 172.30.1.1 255.255.255.0
ip ospf network point-to-point
!
50

interface Loopback3
ip address 172.30.2.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback4
ip address 172.30.3.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
bandwidth 500
ip address 10.23.1.3 255.255.255.0
Autenticacin Texto Plano
ip ospf authentication
ip ospf authentication-key cisco
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
rea Totally Stub
router-id 3.3.3.3
log-adjacency-changes
area 23 stub no-summary
Costo por defecto 100
area 23 default-cost 100
passive-interface default
no passive-interface Serial0/0
network 10.23.1.0 0.0.0.255 area 23
Conocimiento de las
network 172.30.0.0 0.0.0.255 area 23
LOOPBACK en OSPF
network 172.30.1.0 0.0.0.255 area 23
network 172.30.2.0 0.0.0.255 area 23
network 172.30.3.0 0.0.0.255 area 23
51

!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
login
!
End

R7#show running-config
Building configuration...
Current configuration : 1005 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R7
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
52

interface Serial0/0
bandwidth 500
ip address 10.78.1.7 255.255.255.0
clock rate 500000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
bandwidth 500
ip address 10.67.1.7 255.255.255.0
clock rate 2000000
!
router ospf 1
router-id 7.7.7.7
Virtual Link
log-adjacency-changes
area 67 virtual-link 6.6.6.6
network 10.67.1.0 0.0.0.255 area 67
network 10.78.1.0 0.0.0.255 area 78
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
login
!
!
End

53

R8#show running-config
Building configuration...
Current configuration : 913 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R8
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
ip cef
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
bandwidth 500
ip address 10.78.1.8 255.255.255.0
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
54

router-id 8.8.8.8
log-adjacency-changes
network 10.78.1.0 0.0.0.255 area 78
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
login
!
End

R5#show running-config
Building configuration...
Current configuration : 1102 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
ip cef
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
interface FastEthernet0/0
55

no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
bandwidth 500
ip address 10.45.1.5 255.255.255.0
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
bandwidth 500
ip address 192.168.1.5 255.255.255.0
clock rate 500000
!
Enrutamiento EIGRP
router eigrp 100
redistribute ospf 1 metric 100 100 100 100 100
network 192.168.1.0
auto-summary
!
Enrutamiento OSPF
router ospf 1
router-id 5.5.5.5
log-adjacency-changes
Area OSPF NSSA
area 45 nssa
redistribute eigrp 100 metric-type 1 subnets
network 10.45.1.0 0.0.0.255 area 45
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
login

Inyeccin EIGRP en OSPF

Inyeccin OSPF en EIGRP

56

!
End

R9#show running-config
Building configuration...
Current configuration : 1292 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R9
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
ip cef
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
interface Loopback1
ip address 172.16.0.1 255.255.255.0
!
interface Loopback2
ip address 172.16.1.1 255.255.255.0
!
interface Loopback3
ip address 172.16.2.1 255.255.255.0
!
interface Loopback4
ip address 172.16.3.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
57

duplex auto
speed auto
!
interface Serial0/0
bandwidth 500
ip address 192.168.1.9 255.255.255.0
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
Enrutamiento EIGRP
router eigrp 100
network 172.16.0.0 0.0.0.255
Conocimiento de
network 172.16.1.0 0.0.0.255
LOOPBACKs
en EIGPR
network 172.16.2.0 0.0.0.255
network 172.16.3.0 0.0.0.255
network 192.168.1.0
auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
End

58

R1#show ip protocols
Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 1.1.1.1
It is an autonomous system boundary router
Redistributing External Routes from,
static with metric mapped to 50, includes subnets in redistribution
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
10.100.1.0 0.0.0.255 area 0
Reference bandwidth unit is 100 mbps
Routing Information Sources:
Gateway
Distance Last Update
7.7.7.7
110 00:01:03
6.6.6.6
110 00:01:03
4.4.4.4
110 00:01:03
2.2.2.2
110 00:01:03
Distance: (default is 110)

R2#show ip protocols
Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 2.2.2.2
It is an area border router
Number of areas in this router is 2. 1 normal 1 stub 0 nssa
Maximum path: 4
Routing for Networks:
10.23.1.0 0.0.0.255 area 23
10.100.1.0 0.0.0.255 area 0
Reference bandwidth unit is 100 mbps
Routing Information Sources:
Gateway
Distance Last Update
1.1.1.1
110 00:01:32
7.7.7.7
110 00:01:32
6.6.6.6
110 00:01:32
4.4.4.4
110 00:01:32
3.3.3.3
110 00:02:18
Distance: (default is 110)

59

R3#show ip protocols
Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 3.3.3.3
Number of areas in this router is 1. 0 normal 1 stub 0 nssa
Maximum path: 4
Routing for Networks:
10.23.1.0 0.0.0.255 area 23
172.30.0.0 0.0.0.255 area 23
172.30.1.0 0.0.0.255 area 23
172.30.2.0 0.0.0.255 area 23
172.30.3.0 0.0.0.255 area 23
Reference bandwidth unit is 100 mbps
Passive Interface(s):
FastEthernet0/0
FastEthernet0/1
Serial0/1
Loopback1
Loopback2
Loopback3
Loopback4
VoIP-Null0
Routing Information Sources:
Gateway
Distance Last Update
2.2.2.2
110 00:07:20
Distance: (default is 110)

R6#show ip protocols
Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 6.6.6.6
It is an area border router
Number of areas in this router is 2. 2 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
10.67.1.0 0.0.0.255 area 67
10.100.1.0 0.0.0.255 area 0
Reference bandwidth unit is 100 mbps
Routing Information Sources:
60

Gateway
Distance Last Update
1.1.1.1
110 00:09:00
4.4.4.4
110 00:09:00
2.2.2.2
110 00:09:10
7.7.7.7
110 00:09:10
Distance: (default is 110)

R7#show ip protocols
Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 7.7.7.7
It is an area border router
Number of areas in this router is 3. 3 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
10.67.1.0 0.0.0.255 area 67
10.78.1.0 0.0.0.255 area 78
Reference bandwidth unit is 100 mbps
Routing Information Sources:
Gateway
Distance Last Update
1.1.1.1
110 00:13:10
4.4.4.4
110 00:13:10
2.2.2.2
110 00:13:10
6.6.6.6
110 00:13:10
Distance: (default is 110)

R8#show ip protocols
Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 8.8.8.8
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
10.78.1.0 0.0.0.255 area 78
Reference bandwidth unit is 100 mbps
Routing Information Sources:
Gateway
Distance Last Update
1.1.1.1
110 00:13:40
61

4.4.4.4
110 00:13:40
7.7.7.7
110 00:13:45
Distance: (default is 110)

R4#show ip protocols
Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 4.4.4.4
It is an area border and autonomous system boundary router
Redistributing External Routes from,
Number of areas in this router is 2. 1 normal 0 stub 1 nssa
Maximum path: 4
Routing for Networks:
10.45.1.0 0.0.0.255 area 45
10.100.1.0 0.0.0.255 area 0
Reference bandwidth unit is 100 mbps
Routing Information Sources:
Gateway
Distance Last Update
1.1.1.1
110 00:14:35
7.7.7.7
110 00:14:35
6.6.6.6
110 00:14:35
2.2.2.2
110 00:14:35
5.5.5.5
110 00:14:35
Distance: (default is 110)

R5#show ip protocols
Routing Protocol is "eigrp 100"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 100, ospf 1
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
62

192.168.1.0
Routing Information Sources:
Gateway
Distance Last Update
192.168.1.9
90 00:16:12
Distance: internal 90 external 170
Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 5.5.5.5
It is an autonomous system boundary router
Redistributing External Routes from,
eigrp 100, includes subnets in redistribution
Number of areas in this router is 1. 0 normal 0 stub 1 nssa
Maximum path: 4
Routing for Networks:
10.45.1.0 0.0.0.255 area 45
Reference bandwidth unit is 100 mbps
Routing Information Sources:
Gateway
Distance Last Update
4.4.4.4
110 00:15:26
Distance: (default is 110)

R9#show ip protocols
Routing Protocol is "eigrp 100"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 100
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is in effect
Automatic address summarization:
192.168.1.0/24 for Loopback1, Loopback2, Loopback3
Loopback4
172.16.0.0/16 for Serial0/0
Summarizing with metric 128256
Maximum path: 4
63

Routing for Networks:


172.16.0.0/24
172.16.1.0/24
172.16.2.0/24
172.16.3.0/24
192.168.1.0
Routing Information Sources:
Gateway
Distance Last Update
(this router)
90 00:17:12
192.168.1.5
90 00:16:12
Distance: internal 90 external 170

64