Anda di halaman 1dari 4

CLASE DE COMPUTACIN Y ALGORITMOS I

FECHA: 21-06-2016

Ejercicio Resuelto
Los trabajadores de una fbrica tienen 3 turnos, M: maana, T: tarde y N: noche. La tarifa por hora
de los turnos de maana y tarde son iguales, mientras que de noche son 30% mayores. Adems si
la cantidad de horas trabajadas a la semana supera las 40, el trabajador recibe una bonificacin del
10% de su salario, y si pertenece al turno noche, la bonificacin es del 15%. Construya un programa
que lea el nmero de horas laboradas en una semana de un trabajador, la tarifa y su turno, para
luego calcular el salario semanal. Considere que durante la semana el trabajador se encuentra
siempre en el mismo turno.
a) ANLISIS DEL PROBLEMA
Sean:
h : horas laboradas.
ta: tarifa por hora.

h, ta, tu

tu=M o tu=T
h>40
(V) sa = 1.10 * (h * ta)
(F) sa = h * ta
tu=N
h>40
(V) sa = 1.15 * (h * ta*1.30)
(F) sa = h * ta

b) DISEO DEL ALGORITMO


Pseudocdigo
Inicio
Entero h
Real ta, sa
Caracter tu
Leer h, ta, tu
si (tu='M' o tu='T')
si (h>40)
sa=1.10*(h*ta)
Sino
sa=h*ta
FinSi
Sino

tu: turno de trabajo.


sa: salario semanal.

sa

si (h>40)
sa=1.15*(h*ta*1.30)
Sino
sa=h*ta
FinSi
FinSi
Escribir "Salario semanal S/. : ", sa
Fin

Diagrama de Flujo

Diagrama N/S

c) PRUEBA DE ESCRITORIO
N
Ejec
.
1
2
3

ta

tu

tu='M' o tu='T'

h>40

sa

10
41
42

5
5
5

M
T
N

V
V
F

F
V
V

50
225.5
313.95

Pantalla

Salario semanal S/. 50


Salario semanal S/. 225.5
Salario semanal S/. 313.95

d) CODIFICACIN EN C#

static void Main(string[] args)


{
int h;
double ta,sa;
char tu;
Console.WriteLine("Ing. horas laboradas:");
h = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Ingrese tarifa por hora:");
ta = Convert.ToDouble(Console.ReadLine());
Console.WriteLine("Ingrese turno:");
tu = Convert.ToChar(Console.ReadLine());
if (tu == 'M' || tu == 'T')
{

if (h > 40)
sa = 1.10 * (h * ta);
else
sa = h * ta;
}
else
{
if (h > 40)
sa = 1.15 * (h * ta * 1.30);
else
sa = h * ta;
}
Console.WriteLine("Salario semanal S/.:"+sa);
Console.Read();

TAREA INDIVIDUAL
Desarrollar 2 ejercicios de la Practica N 02.