Anda di halaman 1dari 10

Step By Step Instalasi Squid 3.5.0.

2 CLEAR
OS 6.xx Versi 64bit Untuk Cache HTTPS
SSLBUMP + TPPROXY MODE
STANDALONE /STANDALONE NO
FIREWAAL Marsha Manihuruk

posted by Marsha Manihuruk on 1:08:00 AM No Comments Clear Os

Clear Os & Proxy


Halo Assalammualaikum para pengunjung blog saya yang tercinta, malam ini tanggal 7/11/2016
Sha akan share artikel yang lumayan menarik nih,
Artikelnya adalah Instal Squid 3.5.0.2 CLEAR OS 6.xx 64bit Untuk Cache HTTPS
SSLBUMP + TPPROXY sekilas di baca pasti bertanya kenapa 64 bit? kenapa nggak 32 bit?
Tidak ada alasan khusus hanya saya pribadi merasa OS yang mempunyai kemampuan 64 bit
lebih baik dri 32 bit :).
Ok Petunjuk ini Sha buatin biar yang masih meraba belajar Sendiri itu namanya mengerti paham
dan bagaimana cara setting Linux jenis ini Khususnya untuk optimasi Squid Cache nya kenapa
begitu?

Saya tidak tau mengapa mungkin pihak Developernya malas update versi squidnya hingga
memancing rasa penasaran para pemakainya memodifikasi isi dari linux ini :).
Saya Pribadi menilai Developer hanya menyediakan versi squid 3.xx untuk versi 6 ke atas doang
tanpa ada embel apa-apa entahkah itu ZPH/QoS atau mendukung versi SSL BUMP.
Setiap mengeluarkan versi Clear Os yang sudah mencapai versi 7 hanya di bekali squid versi 3
polos :),
Ataukah Pihak Developer lebih Fokus ke penOptimalan Linux ini ke Fungsi Server?.
Apa mungkin Developer lebih memilih memanjakan versi yg berbayar? kemungkina iya sih,
kalau udah bayar kan pasti di dukung penuh hi hi.
Silahkan anda nilai sendiri :).
Nah karena manusia itu memiliki rasa penasaran yang tinggi, nah saya juga begitu pada saat
belajar setting ini Linux, saya mutar-mutar di Google di Forum ketika terbentur masalah
akhirnya alhamdulillah selesai dan linux jenis ini emang handal dan tahan lama, masalahnya
hanya lama instal doang huahahahah (wajar karena banyak modul yang mungkin untuk
keperluan server yang ikut di instal).
Tutor ini udah lama sih Sha Terapkan cuma belum sha posting di blog seorang sahabat di
Facebook yang bernama Wak Kampret (panggilan akrabnya) :v :v meminta tolong akhirnya Sha
membuat postingan ini, semoga yang lain yang mengikuti dari awal sampe akhir juga berhasil
amin.
Ok syarat utama agar semua berhasil menginstal Squid versi ini adalah:
1.clear os sudah terinstal dengan baik dan mode nya standalone atau standalone
no firewaal.
2.sudah bisa di remote dengan komputer lain.
3.kamu sudah instal web proxy nya (download dari marketnya gratis kok)
4.sudah ada squid yang berjalan ( hanya mancing doang ) itu squidnya bakal
kita hapus bersih.
5.kamu udah download alat perangnya antara lain putty,winscp dan notepad ++
6.udah terhubung ke internet

7.di link akhir ada link download squid calculator (apa itu?) software kecil
tapi berguna untuk menghitung kapasitas yang tepat untuk pemakaian memory Ram
proxy external.
8.kue makanan buku karena kalau internet kamu lelet bakalan lama nunggu
updatenya hi hi

Periksa semua ketentuan di atas, sudah ada atau belum? kalau masih belum silahkan di lengkapi
semua :)
Kalau sudah mari ke topik nya cara instal ulang squidnya sampe sukses :).
Buka Putty Loginkan sebagai Root dan ketik atau copas perintah berikut di Puttynya.
yum remove app-web-proxy

Selesai di uninstal web proxynya,


Download dan Instal Squid 3.5.0.2 yang sudah Sha siapkan di Sini .
(yang perlu pindahkan ke root adalah file squid-3.5.0.2-1.v6.x86_64.rpm doang yg sisanya tidak
perlu).
Buka Winscp Loginkan dan dan pindahkan hasil downloadnya ke Root ClearOsnya, stelah
sukses kamu buka Puttynya terus ketik atau copas perintah seperti ini:
rpm -ivh squid-3.5.0.2-1.v6.x86_64.rpm

Silahkan di tunggu proses Instalnya berlangsung, slesai dan sukses ikutin semua step-stepnya
yang Sha buat ok.
squid -v
chown squid:squid /cache && chmod 777 /cache
chown squid:squid /var/log/squid
rm /etc/squid/squid.conf
cd /etc/squid
wget https://www.dropbox.com/s/zy8y5ygnwy3txay/squid.conf
wget https://www.dropbox.com/s/6x7d86iyogb8qgi/store-id.pl?m=
chmod 777 /etc/squid/store-id.pl

Silahkan Download File Squid Untuk /etc/init.d


File ada di Sini.
Masukkan ke folder /etc/init.d dengan menggunakan winscp.
Selanjutnya.
Di Terminal Putty
chmod +x /etc/init.d/squid

Langkah Selanjutnya adalah Setup SSL Bump Squid 3.5.0.


Ketik atau copas satu-persatu perintah di bawah dengan menggunakan Putty jangan semuanya
nanti Error.
cd /etc/squid
mkdir ssl_cert
cd ssl_cert
openssl req -new -newkey rsa:1024 -days 365 -nodes -x509 -keyout myCA.pem
-out myCA.pem
openssl x509 -in myCA.pem -outform DER -out myCA.der
cd
mkdir /var/squid
cd /var/squid
mkdir ssl_db
cd
chown -R nobody /var/squid/ssl_db/
/usr/lib/squid/ssl_crtd -c -s
/var/squid/ssl_db/certs
chown -R squid:squid /var/squid/ssl_db/

squid -k parse
squid -z

Buka winscp dan temukan file rc.local dan tambahkan kode berikut.
modprobe
modprobe
modprobe
modprobe
modprobe
modprobe
modprobe
modprobe
modprobe
modprobe

xt_TPROXY
xt_socket
nf_tproxy_core
xt_mark
nf_nat
nf_conntrack_ipv4
nf_conntrack
nf_defrag_ipv4
ipt_REDIRECT
iptable_nat

Setelah kamu tambahkan Save.


Buka Puttynya ketik perintah ini.
dmesg | grep PROXY

kalau sukses ada Tulisan seperti ini.


NF_TPROXY: Transparent proxy support initialized, version 4.1.0
NF_TPROXY: Copyright (c) 2006-2007 BalaBit IT Ltd.
Kalau masih belum Cek dan Ricek lagi stepnya mungkin ada yang salah
Selanjutnya adalah menambahkan rule TProxy ke /etc/rc.d/rc.local dengan menngunakan
WinSCP.
modprobe
modprobe
modprobe
modprobe
modprobe
modprobe
modprobe
modprobe
modprobe
modprobe

xt_TPROXY
xt_socket
nf_tproxy_core
xt_mark
nf_nat
nf_conntrack_ipv4
nf_conntrack
nf_defrag_ipv4
ipt_REDIRECT
iptable_nat

iptables -t mangle -F

iptables -t mangle -X
iptables -t mangle -N DIVERT
iptables -t mangle -A DIVERT -j MARK --set-mark 1
iptables -t mangle -A DIVERT -j ACCEPT
iptables -t mangle -A INPUT -j ACCEPT
iptables -t mangle -A PREROUTING -p tcp -m socket -j DIVERT
iptables -t mangle -A PREROUTING ! -d XX.XX.XX.XX/XX -p tcp --dport 80 -j
TPROXY --tproxy-mark 0x1/0x1 --on-port 3129
iptables -t mangle -A PREROUTING ! -d XX.XX.XX.XX/XX -p tcp --dport 443 -j
TPROXY --tproxy-mark 0x1/0x1 --on-port 3127
/sbin/ip rule add fwmark 1 lookup 100
/sbin/ip route add local 0.0.0.0/0 dev lo table 100
echo 0 > /proc/sys/net/ipv4/conf/lo/rp_filter
echo 1 > /proc/sys/net/ipv4/ip_forward
exit 0

Ket :
xx.xx.xx.xx/xx di sesuaikan sama ip proxy masing-masing.
Langkah Selanjutnya.
vi /etc/selinux/config

Ubah menjadi SELINUX=disabled.


Tambah dan edit settingan sysctl.conf dengan menggunakan Winscp
# vi /etc/sysctl.conf
net.ipv4.ip_nonlocal_bind=1
net.ipv4.conf.default.forwarding=1
net.ipv4.conf.all.forwarding=1
net.ipv4.ip_forward = 1
net.ipv4.conf.default.rp_filter = 0

Tambahkan baris berikut di rc.local masih menggunakan winscp


echo 1024 65535 > /proc/sys/net/ipv4/ip_local_port_range
ulimit -HSn 65535
/usr/sbin/squid -Nd1 &

Setup SSL BUMP untuk squid 3.5.0.2 selesai!!.


Saatnya kamu instal ulang app-web-proxy dari marketnya agar squidnya di kenali sama Clear Os
nya.
Atau kamu juga bisa menambahkan perintah di bawah untuk menambah keamanan ClearOs
nya :).
yum install app-web-access-control app-content-filter dansguardian-av

Pertanyaan!!
Kenapa nggak sekalian aja make perintah Yum instal web proxy? nya sekalian di ketik di terminal
Putty?
Pertanyaan bagus tetapi sesuai dengan pengalaman pribadi saya sendiri saat saya menggunakan
perintah "yum install app-web-proxy" di Terminal Puttynya stelah update squidnya bla-bla,
"Di start Error MULU nggak mau jalan!!.
Saya tidak tau penyebabnya apa kenapa dimana salahnya, atau mungkin servernya mulai
LAPAR atau mulai LELAH atau menjadi GILA biarlah dia dan Tuhan yang tau Terimakasih!!
Setelah semua app web proxynya selesai instal jgn di jalankan dulu web proxy nya yak :).
kita memulai semuanya dengan Terminal Putty ea ea :v :v .
service firewall restart
/usr/sbin/squid -Nd1 &

Perintah di atas untuk Restart firewall dan menjalankan Squidnya.


Setelah semua selesai dan sukses tanpa ada kendala selamat kamu sudah berhasil Instalasi
Squid 3.5.0.2 CLEAR OS 6.xx Versi 64bit Untuk Cache HTTPS SSLBUMP + TPPROXY
MODE STANDALONE /STANDALONE NO FIREWAAL
Langkah
terakhir
adalah
folder /var/squid/ssl_db/certs

menanam
di

kan myCA.der
Browser

manual yang
berada
masing-masing

Tanpa itu kalau buka situs Https Bakalan Error :)


Oh iya untuk konfigurasi Firewall Manglenya di Mikrotik boleh di contoh seperti ini:
/ip firewall mangle

di
:).

add action=mark-routing chain=prerouting comment="TPROXY ROUTING" disabled=no


dst-port=80,443 in-interface=ether2 new-routing-mark=tproxy_rm
passthrough=no \protocol=tcp
add action=mark-connection chain=prerouting disabled=no dst-port=80,443 ininterface=ether3-proxy new-connection-mark=tproxy_cm passthrough=yes
protocol=tcp \src-address=!XX.XX.XX.XX
add action=mark-routing chain=prerouting connection-mark=tproxy_cm
disabled=yes in-interface=!ether3-proxy new-routing-mark=tproxy_rm
passthrough=no

/ip route
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=XX.XX.XX.XX routingmark=tproxy_rm scope=30 target-scope=10

Seperti biasa yg xxx: itu Ip Addrees Proxy Externalnya.


Sistem di atas menggunakan sistem Mangle untuk membelokkan aktifitas Browsing ke proxy
external kalau kamu nggak suka silahkan memakai Nat juga gpp
Kalau make Sistem Nat baris Ip Routenya jgn di Pake.
Oh iya bagi yang mau nyoba confiq squid racikan Sha untuk squid versi 3 atau kamu lebih puas
dengan racikan standartnya ya silahkan kembali ke masing-masing admin jaringan.
Disini Dan Disini << untuk bisa Browsing Http karena model Squid defaultnya Http di Blokir.
Atau untuk menghitung jumlah memory untuk squidnya atau istilahnya squid calculator silahkan
Download
di Sini.
Passwordnya sama : marsha-manihuruk
Gambar Log di Squid Proxy yang udah sukses cache HTTPS.

Ok sekian dulu dari Marsha tutornya semoga yang menerapkan sukses :).
Terimakasih sudah berkunjung.
https://ipaddrCOS:81/app/base/wizard/stop

http_access allow localhost

/ip firewall mangle


add action=mark-routing chain=prerouting comment="TPROXY ROUTING" disabled=no
dst-port=80,443 in-interface=ether2-local new-routing-mark=tproxy_rm passthrough=no \
protocol=tcp
add action=mark-connection chain=prerouting disabled=no dst-port=80,443 ininterface=ether3-proxy new-connection-mark=tproxy_cm passthrough=yes protocol=tcp \
src-address=!XX.XX.XX.XX
add action=mark-routing chain=prerouting connection-mark=tproxy_cm disabled=yes ininterface=!ether3-proxy new-routing-mark=tproxy_rm passthrough=no

/ip route
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=XX.XX.XX.XX routingmark=tproxy_rm scope=30 target-scope=10

route add default gateway 192.168.2.1


iptables -A PREROUTING -t nat -j REDIRECT -p tcp -s 192.168.0.0/24 -d 0/0
--dport 80 --to-ports 3128
iptables -A INPUT -p tcp -s 0.0.0.0/0 -d 192.168.2.2 -m state --state
NEW,ESTABLISHED -j ACCEPT
iptables -A OUTPUT -p tcp -s 192.168.2.2 --sport 3128 -d 0.0.0.0/0 -m state
--state ESTABLISHED -j ACCEPT