Anda di halaman 1dari 17

Enrutamiento entre Vlan

Resumen
El enrutamiento inter VLAN es el proceso de trfico de enrutamiento entre diferentes
VLAN, mediante un router dedicado o un switch multicapa. El enrutamiento inter VLAN
facilita la comunicacin entre los dispositivos aislados por los lmites de la VLAN.
El routing entre VLAN antiguo dependa de que un puerto de router fsico estuviera
disponible para cada VLAN configurada. Esto fue reemplazado por la topologa de routeron-a-stick, que depende de un router externo con subinterfaces de enlace troncal a un
switch de capa 2. Con la opcin de router-on-a-stick, se deben configurar en cada
subinterfaz lgica el direccionamiento IP y la informacin de VLAN adecuados, y se debe
configurar una encapsulacin de enlace troncal que coincida con la interfaz troncal del
switch.
Tambin existe la opcin de multicapa entre VLAN mediante switching de capa 3. El
switching de capa 3 incluye SVI y puertos enrutados. El switching de capa 3 se suele
configurar en las capas de distribucin y de ncleo del modelo de diseo jerrquico. El
switching de capa 3 con SVI es una forma de routing entre VLAN. Un puerto enrutado es
un puerto fsico que funciona de manera similar a una interfaz en un router. A diferencia de
los puertos de acceso, los puertos enrutados no se asocian a una VLAN determinada.
Los switches Catalyst 2960 se pueden utilizar para routing multicapa entre VLAN. Estos
switches admiten routing esttico, pero no son compatibles con protocolos de routing
dinmico. Para habilitar el routing IP en los switches 2960, son necesarias plantillas SDM.
La resolucin de problemas de routing entre VLAN con un router o con un switch de capa
3 es similar. Los errores comunes suelen estar relacionados con las configuraciones de
VLAN, enlace troncal, la interfaz de capa 3 y las direcciones IP.

Configuracin de enrutamiento Inter-VLAN heredado


Configuracin del Switch

ROUTER

Configuracin de Router-On-A-Stick
Configuracin del Switch

Configuracin de Router-On-A-Stick
Configuracin de Interfaces (Router)

Configuracin de Router-On-A-Stick
Verificacin de Subinterfaces

Problemas de Configuracin Inter-VLAN


Verificando la Configuracin del Switch

Un problema comn en la configuracin router-on-a-stick es la


asignacin erronea del VLAN ID a las interfaces

El comando show interface puede ayudar a detectar este problema

Si este es el caso, usando el comando de interface encapsulation


dot1q <vlan id> para corregir este problema

Errores con la IP y la Mscara de Subred

Cuando se usa enrutamiento inter-VLAN heredado, revisar que el router


tiene la direccin IP y mscara correctas en las interfaces conectadas al
switch

Revisar que el dispositivo de red sea configurado con la direccin IP y


mscara correcta

En el router, el comando ip address puede ser usado para corregir


cualquier asignacin de IP errnea

En el PC, revisar la documentacin del sistema operativo instalado para


realizar los cambios de configuracin IP correctos

Para verificar que la direccin IP correcta haya sido configurada en el


router, usar el comando show ip interface

El comando show running-config tambin puede ser til cuando se


desean resolver problemas similares

Aunque configurar el ID de la subinterface con el nmero de la VLAN


puede facilitar la configuracin de inter-VLAN, no es necesario.

Enrutamiento Inter-VLAN con SVIs

Hoy en da el enrutamiento se ha vuelto ms rpido y barato y se puede


desarrollar a velocidad de hardware

Puede transferirse a los dispositivos de distribucin y ncleo sin mayor


impacto en el desempeo de la red

Muchos usurios estn en VLANs separadas y cada VLAN es una subred


aparte

Esto implica que cada switch de distribucin debe tener un


direccionamiento IP que coincida con cada VLAN de los swith de acceso

Los puertos de capa 3 (enrutados) son normalmente implementados en


las capas de ncleo y distribucin

Este modelo es menos dependiente del spanning-tree y no existen loops


en la porcin de la topologa de capa 2

Por defecto, se crea una SVI para la VLAN por defecto (VLAN 1). Esto
permite la administracin remota

Cualquier SVI adicional debe ser creada por el administrador

Las SVI son creadas la primera vez que se ingresa al modo de


configuracin para la SVI de una VLAN en particular

La interface vlan 10 crea una SVI llamada VLAN 10

El nmero de VLAN usado corresponde a la etiqueta de VALN asociada


con la encapsulacin 802.1Q

Cuando una SVI es creada, verificar que la VLAN es particular esta


presente en la base de datos VLAN

Las ventajas de las SVI son:

Son mucho ms rpidas que usar router-on-a-stick, porque toda la


conmutacin y enrutamiento se realiza por hardware.

No se necesitan enlaces externos desde el switch a un router para


enrutar.

No se limita a un solo enlace. Tnicas de capa 2 como


EtherChannels pueden ser usadas para obtener mayor ancho de
banda.

La latencia es mas baja, debido a que no se necesita abandonar el


switch.

Un puerto enrutado es un puerto fsico que acta similar a una interface


de router

Los puertos enrutados no se asocian con ninguna VLAN

Los protocolos de capa 2, tales como STP, no funcionan en las interfaces


de un router

Los puertos enrutados en un switch con IOS Cisco no soportan


subinterfaces

Para configurar puertos enrutados, usar el comando no switchport en


el modo de configuracin global

Nota: los puertos enrutados no son soportados por los switchs Catalyst
2960

Investigar trafico etiquetado

Ejemploos en el switch

Switch>ena
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#swi
Switch(config)#switch
Switch(config)#inter
Switch(config)#interface f0/24
Switch(config-if)#sw
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan none

Switch(config-if)#switchport trunk allowed vlan 10,20,30


Switch(config-if)#switchport trunk native vlan 80
Switch(config-if)#duple
Switch(config-if)#duplex full
Switch(config-if)#speed 1000
^
% Invalid input detected at '^' marker.
Switch(config-if)#speed 100
Switch(config-if)#
Switch#
%SYS-5-CONFIG_I: Configured from console by console
Switch#show vlan brie
Switch#show vlan brief
VLAN Name Status Ports
---- -------------------------------- --------- ------------------------------1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
10 CUERPO_DOCENTE active
20 ESTUDIANTE active
30 INVITADO_ADMIN active
80 NATIVA active
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active
Switch#write
Building configuration...
[OK]
Switch#do reload
^
% Invalid input detected at '^' marker.
Switch# ?
Exec commands:
clear Reset functions
clock Manage the system clock
configure Enter configuration mode
connect Open a terminal connection
copy Copy from one file to another
debug Debugging functions (see also 'undebug')
delete Delete a file
dir List files on a filesystem

disable Turn off privileged commands


disconnect Disconnect an existing network connection
enable Turn on privileged commands
erase Erase a filesystem
exit Exit from the EXEC
logout Exit from the EXEC
more Display the contents of a file
no Disable debugging informations
ping Send echo messages
reload Halt and perform a cold restart
resume Resume an active network connection
setup Run the SETUP command facility
show Show running system information
ssh Open a secure shell client connection
telnet Open a telnet connection
terminal Set terminal line parameters
traceroute Trace route to destination
undebug Disable debugging functions (see also 'debug')
vlan Configure VLAN parameters
write Write running configuration to memory, network, or terminal
Switch# doreload
Translating "doreload"...domain server (255.255.255.255) % Name lookup aborted
Switch#do reload
^
% Invalid input detected at '^' marker.
Switch#

Continue with configuration dialog? [yes/no]: n


Press RETURN to get started!

Router>ena
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#inter
Router(config)#interface g
Router(config)#interface gigabitEthernet 0/0
Router(config-if)#no s
Router(config-if)#no shutd
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#inter
Router(config)#interface g
Router(config)#interface gigabitEthernet 0/0.10
Router(config-subif)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0.10, changed state to up
Router(config-subif)#enc
Router(config-subif)#encapsulation dot1q 10
Router(config-subif)#ip addre
Router(config-subif)#encap
Router(config-subif)#encapsulation do
Router(config-subif)#encapsulation dot1Q 80 nati
Router(config-subif)#encapsulation dot1Q 80 native
Router(config-subif)#ip addre
Router(config-subif)#ip address 172.17.10.1 255.255.255.0
Router(config-subif)#exit
Router(config)#interf
Router(config)#interface
Router(config)#interface g
Router(config)#interface gigabitEthernet 0/0
Router(config-if)#duplex full
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state
to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.10, changed
state to up
Router(config-if)#speed 100
Router(config-if)#exit
Router(config)#ip routing
Router(config)#
Router#show inter
Router#show interfaces g
Router#show interfaces gigabitEthernet 0/0.20
GigabitEthernet0/0.20 is up, line protocol is up (connected)
Hardware is PQUICC_FEC, address is 00e0.a304.7d01 (bia 00e0.a304.7d01)
Internet address is 172.17.20.1/24
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 20

ARP type: ARPA, ARP Timeout 04:00:00,


Last clearing of "show interface" counters never

Multicapa
Switch>ena
Switch#conf
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#vlan 10
Switch(config-vlan)#name CUERPO_DOCENTE
Switch(config-vlan)#EXIT
Switch(config)#vlan 20
Switch(config-vlan)#name ESTUDIANTE
Switch(config-vlan)#EXIT
Switch(config)#vlan 30
Switch(config-vlan)#name INVITADO_ADMIN
Switch(config-vlan)#EXIT
Switch(config)#
Switch#
%SYS-5-CONFIG_I: Configured from console by console
Switch#SHOW VLAN
VLAN Name Status Ports
---- -------------------------------- --------- ------------------------------1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
Gig0/1, Gig0/2
10 CUERPO_DOCENTE active
20 ESTUDIANTE active
30 INVITADO_ADMIN active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ -----1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0
30 enet 100030 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0
Remote SPAN VLANs
-----------------------------------------------------------------------------Primary Secondary Type Ports
------- --------- ----------------- -----------------------------------------Switch# CONF T
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#interfa
Switch(config)#interface vlan 10
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan10, changed state to up
Switch(config-if)#ip address
Switch(config-if)#ip address 172.17.10.1 255.255.255.0
Switch(config-if)#no shu
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#interface vlan 20
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan20, changed state to up
Switch(config-if)#ip address 172.17.20.1 255.255.255.0
Switch(config-if)#no shutdo
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#interface vlan 30
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan30, changed state to up
Switch(config-if)#ip address 172.17.30.1 255.255.255.0
Switch(config-if)#exit
Switch(config-if)#exit
Switch(config)#ip routing
Switch(config)#interf

Switch(config)#interface f0/1
Switch(config-if)#duplex full
Switch(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to
up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to
down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to
up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to up
%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on
FastEthernet0/1 (1), with Switch FastEthernet0/24 (80).
Switch(config-if)#speed 100
Switch(config-if)#
%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on
FastEthernet0/1 (1), with Switch FastEthernet0/24 (80).
Switch(config-if)#exit
Switch(config)#interfa
Switch(config)#interface fas
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#swit
Switch(config-if)#switchport trunk native vlan 80
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#swit
Switch(config-if)#switchport trunk
Switch(config-if)#switchport trunk alloed vlan none
^
% Invalid input detected at '^' marker.
Switch(config-if)#switchport trunk allowed vlan none
Switch(config-if)#switchport trunk allowed vlan 10,20,30
Switch(config-if)#exit
Switch(config)#
Switch#
Buscar puerto enrutado

No switchport permita habilitar la interfaz para colocar ip