Anda di halaman 1dari 11

Proprietary Confidential

Con adno

ZXMSG 5200
Multiplex Service Gateway

Configuration Manual

Version: V3.2
Using SIP Protocol

Untuk case dengan Alokasi Parameter logic sbb:


SIGNALLING/CONTROL :
VOICE/MEDIA :

172.27.237.206/26 gw: 172.27.237.193 vlan : 1027

172.27.235.206/26 gw: 172.27.235.193 vlan : 2027

MANAGEMENT/OAM :

172.27.239.206/26 gw: 172.27.239.193 vlan : 27

1. Modify License

<PT ZTE INDONESIA copyright reserved,No spreading abroad>

Page1

Proprietary Confidential
Before begin the integration, first we have to modify the license.dat;
1.1. Upload the license.dat to your laptop
Open telnet from command prompt;

ZXAN#dir cfg
Directory of flash:/cfg
attribute size
date
time
name
1
drwx
16384
APR-17-2013 16:50:20 .
2
drwx
16384
JAN-01-1970 00:00:00 ..
3
-rwx
4096
APR-17-2013 13:50:12 nvram.dat
4
-rwx
900
NOV-08-2012 14:37:56 license.dat
5
-rwx
5426
APR-17-2013 16:50:20 startrun.dat
ZXAN#con t
ZXAN(config)# interface mng1
ZXAN(config-if)# boot-server 136.1.1.1 ------- base on clien IP
ZXAN(config-if)# boot-user zte
ZXAN(config-if)# boot-password zte
Con t

1.2. Open WFTP, set username and password by zte and set Home directory as
well

<PT ZTE INDONESIA copyright reserved,No spreading abroad>

Page2

Proprietary Confidential

ZXAN#upload license.dat
1.3. Modify the license.dat as following (open file with *WordPad)

1=1 modify 1=0


7=0 modify 7=1

<PT ZTE INDONESIA copyright reserved,No spreading abroad>

Page3

Proprietary Confidential
co

Save and close the file.


1.4. Download the license.dat to GISB again.
ZXAN#download license.dat
ZXAN#reboot
Abis itu di WRITE..
2. Delete Previous Data and Configuration
ZXAN#delete v0100 *.*
ZXAN#delete v0101 *.*
ZXAN#delete cfg startrun.dat
ZXAN#reboot

langkahi saja

3. Configuration
3.1. Configuring a Rack
ZXAN#configure terminal
Enter configuration commands, one per line.
End with CTRL/Z.ctr
ZXAN(config)#
Configure the control rack.
ZXAN(config)#add-rack rackno 1 racktype MSAG
3.2. Configuring a Master Shelf and Subordinate Shelf
ZXAN(config)#add-shelf rackno 1 shelfno 1 shelftype MBSL_CTL
ZXAN(config)#add-shelf rackno 1 shelfno 2 shelftype MBSL_EX connectid 1
-> if have subordinate shelf
3.3. Configuring Card
Configing the card based on the modules are installed on the shelf
ZXAN(config)# add-card rackno 1 shelfno 1 slotno 1 POWER
ZXAN(config)# add-card rackno 1 shelfno 1 slotno 3 GELCA
ZXAN(config)# add-card rackno 1 shelfno 1 slotno 4 GELCA
ZXAN(config)# add-card rackno 1 shelfno 1 slotno 5 GELCA
ZXAN(config)# add-card rackno 1 shelfno 1 slotno 6 GELCA
ZXAN(config)# add-card rackno 1 shelfno 1 slotno 7 GPNI
ZXAN(config)# add-card rackno 1 shelfno 1 slotno 8 GPNI
ZXAN(config)# add-card rackno 1 shelfno 1 slotno 16 TSLCE
ZXAN(config)# add-card rackno 1 shelfno 1 slotno 17 POWER

<PT ZTE INDONESIA copyright reserved,No spreading abroad>

Page4

Proprietary Confidential
3.4. Configuring Sub-Card
To configure a VoIP sub-card in sub-card 2 slot 9 and 10, perform the
following commands:
ZXAN(config)# del-subcard slotno 9 subcard 2
ZXAN(config)# add-subcard slotno 9 subcardno 2 VOIP
ZXAN(config)# add-subcard slotno 10 subcardno 2 VOIP
3.5. Configuring VLAN
ZXAN(config)# interface pni- gei_1/8/1
ZXAN(config-if)# switchport mode hybrid
ZXAN(config-if)# switchport vlan 1048 tag
ZXAN(config-if)# switchport vlan 2048 tag
ZXAN(config-if)# switchport vlan 3136 tag
ZXAN(config-if)# switchport vlan 161 tag
ZXAN(config-if)# switchport vlan 110 tag
ZXAN(config-if)# switchport vlan 111 tag
ZXAN(config-if)# no shutdown
ZXAN(config-if)# exit

----> signaling VLAN example


----> media VLAN example
----> data VLAN example
----> OAM VLAN example
----> IPTV VLAN
----> IPTV VLAN

3.6. Configuring VoIP Service (SIP)


3.6.1. Configure the Control Port
ZXAN(config)#msag
ZXAN(config-msag)# ctrlport add 15 5060
3.6.2. Configure the MGC
ZXAN(config-msag)# mgc add 1 ipaddresnya IMS port 5060 type 8 (IP IMS
172.27.65.228) usahakan coment ?
3.6.3. Configure the MG
ZXAN(config-msag)# mg add 1 1 domain-name telkom.net.id protocol-type 3
port 5060 -- ingat ? dulu.
3.6.4. Configure the SIP Proxy Server
deZXAN(config-msag)# sip proxy-server add 1 5060 1 ProxyIP xxxxxxxxx
(xxxxxx=ip ims)
3.6.5. Configure the SIP User Agent
ZXAN(config-msag)# sip user-agent add 1 1 domname telkom.net.id
3.6.6. Configure the Media and Signalling IP address
ZXAN(config-msag)# voip interface add ctrl-ip 172.27.237.206 ctrl-mask
255.255.255.192
media-ip 172.27.235.206 media-mask
255.255.255.192
ZXAN(config-msag)# voip route add 172.27.237.193 destipaddr
172.27.65.228 submask 255.255.255.0 type 2
-- GW
signalling
ZXAN(config-msag)# voip route add 172.27.235.193 type 1
Lihat hasilnya = sho MSAG VOIP-IPADDR
3.6.7. Configure the SIP number analysis table
ZXAN(config-msag)# digitmap add 1 SIPDM digit-map e
ExxEx.Ex.F|x|xF|ExxF|3F|ExxE|EE0x|FxxF|x.|xxxxxx|xxxxxxxxxxxxx|
ExxE85xxxxxF|ExxE08xxxxxxxxxF|0[2-9]xxxxxSxxxxxx|03[1-9]xxxxxSxxx|
[2-9]xxxxSxxx|1[2-9]x|04[2-9]xxxxxSxxx|85xxxxx mgid 1 servicetype 2
digitmap legend:
S = bisa habis sebelum S atau nambah di belakang S
[2-9] = bisa diisi dari 2 sampai 9
X = diisi angka 0-9
E = diisi *

<PT ZTE INDONESIA copyright reserved,No spreading abroad>

Page5

Proprietary Confidential
F = diisi #
. = bisa diisi brpa aja bisa banyak digit
3.6.8. Configure the SIP User
Digitmapname based on the name we use when we creat SIP number
analysis table and password according to information from IMS. Usually each
number has its own password.
ZXAN(config-msag)# sip user add 3 begin-index 1 num 1 +624113780526
digitmapname SIPDM password 123456 authUsername
+624113780526 digitlen 0 type 3
+622129875040 adalah nomor test yg diberikan oleh Sentral IMS
3.6.9. Configure the SIP UserID
ZXAN(config-msag)# sip userid add 3 begin-index 1 num 1 +622129875040
digitlen 0 type 3
3.6.10. Configure the RTP Resource
ZXAN(config-msag)# rtp terminationid add RTP/ 240 mgid 1 type 2 begin-no
0
3.6.11. Configure the internal media flow route
ZXAN(config-msag)# media-nat add 9 1 9 5 5 172.27.235.206 10000
(LANGKAHi yg warna merah)
3.7. Configuring VoIP Service (H248)
3.7.1. Configure the MGC
ZXAN(config-msag)# mgc add 1 172.28.5.7 port 2944 type 2
ZXAN(config-msag)# mgc add 2 172.28.4.7 port 2944 type 2
ZXAN(config-msag)# mg add 1 1 mgcid2 2 port 2944
3.7.2. Configure the Media and Signalling IP address
ZXAN(config-msag)# voip interface add ctrl-ip 172.24.79.7 ctrl-mask
255.255.255.192
media-ip 172.24.48.7 media-mask
255.255.255.192
ZXAN(config-msag)# voip route add 172.24.79.1 destipaddr
172.28.5.7 submask 255.255.255.192 type 2
ZXAN(config-msag)# voip route add 172.24.48.1 type 1
3.7.3. Configure TID (H248)
ZXAN(config-msag)# slc terminationid add rackno 1 shelfno 1 3
begin-index 1 num 32 A begin-no 0 type 2 mgid 1
ZXAN(config-msag)# slc terminationid add rackno 1 shelfno 1 4
begin-index 1 num 32 A begin-no 32 type 2 mgid 1
ZXAN(config-msag)# slc terminationid add rackno 1 shelfno 1 5
begin-index 1 num 32 A begin-no 64 type 2 mgid 1
ZXAN(config-msag)# slc terminationid add rackno 1 shelfno 1 6
begin-index 1 num 32 A begin-no 96 type 2 mgid 1
ZXAN(config-msag)# slc terminationid add rackno 1 shelfno 1 11
begin-index 1 num 32 A begin-no 128 type 2 mgid 1
3.8. Configuring Media IP, Signaling IP, and Management IP
3.8.1. Configure Media IP
ZXAN(config)#vlan 2040 (vlan media)
ZXAN(config-vlan)#voip-bind
ZXAN(config-vlan)#exit
ZXAN(config)#interface vlan 2040
ZXAN(config-if)# ip address 172.24.48.7 255.255.255.192
(ip media)
ZXAN(config-if)# exit
3.8.2. Configure Signalling IP
ZXAN(config)#vlan 1040 (vlan signalling)
ZXAN(config-vlan)#voip-ctrl
ZXAN(config-vlan)#exit
ZXAN(config)#interface vlan 1040
ZXAN(config-if)# ip address 172.24.79.7 255.255.255.192 (ip signalling)

<PT ZTE INDONESIA copyright reserved,No spreading abroad>

Page6

Proprietary Confidential
ZXAN(config-if)# exit
3.8.3. Configure Management IP?
ZXAN(config)#vlan 161 (vlan OAM)
ZXAN(config-vlan)#exit
ZXAN(config)#interface vlan 1612
ZXAN(config-if)# ip address 172.24.112.7 255.255.255.192 (IP OAM)
ZXAN(config-if)# exit
Use the ip route command to set default gateway, if the NM server and
ZXMSG 5200 are not in the same network segment.
Sho ip route
ZXAN(config)# ip route 172.28.53.0 255.255.255.192 172.24.79.1
nda usah di urus
ZXAN(config)# ip route 172.28.1.0 255.255.255.192 172.24.112.1
ZXAN(config)# ip route 0.0.0.0 0.0.0.0 172.27.239.193 (gateway OAM)
Test ping ip IMS belum bias krn belum ada yg mengarahkan ke stu
Buat routing :
Ip route 172.27.65.0 255.255.255.0 172.27.237.193
Sho ip route lagi kemudian test ping ke IMS..
Sho MSAG SIPdebug reg-TM
Muncul fail , itu krn komunikasiantara kita dan sentral blm di Creat..
WRITE..

(SETTING SIP SAMPAI DISINI SAJA)


3.9. Set SIP Capability
At MSAN the SIP capability have to modify,
For IMS Huawei do not Support Timer, so at MSAN we have to disable Support
Timer,
ZXAN(config-msag)# sip capability modify SPTIMER 0
For both IMS Ericsson and Huawei support 100REL, so enable support
100REL,
ZXAN(config-msag)# sip capability modify SP100REL 1
AuthorisationUsername with Domain is enable for both Huawei and Ericsson
IMS,
ZXAN(config-msag)# sip capability modify AuthUsernamewithDom 1
For Fax service, Huawei IMS using FaxoverIP T30
ZXAN (config-msag)#sip capability modify FaxOverIp1 ?
<0-2> 1:T30,2:T38,0:NULL
ZXAN (config-msag)#sip capability modify FaxOverIp1 1
3.10. Configuring
ZXAN(config)#
ZXAN(config)#
ZXAN(config)#
ZXAN(config)#
ZXAN(config)#
ZXAN(config)#

IPTV Service
igmp enable
igmp mvlan 110
igmp mvlan 110
igmp mvlan 110
igmp mvlan 110
igmp mvlan 110

group 239.1.1.1 to 239.1.1.254


group 239.1.2.1 to 239.1.2.254
source-port pni-gei_1/8/1
receive-port adsl_1/3-6/1-32

3.11.
Configuring ADSL Port
ZXAN(config)#interface adsl_1/3-6/1-32
ZXAN(config-if)# atm pvc 1 vpi 8 vci 88
ZXAN(config-if)# pvc 1 enable
ZXAN(config-if)# pvc 2 enable
ZXAN(config-if)# pvc 3 enable
ZXAN(config-if)# switchport mode hybrid pvc 1

<PT ZTE INDONESIA copyright reserved,No spreading abroad>

Page7

Proprietary Confidential
ZXAN(config-if)#
ZXAN(config-if)#
ZXAN(config-if)#
ZXAN(config-if)#
ZXAN(config-if)#
ZXAN(config-if)#
ZXAN(config-if)#
ZXAN(config-if)#
ZXAN(config-if)#

switchport default vlan 111 pvc 1


switchport vlan 110 untag pvc 1
switchport mode hybrid pvc 2
switchport default vlan 3136 pvc 2
port-location format dsl-forum pvc 1
port-location format dsl-forum pvc 2
pppoe-plus enable pvc 2
igmp version v2 pvc 1
adsl profile DEF1M.PRF

3.12.
Fax Configuration (H248)
ZXAN(config-msag)# rtp voip-parameter dtmf dtmfrelaymode 1
ZXAN(config-msag)# rtp voip-parameter dtmf dtmfpayload 97
ZXAN(config-msag)# rtp voip-parameter fax-modem faxmode 11
ZXAN(config-msag)# rtp voip-parameter fax-modem modemmode 11
ZXAN(config-msag)# tone fax-event 1 answi-tone 1
ZXAN(config-msag)# tone fax-event 1 answo-tone 1
ZXAN(config-msag)# tone fax-event 1 v21-flags-tone 1
ZXAN(config-msag)# rtp voip-parameter rxhandle mindelay 20 maxdelay 120
nomdelay 20
ZXAN(config-msag)# mg capability 1 fax-pri1 2 fax-pri2 1
3.13.
Configuring Phone Features
For all the features, it provide by IMS, at MSAN will make some change at
parameter.
3.13.1. Call wait
For call wait feature the configuration execute under 9999 port.
Open telnet;

[ROS10]: callwaitno180=0
callwaitno180 = 0x216b568: value = 0 = 0x0
For callwait service, callwait parameter have to be set
ZXAN(config-msag)#sip accesscode add mgid 1 id 1 2 (id 1 is accesscode
for callwait)
For activation dial *43# and deactivation #43#.
Scenario; B with callwait feature, A call B, and B busy now
C call B, callwait tone on, B accept C call by dial Flash+2
3.13.2. Call Forward
Only for call forward conditional busy have to change the user
paramenter.
a. Call Forward Unconditional
For activation dial *21*(phone number to forward)# and deactivation
#21#.
Scenario; B with call forward unconditional feature, A call B,

<PT ZTE INDONESIA copyright reserved,No spreading abroad>

Page8

Proprietary Confidential
A will forwarding to C unconditional
b. Call Forward Conditional Busy
For call forward conditional busy, user have not support multi call
ZXAN#show msag sip user 3
rack:1
shelf:1
slot:3
index:1
sip-digits: +622129860005
groupid:0
password:123456
dstngring:15
hotlinetype:0
hotlinenum:
userid: +622129860005
digitmap:SIPDM
username: +622129860005
enableflag:1
sessionlimit:0 ---------- > user support multi call
disable multi call by modify the session limit
ZXAN(config-msag)# sip user mod 3 begin-index 1 num 1 sessionlimit
1
For activation dial *67*(phone number to forward)# and deactivation
#67#.
Scenario; B with call forward conditional busy feature. A call B, B busy
now
A forwarding to C because B busy.
c. Call Forward Conditional No Reply
For activation dial *61*(phone number to forward)# and deactivation
#61#.
Scenario; B with call forward conditional no reply. A call B
A forwarding to C because B not reply.
3.13.3. Three Party
For three party service, all the three party parameters have to be set.
ZXAN(config-msag)#sip servcode add 0 3F (0 mean type conference, F
mean #)
ZXAN(config-msag)#sip accesscode add mgid 1 id 6 3F (id 6 is
accesscode for threeparty)
ZXAN(config-msag)#sip capability mod ThreptySvr jk1magcf01conf
Show the configuration
ZXAN(config)#sho msag sip servcode
mgid:1
type: Conference
sip service code:3F
ZXAN(config)#sho msag sip accesscode
mgid:1
id: 6
sip access code:3F
Scenario; B with three party feature, B calling A, A on hold now and B
calling C
B press FLASH+3+#, A and B and C join conference.
Make sure that digitmap for 3# is available. Note: # to be symbolized by
F
ZXAN#sho msag digitmap

<PT ZTE INDONESIA copyright reserved,No spreading abroad>

Page9

Proprietary Confidential
digitmap:ExxEx.ExF|2|3F|E43F|xF|ExxE|EE0x|ExxF|FxxF|xxxxxx|
xxxxxxxxxxxxx|ExxE85
xxxxxF|ExxE08xxxxxxxxxF|0[2-9]xxxxxSxxxxxx|03[1-9]xxxxxSxxx|[29]xxxxSxxx|1[2-9]
x|04[2-9]xxxxxSxxx|85xxxxx
3.13.4. HotLine
HotLine services, both immediate and delay, parameter change under
9999 port.
Execute command:HotLineServCode
[ROS10]:HotLineServCode
HotLineServCode = 0x216b568: value = 0 = 0x0 (blue color show hot line
service code)
Display service code by execute command: d 0x216b568
[ROS10]:d 0x216b568
0216b560:
0000 0000 0000 0000 *
......*
0216b570: 0000 0000 0000 0000 0000 0000 0000 0000 *................*
0216b580: 0000 0000 0000 0000 0000 0000 0000 0000 *................*
0216b590: 0000 0000 0000 000b 0000 0001 0000 0000 *................*
0216b5a0: 0000 0000 0000 0005 5a54 4500 0000 0000 *........ZTE.....*
0216b5b0: 0000 0000 0000 0000 0000 0000 0000 0001 *................*
..
value = 21 = 0x15
Modify service code by execute command: m 0x216b568
[ROS10]:m 0x216b568
It will output '0000-...',then type 0302(No display,just input),
0216b568: 0000-0302
The'0000-' will display again,and then type 0100,
0216b56a: 0000-0100
Input .(dot) after display '0000-'.
0216b56c: 0000-.
After all the modify, it will show;
value = 1 = 0x1
Disply service code again after modify
[ROS10]:d 0x216b568
0216b560:
0302 0100 0000 0000 *
......*
0216b570: 0000 0000 0000 0000 0000 0000 0000 0000
0216b580: 0000 0000 0000 0000 0000 0000 0000 0000
0216b590: 0000 0000 0000 000b 0000 0001 0000 0000
0216b5a0: 0000 0000 0000 0005 5a54 4500 0000 0000
0216b5b0: 0000 0000 0000 0000 0000 0000 0000 0001

value = 21 = 0x15

*................*
*................*
*................*
*........ZTE.....*
*................*

It should be successful if it show 0302 0100.


Make sure the number that we created already provisioning by IMS MTAS.
IMS will send message on notify section when we registered the user
number.
a. HotLine Immediate
For immediate hotline, will get message like below:
<?xml version="1.0" encoding="UTF-8"?> <simservs
xmlns="http://uri.etsi.org/ngn/params/xml/simservs/xcap"> <dial-tonemanagement><no-dialling-behaviour>immediateCallSetup</no-diallingbehaviour><centrex-info/></dial-tone-management></simse
Scenario: A with hot line immediate feature, A pickup handset immediate
calling B

<PT ZTE INDONESIA copyright reserved,No spreading abroad>

Page10

Proprietary Confidential
b. HotLine Delay
For delay hotline, will get message like below:
<?xml version="1.0" encoding="UTF-8"?> <simservs
xmlns="http://uri.etsi.org/ngn/params/xml/simservs/xcap"> <dial-tonemanagement><no-dialling-behaviour>deferredCallSetup</no-diallingbehaviour><centrex-info/></dial-tone-management></simser
For activation dial *52*B number#
Scenario: A with hot line delay feature, A pickup handset after couple
seconds, A calling B
3.13.5. Abbreviated
For abbreviated feature, make sure the digitmat for abbreviate is
available. For example by dialing **03 will connecting to specified
number, so the digitmap format will be EE03. Note: * to be
symbolized by E.
ZXAN#sho msag digitmap
digitmap:ExxEx.ExF|2|3F|E43F|xF|ExxE|EE0x|ExxF|FxxF|xxxxxx|
xxxxxxxxxxxxx|ExxE85
xxxxxF|ExxE08xxxxxxxxxF|0[2-9]xxxxxSxxxxxx|03[1-9]xxxxxSxxx|[29]xxxxSxxx|1[2-9]
x|04[2-9]xxxxxSxxx|85xxxxx
3.13.6. Keyboard
Keyword feature depends on digitmat format. The form for keyword
feature is *34*password*class#
Scenario: A dial *34*1234*1#. So the password is 1234 and class is 1
Note; Class (0=block all, 1=local only, 2=interlocal, 3=international call)
ZXAN#sho msag digitmap
digitmap:ExxEx.ExF|2|3F|E43F|xF|ExxE|EE0x|ExxF|FxxF|xxxxxx|
xxxxxxxxxxxxx|ExxE85
xxxxxF|ExxE08xxxxxxxxxF|0[2-9]xxxxxSxxxxxx|03[1-9]xxxxxSxxx|[29]xxxxSxxx|1[2-9]
x|04[2-9]xxxxxSxxx|85xxxxx
3.13.7. Fax
Both Huawei and Ericsson IMS do not support T38 and VBD for Fax
service, disable fax priority 1 and fax priority 2
ZXAN(config-msag)# mg capability 1 fax-pri1 0
ZXAN(config-msag)# mg capability 1 fax-pri2 0
3.13.8. EDC
For EDC just make sure the digitmap is available. For example, B*A EDC
server number usually depend on 13 digits. So the digitmap consists of
13 digits.
ZXAN#sho msag digitmap
digitmap:ExxEx.ExF|2|3F|E43F|xF|ExxE|EE0x|ExxF|FxxF|xxxxxx|
xxxxxxxxxxxxx|ExxE85
xxxxxF|ExxE08xxxxxxxxxF|0[2-9]xxxxxSxxxxxx|03[1-9]xxxxxSxxx|[29]xxxxSxxx|1[2-9]
x|04[2-9]xxxxxSxxx|85xxxxx

<PT ZTE INDONESIA copyright reserved,No spreading abroad>

Page11