Anda di halaman 1dari 6

INSTITUTE OF INFORMATION TECHNOLOGY

MEHRAN UNIVERSITY OF ENGINEERING & TECHNOLOGY, JAMSHORO


ADVANCED COMPUTER NETWORK
ST
(1 Term, 1st Year B14 ME CSN) LAB EXPERIMET # 5
DYNAMIC ROUTING & RIP ROUTING
PERFORMANCE OBJECTIVE

This Lab comprises of two parts.


Part A: To become familiar with Dynamic Routing
Part B: To Perform RIP Routing

LAB # 5A
EQUIPMENT

PC
Router with console
RJ-45 TO DB-9 adapter
RJ-45 TO RJ 45 rollover cable

DISCUSSION & CONFIGRATION


ROUTER A
170.16.54.1

net 192.168.6.2

Start the router Go into privileged mode.


Type "show ip route". Note that two directly connected routes are shown.
Enter config mode. (Type "configure terminal" or "config t")
Type "router rip" to enable RIP on your router.

ROUTER B
170.16.54.0

net 192.182.6.1

Once RIP is enabled on a router, you must specify each network in which the router will advertise
routing.
Type "network 210.16.54.0"
Type "network 172.10.0.0"
Dynamic routing is now configured through RIP.
Type Ctrl-z to exit config mode.
Type "show ip route". Note that routes to all four networks are shown.
The same steps would be used to establish IGRP routing:
Enter config mode. (Type "configure terminal" or "config t")
First remove RIP by typing "no router rip"
Type "router igrp" to enable IGRP on your router.
Once IGRP is enabled on a router, you must specify each network in which the router will
advertise routing.
Type "network 210.16.54.0"
Type "network 172.10.0.0"
Dynamic routing is now configured through IGRP.
Type Ctrl-z to exit config mode.
Type "show ip route". Note that routes to all four networks are shown.

LAB # 5B
Part B:To Perform RIP Routing
PERFORMANCE OBJECTIVE
To become familiar with RIP router
EQUIPMENT

Two PC
Two Router with console
Two RJ-45 TO DB-9 adapter
Two RJ-45 TO RJ 45 rollover cable

DISCUSSION & CONFIGRATION :


The Routing Information Protocol (RIP) is perhaps the simplest of routing protocols. It
functions by broadcasting its entire routing table to all participating networks once
every 60 seconds for IP or once every 90 seconds for IPX. When a route is heard from a
remote router, the metric is increased by one. This number cannot exceed 15. A metric
of 16 describes an unreachable network.
The simplicity of this protocol means that there is very little that the router must do
each update. This allows the processor to perform other tasks. At the same time, there is
no database being maintained. Its all contained in the routing tables. This simplicity,
however, requires increased bandwidth as the entire routing table must be sent across
the network. In a large network, this can take considerable time. In addition, It is not
uncommon for networks to be more than 15 hops apart. This means that end nodes will
not be able to contact each other because the metrics surpass the "unreachable" point

Before you start, make sure you clear both routers' configuration using the
Router#erase startup-config

command.
First we will configure RouterA, after the router reboots, the following message will be
displayed:
% Please answer 'yes' or 'no'.
Would you like to enter the initial configuration dialog? [yes/no]

Type no and press ENTER. Press ENTER again when the message Press RETURN to
get started appears. Type enable at the Router> command prompt to enter
Privileged Exec mode, notice the prompt chances to Router#.

STEP 1. Change the router's host name to RouterA


Enter configuration mode using the following command:
Router#configure terminal

Change the host name of the router to Router A using the following command:
Router(config)#hostname Router A

STEP 2. Disable domain lookups


To prevent the router from interpreting every incorrectly typed command as a host
name and trying to resolve it to an IP address to setup a telnet connection with it, use
the following command:
Router(config)#no ip domain-lookup

STEP 3. Configure passwords


First set the enable password to Imad using the following command:
Router(config)#enable password imad

Next, set the password for telnet connections to cisco456 using the following
commands:
Router(config)#line vty 0 4
Router(config-line)#password imad
Router(config-line)#login

The passwords stored in the router's configuration must be encrypted, use the following
command:
Router(config)#service password-encryption

STEP 4. Configure LAN interfaces


Switch to Interface configuration mode for the Ethernet interface, using the following
command:
Router(config)#interface Ethernet 0

Give it the description "Connected to LAN" using the following command:


Router(config-if)#description connected to LAN

Configure the IP address (see diagram for correct address) for the interface using the
following command:
Router(config-if)#ip address 192.168.11.1 255.255.255.0

Enable the interface using the following command:


Router(config-if)#no shutdown

STEP 5. Configure WAN interfaces


Switch to Interface configuration mode for the first Serial interface, using the following
command:
Router(config)#interface Serial 0

Give it the description "Direct connection to RouterB" using the following command:

Router(config-if)#description connected to RouterB

Configure the IP address (see diagram for correct address) for the interface using the
following command:
Router(config-if)#ip address 192.168.22.5 255.255.255.0

Configure the interface to use PPP encapsulation using the following command:
Router(config-if)#encapsulation ppp

Enable the interface using the following command:


Router(config-if)#no shutdown

STEP 6. Configure RIP


Use the following command to enable RIP on RouterA:
Router(config)#router rip

Configure the router to receive and send only RIP Version 2 packets using the following
command:
Router(config-router)#version 2

Use the following commands to specify the networks directly connected to the router:
Router(config-router)#network 192.168.11.0
Router(config-router)#network 192.168.22.0

Change the update timer to 45 seconds, the invalid timer and the holddown timer to
270, and the flush timer to 360 seconds, using the following command:
Router(config-router)#timers-basic 45 270 270 360

STEP 7. Save configuration


To copy the currently running active configuration to NVRAM, so it will be used the
next time you reload the router, use the following command:
Router#copy running-config startup-config

STEP 8. Configuration second router


To configure the other router, RouterB, repeat the steps above. Use the network
diagram to determine the correct addressing and names. To enable the back-to-back
serial connection between te routers, you need to configure one router as DCE using the
following command in Interface configuration mode for the serial connection on
RouterB:
Router(config-if)#clock rate 64000

STEP 9. Verify and test the configuration


Verify using the ping command Host A to Host B, make sure you configured both hosts
to use the nearest router's interface as the default gateway in the TCP/IP settings.

On both routers, run the following command in Privileged Exec mode to determine
which device is the DCE:
Router#show controllers s0

On one of the routers, run the following command in Privileged Exec mode to display
the parameters and current state of the active routing protocol process, and examine the
output:
Router#show ip protocols

Use the following command to verify routing table entries on both routers:
Router#show ip route

Use the following command to list a summary of the interface's IP information and
status on both routers, and examine the output:
Router#show ip interface

Use the same command with the brief option, and the notice output:
Router#show ip interface brief