Anda di halaman 1dari 4

*ipv6 ruta por defecto

ipv6 route ::/0 salto siguiente


============EIGRP==============
*balanceo de carga*
router eigrp 100
variance X
*sumarizacion
interface serial 0/0/0
ip summary-addres eigrp 100 192.168.0.0 255.255.248.0
router eigrp 100
network 192.168.0.0 255.255.248.0
*ipv6
ipv6 unicast-routing
ipv6 router eigrp 1
eigrp router-id 1.1.1.1
no shutdown
interface g0/0
ipv6 eigrp 1
*sumarizacin ipv6
interface serial 0/0/0
ipv6 summary-address eigrp 1 2001:db8:abcd::/61
*autenticacin
key chain duoc
key 1
kay string duoc
interface serial 0/0/0
ip authentication mode eigrp 1 md5
ip authentication key chain eigrp 1 duoc
*DISTRIBUTE LIST
access-list 10 deny 192.168.1.0 0.0.0.255
access-list 10 permit any
router eigrp 1
distribute-list 10 out s0/0/0
*NEIGHBOR ESTATICOS
router eigrp 1
neighbor 10.10.10.1 g0/0
=============OSPF==============
*DR
ip ospf priority
*Cambiar costo
router ospf 1
auto-cost reference-bandwith XXX
*Virtual link
-para ver router id con que est trabajando el router
show ip ospf
-para ver router id del vecino
show ip ospf neighbor
router ospf 1

area 23 virtual-link 2.2.2.2


tino.

<------area es la de transito, router-id del des

*Sumarizacin
router ospf 1
area 100 range 192.168.100.0 255.255.252.0
*STUB (remueve LSA TIPO 5, CREA RUTA POR DEFECTO, NO REDISTRIBUCIN)
router ospf 1
area 100 stub
<-------en todos los routers
*TOTALLY STUB (remueve LSA TIPO 3, 4 y 5, CREA RUTA POR DEFECTO, NO REDISTRIBUCIN
)
router ospf 1
area 100 stub no-summary
<-------solo en router ABR
router ospf 1
area 100 stub

<-------en el resto de router

*NSSA (remueve LSA TIPO 5, TIPO 7 CONVERTIDOS EN 5, NO RUTA POR DEFECTO)


router ospf 1
area 100 nssa
<-------en todos los routers
area 100 nssa default-information-originate
<---redistribuir
*TOTALLY NSSA (remueve tipo 3, 4 y 5, ABR origina ruta por defecto, tipo 7 conve
rtidos en 5)
router ospf 1
area 100 nssa no-summary
*AUTENTICACIN
interface serial 0/0/1
ip ospf autheticacion message-digest
ip ospf message-digest key 1 md5 cisco
*DISTRIBUTE LIST
ip access-list standard EJEMPLO
deny host 1.1.1.1
permyt any
router ospf 1
distribute-list EJEMPLO in
*NEIGHBOR ESTATICO
router ospf 1
neighbor 10.0.0.2
=============PBR=================
ip access-list standard PBR
permit 192.168.1.1 0.0.0.255
exit
route map NOMBRE
match ip address PBR
set ip next-hop 172.16.13.1
exit
interface s0/1/0
ip policy route-map NOMBRE
============BGP===================
*ejemplo bsico

router bgp 100


neighbor 10.10.10.1 remote-as 100
redistribute conected
network 2.2.2.2 mask 255.255.255.255
*reflejar rutas (generalmente en router del medio de un AS)
router bgp 100
neighbor 40.40.40.2 route-reflection-client
*indicar el next hop (generalmente en router de BORDE)
router bgp 100
neighbor 40.40.40.1 next-hop-self
*CONFIGURAR UPDATE-SOURCE desde las LOOPBACKS (ES NECESARIO TENER OTRO IGP YA CO
NFIGURADO)
-aqu establece que el vecino sea desde la loopback, se da el caso que la direccin
del neighbor se mantiene y solo la actualizacin la manda desde la loopback
router bgp 100
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source loopback 0
*WEIGHT (A NIVEL LOCAL)
-para todas las rutas
router bgp 100
neighbor 20.20.20.2 weight 500
-solo para una ruta
access-list 1 permit 3.3.3.3 0.0.0.0
route-map SETWEIGHT permit 10
match ip addresss 1
set weight 500
exit
route-map SETWEIGHT permit 20
set weight 0
exit
router bgp
neighbor 20.20.20.2 route-map SETWEIGHT in

<---mismo nmero que ACL

*LOCAL PREFERENCE (A NIVEL LOCAL)


-para todas lsa rutas
router bgp 100
bgp default local-preference 400
-para solo una ruta
access-list 1 permit 3.3.3.3 0.0.0.0
route-map SETWEIGHT permit 10
match ip addresss 1
set local-preference 500
exit
route-map SETWEIGHT permit 20
exit
router bgp
neighbor 20.20.20.2 route-map SETWEIGHT in
*MED (METRICA)
-para todos
router bgp
default-metric 300
-cambiar para una ruta

<---mismo nmero que ACL

route-map METRICA permit 10


set metric 800
router bgp 100
neighbor 50.50.50.2 route-map METRICA out
-otra opcin
access-list 1 permit
route-map MED permit
match ip address 1
set metric 20000
route-map MED permit
router bgp 100
neighbor 50.50.50.2

3.3.3.3 0.0.0.0
10
10000
route-map MED out

*SUMARIZACIN
router bgp 100
aggregate-address 192.168.0.0 255.255.252.0 summary-only

Anda mungkin juga menyukai