Anda di halaman 1dari 15

Konfigurasi RIP, OSPF dan BGP pada router

1. Router SonicWall
a. Ospf
Berikut proses pemasangan dua atau lebih SonicWalls untuk
mendistribusikan informasi OSPF di dalam Area yang sama.

1. Login ke SonicWall Management GUI dan Arahkan ke Network | Rute.

2. Di bawah Routing Mode, atur menu drop down ke Advanced Routing.


Buka menu Configure OSPF untuk Interface dengan Routes atau Networks
yang relevan untuk didistribusikan.

2. Pada jendela pop-up, atur OSPFv2 ke Enabled dan masukan informasi berikut:
Dead Interval, Hello Interval, dan OSPF Area. Semua informasi ini harus
sesuai dengan semua SonicWalls atau Routes and Networks tidak akan
didistribusikan.
3. Setiap SonicWall juga harus memiliki ID Router yang unik, yang biasanya
adalah Interface IP Address. Namun Anda dapat mengaturnya ke Lokal
manapun, alamat IP yang tidak terpakai.
4. Isikan Tipe ABR ke Cisco.
6. kemudian, pilih opsi alternatif mana yang akan didistribusikan ulang: Rute
Statis, Jaringan Tersambung, Rute RIP, dan Jaringan VPN Jarak Jauh.

Setelah konfigurasi pada semua perangkat Area selesai, Anda dapat


mengatur Metrik untuk Rute yang dipelajari melalui protokol Routing
Lanjutan. Untuk melakukannya navigasikan ke Network | Routing dan edit
Terapkan metrik berikut ke rute default yang diterima dari kolom protokol
Routing Tingkat Lanjut. Nilai defaultnya adalah 110.

Setelah semuanya dikonfigurasi, Anda akan melihat Status Tetangga OSPF di


Jaringan | Rute. Gelembung hijau menunjukkan bahwa tetangga mampu
berkomunikasi, gelembung Merah menunjukkan adanya kegagalan. Anda
dapat memeriksa Log SonicWall di bawah Logs | Log Monitor untuk informasi
lebih lanjut tentang mengetahui kegagalan.
b. RIP
Untuk mengkonfigurasi RIP pada SonicOS Standard:

- Masuk ke SonicWALL Management GUI sebagai admin.


- Pergi ke Network -> Routing.
- Pilih Advanced Routing dalam Routing Mode.
Mode RIP:

Dinonaktifkan - RIP dinonaktifkan pada antarmuka ini.


Send and Receive - Router RIP pada interface ini akan mengirimkan update
dan proses update yang diterima.
Send Only - Router RIP pada antarmuka ini hanya akan mengirim update, dan
tidak akan memproses update yang diterima. Ini mirip dengan implementasi
routing dasar.
Hanya Menerima - Router RIP pada antarmuka ini hanya akan memproses
pembaruan yang diterima.
Pasif - Router RIP pada antarmuka ini tidak akan memproses pembaruan yang
diterima, dan hanya akan mengirim update ke router RIP tetangga yang
ditentukan dengan perintah 'tetangga' CLI. Mode ini hanya boleh digunakan
saat mengkonfigurasi opsi RIP lanjutan dari CLI ars-rip.

RIPv1 - Menerima hanya menyiarkan paket RIPv1.


RIPv2 - Menerima hanya paket RIPv2 multicast. Paket RIPv2 dikirim dengan
alamat multicast (224.0.0.9), walaupun beberapa implementasi router RIP
(termasuk perutean dasar pada perangkat SonicWALL) memiliki kemampuan
untuk mengirim RIPv2 dalam format broadcast atau multicast.

Kirim (Tersedia dalam mode 'Kirim dan Terima' dan 'Kirim Saja'):
RIPv1 - Mengirimkan paket RIPv1.
RIPv2 - Mengirim paket multicast RIPv2.
Horizon Split - Mengaktifkan Split Horizon akan menekan masuknya rute yang
dikirim melalui pembaruan ke router tempat mereka belajar. Ini adalah
mekanisme RIP yang umum untuk mencegah loop routing.

Poisoned Reverse - Poison reverse adalah mode opsional operasi Split


Horizon. Alih-alih menekan masuknya rute yang dipelajari, rute dikirim
dengan metrik tak terhingga (16) sehingga mengindikasikan bahwa
semuanya tidak terjangkau.

Use Password - Memungkinkan penggunaan kata kunci teks biasa pada


antarmuka ini, hingga 16 karakter alfa-numerik, untuk otentikasi. Ini hanya
mendukung RIPv2.

Metrik Default - Digunakan untuk menentukan metrik yang akan digunakan


saat mendistribusikan ulang rute dari sumber informasi perutean (Default,
Statis, Tersambung, OSPF, atau VPN) lainnya. Nilai default (undefined) adalah
1 dan maksimal 15.

Jarak Administrasi - Nilai jarak administratif digunakan oleh router dalam


memilih jalur bila ada lebih dari satu rute ke tujuan, dengan jarak yang lebih
kecil lebih disukai. Nilai default adalah 120, minimum adalah 1, dan
maksimum adalah 255.

Originate Default Route - Kotak centang ini memungkinkan atau


menonaktifkan perayapan rute default SonicWALL ke dalam sistem RIP.

Redistribusi Rute Statis - Mengaktifkan atau menonaktifkan periklanan rute


statis (Routing Berbasis Kebijakan) ke dalam sistem RIP. Metrik dapat
ditetapkan secara eksplisit untuk redistribusi ini, atau dapat menggunakan
nilai (default) yang ditentukan dalam pengaturan 'Metrik Default'.

Redistribusi Jaringan Terhubung - Mengaktifkan atau menonaktifkan


periklanan jaringan yang terhubung secara lokal ke dalam sistem RIP. Metrik
dapat ditetapkan secara eksplisit untuk redistribusi ini, atau dapat
menggunakan nilai (default) yang ditentukan dalam pengaturan 'Metrik
Default'.

Redistribusi Rute OSPF - Mengaktifkan atau menonaktifkan periklanan rute


yang dipelajari melalui OSPF ke dalam sistem RIP. Metrik dapat ditetapkan
secara eksplisit untuk redistribusi ini, atau dapat menggunakan nilai (default)
yang ditentukan dalam pengaturan 'Metrik Default'.

Redistribusi Jaringan VPN Jarak Jauh - Mengaktifkan atau menonaktifkan


periklanan rute statis (Routing Berbasis Kebijakan) ke dalam sistem RIP.
Metrik dapat ditetapkan secara eksplisit untuk redistribusi ini, atau dapat
menggunakan nilai (default) yang ditentukan dalam pengaturan 'Metrik
Default'.
c. BGP
Langkah 1: Aktifkan Perutean Lanjutan
Jaringan | Routing | Routing Mode: Advanced Routing

Langkah 2: Aktifkan BGP (Konfigurasi dengan CLI)


Jaringan | Routing | BGP: Aktifkan (Konfigurasi dengan CLI)
Step 3: Connect to SonicWall using port 22(SSH)

Step 4: Configure BGP


User:admin
Password:
admin@C0EAE45C0360> configure
/ Enter to the configure mode
admin at GUI from 10.60.2.102 is editing.
Do you wish to preempt them (yes/no)?
[no]: yes
/ Confirm preemption from GUI user who has logged in to SonicWALL
config(C0EAE45C0360)# routing
/ Enter to Routing Module
(config-routing)# bgp
/ Enter to BGP module
ZebOS version 7.7.0 IPIRouter 7/2009
ARS BGP>
ARS BGP>configure terminal /
Enter configure mode
ARS BGP(config)>router bgp 6501 /
Set up AS number on SonicWALL
ARS BGP(config-router)>neighbor 2.2.2.1 remote-as 6500 /
Configure neighbor connection
ARS BGP(config-router)>network 20.20.20.0 mask 255.255.255.0 /
Advertise your network
ARS BGP(config-router)>Ctrl+Z
ARS BGP>Write /
To write the changes into memory
ARS BGP>Exit
config(C0EAE45C0360)#commit /
To save the configuration
Step 5: Check BGP neighbor status
ARS BGP> tampilkan ip bgp summary
Jika output dari perintah tersebut menunjukkan nomor di bawah State /
PfcRcd, ini menunjukkan bahwa tetangga dapat berkomunikasi satu sama
lain.

Langkah 6: Periksa jaringan yang diiklankan ke tetangga


ARS BGP> tampilkan ip bgp tetangga advertised-routes

Sumber : https://support.sonicwall.com/
2. mikrotik
a. ospf
Konfigurasi dari setiap router juga sama tidak ada perbedaan. Langkah awal
kita masuk pada menu Routing -> OSPF -> Network. Kemudian tambahkan
network yang terdapat di router.

OSPF Networks - Router Pertama


OSPF Networks - Router Kedua

OSPF Networks - Router Ketiga


Setelah kita menambahkan network pada masing-masing router, jika kita
melihat pada OSPF -> Interfaces maka secara otomatis akan muncul
interface router dimana network tersebut terpasang. Dengan kita
menambahkan network itu secara otomatis pula OSPF pada masing-masing
router telah aktif.
Pada menu IP -> Routes juga akan ditambahkan secara dinamis rule routing
baru dengan flag DAo (Dinamic, Active, Ospf).

Nah, sampai pada langkah ini seharusnya jika kita melakukan test ping maka
setiap jaringan lokal sudah bisa reply. Dan berarti konfigurasi untuk OSPF
Backbone (Area 0) telah selesai.
b. BGP
Konfigurasi BGP
Setelah kita tambahkan IP Address tersebut pada router, selanjutnya kita
akan konfigurasi pada menu BGP. Kita pilih pada menu Routing -> BGP.
Pada tab 'Instance' kita tentukan nilai dari paramter AS (Autonomus System
Number). Kita bisa tambahkan satu profile intsance baru atau kita juga bisa
mengubah konfigurasi pada profile yang telah ada (default). Nilai dari ASN ini
kita sesuaikan dengan informasi dari ISP. Sebagai contoh disini kita
menggunakan 65432.

Kemudian kita juga akan melakukan konfigurasi pada tab 'Peers'. Disini kita
akan menambahkan dua buah rule untuk peering (memasangkan) dengan
BGP Router yang ada di ISP. Kita tambahkan peering untuk link koneksi
Internasional dan juga IIX (lokal).

Pada parameter name kita tentukan nama dari jenis koneksi tersebut
(Internasional dan IIX). Kemudian kita arahkan parameter instance ke profile
yang telah kita buat sebelumnya yaitu 'default'. Untuk 'Remote Address'
adalah gateway dari masing-masing link koneksi, Jangan lupa untuk
menentukan 'Remote AS'. Hal ini juga disesuaikan dengan informasi dari ISP.
Sebagai contoh kita kali ini kita menggunakan 65530.
Apabila proses 'peering' berhasil maka pada kolom state akan mucul
keterangan 'Established' dan jika kita melihat melalui New terminal dengan
script /routing bgp peer print, maka pada dua rule yang kita buat tadi
terdapat flag 'E'.
Dan apabila kita lihat pada menu IP ->Routes maka akan muncul banyak
sekali rule routing dengan flag 'DAb' (Dynamic Active BGP) yang mana rule
tersebut merupakan rule untuk destination dari IIX (lokal) dan juga
Internasional.

Sampai langkah ini IP Public yang ada pada router kita sudah bisa diakses
dari luar. Namun, untuk koneksi internetnya sendiri dari router maupun LAN
(client) masih belum bisa diakses. Untuk itu kita akan menambahkan rule
pada firewall NAT. Namun disini kita tidak akan menggunakan rule NAT
dengan "action=masquerade", karena link yang menuju ke internet yaitu
ether1 dan ether2 menggunakan IP Private. Sehingga kita akan
menggunakan "action=src-nat" dengan menunjuk IP Public yang berada
pada salah satu interface router yaitu di ether5.
Pertama, kita tambahkan NAT untuk dua link koneksi ke internet
(Internasional dan IIX). Contoh scriptnya adalah sebagai berikut:
/ip firewall nat
add action=src-nat chain=srcnat out-interface=ether1 src-
address=172.16.1.2 to-addresses=202.73.xxx.11
add action=src-nat chain=srcnat out-interface=ether2 src-
address=172.16.4.2 to-addresses=202.73.xxx.11
Kedua, kita tambahkan NAT untuk akses internet dari jaringan LAN. Contoh
scriptnya adalah sebagai berikut:
/ip firewall nat
add action=src-nat chain=srcnat src-address=192.168.88.0/24 to-
addresses=202.73.xxx.11
Dari langkah ini seharusnya client maupun router sudah bisa koneksi ke
internet. Kita bisa melakukan traceroute atau test ping untuk pengecekan.
Nah, demikianlah langkah-langkah bagaimana cara konfigurasi dasar dari
BGP. Anda bisa sesuaikan alokasi ip addressing sesuai dengan kondisi real
pada jaringan Anda.
c. RIP
Langkah-langkah konfigurasi routing RIP :
Siapkan mikrotikoard

Hubungkan pc ke mikrotikboard menggunakan kabel straight

Lakukan setting menggunakan winbox Maka akan muncul tampilan awal


winboxKlik tombol yang memiliki tiga titik [...] di samping tombol
[connect] Jika router sudah terkoneksi dengan baik dengan LAN maka akan
muncul sebuah list mac address dan Ip address
Apabila PC router mikrotik sudah pernah di setting lakukan reset dengan cara
seperti berikut :Masuk winbox > Klik tombol [new terminal] > ketikan system
reset > yesSetelah di reset biasanya router akan terdisconect
Lalu masuk kembali ke winbox,klik tombol yang memiliki tiga titik [...] lalu
pilih mac address yang tersedia dan connectBeri ip yang telah di tentukan
dengan cara seperti berikut :

ROUTER 1
[admin@R1] > ip address add 192.168.1.1/24 interface=ether3
[admin@R1] > ip address add 172.160.1.1/16 interface=ether4
ROUTER 2
[admin@R2] > ip address add 192.168.2.1/24 interface=ether3
[admin@R2] > ip address add 172.160.2.1/16 interface=ether4

Lakukan routing RIP dengan perintah sebagai berikut :


ROUTER 1
[admin@R1] > routing rip interface add interface=ether4 send=v1
receive=v1
[admin@R1] > routing network add network=192.168.1.0/30
[admin@R1] > routing network add network=172.160.0.0/16

ROUTER 2
[admin@R2] > routing rip interface add interface=ether4 send=v1
receive=v1
[admin@R2] > routing network add network=192.168.2.0/30
[admin@R2] > routing network add network=172.160.0.0/16

Setelah konfigurasi, atur ip address client yang sudah di tentukan di atas


Client 1 : IP Address : 192.168.1.10
Subnetmask : 255.255.255.0
Gateway : 192.168.1.1
Client 2 : IP Address : 192.168.2.10
Subnetmask : 255.255.255.0
Gateway : 192.168.2.1
Mengecek hasil routing RIP :
[admin@R2] > ip route print
Dan lakukan ping di client untuk menguji koneksi dari client.