Anda di halaman 1dari 6

1.

Pengertian dan Cara Kerja ARP

Pengertian ARP

ARP adalah protocol yang berfungsi memetakan IP address menjadi MAC (Media Access Control)
address. Dia adalah penghubung antara datalink layer dan IP layer pada TCP/IP. Semua komunikasi yang
berbasis ethernet menggunakan protocol ARP ini. Intinya setiap komputer atau device yang akan
berkomunikasi pasti akan melakukan transaksi atau tukar menukar informasi terkait antara IP dan MAC
address. Setiap transaksi akan disimpan di dalam cache OS Anda.

Namun protocol ini punya kelemahan serius, karena setiap komputer bisa saja memberikan paket
transaksi ARP yang dimanipulasi. Dengan merubah MAC address yang sesungguhnya. Kelemahan ini
dimanfaatkan untuk jenis serangan ARP Poisoning atau ARP Spoofing atau Man In The Middle Attack.
Siapa pun dapat menyadap bahkan meng-kill koneksi aktif pada LAN.

Cara Kerja ARP

Saat komputer pertama dinyalakan dan ia bergabung dengan jaringan, ia hanya tahu alamat IP dan
nomor MAC milik dirinya sendiri. Kita namakan komputer ini si A.

Ketika ada komputer yang bicara dengan komputer yang lain, A juga ikut mendapat paket yang
dikirimkan ke komputer lain tersebut, meski paket itu bukan untuk dirinya. Ini adalah sifat dari jaringan
Ethernet.

Setelah paket dibuka, disana terdapat data pengirim paket yang berisi nomor IP dan MAC. Data tersebut
lalu disimpan oleh si A kedalam daftar tabel MAC miliknya. Satu data sudah tersimpan.

Dalam paket tersebut juga ada data penerima, yang terdiri dari nomor IP dan MAC si penerima. Data
tersebut juga disimpan.

Begitu seterusnya. Jadi meski si A diam saja, ia bisa tahu banyak tentang siapa saja yang ada di jaringan
ini, meski tidak semua.

Ketika dia mau mengirim data ke suatu nomor IP, maka dia harus tahu alamat MAC komputer yang akan
ditujunya.
Jika dalam daftar MAC miliknya terdapat nomor IP komputer tujuan, maka dia dapat langsung
mengambil data tersebut.

Tapi jika tidak ada, maka si A melakukan broadcasting (pengumuman), 'nomor IP ini, MAC-nya berapa?,
jika ada yang punya, hubungi saya di alamat IP dan MAC ini'. Dan semua anggota jaringan akan
mendengarkan.

Jika ada yang sudah kenal A, maka diam saja. Tapi bagi yang belum, harus mencatat data A (IP dan MAC)
yang melakukan broadcast tadi.

Bagi yang merasa dicari oleh si A, maka harus menjawab: 'itu IP-saya, dan MAC-saya adalah ini'. Jawaban
itu didengarkan oleh semua anggota jaringan.

Jika ada yang sudah kenal si penjawab, maka diam saja. Tapi bagi yang belum, harus mencatat jawaban
tadi kedalam dafatr MAC masing-masing.

2. Static dan Dinamic Routing

Static Routing

Konfigurasi routing jenis ini biasanya dibangun dalam network yang hanya mempunyai beberapa
gateway, umumnya tidak lebih dari 2 atau 3. Static routing dibuat secara manual pada masing-masing
gateway. Jenis ini masih memungkinkan untuk jaringan kecil dan stabil. Stabil dalam arti kata jarang
down. Jaringan yang tidak stabil yang dipasang static routing dapat membuat kacau seluruh routing,
karena tabel routing yang diberikan oleh gateway tidak benar sehingga paket data yang seharusnya
tidak bisa diteruskan masih saja dicoba sehingga menghabiskan bandwith. Terlebih menyusahkan lagi
apabila network semakin berkembang.

Setiap penambahan sebuah router, maka router yang telah ada sebelumnya harus diberikan tabel
routing tambahan secara manual. Jadi jelas, static routing tidak mungkin dipakai untuk jaringan besar,
karena membutuh effort yang besar untuk mengupdatenya.

Konfigurasi static routing


Router(Config)# ip route <Network yang tidak berhubungan secara langsung> <subnetmask> <Next Hop
atau Default Gateway>

dari gambar diatas terlihat bahwa ada 3 network, yaitu :

Network 1. 220.12.10.0

Network 2. 192.168.10.0

Network 3. 172.16.0.0

Konfigurasi R A :

Memberikan IP add pada interface S0/0 dan F0/0

S0/0 adalah interface Serial

F0/0 adalah interface Fast Ethernet

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int s0/0
Router(config-if)#ip add 220.12.10.2 255.255.255.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0, changed state to down

Router(config-if)#int f0/0
Router(config-if)#ip add 192.168.10.100 255.255.255.0
Router(config-if)#no shut
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

Router(config-if)#ip route 172.16.0.0 255.255.0.0 220.12.10.1


Dynamic Routing

Dalam sebuah network dimana terdapat jalur routing lebih dari satu rute untuk mencapai tujuan yang
sama biasanya menggunakan dynamic routing. Dan juga selain itu network besar yang terdapat lebih
dari 3 gateway. Dengan dynamic routing, tinggal menjalankan routing protokol yang dipilih dan biarkan
bekerja. Secara otomatis tabel routing yang terbaru akan didapatkan.

Seperti dua sisi uang, dynamic routing selain menguntungkan juga sedikit merugikan. Dynamic routing
memerlukan routing protokol untuk membuat tabel routing dan routing protokol ini bisa memakan
resource komputer.

Konfigurasi dynamic routing

konfigurasi pada router 0

(masuk ke menu privilege)


Router>enable
(konfigurasi router)
Router#configure terminal
(setting interface serial 0)
Router(config)#interface serial 0/0
(beri ip address router pada interface serial 0)
Router(config-if)#ip address 200.100.1.1 255.255.255.252
(aktifkan interface serial 0)
Router(config-if)#no shutdown
(beri clock rate pada interface serial 0)
Router(config-if)#clock rate 64000
(kembali ke menu sebelumnya)
Router(config-if)#exit
(setting interface fastethernet 0)
Router(config)#interface fastEthernet 0/0
(beri ip address router pada interface fast ethernet 0)
Router(config-if)#ip address 192.168.1.1 255.255.255.0
(aktifkan interface fastethernet 0)
Router(config-if)#no shutdown
(kembali ke menu sebelumnya)
Router(config-if)#exit
(setting routing dinamis mode eigrp 200)
Router(config)#router eigrp 200
(memberikan network 200.100.1.0 pada router)
Router(config-router)#network 200.100.1.0
(memberikan network 192.168.1.0 pada router)
Router(config-router)#network 192.168.1.0
(ctrl+z untuk kembali ke menu utama)
Router(config-router)#^Z
Router#

konfigurasi pada router 1

Router>enable
Router#configure terminal
Router(config)#interface serial 0/0
Router(config-if)#ip address 200.100.1.2 255.255.255.252
Router(config-if)#exit
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown
Router(config)#router eigrp 200
Router(config-router)#network 200.100.1.0
Router(config-router)#network 192.168.2.0
Router(config-router)#^Z
Router#

setelah itu tes ping dari router 1 ke router 0 untuk memastikan apakah kedua router telah dapat
berkomunikasi jika telah benar dikonfigurasi maka hasilnya :

Router#ping 200.100.1.1

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 200.100.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/9/16 ms
selanjutnya konfigurasi tcp/ip pada kedua pc

pc0
ip address = 192.168.1.2
netmask = 255.255.255.0
gateway = 192.168.1.1

pc1
ip address = 192.168.2.2
netmask = 255.255.255.0
gateway = 192.168.2.1

tes ping dari pc 0 ke pc 1 dan sebaliknya

3. Netmask yang diperlukan jika memiliki 28 Host ID

Jumlah Host ID diubah menjadi biner.

28 = 11100, 5 bit

Jadi subnet mask yang diperlukan :

11111111. 11111111. 11111111. 11100000

255. 255. 255. 224