Anda di halaman 1dari 1

Se debe ingresar el peso anterior, tener un contador para el numero de veces que se va a

ingresar el peso de las 10 diferentes basculas teniendo asi un ciclo repetitivo guardando la
suma en una variable, luego dividirlo en 10 y asi obtener el promedio. Luego hacer una nueva
variable para guardar la resta del promedio con el peso anterior, mostrando con la decisional si
bajo o subio de peso dependiendo el numero negativo o positivo q de como respuesta

Algoritmo peso_subio_o_bajo
//variables pa, peso,promedio,peso
c=1
s=0
Escribir "ingrese peso anterior"
Leer pa
Mientras c<=10 Hacer
Escribir "ingrese peso ", c
Leer p
c=c+1
s=s+p
Fin Mientras
promedio=s/10
peso=promedio-pa
Si peso<0 Entonces
peso=peso*(-1)
Escribir "BAJO ", peso, " Kg"
Sino
Escribir "SUBIO ", peso, " Kg"
Fin Si
FinAlgoritmo