Anda di halaman 1dari 62

Universitas Muhammadiyah Prof. DR.

Hamka
(UHAMKA)

Basic Networking and Routing


Workshop

Gatot
1 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
• 7 Layer OSI dan 4 Layer TCP/IP Model
• Networking Fundamentals
• Pengkabelan
• IP Address
• Subnetting
• Konfigurasi Pengakelan
• Konfigurasi IP Address

• Collision and Broadcast Domain


• Router dan Switch
• Pengenalan Router CISCO
• IOS CISCO
• Pengenalan Switch CISCO
• Software Simulasi (BOSON)
• Mengkonfigurasi Router CISCO
• Mengkonfigurasi Switch CISCO
• Konfigurasi Routing
Gatot
2 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Collision
Adalah suatu kondisi yang terjadi bila dua buah device mengirim
data pada saat yang bersamaan. Akibat dari kejadian ini adalah
hilangnya data.

Collisions terjadi pada topologi broadcast karena semua


peralatan/devais terhubung ke media yang sama

Gatot
3 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Collision Domains adalah daerah/lokasi terjadinya collision.

Gatot
4 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Bila suatu jaringan terhubung dengan Segmentation

Gatot
5 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Data yang dikirim oleh sebuah computer akan disampaikan ke tujuan dengan
menyebarkan berita (broadcast) ke seluruh computer yang terhubung dalam
satu terminal (Hub/Repeater), akibatnya seluruh computer yang terhubung
akan menerima paket data dan jika dalam waktu yang bersamaan ada
computer lain yang mengirim paket data maka yang terjadi adalah crush atau
tumbukan data, dan ini akan mempengaruhi kelancaran arus data dalam
jaringan tersebut. Computer-computer yang berada dalam LAN yang sama
akan memiliki broadcast yang sama atau yang disebut broadcast domain.

Gatot
6 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
PC A yang berada dalam 1 A
network dan 1 terminal dengan B
IP 192.168.1.4 sampai dengan
192.168.1.52 dengan subnet
255.255.255.0 dan PC B yang
berada dalam 1 network lain
dan 1 terminal dengan IP
192.168.2.6 sampai dengan
192.168.2.70 dengan subnet
255.255.255.0 maka PC A yang
berada pada network
192.168.1.4 disebut 1 broadcast
domain dan PC B yang berada
pada network 192.168.2.6
berada pada broadcast domain
yang lain.

Gatot
7 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
• Definisi Router

sebuah device yang berfungsi untuk meneruskan paket-paket dari sebuah


network ke network yang lainnya (baik LAN ke LAN atau LAN ke WAN)
sehingga host-host yang ada pada sebuah network bisa berkomunikasi
dengan host-host yang ada pada network yang lain. sehingga secara
teknis Router adalah Layer 3.

Router bisa berupa sebuah device yang dirancang khusus untuk berfungsi
sebagai router (dedicated router), atau bisa juga berupa sebuah PC yang
difungsikan sebagai router.

Gatot
8 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
2Wire (www.2wire.com) Ericsson AB (www.netcomm.com)
3Com (www.3com.com) (www.ericsson.com) NETGEAR
Adtran (www.adtran.com) Huawei Technologies (www.netgear.com)
Alcatel (www.alcatel.com) (www.huawei.com) Nortel (www.nortel.com)
Apple Computer (termed Juniper Networks Redback Networks
'AirPort Base Stations') (www.juniper.net) (www.redback.com)
Asus (www.asus.com) LINKSYS Siemens AG
CISCO SYSTEMS, INC. (www.linksys.com) (www.siemens.com)
(www.cisco.com) Motorola SMC Networks
D-Link Systems (www.motorola.com) (www.smc.com)
(www.dlink.com) MRV Communications Tellabs (www.tellabs.com)
Enterasys Networks (www.mrv.com) U.S. Robotics
(www.enterasys.com) NetComm (www.usr.com)

Gatot
9 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
• Network Interface

Network Interface adalah sebuah Interface yang berfungsi untuk


menyambungkan sebuah host ke network. Network Interface adalah
perangkat keras yang bekerja pada layer 1 dari Model OSI.

Network Interface dibutuhkan oleh Router untuk menghubungkan Router


dengan sebuah LAN atau WAN. Karena Router bertugas menyambungkan
network-network, sebuah router harus mempunyai minimal 2 network
interface. Dengan konfigurasi minimal ini, router tersebut bisa
menghubungkan 2 network, karena masing-masing network
membutuhkan satu network interface yang terhubung ke Router.

Gatot
10 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
• Network Interface

Gatot
11 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
• Definisi Switch

perangkat jaringan yang bekerja di lapisan Data-link, menghubungkan banyak


segmen LAN ke dalam satu jaringan yang lebih besar. switch bekerja atas dasar
informasi MAC address.

Gatot
12 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
• Perancangan jaringan switch

Switch LAN Perangkat yang secara tipikal mempunyai beberapa port yang
menghubungkan beberapa segmen LAN lain dan port pada switch ini
berkecepatan tinggi

Gatot
13 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Virtual LAN
Sebuah Virtual LAN atau dikenal
sebagai VLAN merupakan fungsi logik
dari sebuah switch. Fungsi logik ini
mampu membagi jaringan LAN ke
dalam beberapa jaringan virtual.
Jaringan virtual ini tersambung ke dalam
perangkat fisik yang sama.
Implementasi VLAN dalam jaringan
memudahkan seorang administrator
jaringan dalam membagi secara logik
group-group workstation

Gatot
14 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Campus LAN
Sebuah jaringan yang terdiri dari beberapa segmen dan menggunakan
perangkat switch sering disebut sebagai Campus LAN. Selain teknologi
switching yang mengendalikan jalur data juga diterapkan teknologi
routing untuk mewadahi kebutuhan komunikasi antar VLAN

Gatot
15 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Cisco 3600

Dedicated router yang dibuat oleh Vendor bernama Cisco


(http://www.cisco.com).

Cisco router menggunakan tabel dan protocol routing yang berfungsi


untuk mengatur lalu lintas data. Paket data yang tiba di router diperiksa
dan diteruskan ke alamat yang dituju

Cisco Router menggunakan Central Processing Unit (CPU) dan


mempunyai sejumlah jenis memori

Gatot
16 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Cisco 1721
Cisco 2600 ROUTER TIPE FIXED

ROUTER TIPE MODULAR Gatot


17 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
ROM berguna untuk menyimpan sistem bootstrap yang berfungsi untuk
mengaturproses boot dan menjalankan Power On Self Test (POST) dan
IOS image.

RAM berguna untuk menyimpan running configuration dan dan sistem


operasi IOS yang aktif.

NVRAM berguna untuk menyimpan konfigurasi awal (start-up


configuration)

FLASH berguna untuk menyimpan IOS image. Dengan menggunakan


FLASH, IOS versi baru dapat diperoleh dari TFTP server tanpa harus
mengganti komponen dalam router

Gatot
18 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
1. CISCO ROUTER TIPE FIXED TINGKAT AKSES
• Cisco router 700 series
• Cisco router 801-804
• Cisco router 805
• Cisco router 811 dan 813

2. CISCO ROUTER TIPE MODULAR TINGKAT AKSES


• Cisco router 1600 series
• Cisco router 1720 dan 1750
• Cisco router 2500 series
• Cisco router 2600 series
• Cisco router 3600 series
• Cisco router 4000 series

3. CISCO ROUTER TIPE MODULAR TINGKAT INTI


• Cisco router 7000 series, untuk enterprise
• Cisco router 10000 dan 12000 series, untuk enterprise

Gatot
19 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
IOS (Internetwork Operating System), yaitu suatu system operasi yang
berfungsi untuk mengatur dan mengkonfigurasi Cisco router.

Gatot
20 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
1. Power On Self Test (POST) untuk memeriksa CPU, memori, dan
interface peralatan.

2. boostrap system akan bekerja untuk mencari Cisco IOS image yang
dapat dipakai. Umumnya cisco IOS image ini dapat diperoleh dari
memori FLASH atau dari TFTP server. Secara default daftar konfigurasi
ini bernilai 0x2120 yang akan memerintahkan router untuk mencari IOS
image dari memori FLASH.

3. Usaha pencarian IOS ini dilakukan sebanyak lima kali. Jika tidak
berhasil, router akan masuk ROM mode.

4. Jika IOS image ditemukan, IOS image tersebut akan dimuat ke dalam
sistem memori RAM. Kemudian router akan mencari konfigurasi awal
(start-up Configuration) yang umumnya disimpan di NVRAM.

Gatot
21 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Gatot
22 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Gatot
23 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Gatot
24 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Switch menerima frame dari host dan switch akan melihat MAC address
tujuan di dalam tabel forwarding untuk menentukan ke mana frame harus
diteruskan.

Store-and-forward
1. Membaca keseluruhan frame.
2. Menyimpan salinan frame ke buffer.
3. Mengecek CRC (Cyclical Redundancy Check) untuk mengetahui
adanya error pada waktu transfer.
4. Jika frame dalam keadaan error maka frame akan diabaikan. Jika
tidak ada error, frame akan diteruskan.
5. Waktu tunda paling tinggi.
6. Mengurangi jumlah frame yang error.

Gatot
25 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Cut-through
1. Hanya membaca 6-bit pertama.
2. Waktu tunda lebih rendah
3. Tidak ada pengecekan CRC.
4. Jumlah frame yang error lebih banyak.

FragmentFree
1. Modifikasi dari metode cut-through.
2. Membaca 64 byte pertama.
3. Pengecekan error lebih baik dari cut-through.
4. Waktu tunda tidak selama store-and-forward.

Gatot
26 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Gatot
27 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Boson Netwotk Designer adalah sebuah software untuk simulasi jaringan
komputer baik LAN ataupun WAN. Software simulasi ini sangat tepat bagi anda
yang sedang mendalami/kursus CCNA. Di dalam simulator kita bisa belajar
mengkonfigurasi router, switch (tentunya produk CISCO)dengan tampilan
"CISCO style", tanpa harus memiliki hardware router atau switch yang
sesungguhnya (karena harganya relatif sangat mahal sekali). Trial version bagi
anda yang ingin mendalami CCNA dapat diunduh melalui:
http://bosondownload.com/netsim/ccna_netsim.exe

Gatot
28 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Gatot
29 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Melalui console port
Sebuah kabel Roll Over dibutuhkan untuk menghubungkan serial interface
pada PC dan Console port pada router tersebut. Setelah Router terhubung
dengan PC, Router dapat dikonfigurasi dengan menjalankan applikasi
HyperTerminal dari PC.

Gatot
30 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Gatot
31 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Melalui Network
C:\> telnet IP-address-Router
Contoh:
C:\> telnet 172.16.148.1

Gatot
32 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Gatot
33 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
User Exec Mode
• Untuk melihat status router.
• Tidak bisa mengubah konfigurasi router.
• Saat log on ke router pertama kali.
• tanda (>)
Privileged Mode
• Untuk melihat status router.
• Bisa mengubah configurasi router
• tanda (#)
router con0 is now available
Press RETURN to get started
router >
router > enable
router # disable
router >
router > logout

Gatot
34 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
• Global configuration mode
Mengubah konfigurasi router secara global.

• Interface Configuration Mode


Suatu mode yang digunakan untuk mengkonfigurasikan suatu interface
tertentu.

router con0 is now available


Press RETURN to get started
router >
router >
router > enable
router # configure terminal
router (config) # interface ethernet 0

Gatot
35 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
• Merubah Nama Router
Router # configure terminal
Router(config)#hostname Router1
• Password untuk console
Router(config) # line console 0
Router(config-line) # login
Router(config-line) # password cisco
Router(config-line) # exit
Router(config) # exit
Router(config) #
• Password untuk Virtual Terminal
Router(config) # line vty 0 4
Router(config-line) # password cisco
Router(config-line) # exit
Router(config) # exit
Router(config) #

Gatot
36 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
• Password untuk mode priviledge
Router(config) # enable password cisco
Atau
Router(config) # enable secret cisco
• Menghapus password enable secret

Router(config) # no enable secret cisco

• Mengkonfigurasi Ethernet Interface

Router# configure terminal


Router(config)# interface ethernet 1/0
Router(config-if)# description LAN pada Department IT
Router(config-if)# ip address 172.16.148.1 255.255.255.128
Router(config-if)# exit
Router(config)# exit
Router#

Gatot
37 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
• Melihat Informasi versi router
Router # show version

• Melihat Informasi mengenai interface


Router # show interfaces

• Melihat Interface Serial DTE/DCE


Router # show controllers serial 0

• Melihat konfigurasi router


Router # show running-config

• Melihat status interface


Router # show ip interface brief

Gatot
38 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
• konfigurasi interface serial sebagai DTE
Router # configure terminal
Router(config)# interface serial 0
Router(config-if)# description WAN ke Natuna
Router(config-if)# ip address 172.16.158.1 255.255.255.252
Router(config-if)# bandwith 64
Router(config-if)# exit
Router(config)# exit
Router#
• konfigurasi interface serial sebagai DCE
Router # configure terminal
Router(config)# interface serial 0
Router(config-if)# description Lab Cisco sebagai DCE
Router(config-if)# ip address 172.16.158.1 255.255.255.252
Router(config-if)# bandwith 64
Router(config-if)# clock rate 64000
Router(config-if)# exit
Router(config)# exit
Router# Gatot
39 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
• Men-disable sebuah interface

Router(config-if)# shutdown
Dan
Router(config-if)# no shutdown

• Menyimpan dan mengambil Konfigurasi

Router# copy running-config startup-config //RAM ke NVRAM


Dan
Router# copy startup-config running-config //NVRAM ke RAM

Gatot
40 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
1. Membuat hostname : switch
2. Previlage password : cisco
3. Console password : console
4. Telnet password : telnet

Switch # configure terminal


Switch(config)# hostname switch1
Switch1(config)# enable password cisco
Switch1(config)# line console 0
Switch1(config-line)# password console
Switch1(config-line)# login
Switch1(config-line)# exit
Switch1(config)# line vty 0 15
Switch1(config-line)# password telnet
Switch1(config-line)# login
Switch1(config-line)# exit
Switch1(config)# exit
Switch1#

Gatot
41 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
• Melihat VLAN
Switch # show vlan
• Melihat seluruh Port Interface, VLAN, Membership
Switch # show vlan
• Membuat VLAN
Switch # configure terminal
Switch(config)# vlan (nomerVLAN) name (nama VLAN)
Switch(config)# exit
• Setting VLAN di interface port
Switch # configure terminal
Switch(config)# interface (nomer port Interface)
Switch(config-if)# vlan-membership static (nomer VLAN)
Switch(config-if)# exit
Switch(config)# exit

Gatot
42 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
PC1

Swich1
24.17.2.1 /24 E 0/1 24.17.2.3 /24
Fa 0/0
Fa 0/0
Router1
E 0/2 24.17.2.4 /24

PC2
1. Membuat hostname : Router1, Switch1
2. Previlage password : cisco
3. Console password : console
4. Telnet password : telnet
5. Buat agar PC2 dapat komunikasi dengan Router Saja
6. Buat agar PC1 dapat komunikasi dnegan PC2 saja
7. Buat agar PC1, PC2 dan Router dapat berkomunikasi

Gatot
43 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Routing merupakan proses pencarian path atau alur guna
memindahkan informasi dari host sumber (source address) ke host
tujuan (destinations address) melalui koneksi internetwork. Jika suatu
network tidak memiliki router, maka dipastikan tidak dapat diselenggarakan
routing.

Agar router dapat mengetahui bagaimana meneruskan paket-paket ke


alamat yang dituju dengan menggunakan jalur yang baik, router
menggunakan peta atau tabel routing.

Tabel routing dapat dibuat secara static, dynamic dan default.

Gatot
44 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Static routing
cara pembuatan tabel routing secara manual. Static routing ini dapat dipakai
pada jaringan sederhana yang hanya menggunakan beberapa buah router
dan berfungsi untuk menghemat penggunaan bandwidth

Dynamic routing
Untuk membuat suatu tabel routing secara dinamis berubah-ubah secara
otomatis jika topologi jaringan berubah sehingga terjadi proses
pembelajaran oleh Router dan meng-update tabel routing. Menggunakan
protocol routing dalam pembuatan tabel routing.

Protokol routing menggunakan konsep metric (suatu nilai hasil perhitungan


algoritma) dalam menentukan jalur yang terbaik yang akan dicapai.

Default Routing
Mengirim paket ke jaringan yang tidak ada di dalam tabel routing ke Router
selanjutnya. Hal ini terjadi jika Router hanya mempunyai satu port keluar.

Gatot
45 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
172.16.30.0

30.1
2501A E0 2501C
S0 S0 S0
E0 S1
20.1 20.2 40.2 E0
10.2 2501B 40.1
F0/0 50.1
2621A 10.1 172.16.20.0 172.16.40.0 172.16.50.0
172.16.10.0

Gatot
46 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
• Tidak membebani CPU
• Tidak diperlukan komunikasi antar Router
• Aman (krn hanya admin yg bisa men-setup)
• Admin harus menguasai jaringan keseluruhan
• Jika ada tambahan jaringan, admin harus menambahkannya pada
semua Router
• Pada jaringan yang besar, hal ini akan sangat menyita waktu dan tenaga

Network Number Next Hope/Port Keterangan


172.16.50.0 172.16.10.2 S
172.16.40.0 172.16.10.2 S
172.16.30.0 172.16.10.2 S
172.16.20.0 172.16.10.2 S
172.16.10.0 F0/0 C (Default Routing)

Gatot
47 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
• Ada beberapa type,
– RIP (Routing Information Protocol)
– IGRP (Interior Gateway Routing Protocol)
– EIGRP (Enhanced IGRP)
– OSPF (Open Shortest Path First)

Gatot
48 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
• Setiap node (router) membuat vektor (Destination, cost, Next Hope) ke
semua node, dan mendistribusikan vektornya kepada tetangga
terdekatnya.
• Awal mula: Setiap node tahu cost ke tetangga sebelahnya adalah 1.
Tetangga yang bukan sebelah cost bernilai  (tak terhingga)

Gatot
49 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
1.0
1.1 4.0
A 4.1
2.1 5.0 5.2 B
2.0

2.2 5.1
C 3.1 3.0 3.2 D
C D
6.1 6.0

A C D B

Dest Cost Next Dest Cost Next Dest Cost Next Dest Cost Next

1.0 0 -- 2.0 0 -- 3.0 0 -- 4.0 0 --

2.0 0 -- 3.0 0 -- 5.0 0 -- 5.0 0 --


6.0 0 --

A B
C D
Dest Cost Next Dest Cost Next
Dest Cost Next Dest Cost Next
1.0 0 -- 4.0 0 --
2.0 0 -- 3.0 0 --
2.0 0 -- 5.0 0 --
3.0 0 -- 5.0 0 --
3.0 1 C=2.2 3.0 1 D=5.1
1.0 1 A=2.1 6.0 0 --
6.0 1 D=5.1
5.0 1 D=3.2 2.0 1 C=3.1
6.0 1 D=3.2 4.0 1 B=5.2

Gatot
50 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
A C D B

Dest Cost Next Dest Cost Next Dest Cost Next Dest Cost Next

1.0 0 -- 2.0 0 -- 3.0 0 -- 4.0 0 --

2.0 0 -- 3.0 0 -- 5.0 0 -- 5.0 0 --

3.0 1 C=2.2 1.0 1 A=2.1 6.0 0 -- 3.0 1 D=5.1

5.0 2 C=2.2 5.0 1 D=3.2 2.0 1 C=3.1 6.0 1 D=5.1

6.0 2 C=2.2 6.0 1 D=3.2 4.0 1 B=5.2 2.0 2 D=5.1


4.0 2 D=3.2 1.0 2 C=3.1

A C D B

Dest Cost Next Dest Cost Next Dest Cost Next Dest Cost Next

1.0 0 -- 2.0 0 -- 3.0 0 -- 4.0 0 --

2.0 0 -- 3.0 0 -- 5.0 0 -- 5.0 0 --

3.0 1 C=2.2 1.0 1 A=2.1 6.0 0 -- 3.0 1 D=5.1

5.0 2 C=2.2 5.0 1 D=3.2 2.0 1 C=3.1 6.0 1 D=5.1

6.0 2 C=2.2 6.0 1 D=3.2 4.0 1 B=5.2 2.0 2 D=5.1

4.0 3 C=2.2 4.0 2 D=3.2 1.0 2 C=3.1 1.0 3 D=5.1

Gatot
51 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
1.2 (host2)

Switch2

1.1 (1eo)

2.1 (1so) 3.1 (1s1)

5.2 (host1) 2.2 (2so) Router1 6.2 (host3)


3.2 (3s1)
6.1 (3eo)
5.1 (2eo)
4.1 (2s1)
4.2 (3s0)
Router2 Router3 Switch3
Switch1

Gatot
52 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Gatot
53 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
• Router 1, Serial0/0
Router1(config)#int serial0/0
Router1(config-if)#ip address 192.168.2.1 255.255.255.0
Router1(config-if)#clock rate 64000
Router1(config-if)#bandwidth 56
Router1(config-if)#encapsulation hdlc
Router1(config-if)#no shutdown
Router1(config-if)#end
Router1#

• Router 1, Serial0/1
Router1(config)#int serial0/1
Router1(config-if)#ip address 192.168.3.1 255.255.255.0
Router1(config-if)#clock rate 64000
Router1(config-if)#bandwidth 56
Router1(config-if)#encapsulation hdlc
Router1(config-if)#no shutdown
Router1(config-if)#end
Router1#
Gatot
54 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
• Router 1, fastethernet0
Router1(config)#int fastethernet0
Router1(config-if)#ip address 192.168.1.1 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#end
Router1#

• Router 2, Serial0/0
Router2(config)#int serial0/0
Router2(config-if)#ip address 192.168.2.2 255.255.255.0
Router2(config-if)#clock rate 64000
Router2(config-if)#bandwidth 56
Router2(config-if)#encapsulation hdlc
Router2(config-if)#no shutdown
Router2(config-if)#end
Router2#

Gatot
55 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
• Router 2, Serial0/1
Router2(config)#int serial0/1
Router2(config-if)#ip address 192.168.4.1 255.255.255.0
Router2(config-if)#clock rate 64000
Router2(config-if)#bandwidth 56
Router2(config-if)#encapsulation hdlc
Router2(config-if)#no shutdown
Router2(config-if)#end
Router2#

• Router 2, fastethernet0
Router2(config)#int fastethernet0
Router2(config-if)#ip address 192.168.5.1 255.255.255.0
Router2(config-if)#no shutdown
Router2(config-if)#end
Router2#

Gatot
56 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
• Router 3, Serial0/0
Router3(config)#int serial0/0
Router3(config-if)#ip address 192.168.4.2 255.255.255.0
Router3(config-if)#clock rate 64000
Router3(config-if)#bandwidth 56
Router3(config-if)#encapsulation hdlc
Router3(config-if)#no shutdown
Router3(config-if)#end
Router3#

• Router 3, Serial0/1
Router3(config)#int serial0/1
Router3(config-if)#ip address 192.168.3.2 255.255.255.0
Router3(config-if)#clock rate 64000
Router3(config-if)#bandwidth 56
Router3(config-if)#encapsulation hdlc
Router3(config-if)#no shutdown
Router3(config-if)#end
Router3#
Gatot
57 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
• Router 3, fastethernet0
Router3(config)#int fastethernet0
Router3(config-if)#ip address 192.168.6.1 255.255.255.0
Router3(config-if)#no shutdown
Router3(config-if)#end
Router3#

Gatot
58 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Router(config)#ip route <network destination id> <subnet mask>
<default gateway>

• Pada Router1:
Router1(config)#ip route 192.168.5.0 255.255.255.0 192.168.2.2
Router1(config)#ip route 192.168.6.0 255.255.255.0 192.168.3.2

• Pada Router2:
Router1(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1
Router1(config)#ip route 192.168.6.0 255.255.255.0 192.168.4.1

• Pada Router3:
Router1(config)#ip route 192.168.5.0 255.255.255.0 192.168.4.1
Router1(config)#ip route 192.168.1.0 255.255.255.0 192.168.3.1

Gatot
59 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Untuk memeriksa apakah konfigurasi routing berhasil, ketik perintah
berikut :

Router1#show ip route

Ketika perintah ini dijalankan maka akan tampil semua daftar ip route yang
ada pada router. Biasanya terdapat kode S yang berarti menandakan
hubungan secara statis (statically connected) dan C menandakan
hubungan secara langsung (directly connected)

Gatot
60 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Sistem sertifikasi ini dibagi menjadi tiga tingkatan :
• CCNA (Cisco Certified Networking Associate)
• CCNP (Cisco Certified Networking Profesional)
• CCIE (Cisco Certified Internetworking Expert)

Gatot
61 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA
Universitas Muhammadiyah Prof. DR. Hamka
(UHAMKA)
http://www.scribd.com/people/view/1121567
ID YM : gete_tel@yahoo.com.au

Thank You
Gatot
62 BASIC NETWORKING and ROUTING WORKSHOP
UNIVERSITAS MUHAMMADIYAH PROF DR HAMKA