Anda di halaman 1dari 20

Cajamarca, 9 de diciembre del 2013

El presente trabajo va dedicado a mis padres, y todos


esos familiares que siempre se preocupan por mi
bienestar, y desean lo mejor para mi.

Además quiero agradecer al profesor por haber


brindado este tiempo, sus conocimientos y
compartirlos con nosotros.
INTRODUCCION

El rol de la programación en los últimos sesenta años ha sido crucial para


comprender la evolución que ha tenido la sistematización de tareas y el manejo
de la información que hoy en día damos como un hecho. En efecto, la misma
tiene como principal función el hecho de conseguir que innumerables trabajos
que antes ejercíamos de forma manual y con un alto costo sean ejecutados por
un ordenador con un ahorro significativo de tiempo. Por otro lado, dada la
increíble cantidad de información que hoy en día se maneja para distintas
tareas, la programación es una herramienta de enorme valor porque permite
bucear en la misma con muchísima facilidad.
MARCO TEORICO
Un programa es un conjunto de líneas de código escritas en un lenguaje de
programación determinado. Pero el código escrito en un lenguaje de alto nivel no
puede ser entendido por el ordenador, por lo que es necesaria la traducción a código
máquina. En este proceso tienen lugar dos fases. En la primera fase (compilación) el
compilador traduce cada uno de las partes del programa y crea módulos objeto, que
posteriormente serán unidos por el linker (enlazado), creando el módulo ejecutable
.exe. Como la compilación y el enlazado son dos procesos dependientes, a menudo se
suele denominar a todo el proceso compilación.

1. Definición del problema

Requiere que el problema sea definido y comprendido claramente para que pueda ser
analizado con todo detalle.

2. Análisis del problema

El propósito del análisis de un problema es ayudar al programador para llegar a una


cierta comprensión de la naturaleza del problema. El problema debe estar bien
definido si se desea llegar a una solución satisfactoria.

Para poder definir con precisión el problema se requiere que las especificaciones de
entrada, proceso y salida sean descritas con detalles.

 Entrada, son todos los datos que hay que ingresar para la resolución del
problema.
 Proceso, son los diferentes procedimientos en los cuales usare los datos
proporcionados por el usuario en el paso anterior para resolver el problema.
 Salida, la resolución del problema.

Una buena definición del problema, junto con una descripción detallada de las
especificaciones de entrada y salida, son los requisitos mas importantes para llegar a
una solución eficaz.

El análisis del problema exige una lectura previa del problema a fin de obtener una
idea general de lo que se solicita . la segunda lectura deberá servir para responder a
las preguntas:

 ¿Qué información debe proporcionar la resolución del problema?

 ¿Qué datos se necesitan para resolver el problema?


La respuesta a la primera pregunta indicara los resultados deseados o las salidas del
problema. La respuesta a la segunda pregunta indicara que datos proporcionan o las
entradas del problema.

En esta fase debemos aprender a analizar la documentación de la empresa ,


investigar, observar todo lo que rodea el problema.

3. Diseño de la solución

Una computadora no tiene la capacidad para solucionar mas que cuanto se le


proporcionan los sucesivos pasos a realizar. Estos pasos sucesivos que indican las
instrucciones a ejecutar por la maquina constituyen, como ya sabemos el algoritmo.

La información proporcionada al algoritmo constituye su entrada y la información


producida por el algoritmo constituye su salida.

Los problemas complejos se pueden resolver mas eficazmente con la computadora


cuando se rompen en subproblemas que sean mas fáciles de solucionar que el
original. La descomposición del problema original en subproblemas mas simples y a
continuación dividir estos subproblemas en otros mas simples que puedan ser
implementados para su solución en la computadora de denomina diseño descendente
(top - down design ).

Es presiso representar el algoritmo mediante una determinada herramienta de


programación: diagramas de flujo, pseudocódigo o diagramas N - S.

 DIAGRAMAS DE FLUJO: Un diagrama de flujo o flujograma es una forma de


representar gráficamente los pasos para resolver un problema en específico.
Estos diagramas utilizan una serie de símbolos con significados especiales y
son la representación gráfica de los pasos de un proceso. En computación es
un primer enfoque con lo que sería la programación formal.

SIMBOLOGIA DE LOS DIAGRAMS DE FLUJO:


 PSEUDOCODIGO: Un pseudocódigo (falso lenguaje), es una serie de
instrucciones a seguir pero utilizando palabras léxicas y gramaticales referidos
a los lenguajes de programación, pero sin llegar estar estrictamente correcta su
sintaxis de programación; ni tener la fluidez del lenguaje coloquial. Permitiendo
codificar un programa con mayor agilidad que en cualquier lenguaje de
programación. Forma parte de las distintas herramientas de la ingeniería de
software y es, netamente, lenguaje de tipo informático.
4. Codificación

Es el algoritmo traspasado a la computadora a través de un lenguaje de programación,

debe ser escrito de acuerdo a las reglas gramaticales o sintaxis del mismo.

Generamos un algoritmo el cual se denomina código, y al pasarlo a un lenguaje de


programación se le llama código fuente.

5. Compilación y ejecución

Compilación, el lenguaje de programación seleccionado revisa que ya no halla errores


en el código fuente.

Ejecución, ejecutar el programa después del ser compilado.

6. Verificación y pruebas

Revisar que el programa de los resultados que el usuario quiere, hay que revisar si
hay algún error el cual puede ser de tipo lógico, de semántica o ejecución.

7. Depuración

Corregir los errores encontrados en la etapa anterior, si hubiese algún error se tiene
que regresar hasta la etapa que sea necesaria para que la solución sea la que el
usuario requiere.

8. Documentación

Son todos los comentarios, referencias desde que se dio el problema hasta que se
encontró la solución.

a) documentación interna, es el encabezado, descripción, declaración del problema,


son todos los comentarios que puedan llegar a servir dentro del código fuente.

b) documentación externa, son los manuales que se hacen para una mejor ejecución
del programa, ahí se explicara como usar el programa.

9. Capacitación

Una ves que tenemos lo manuales viene la capacitación de usuarios, como no a todos
les interesa los mismo porque hay diferentes tipos de usuarios, se tienen que dividir de
acuerdo a sus conveniencias.

10. Implantación o implementación del sistema


Hay diferentes formas de implementar el sistema:

 Depende del tamaño del sistema

 Si existiera un sistema se tiene que poner el nuevo y quitar el que ya estaba.

 Trabajar primero con el sistema viejo(si existe), y después empezar a trabajar


con el nuevo.

 Sistemas implantados por regiones.

 Trabajar con el sistema viejo (si existe) y con el sistema nuevo


simultáneamente después quitar el sistema viejo.

 Ir quitando el sistema viejo(si existe) poco a poco e ir implantando el sistema


nuevo.

11. Mantenimiento

El mantenimiento preventivo es que hagamos lo posible por no caer en errores, la


actualización si el usuario tiene la necesidad de quitar o poner algo; téngase en cuenta
que cuando surge mantenimiento tenemos que volver a hacer todos los pasos
anteriores revisando que todas la condiciones sean favorables alrededor del sistema.
PSEUDOCODIGOS

 SUMA DE MATRICES

INICIO
Entero matriza (1,1)
Entero matrizb (1,1)
Entero matrizresultado (1,1)

Mostrar (“Llenar Matriz A”)


Para (entero i=0 hasta i=1) hacer
Para (entero j=0 hasta j=1) hacer
Mostrar (“Valor” & i & “-“ & j & “:”)
Leer matriza (i,j)
Fin_Para
Fin_Para

Mostrar (“Llenar Matriz B”)


Para (entero i=0 hasta i=1) hacer
Para (entero j=0 hasta j=1) hacer
Mostrar (“Valor” & i & “-“ & j & “:”)
Leer matrizb (i,j)
Fin_Para
Fin_Para

Para (entero i=0 hasta i=1) hacer


Para (entero j=0 hasta j=1) hacer
Matrizresultado (i,j) = matriza (i,j) + matrizb (i,j)
Fin_Para
Fin_Para

Mostrar (“Suma de Matriz A + B”)


Para (entero i=0 hasta i=1) hacer
Para (entero i=0 hasta i=1) hacer
Mostrar (matrizresultado (i,j))
Fin_Para
Fin_Para
FIN
DIAGRAMA DE FLUJO

Inicio

Entero matriza(1,1)
Entero matrizb(1,1)
Entero matrizresultado(1,1)

Mostrar “Ingrese los


datos de la matriz A”

Para
i=0
j<0

Leer
Matriza(i,j)

Fin_para

Mostrar “Ingrese los


datos de la matriz B”

Para
i=0
j<0

Leer
Matrizb(i,j)

Fin_para
Para
i=0
j<0

Matrizresultado(i,j) =
matriza(i,j) +
matrizb(i,j)

Fin_para

Mostrar “Suma de
matriz A + B”

Para
i=0
j<0

Mostrar
matrizresultado

Fin_para

Fin
 PRODUCTO DE MATRICES

INICIO
Entero matriza (1,1)
Entero matrizb (1,1)
Entero matrizresultado (1,1)

Mostrar (“Llenar Matriz A”)


Para (entero i=0 hasta i=1) hacer
Para (entero j=0 hasta j=1) hacer
Mostrar (“Valor” & i & “-“ & j & “:”)
Leer matriza (i,j)
Fin_Para
Fin_Para

Mostrar (“Llenar Matriz B”)


Para (entero i=0 hasta i=1) hacer
Para (entero j=0 hasta j=1) hacer
Mostrar (“Valor” & i & “-“ & j & “:”)
Leer matrizb (i,j)
Fin_Para
Fin_Para

Para (entero i=0 hasta i=1) hacer


Para (entero j=0 hasta j=1) hacer
Matrizresultado (i,j) = matriza (i,j) * matrizb (i,j)
Fin_Para
Fin_Para

Mostrar (“Suma de Matriz A + B”)


Para (entero i=0 hasta i=1) hacer
Para (entero i=0 hasta i=1) hacer
Mostrar (matrizresultado (i,j))
Fin_Para
Fin_Para
FIN
DIAGRAMA DE FLUJO

Inicio

Entero matriza(1,1)
Entero matrizb(1,1)
Entero matrizresultado(1,1)

Mostrar “Ingrese los


datos de la matriz A”

Para
i=0
j<0

Leer
Matriza(i,j)

Fin_para

Mostrar “Ingrese los


datos de la matriz B”

Para
i=0
j<0

Leer
Matrizb(i,j)

Fin_para
Para
i=0
j<0

Matrizresultado(i,j) =
matriza(i,j) *
matrizb(i,j)

Fin_para

Mostrar “Producto
de la Matriz A * B”

Para
i=0
j<0

Mostrar
matrizresultado

Fin_para

Fin
 MAYOR VALOR DE UNA COLUMNA

INICIO
Entero matriza(1,1)

Mostrar (“Llenar Matriz”)


Para (entero i=0 hasta i=1) hacer
Para (entero j=0 hasta j=1) hacer
Mostrar (“Valor” & i & “-“ & j & “:”)
Leer matriza (i,j)
Fin_Para
Fin_Para

Entero mayorcol1
Entero mayorcol2
Para (entero i=0 hasta i=1)
Para (entero i=0 hasta i=1)
Si (j=0) entonces
Si matriza(i,j) > mayorcol1 entonces
Mayorcol1 = matriza(i,j)
Fin_Si
Si_no
Si matriza(i,j) > mayorcol2 entonces
Mayorcol2 = matriza(i,j)
Fin_Si
Fin_Si
Fin_Para
Fin_Para

Mostrar (“Matriz A: “)
Para (entero i=0 hasta i=1)
Para (entero i=0 hasta i=1)
Mostrar (matriza(i,j))
Fin_Para
Fin_Para
DIAGRAMA DE FLUJO

Inicio

Entero matriza(1,1)

Mostrar “Llenar
Matriz”

Para
i=0
j<0

Leer
Matriza(i,j)

Fin_para

Entero mayorcol1
Entero mayorcol2

Para
i=0
j<0

Si
j=0
Si matriza(i,j) > Si matriza(i,j) >
mayorcol1 mayorcol2

Mayorcol1 = Mayorcol2 =
matriza(i,j) matriza(i,j)

Mostrar
“Matriz”

Para
i=0
j<0

Mostrar
matriza

Fin_para

Fin
MENOR VALOR DE UNA FILA

INICIO
Entero matriza(1,1)

Mostrar (“Llenar Matriz”)


Para (entero i=0 hasta i=1) hacer
Para (entero j=0 hasta j=1) hacer
Mostrar (“Valor” & i & “-“ & j & “:”)
Leer matriza (i,j)
Fin_Para
Fin_Para

Entero menorfil1
Entero menorfil2
Para (entero i=0 hasta i=1)
Para (entero i=0 hasta i=1)
Si (j=0) entonces
Si matriza(i,j) < menorfil1 entonces
menorfil1 = matriza(i,j)
Fin_Si
Si_no
Si matriza(i,j) < menorfil2 entonces
menorfil2 = matriza(i,j)
Fin_Si
Fin_Si
Fin_Para
Fin_Para

Mostrar (“Matriz A: “)
Para (entero i=0 hasta i=1)
Para (entero i=0 hasta i=1)
Mostrar (matriza(i,j))
Fin_Para
Fin_Para
DIAGRAMA DE FLUJO

Inicio

Entero matriza(1,1)

Mostrar “Llenar
Matriz”

Para
i=0
j<0

Leer
Matriza(i,j)

Fin_para

Entero menorfil1
Entero menorfil2

Para
i=0
j<0

Si
j=0
Si matriza(i,j) > Si matriza(i,j) >
menorfil1 menorfil2

menorfil1 = menorfil2 =
matriza(i,j) matriza(i,j)

Mostrar
“Matriz”

Para
i=0
j<0

Mostrar
matriza

Fin_para

Fin