Anda di halaman 1dari 4

UNIVERSIDAD TÉCNICA DE COTOPAXI

“EXTENSIÓN LA MANA”

TEMA:

COMO TRABAJAR EN LENGUAJE ESTRICTO EN PSEINT

DOCENTE:
ING. DANNY DÍAZ

INTEGRANTE:
BAYAS PAOLA

CICLO ACADÉMICO:

NIVELACIÓN DE CARRERA DE LA ÁREA DE SISTEMAS DE INFORMACIÓN

AÑO LECTIVO:

2017/2018
Como trabajar en lenguaje estricto en pseint

PSeInt permite personalizar algunos aspectos del lenguaje. Para evitar confusión en los
alumnos, la idea es que la primera vez que se ejecute el programa, solicite al estudiante elegir
un "perfil de configuración" para su universidad/facultad/carrera, definiendo rápidamente y
en un solo paso la configuración del lenguaje de acuerdo a las exigencias de su docente. Este
mensaje es para solicitar a los docentes que envíen sus perfiles para agregarlos a la lista. Para
ello, deben realizar los siguientes pasos:

1. Ejecute PSeInt (asegúrese de haber instalado la última versión).

2. Seleccione el ítem "Opciones del Lenguaje (perfiles)" del menú "Configurar".

3. En el cuadro de diálogo que aparece, haga click en "Personalizar".

4. En el nuevo cuadro de diálogo que aparece, configure el perfil como lo desee.

5. Haga click en el segundo botón de la esquina inferior izquierda del cuadro de diálogo
(el que muestra un disquete) para guardar el perfil en un archivo.

6. Seleccione una ubicación cualquiera para el archivo e introduzca una breve


descripción del perfil (se recomienda mencionar la institución donde se utiliza, la
cátedra o carrera, y el nombre del docente responsable o de quien envía el perfil).

7. Envíe el archivo por email a zaskar_84<arroba>yahoo.com.ar.

En el correo incluyan además del archivo generado e información de la cátedra donde lo


utilizan (nombre de la universidad y facultad o instituto, nombre de la carrera, nombre de la
cátedra/materia, docente responsable de la misma, y qué lenguaje de programación real
utilizan en las clases luego de la etapa de pseudocódigo). Además, cada perfil se muestra con
un pequeño ícono de 24x24px, que tomaré del favicon del sitio web de la institución a menos
que sugieran o envíen otro (tengan en cuenta que si el logo de la institución es muy complejo,
al reducirlo a 24x24 puede que ya no se reconozca).

Si creen que sería útil agregar otras personalizaciones además de las ya implementadas no
duden en sugerirlo.
A continuación se muestra un ejemplo escrito Para los perfiles Estricto y Flexible, ilustrando
algunas diferencias entre configuraciones:

Algoritmo Flexible

Proceso Estricto

Definir VAL_MAYOR,ARREGLO,CANT,I Escribir "Ingrese la cantidad


Como Enteros; de números:"
Leer CANT
Dimensión ARREGLO[100]; Dimensión ARREGLO[CANT]
Escribir "Ingrese la cantidad de
números:"; Para Cada Elemento de ARREGLO
Leer CANT; Escribir "Ingrese un
numero:"
Para I<-0 Hasta CANT-1 Hacer Leer ELEMENTO
Escribir "Ingrese un numero:"; Fin Para
Leer ARREGLO[I];
Fin Para VAL_MAYOR<-0
Para Cada ELEMENTO de ARREGLO
VAL_MAYOR<-0; Si ELEMENTO Es Mayor Que
Para I<-0 Hasta CANT-1 Hacer VAL_MAYOR
Si ARREGLO[I]>VAL_MAYOR Entonces VAL_MAYOR<-ELEMENTO
VAL_MAYOR<-ARREGLO[i]; Fin Si
Fin Si Fin Para
Fin Para
Si VAL_MAYOR Es Par
Si VAL_MAYOR % 2 = 0 Entonces Escribir "El mayor es "
Escribir "El mayor es VAL_MAYOR " y es par"
",VAL_MAYOR," y es par"; Sino
Sino Escribir "El mayor es "
Escribir "El mayor es VAL_MAYOR " y es impar"
",VAL_MAYOR," y es impar"; Fin Si
Fin Si
Fin Algoritmo
Fin Proceso

Este manual se maneja con dos perfiles. El estricto, que es el más parecido a un lenguaje de
programación real, se debe respetar al pie de la letra el formato del pseudocódigo propuesto
por Novara. La sintaxis flexible la usamos para ejecutar ciertos códigos que requieren más
flexibilidad a la hora de ejecutarse. A menos que se indique que se usa sintaxis flexible, se
utilizará la sintaxis estricta.