Anda di halaman 1dari 20

Principios de Algoritmos

 Estructuras de Control Iterativas


Agenda

• Introducción
• Estructuras de control Repetitivas
• Estructura Mientras
• Ejemplo
• Acumulador y contador
• Ejercicios
• Recapitulación

2
Introducción

“La vida se comprende de ciclos y debemos saber

cuando es tiempo de cerrar uno y empezar otro.”

3
Logro de aprendizaje

Al final de la sesión el alumno elabora


seudocódigos básicos empleando la
estructura repetitiva “Mientras”.

4
Video

https://www.youtube.com/watch?v=pJGufKqnhLU

5
TIPOS DE ESTRUCTURAS REPETITIVAS

Estructura Mientras

Estructuras Repetitivas Estructura Repetir

Estructura Para

6
Recordando …

Señale diferencia entre condicional simple y


doble.
Cuando usa condicional múltiple (Según …)
¿de qué tipo puede ser la variable?
¿En qué casos usaría condicionales anidados?

7
¿Qué es un ciclo?

Palabra clave: Repetición o iteración


Conjunto de sentencias que se repiten siempre
que una condición dada sea cierta.
Ejemplo: Realizar un algoritmo que sume los 10
primeros números (1, 2, 3, 4, 5, 6, 7, 8, 9, 10).

8
¿Qué es un ciclo?

Solución sin ciclos


Proceso Diez
Definir
suma como Entero
suma  1 + 2 + 3 + 4 + 5 + 6 + 7 + 8 + 9 + 10
Escribir “La suma de los primeros 10 numeros es”,suma
FinProceso

Que sucede para el caso en el cual se cambie el


enunciado del problema y ya se quieran sumar
los mil primeros números.

9
¿Qué es un ciclo?

Siguiendo mi solución anterior


Y si el problema cambia a los
primeros 1000 números. No puede
ser, no!!!
Proceso Diez
Definir
suma como Entero
suma  1 … + 997 + 998 + 999 + 1000
Escribir “La suma de los primeros 1000 numeros es”,suma
FinProceso

10
ESTRUCTURA MIENTRAS

La instrucción Mientras ejecuta una secuencia


de instrucciones mientras una condición sea
verdadera.

Mientras <condición> Hacer


<instrucciones>
FinMientras

11
Ejemplo 1

Realizar un pseudocódigo que sume los n


primeros números (1, 2, 3, 4, …., n).

12
Solución

13
CONTADORES

CONTADOR
Un contador es una variable que se incrementa
o disminuye en un valor constante. Un contador
tiene la siguiente forma:

contador  contador + valor constante

Algunos ejemplos:
jj+2
ii–1
carros  carros + 1
14
ACUMULADOR

ACUMULADOR
Un acumulador o totalizador es una variable cuya
misión es el almacenamiento de cantidades variables
de procesos sucesivos. La diferencia con el contador
radica en que el incremento o disminución del
acumulador es variable, la forma general de un
acumulador es la siguiente:

acumulador  acumulador + valor variable

Algunos ejemplos:
acum  acum + i
suma suma + algo
resta  resta + algo
15
Identifique al acumulador y contador

16
Actividad en aula

• Elabore un pseudocódigo para el siguiente


caso:
• Hallar total de n términos: 1+3+5+7+…..

17
Preguntas

18
Ejercicios

• Elabore un pseudocódigo para cada caso:


• Hallar total de n términos: 2+4+6+8+…..
• Ingresar un numero entero n y mostrar todos los
múltiplos de 3 hasta n.
• Mostrar al mayor de n enteros positivos.

19
Recapitulando …

Estructura Mientras ejecuta instrucciones


mientras la expresión lógica sea ……..
Si la expresión lógica siempre es verdadera
se producirá un ciclo …………..
Finalmente, se elaboró un pseudocódigo
empleando la estructura Mientras. Recordar a
la variable acumulador y al contador.

20