Anda di halaman 1dari 14

LAB 12 Switch Configuration.

Login: celadxxmin Pwd: enable xx= VNX#


Example: VNX8 login: celad08min Pwd: enable
Note: The login and password will be typed in sequentially2x to login properly
There are several steps you need to take to ensure that the student’s LACP configurations work
properly during lab 12. You need to make sure that the students configure their device speed and duplex
settings to Auto-negotiate. This must be done on the Celerra for each connected device.

LACP employs a feature called port channel groups. You need to set up the port channel groups
on the switch. Each LACP connection will have a port channel group. The port channel number in this
configuration will be two digits long and tell you which lab team and which data mover in that team the
channel group is for. An example would be channel group 21. The first digit will be the Data Mover
number (either 2 or 3), and the second digit will be the lab Team number. So for example, channel group
21 would be for data mover 2 on lab team 1. The commands used to set up the channel groups will also
set the protocol and mode. Your configuration will be protocol LACP and mode active.

Here is an example of the command creating channel group 21 LACP active mode:

interface GigabitEthernet1/0/1
channel-group 21 mode active
interface GigabitEthernet1/0/2
channel-group 21 mode active

These commands will create a channel group numbered 21 (data mover 2 team 1) and put it into LACP
active mode. The group is being created on two interfaces, gigabitethernet 1/0/1 and 1/0/2. Channel
groups are treated as interfaces as well and as such may need to be turned on after they’ve been created.
This command would turn on port channel 21.

interface Po21
no shut

To prepare the switch for lab 12 you must create 2 channel groups for each team. One group for each data
mover. Each group combines two switch ports.
Note: DO NOT use these commands to set up channel groups in the lab as the configuration will not
support the VLAN tagging lab.

During lab 12 you will be called upon to turn switch ports on and off. To turn a port off

telnet into the switch

To turn the interface off do the following commands

Enable
conf t
interface GigabitEthernet1/0/1
shut

To turn the interface back on do the following commands

interface GigabitEthernet1/0/1
no shut

The students will tell you when they need their interfaces turned on and off. Their switch ports are listed
on their team sheets in section F:

Once you are done with the lab, you will need to remove the channel groups and LACP configuration and
change the switch ports back to normal.

The command to remove the channel group would be;

no interface Po21

Doing this one command removes both the port channel interface, and the LACP configuration
commands associated with it.

Removing this configuration may cause the switch ports used by the LACP aggregated links to shut down
so you should also insure that the switch ports are turned back on after removing the port channel and
LACP configuration.

The following commands would ensure ports 1/0/1 and 2 were back on;

interface GigabitEthernet1/0/1
no shut
interface GigabitEthernet1/0/2
no shut

Full instructions and command sets are found on the next pages.
Instructor Preparation Steps to Complete LAB 12

1. Log in to the switch. Telnet to the IP address, use celadxxmin for the password. Type “en” to enter
privileged mode. Password: celadxxmin

2. Initiate the Set One Commands (These commands make sure all the switch ports being used for the
aggregated links are turned on).

3. Initiate the Set Two Commands (These commands insure all the applicable switch ports are set to
speed/duplex auto).

4. Initiate the Set Three Commands (These commands set up each of the port channel groups,
configures them for trunking, and puts them in LACP active mode).

5. Initiate the Set Four Commands (These commands make sure all the port channel group virtual
interfaces are turned on and configured for trunking).

Note
Always initiate command sets 1-4 in order before the lab.

Additional Info

You will need to be logged in and enabled on the switch. You then simply cut and paste the set of
commands to make the changes.

Once the changes are pasted in type return, then control Z.


SET ONE: This makes sure that all the switch ports used for LACP aggregated links are turned on

conf t
interface GigabitEthernet1/0/1
no shut
interface GigabitEthernet1/0/2
no shut
interface GigabitEthernet1/0/3
no shut
interface GigabitEthernet1/0/4
no shut
interface GigabitEthernet1/0/7
no shut
interface GigabitEthernet1/0/8
no shut
interface GigabitEthernet1/0/9
no shut
interface GigabitEthernet1/0/10
no shut
interface GigabitEthernet1/0/13
no shut
interface GigabitEthernet1/0/14
no shut
interface GigabitEthernet1/0/15
no shut
interface GigabitEthernet1/0/16
no shut
interface GigabitEthernet1/0/19
no shut
interface GigabitEthernet1/0/20
no shut
interface GigabitEthernet1/0/21
no shut
interface GigabitEthernet1/0/22
no shut
interface GigabitEthernet1/0/25
no shut
interface GigabitEthernet1/0/26
no shut
interface GigabitEthernet1/0/27
no shut
interface GigabitEthernet1/0/28
no shut
interface GigabitEthernet1/0/31
no shut
interface GigabitEthernet1/0/32
no shut
interface GigabitEthernet1/0/33
no shut
interface GigabitEthernet1/0/34
no shut
SET TWO
This sets the speed and duplex to auto for all switch ports connected to Data movers

interface GigabitEthernet1/0/1
speed auto
duplex auto
interface GigabitEthernet1/0/2
speed auto
duplex auto
interface GigabitEthernet1/0/3
speed auto
duplex auto
interface GigabitEthernet1/0/4
speed auto
duplex auto
interface GigabitEthernet1/0/7
speed auto
duplex auto
interface GigabitEthernet1/0/8
speed auto
duplex auto
interface GigabitEthernet1/0/9
speed auto
duplex auto
interface GigabitEthernet1/0/10
speed auto
duplex auto
interface GigabitEthernet1/0/13
speed auto
duplex auto
interface GigabitEthernet1/0/14
speed auto
duplex auto
interface GigabitEthernet1/0/15
speed auto
duplex auto
interface GigabitEthernet1/0/16
speed auto
duplex auto
interface GigabitEthernet1/0/19
speed auto
duplex auto
interface GigabitEthernet1/0/20
speed auto
duplex auto
interface GigabitEthernet1/0/21
speed auto
duplex auto
interface GigabitEthernet1/0/22
speed auto
duplex auto
interface GigabitEthernet1/0/25
speed auto
duplex auto
interface GigabitEthernet1/0/26
speed auto
duplex auto
interface GigabitEthernet1/0/27
speed auto
duplex auto
interface GigabitEthernet1/0/28
speed auto
duplex auto
interface GigabitEthernet1/0/31
speed auto
duplex auto
interface GigabitEthernet1/0/32
speed auto
duplex auto
interface GigabitEthernet1/0/33
speed auto
duplex auto
interface GigabitEthernet1/0/34
speed auto
duplex auto
SET THREE
This sets up each of the port channel groups and puts them in LACP active mode and configures them for
trunking

interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 21 mode active
interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 21 mode active
interface GigabitEthernet1/0/3
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 31 mode active
interface GigabitEthernet1/0/4
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 31 mode active
interface GigabitEthernet1/0/7
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 22 mode active
interface GigabitEthernet1/0/8
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 22 mode active
interface GigabitEthernet1/0/9
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 32 mode active
interface GigabitEthernet1/0/10
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 32 mode active
interface GigabitEthernet1/0/13
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 23 mode active
interface GigabitEthernet1/0/14
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 23 mode active
interface GigabitEthernet1/0/15
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 33 mode active
interface GigabitEthernet1/0/16
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 33 mode active
interface GigabitEthernet1/0/19
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 24 mode active
interface GigabitEthernet1/0/20
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 24 mode active
interface GigabitEthernet1/0/21
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 34 mode active
interface GigabitEthernet1/0/22
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 34 mode active
interface GigabitEthernet1/0/25
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 25 mode active
interface GigabitEthernet1/0/26
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 25 mode active
interface GigabitEthernet1/0/27
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 35 mode active
interface GigabitEthernet1/0/28
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 35 mode active
interface GigabitEthernet1/0/31
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 26 mode active
interface GigabitEthernet1/0/32
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 26 mode active
interface GigabitEthernet1/0/33
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 36 mode active
interface GigabitEthernet1/0/34
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 36 mode active
SET FOUR
This makes sure all the port channel groups virtual interfaces are turned on and configured for trunking

interface Po21
switchport trunk encapsulation dot1q
switchport mode trunk
no shut
interface Po31
switchport trunk encapsulation dot1q
switchport mode trunk
no shut
interface Po22
switchport trunk encapsulation dot1q
switchport mode trunk
no shut
interface Po32
switchport trunk encapsulation dot1q
switchport mode trunk
no shut
interface Po23
switchport trunk encapsulation dot1q
switchport mode trunk
no shut
interface Po33
switchport trunk encapsulation dot1q
switchport mode trunk
no shut
interface Po24
switchport trunk encapsulation dot1q
switchport mode trunk
no shut
interface Po34
switchport trunk encapsulation dot1q
switchport mode trunk
no shut
interface Po25
switchport trunk encapsulation dot1q
switchport mode trunk
no shut
interface Po35
switchport trunk encapsulation dot1q
switchport mode trunk
no shut
interface Po26
switchport trunk encapsulation dot1q
switchport mode trunk
no shut
interface Po36
switchport trunk encapsulation dot1q
switchport mode trunk
no shut
AFTER THE NETWORK LAB IS DONE.

Resetting the switch after the lab is somewhat easier than the setup was. There is only one set of
commands (the Reset) to cut and paste. It removes all of the port channel groups. It then enables (no
shuts) all the individual physical switch ports.

RESET

conf t
no interface Po21
no interface Po31
no interface Po22
no interface Po32
no interface Po23
no interface Po33
no interface Po24
no interface Po34
no interface Po25
no interface Po35
no interface Po26
no interface Po36
interface GigabitEthernet1/0/1
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/2
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/3
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/4
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/7
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/8
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/9
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/10
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/13
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/14
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/15
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/16
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/19
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/20
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/21
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/22
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/25
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/26
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/27
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/28
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/31
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/32
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/33
switchport mode access
no switchport trunk encapsulation dot1q
no shut
interface GigabitEthernet1/0/34
switchport mode access
no switchport trunk encapsulation dot1q
no shut
Here is the relevant Primus solution for the Network Features lab error condition you
may see when running the server_netstat command. The root cause of the problem is a
bug in VIA (VNX Installation Assistant) no resetting the CST lockbox after the CS
hostname change that happens on installation.
Simply running the /nas/sbin/cst_setup -reset command fixes the issue.

The following is a Primus(R) eServer solution:

ID: emc254235
Domain: EMC1
Solution Class: 3.X Compatibility

Fact Product: Celerra

Fact EMC SW: NAS Code 6.0

Fact Feature: RSA Common Security Toolkit (CST)

Symptom The server_netstat command does not output any values.

Symptom $ server_netstat server_2


server_snmpwalk : error msg : The system hostname key is missing
from the lockbox.
Proto Local Address Foreign
Address (state)
****************************************************************
**

Proto Local Address Foreign


Address
(state)
****************************************************************
***

Change - The Control Station hostname was changed or the Control Station was manually
configured rather than using the CSA after factory installation (where a hostname change is
made).

- In a dual control station setup, failover took place to the standby control station.

Cause NAS 6.0 uses a new feature call RSA Common Security Toolkit (CST) to handle
communications with external authentication servers that manage user accounts for access to the
Celerra Control Station. The RSA CST includes generic cryptography interfaces and
mechanisms (for example, lockbox) that assist in protecting application secrets such as
passwords and keys. When the Control Station hostname is changed, the RSA CST lockbox
encryption is invalidated.

Fix

Reset the lockbox encryption by setting the user to root (su root) and then running the
/nas/sbin/cst_setup -reset command. The server_netstat command should now work
correctly. Each time the hostname is changed thereafter, cst_setup -reset will need to be run
again.

In the case of the dual control station, /nas/sbin/cst_setup -reset should be run on the active
control station. After this, the issue should not be seen again, even on future failovers.

Anda mungkin juga menyukai