Anda di halaman 1dari 7

ESTRUCTURAS DE DECISIÓN

Los programas que hemos escrito hasta ahora han consistido en una serie de sentencias
que se ejecutan secuencialmente, una después de la otra (asignación, lectura y escritura).
Las estructuras de decisión o también llamadas de selección permiten que el algoritmo
tome decisiones y ejecute u omita algunos procesos dependiendo del cumplimiento de
una condición, permitiendo seleccionar la próxima sentencia a ejecutarse y en función del
resultado de la valuación, se bifurcará a un determinado punto para continuar la ejecución
del programa.

Condición
Expresión lógica o una variable lógica.

Resultado
Verdadero o falso.

Flujo de control
Habilidad de definir el orden en el cual las sentencias de un programa son
ejecutadas. Se pueden manejar tres tipos de decisiones: simple, doble y múltiple.

a. Decisión simple.
Se ejecuta una determinada acción, cuando se cumple una determinada condición.

Esta estructura evalúa la condición, luego:


Si la condición es cierta entonces ejecuta el conjunto de sentencias definidas por
Si.
Si la condición es falsa entonces no ejecuta el con junto de sentencias definidas
por Si.

Una decisión es simple (Si / if), cuando solo se t iene determinado los pasos a seguir si el
resultado de la condición es verdadero, mientras que si es falso, la ejecución del algoritmo
continúa después de la estructura condicional.

Diagrama de Flujo

Verdad Falso
?
Condición

Acciones

Docente: Jennifer Pillaca De La cruz Página 1


Pseudocódigo en Español

Si ˂ condición ˃ Entonces
˂ Acción S1 ˃
˂ Acción S2 ˃
.
.
.
˂ Acción Sn ˃
Fin_si

Código en Java
if (<condición >)
{
˂ Acción S1 ˃
˂ Acción S2 ˃
.
.
.
˂ Acción Sn ˃
}

Ejemplos

Pseudocódigo Código python


Realizar un algoritmo que lea un número por
teclado y escriba en pantalla positivo si es mayor
que cero.

1. Inicio
2. Leer numero
3. Si (numero > 0) Entonces If ( numero >0):
4. Escribir “ Número positivo”
print(“El número es positivo”)
5. Fin_Si.
6. Fin.
Realizar un algoritmo que lea dos número por
teclado (a y b). Si a es menor que b, entonces
imprima en pantalla la suma de los números.

1. Inicio
2. Leer a,b
3. Si (a <b) Entonces
4. Escribir (a+b) If ( a<b):
println(“La suma” , (a+b))

Docente: Jennifer Pillaca De La cruz Página 2


5. Fin_Si.
6. Fin
Otra forma

1. Inicio
2. Leer a,b
If ( a<b):
3. Si (a <b) Entonces
4. s=a+b
s=a+b
5. Escribir “La suma” s
print(“La suma es” ,s)
6. Fin_Si.
7. Fin

b. Decisión doble.
Permite elegir entre dos opciones o alternativas posibles, en función del cumplimiento
o no de la condición:
a. Si el resultado de evaluar la condición el CIERTO s e ejecutará un
determinado grupo de instrucciones 1i,
b. Si el resultado de evaluar la condición es FALSO se ejecutará otro grupo de
instrucciones 2k, para

Una decisión es doble (Si- Si_no / if - else), cuan do se tiene un curso de acción para el
caso que el resultado de la comparación sea verdade ro y otro para cuando sea falso.

Pseudocódigo en Español

Si ˂ condición ˃ Entonces
˂ Acción S1 ˃
Si_no
˂ Acción S2 ˃
Fin_si

Código en Java

if (condición ) :
˂ Acción S1 ˃
else :
˂ Acción S2 ˃

Docente: Jennifer Pillaca De La cruz Página 3


Diagrama de Flujo

Verdad Falso
?
Condición

Acción S1 Acción S2

Ejemplos
Pseudocódigo Código PYTHON
Realizar un algoritmo que lea la nota (n) de un
alumno y escriba en pantalla si está aprobado o
desaprobado.

7. Inicio
8. Leer n
9. Si (n > 10) Entonces if ( n >10) :
10. Escribir “ Aprobado”
11. Si_no print(“Aprobado”)
12. Escribir “ Desaprobado”
else :
13. Fin_Si.
14. Fin. print(“Desaprobado”)

c. Decisión múltiple (según_sea, caso de / case)


Muchas decisiones deben tomarse, no solo entre dos alternativas, sino de un conjunto
mayor. Estos casos bien pueden solucionarse utilizando condicionales dobles anidados;
sin embargo, en favor de la claridad del algoritmo y la facilidad para el programador, es
mejor utilizar una estructura de decisión múltiple, la cual es fácil de llevar a un lenguaje
de programación, ya que éstos incluyen alguna instrucción con este fin.

La decisión múltiple determina el valor de una variable y dependiendo de éste sigue un


curso de acción. Es importante tener en cuenta que solo se verifica la condición de
igualdad entre la variable y la constante.

Docente: Jennifer Pillaca De La cruz Página 4


Pseudocódigo en Español

Según_sea expresión (E) Hacer


E1: accion S11
accion S12
accion S13
.
.
.
E2: accion S21
accion S22
accion S23
.
.
.
En: accion Sn1
accion Sn2
accion Sn3
.
.
.
accion Snn
Si_no: accion Sx
Fin_segun

Diagrama de Flujo

E1 E2 E3 E4 En

Acción S1 Acción S2 Acción S3 Acción S4 … Acción Sn

Docente: Jennifer Pillaca De La cruz Página 5


Estructuras de decisión anidadas.

Las estructuras de decisión anidadas están contenidas unas dentro de otras.

Pseudocódigo en Español código en python

if (condición1):
Si (condición1) entonces sentencias1
sentencias1
Si no elif
(condición2):
sentencias2
Si (condición2) entonces
sentencias2 elif
Si no (condición3):
Si (condición3) entonces sentencias3
sentencias3
Fin_Si
Fin_Si

Fin_Si

1. Realizar un programa que imprima en pantalla el valor absoluto de un número. Crear


la clase Absoluto

numero=int(input("Ingrese un numero"))
if(numero<0):
numero=numero*-1
print("El valor absoluto del nùmero es ",numero)

2. Realizar un programa que identifique a un número como par o impar. Crear la clase
Numero.
numero=int(input("Ingrese un numero"))
if(numero%2==0):
print("Par")
else:
print("Impar")

3. Realizar un programa que defina si un número es positivo o negativo. Crear la clase


PositivoNegativo.

numero=int(input("Ingrese un numero"))
if(numero==0):
print("Neutro")
elif(numero<0):
print("negativo")
else:
print("positivo")

Ejercicios.

5. Realizar un programa que identifique el tipo de triángulo. (equilátero, Isósceles,


Escaleno)

6. Realizar un programa que defina si un número es par, impar, positivo o negativo.


7. Realizar un programa que dado tres números identifique el mayor y menor

8. Realizar un programa que dado dos números, realice la función de suma, reta,
multiplicación o división según el operador dado (+ , - , *, /).

Tarea

9. Realizar un programa que ingrese 5 datos de temperaturas, halle el promedio. El


programa debe determinar el tipo de clima según:

Temperatura promedio (tp) Tipo de clima


tp<=10° Frío
10<tp<=20º Nublado
20<tp<=30º Caluroso
tp>30 Tropical

11. Una obra de teatro realiza la venta de entradas según el tipo de persona (Estudiante
(s/. 50.00), Adulto (s/. 100.00)). Si al comprar la entrada lo hace al contado se le aplica
un descuento; pero si lo compra a plazos, se le realiza un recargo. Ver la siguente tabla.
Realizar un programa que imprima el monto real a pagar por la entrada.

Tipo Descuento al contado Recargo a plazos


Estudiante 15% 10%
Adulto 25% 35%

Docente: Jennifer Pillaca De La cruz Página 9