Anda di halaman 1dari 96

Carátula para entrega de prácticas

Facultad de Ingeniería Laboratorio de docencia

Laboratorios de computación
salas A y B
Profesor: Saavedra Hernández Honorato
Asignatura: Fundamentos de Programación

Grupo: 2

No de Práctica(s): Práctica 10

Integrante: Avalos Razo Oscar André

Semestre: 2018-2

Fecha de entrega: 30 de abril de 2018


Observaciones:

 
CALIFICACIÓN: __________
Ejercicio 1
-Realizar el programa más pequeño posible.
Diagrama de Flujo

Pseudocódigo
INICIO

FIN

Código en C
#include <stdio.h>

int main()
{
return 0;
}
Ejercicio 2
Imprimir “hola mundo”
Diagrama de Flujo

Pseudocódigo
INICIO
ESCRIBIR “Hola Mundo”
FIN

Código en C
#include <stdio.h>

int main()
{
return 0;
}
Ejercicio 3
Pedir un número al usuario e imprimirlo
Diagrama de Flujo

Pseudocódigo
INICIO
a : REAL
ESCRIBIR “Introduzca un numero”
LEER a
ESCRIBIR “El numero introducido fue “, a
FIN

Código en C
#include <stdio.h>
int main()
{
float a;
printf("Introduzca un numero:\n");
scanf("%f",&a);
printf("El numero introducido fue %f",a);
return 0;
}
Ejercicio 4
Pedir un número al usuario, sumarle 1 e imprimirlo
Diagrama de Flujo

Pseudocódigo
INICIO
a : REAL
ESCRIBIR “Introduzca un numero”
LEER a
ESCRIBIR “El resultado es”, a+1
FIN

Código en C
#include <stdio.h>
int main()
{
float a;
printf("Introduzca un numero:\n");
scanf("%f",&a);
printf("El resultado es %f",a);
return 0;
}
Ejercicio 5
Pedir un número al usuario, multiplicarlo por 2 e imprimirlo
Diagrama de Flujo

Pseudocódigo
INICIO
a : REAL
ESCRIBIR “INTRODUZCA UN NUMERO”
LEER a
ESCRIBIR “El resultado es”, a*2
FIN

Código en C
#include <stdio.h>
int main()
{
float a;
printf("Introduzca un numero:\n");
scanf("%f",&a);
printf("El resultado es %f",a*2);
return 0;
}
Ejercicio 6
Pedir un número al usuario, elevarlo al cubo e imprimirlo.
Diagrama de Flujo

Pseudocódigo
INICIO
a : REAL
ESCRIBIR "Introduzca un numero"
LEER a
ESCRIBIR "El resultado es " , a*a*a
FIN

Código en C
#include <stdio.h>
int main()
{
float a;
printf("Introduzca un numero:\n");
scanf("%f",&a);
printf("El resultado es %f",a*a*a);
return 0;
}
Ejercicio 7
Pedir un número al usuario, indicar si es positivo.
Diagrama de Flujo

Pseudocódigo
INICIO
a<- ENTERO
ESCRIBIR "Introduzca un numero"
LEER a
SI a>0
ESCRIBIR "El numero introducido es positivo"
FINSI
FIN

Código en C
#include <stdio.h>
int main()
{
int a;
printf("Introduzca un numero:\n");
scanf("%d",&a);
if(a%2==0)
{
printf("El numero introducido es par");
}
return 0;
}
Ejercicio 8
Pedir un número al usuario, indicar si es par.
Diagrama de Flujo

Pseudocódigo
INICIO
a : ENTERO
ESCRIBIR "Introduzca un numero"
LEER a
SI (a MOD 2=0) ENTONCES
ESCRIBIR "El numero introducido es par"
FIN SI
FIN

Código en C
#include <stdio.h>
int main()
{
int a;
printf("Introduzca un numero:\n");
scanf("%d",&a);
if(a%2==0)
{
printf("El numero introducido es par");
}
return 0;
}
Ejercicio 9
Pedir dos números al usuario, imprimir el mayor
Diagrama de Flujo

Pseudocódigo
INICIO
a : REAL
b : REAL
ESCRIBIR "Introduzca dos numeros sePARAdos por un espacio"
LEER a,b
Si (a>b) ENTONCES
ESCRIBIR "El numero mayor es ",a
DE LO CONTRARIO
ESCRIBIR "El numero mayor es ",b
FIN SI
FIN

Código en C
#include <stdio.h>
int main()
{
float a,b;
printf("Introduzca dos numeros sePARAdos por un espacio \n");
scanf("%f %f",&a,&b);
if(a>b)
{
printf("El numero mayor es %f",a);
}
else
{
printf("El numero mayor es %f",b);
}
return 0;
}
Ejercicio 10
Pedir tres números al usuario, imprimir el menor
Diagrama de Flujo

Pseudocódigo
INICIO
a : REAL
b : REAL
c : REAL
ESCRIBIR "Introduzca tres numeros "
LEER a,b,c
Si (a<b) ENTONCES
SI (a<c)
ESCRIBIR "El numero menor es ", a
DE LO CONTRARIO
ESCRIBIR "El numero menor es ",c
FIN SI

DE LO CONTRARIO
SI (b<c)
ESCRIBIR "El numero menor es ",b
DE LO CONTRARIO
ESCRIBIR "El numero menor es ",c
FIN SI
FIN SI
FIN

Código en C
#include <stdio.h>
int main()
{
float a,b,c;
printf("Introduzca tres numeros \n");
scanf("%f %f %f",&a,&b,&c);
if(a<b)
{
if(a<c)
{
printf ("El numero menor es %f",a);
}
else
{
printf ("El numero menor es %f",c);
}
}
else
{
if(b<c)
{
printf ("El numero menor es %f",b);
}
else
{
printf ("El numero menor es %f",c);
}
}
return 0;
}
Ejercicio 11
Pedir un número al usuario y calcular el valor absoluto.
Diagrama de Flujo /

Pseudocódigo
INICIO
a : ENTERO
ESCRIBIR "Introduzca un numero"
LEER a
SI a<0 ENTONCES
a : -1*a
FINSI
ESCRIBIR “El valor absoluto es “,a
FIN

Código en C /
#include <stdio.h>
int main()
{
int a;
printf("Introduzca un numero:\n");
scanf("%d",&a);
if(a<0)
{
a = -1*a;
}
printf("El El valor absoluto es %d",a);
return 0;
}
Ejercicio 12
Imprimir “hola mundo” 100 veces
Diagrama de Flujo

Pseudocódigo
INICIO
i : ENTERO
i:0
Mientras i<100 HACER
i : i+1
ESCRIBIR i,".- Hola Mundo"
FinMientras
FIN

Código en C
#include <stdio.h>
int main()
{
int i;
i=0;
while (i<100)
{
i++;
printf("%d.- Hola mundo\n",i);
}
return 0;
}
Ejercicio 13
Pedir un número n al usuario, imprimirlo n veces.
Diagrama de Flujo

Pseudocódigo
INICIO
i : ENTERO
a : ENTERO
i:0
ESCRIBIR "Introduzca un numero: "
LEER a
Mientras i<a HACER
i : i+1
ESCRIBIR i,".- ",a
FinMientras
FIN

Código en C
#include <stdio.h>
int main()
{
int a,i;
i=0;
printf("Introduzca un numero: \n");
scanf("%d",&a);
while (i<a)
{
i++;
printf("%d.- %d\n",i,a);
}
return 0;
}
Ejercicio 14
Pedir un número al usuario hasta que adivine uno que hallamos elegido
Diagrama de Flujo

Pseudocódigo
INICIO
n : ENTERO
m : ENTERO
n:7
Repetir
ESCRIBIR "Trata de adivinar el numero que escogi:"
LEER m
HASTA Que m=n
ESCRIBIR “Felicidades, ganaste”
FIN

Código en C
#include <stdio.h>
int main()
{
int n,m;
n=7;
do
{
printf("Trata de adivinar el numero que escogi \n");
scanf("%d",&m);
} while (n!=m);
printf("Felicidades, ganaste");
return 0;
}
Ejercicio 15
Pedir un número al usuario, obtener su factorial.
Diagrama de Flujo

Pseudocódigo
INICIO
n : ENTERO
m : ENTERO
i : ENTERO
m:1
i:1
ESCRIBIR "Ingrese el numero del cual se obtendra su factorial:"
LEER n
MIENTRAS i<n
i:i+1
m:m*i
FIN MIENTRAS
ESCRIBIR "El factorial de ", n, " es ", m
FIN
Código en C

#include <stdio.h>
int main()
{
int n,m,i;
m=1;
i=1;
printf("Ingrese el numero del cual se obtendra su factorial: \n");
scanf("%d",&n);
while(i<n)
{
i++;
m=m*i;
}
printf("El factorial de %d es %d",n,m);
return 0;
}
Ejercicio 16
Pedir el radio de un círculo al usuario, obtener al área
Diagrama de Flujo

Pseudocódigo
INICIO
r : REAL
ESCRIBIR "Ingrese el radio del circulo PARA calcular el area:"
LEER r
ESCRIBIR "El area del circulo es ",r*r*3.1416, " u^2 "
FIN

Código en C
#include <stdio.h>
int main()
{
float r;

printf("Ingrese el radio del circulo PARA calcular el area: \n");


scanf("%f",&r);
printf("El area del circulo es %f u^2",r*r*3.1416);
return 0;
}
Ejercicio 17
Pedir el radio de un círculo al usuario, obtener la circunferencia
Diagrama de Flujo

Pseudocódigo
INICIO
r : REAL
ESCRIBIR "Ingrese el radio del circulo PARA calcular el perimetro:"
LEER r
ESCRIBIR "El perimetro del circulo es ",r*2*3.1416, " u "
FIN

Código en C
#include <stdio.h>
int main()
{
float r;
printf("Ingrese el radio del circulo PARA calcular el perimetro: \n");
scanf("%f",&r);
printf("El perimetro del circulo es %f u",r*2*3.1416);
return 0;
}
Ejercicio 18
Pedir el lado de un cuadrado al usuario, obtener al área
Diagrama de Flujo

Pseudocódigo
INICIO
l : REAL
ESCRIBIR "Ingrese el lado del cuadrado PARA calcular su area:"
LEER l
ESCRIBIR "El area del cuadrado es ",l*l, " u^2 "
FIN

Código en C
#include <stdio.h>
int main()
{
float l;
printf("Ingrese el lado del cuadrado PARA calcular su area: \n");
scanf("%f",&l);
printf("El area del cuadrado es %f u^2",l*l);
return 0;
}
Ejercicio 19
Pedir la base y la altura de un triángulo, obtener el área
Diagrama de Flujo

Pseudocódigo
INICIO
b : REAL
h : REAL
ESCRIBIR "Ingrese la base del triangulo PARA calcular su area:"
LEER b
ESCRIBIR "Ingrese la altura del triangulo PARA calcular su area:"
LEER h
ESCRIBIR "El area del triangulo es ",b*h/2, " u^2 "
FIN

Código en C
#include <stdio.h>
int main()
{
float b,h;
printf("Ingrese la base del triangulo PARA calcular su area: \n");
scanf("%f",&b);
printf("Ingrese la altura del triangulo PARA calcular su area: \n");
scanf("%f",&h);
printf("El area del triangulo es %f u^2",b*h/2);
return 0;
}
Ejercicio 20
Pedir los catetos de un triángulo rectángulo, obtener la hipotenusa
Diagrama de Flujo

Pseudocódigo
INICIO
c1 : REAL
c2 : REAL
ESCRIBIR "Ingrese un cateto del triangulo rectangulo:"
LEER c1
ESCRIBIR "Ingrese un cateto del triangulo rectangulo:"
LEER c2
ESCRIBIR "La hipotenusa del triangulo rectangulo es
",(c1*c1+c2*c2)^(1/2)
FIN

Código en C
#include <stdio.h>
#include <math.h>
int main()
{
float c1,c2;
printf("Ingrese un cateto del triangulo rectangulo: \n");
scanf("%f",&c1);
printf("Ingrese el cateto restante del triangulo rectangulo: \n");
scanf("%f",&c2);
printf("La hipotenusa del triangulo rectangulo es %f ",sqrt(c1*c1+c2*c2));
return 0;
}
Ejercicio 21
Imprimir los números impares entre 1 y 100
Diagrama de Flujo

Pseudocódigo
INICIO
PARA i:1 HASTA 100 CON PASO 1 HACER
SI i%2!=0
ESCRIBIR i
FIN SI
FIN PARA
FIN

Código en C
#include <stdio.h>
int main()
{
for(int i=1;i<=100;i++)
{
if (i%2!=0)
{
printf("%d ",i);
}
}
return 0;
}
Ejercicio 22
Pedir al usuario y calcular el promedio de 5 números
Diagrama de Flujo

Pseudocódigo
INICIO
aux : REAL
s : REAL
s:0
ESCRIBIR "Introduzca 5 numeros sePARAdos por un espacio"
PARA i:0 HASTA 4 HACER
LEER aux
s : s+aux
FIN PARA
ESCRIBIR “El promedio de los numeros dados es ”s/5
FIN

Código en C
#include <stdio.h>
int main()
{
float aux, s=0;
printf ("Introduzca 5 numeros sePARAdos por un espacio\n");
for(int i=0;i<5;i++)
{
scanf ("%f",&aux);
s=s+aux;
}
printf("El promedio de los numeros es %f",s/5);
return 0;
}
Ejercicio 23
Calcular el promedio final de 10, 8, 9 con los siguientes porcentajes 30%, 50%,
20%
Diagrama de Flujo

Pseudocódigo
INICIO
ESCRIBIR "El promedio final de 10, 8, 9 con los siguientes porcentajes
30%, 50%, 20% es ", 10*.3+8*.5+9*.2
FIN

Código en C
#include <stdio.h>
int main()
{
printf("El promedio final de 10, 8, 9 con los siguientes porcentajes 30%, 50%,
20% es %f",10*.3+8*.5+9*.2);

return 0;
}
Ejercicio 24
Calcular el sueldo de un empleado que trabajó 50 Hrs. a 15 pesos la hora.
Diagrama de Flujo

Pseudocódigo
INICIO
ESCRIBIR "El sueldo de un empleado que trabajó 50 Hrs. a 15 pesos la
hora es ", 50*15, " pesos mexicanos"
FIN

Código en C
#include <stdio.h>
int main()
{
printf("El sueldo de un empleado que trabajó 50 Hrs. a 15 pesos la hora es %i
pesos mexicanos",50*15);
return 0;
}
Ejercicio 25
Imprimir la tabla del 7
Diagrama de Flujo

Pseudocódigo
INICIO
PARA i:1 HASTA 10 HACER
ESCRIBIR i,"x7=",i*7
FIN PARA
FIN

Código en C
#include <stdio.h>
int main()
{
for (int i=1;i<=10;i++)
printf ("%dx7=%d\n",i,i*7);
return 0;
}
Ejercicio 26
Pedir al usuario un número e indicar si es múltiplo de 3
Diagrama de Flujo

Pseudocódigo
INICIO
a: ENTERO
ESCRIBIR "Introduzca un numero PARA determinar si es multiplo de tres"
LEER a
SI (aMOD3=0)
ESCRIBIR a," es multiplo de tres"
DE LO CONTRARIO
ESCRIBIR a," no es multiplo de tres"
FIN SI
FIN

Código en C
#include <stdio.h>
int main()
{
int a;
scanf("%d",&a);
if(a%3==0)
{
printf("%d es multiplo de tres",a);
}
else
{
printf("%d no es multiplo de tres",a );
}
return 0;
}
Ejercicio 27
Pedir al usuario un mes y un día,
indicar su signo zodiacal.
Diagrama de Flujo
Pseudocódigo
INICIO
mes : ENTERO
dia : ENTERO
ESCRIBIR "Introduzca el mes de nacimiento PARA indicar el signo
zodiacal"
ESCRIBIR "1) Enero"
ESCRIBIR "2) Febrero"
ESCRIBIR "3) Marzo"
ESCRIBIR "4) Abril"
ESCRIBIR "5) Mayo"
ESCRIBIR "6) Junio"
ESCRIBIR "7) Julio"
ESCRIBIR "8) Agosto"
ESCRIBIR "9) Septiembre"
ESCRIBIR "10) Octubre"
ESCRIBIR "11) Noviembre"
ESCRIBIR "12) Diciembre"
LEER mes
ESCRIBIR "Introduzca el dia de nacimiento PARA indicar el signo zodiacal"
LEER dia
Segun mes HACER
1:
Si (dia<=19) ENTONCES
ESCRIBIR "Capricornio"
DE LO CONTRARIO
ESCRIBIR "Acuario"
FIN SI
2:
Si (dia<=18) ENTONCES
ESCRIBIR "Acuario"
DE LO CONTRARIO
ESCRIBIR "Piscis"
FIN SI
3:
Si (dia<=20) ENTONCES
ESCRIBIR "Piscis"
DE LO CONTRARIO
ESCRIBIR "Aries"
FIN SI
4:
Si (dia<=19) ENTONCES
ESCRIBIR "Aries"
DE LO CONTRARIO
ESCRIBIR "Tauro"
FIN SI
5:
Si (dia<=20) ENTONCES
ESCRIBIR "Tauro"
DE LO CONTRARIO
ESCRIBIR "Geminis"
FIN SI
6:
Si (dia<=20) ENTONCES
ESCRIBIR "Geminis"
DE LO CONTRARIO
ESCRIBIR "Cancer"
FIN SI
7:
Si (dia<=22) ENTONCES
ESCRIBIR "Cancer"
DE LO CONTRARIO
ESCRIBIR "Leo"
FIN SI
8:
Si (dia<=22) ENTONCES
ESCRIBIR "Leo"
DE LO CONTRARIO
ESCRIBIR "Virgo"
FIN SI
9:
Si (dia<=22) ENTONCES
ESCRIBIR "Virgo"
DE LO CONTRARIO
ESCRIBIR "Libra"
FIN SI
10:
Si (dia<=22) ENTONCES
ESCRIBIR "Libra"
DE LO CONTRARIO
ESCRIBIR "Escorpio"
FIN SI
11:
Si (dia<=22) ENTONCES
ESCRIBIR "Escorpio"
DE LO CONTRARIO
ESCRIBIR "Sagitario"
FIN SI
12:
Si (dia<=21) ENTONCES
ESCRIBIR "Sagitario"
DE LO CONTRARIO
ESCRIBIR "Capricornio"
FIN SI
De Otro Modo:
ESCRIBIR "Datos no validos"
FinSegun
FIN

Código en C
#include <stdio.h>
int main ()
{
int dia, mes;
printf ("Introduzca el mes de nacimiento para indicar el signo zodiacal");
printf ("1) Enero\n");
printf ("2) Febrero\n");
printf ("3) Marzo\n");
printf ("4) Abril\n");
printf ("5) Mayo\n");
printf ("6) Junio\n");
printf ("7) Julio\n");
printf ("8) Agosto\n");
printf ("9) Septiembre\n");
printf ("10) Octubre\n");
printf ("11) Noviembre\n");
printf ("12) Diciembre\n");
scanf("%d",&mes);
printf ("Introduzca el dia de nacimiento para indicar el signo zodiacal\n");
scanf("%d",&dia);
switch (mes)
{
case 1:
if (dia<=19)
{
printf("Capricornio");
}
else
{
printf("Acuario");
}
break;
case 2:
if (dia<=18)
{
printf("Acuario");
}
else
{
printf("Piscis");
}
break;
case 3:
if (dia<=20)
{
printf("Piscis");
}
else
{
printf("Aries");
}
break;
case 4:
if (dia<=19)
{
printf("Aries");
}
else
{
printf("Tauro");
}
break;
case 5:
if (dia<=20)
{
printf("Tauro");
}
else
{
printf("Geminis");
}
break;
case 6:
if (dia<=20)
{
printf("Geminis");
}
else
{
printf("Cancer");
}
break;
case 7:
if (dia<=22)
{
printf("Cancer");
}
else
{
printf("Leo");
}
break;
case 8:
if (dia<=22)
{
printf("Leo");
}
else
{
printf("Virgo");
}
break;
case 9:
if (dia<=22)
{
printf("Virgo");
}
else
{
printf("Libra");
}
break;
case 10:
if (dia<=22)
{
printf("Libra");
}
else
{
printf("Escorpio");
}
break;
case 11:
if (dia<=22)
{
printf("Escorpio");
}
else
{
printf("Sagitario");
}
break;
case 12:
if (dia<=21)
{
printf("Sagitario");
}
else
{
printf("Capricornio");
}
break;
default:
printf("Datos no validos");

}
return 0;
}
Ejercicio 28
Dibujar un menú con cuatro opciones para dibujar figuras y una más para terminar
el programa. Si se selecciona una opción de dibujo se muestra el dibujo y después
se regresa al menú
Diagrama de Flujo

Pseudocódigo
INICIO
aux: ENTERO
REPETIR
ESCRIBIR "Ingrese la opcion correspondiente a la figura que se
desee dibujar"
ESCRIBIR "1) Cuadrado"
ESCRIBIR "2) Rectangulo"
ESCRIBIR "3) Triangulo"
ESCRIBIR "4) Circulo"
ESCRIBIR "5) Terminar"
LEER aux;
SEGUN aux HACER
1:
ESCRIBIR "------"
ESCRIBIR "- -"
ESCRIBIR "- -"
ESCRIBIR "------"
2:
ESCRIBIR "----------"
ESCRIBIR "- -"
ESCRIBIR "- -"
ESCRIBIR "----------"
3:
ESCRIBIR " /|"
ESCRIBIR " / |"
ESCRIBIR " / |"
ESCRIBIR "/___|"
4:
ESCRIBIR " .."
ESCRIBIR " . ."
ESCRIBIR ". ."
ESCRIBIR " . ."
ESCRIBIR " .."
DE OTRO MODO:
ESCRIBIR "Opcion no valida"
FinSegun
HASTA Que aux=5
FIN

Código en C
#include <stdio.h>
int main()
{
int aux;
do
{
printf("Ingrese la opcion correspondiente a la figura que se desee dibujar\n");
printf("1) Cuadrado\n");
printf("2) Rectangulo\n");
printf("3) Triangulo\n");
printf("4) Circulo\n");
printf("5) Terminar\n");
scanf("%d",&aux);
switch (aux)
{
case 1:
printf("------\n");
printf("- -\n");
printf("- -\n");
printf("------\n");
break;
case 2:
printf("----------\n");
printf("- -\n");
printf("- -\n");
printf("----------\n");
break;
case 3:
printf(" /| \n");
printf(" / | \n");
printf(" / | \n");
printf("/___| \n ");
break;
case 4:
printf(" ..\n");
printf(" . .\n");
printf(". .\n");
printf(" . .\n");
printf(" ..\n");
break;
default:
printf("Opcion no valida");
}

} while (aux!=5);
return 0;
}
Ejercicio 29
Pedir al usuario dos números, una operación binaria y realizar la operación con
esos dos números.
Diagrama de Flujo

Pseudocódigo
INICIO
aux : ENTERO
ESCRIBIR "Ingrese la opcion correspondiente a la operacion binaria a
REALizar"
ESCRIBIR "1) Suma"
ESCRIBIR "2) Resta"
ESCRIBIR "3) Triangulo"
ESCRIBIR "4) Division"
LEER aux
ESCRIBIR "Ingrese dos numeros PARA REALizar la operacion
seleccionada"
LEER a,b
Segun aux HACER
1:
ESCRIBIR a,"+",b,"=",a+b
2:
ESCRIBIR a,"-",b,"=",a-b
3:
ESCRIBIR a,"*",b,"=",a*b
4:
Si b!=0 ENTONCES
ESCRIBIR a,"/",b,"=",a/b
DE LO CONTRARIO
ESCRIBIR "La operacion no esta definida"
FIN SI
FinSegun
FIN

Código en C
#include <stdio.h>
int main()
{
float a,b;
int aux;
printf("Ingrese la opcion correspondiente a la operacion binaria a
REALizar\n");
printf("1) Suma\n");
printf("2) Resta\n");
printf("3) Multiplicacion\n");
printf("4) Division\n");
scanf("%d",&aux);
printf("Ingrese dos numeros PARA REALizar la operacion seleccionada\n");
scanf("%f %f",&a,&b);
switch (aux)
{
case 1:
printf("%f+%f=%f",a,b,a+b);
break;
case 2:
printf("%f-%f=%f",a,b,a-b);
break;
case 3:
printf("%f*%f=%f",a,b,a*b);
break;
case 4:
if(b!=0)
printf("%f-%f=%f",a,b,a/b);
else
printf("La operacion no esta definida");
break;
default:
printf("Opcion no valida");
}
return 0;
}
Ejercicio 30
Pedir al usuario un número y escribir la tabla de multiplicar de ese número
Diagrama de Flujo

Pseudocódigo
INICIO
n: ENTERO
ESCRIBIR "Introduzca un numero PARA ESCRIBIR su tabla de multiplicar"
LEER n
ESCRIBIR "Tabla del ",n
PARA i:1 HASTA 10 CON PASO 1 HACER
ESCRIBIR i,"x",n,"=",i*n
FIN PARA
FIN

Código en C
#include <stdio.h>
int main()
{
int n;
printf("Introduzca un numero PARA ESCRIBIR su tabla de multiplicar:\n");
scanf("%d",&n);
printf("Tabla del %d\n",n);
for (int i=1;i<=10;i++)
{
printf("%dx%d=%d\n",i,n,i*n);
}
return 0;
}
Ejercicio 31
Encontrar la media,
mediana y moda de 10
números
Diagrama de Flujo  
Pseudocódigo
INICIO
n[10] : REAL
media : REAL
aux : REAL
v[10] : ENTERO
c : ENTERO
max : ENTERO
c:0
max : 0
media : 0
aux : 0
ESCRIBIR "Introduzca 10 numeros PARA calcular la media, mediana y la
moda"
PARA i:0 HASTA 9 HACER
LEER n[i]
media : n[i]+media
FIN PARA
media : media/10
PARA i:0 HASTA 10 HACER
PARA j:0 HASTA 10-i HACER
Si n[j+1]<n[j] ENTONCES
aux : n[j]
n[j] : n[j+1]
n[j+1]:aux
FIN SI
FIN PARA
FIN PARA
PARA i:0 HASTA 10 HACER
PARA j:0 HASTA 10-i HACER
Si n[j]=n[i] ENTONCES
c : c+1
FIN SI
FIN PARA
v[i] : c
Si (c>max) ENTONCES
max : c
FIN SI
c:0
FIN PARA
ESCRIBIR 'Media = ',media
PARA i:0 HASTA 10 HACER
Si v[i]=max ENTONCES
c : c+1
ESCRIBIR 'Moda',c,' = ',n[i],'con ',v[i],'repeticiones'
FIN SI
i : i+v[i]
FIN PARA
ESCRIBIR 'Mediana = ',(n[4]+n[5])/2
FIN

Código en C
#include <stdio.h>
int main()
{
float n[10], media, aux;
int v[10];
int c=0, max=0;
media=0;
aux=0;
printf("Introduzca 10 numeros PARA calcular la media, mediana y la moda:\n");
for (int i=0;i<10;i++)
{
scanf("%f",&n[i]);
media= media+n[i];
}
media= media/10;
for (int i=0;i<10;i++)
{
for (int j=0;j<10-i;j++)
{
if(n[j+1]<n[j])
{
aux=n[j];
n[j]=n[j+1];
n[j+1]=aux;
}
}
}
for (int i=0;i<10;i++)
{
for (int j=0;j<10;j++)
{
if(n[j]==n[i])
{
c++;
}
}
v[i]=c;
if (c>max)
{
max=c;
}
c=0;
}
printf("Media = %f \n",media);
for (int i=0;i<10;i++)
{
if(v[i]==max)
{
c++;
printf("Moda%d = %f con %d repeticiones \n",c,n[i],v [i]);

}
i=i+v[i];
}
printf("Mediana = %f \n",(n[4]+n[5])/2);
return 0;
}
Ejercicio 32
Imprimir los valores de y=3*x*x + 2*x de 0 a 1 cada 0.01 unidades
Diagrama de Flujo

Pseudocódigo
INICIO
PARA i:0 HASTA 1.01 CON PASO 0.01 HACER
ESCRIBIR i,".- ",3*i*i+2*i
FIN PARA
FIN

Código en C
#include <stdio.h>
int main ()
{
for (float i=0;i<=1;i=i+0.01)
{
printf("%f.- %f\n",i,3*i*i+2*i);
}
return 0;
}
Ejercicio 33
Capturar votos con tres opciones, indicar el
porcentaje de votos de cada opción. Se debe
mostrar un menú para saber las opciones.
Finaliza cuando se elige la opción “terminar”
Pseudocódigo
INICIO
a : REAL
b : REAL
c : REAL
n : REAL
aux : ENTERO
a:0
b:0
c:0
n:0
Repetir
ESCRIBIR "Ejerza su voto"
ESCRIBIR "1) Opcion 1"
ESCRIBIR "2) Opcion 2"
ESCRIBIR "3) Opcion 3"
ESCRIBIR "4) Terminar recuento"
LEER aux
Segun aux HACER
1:
a : a+1
2:
b : b+1
3:
c : c+1
FinSegun
Si aux!=4 ENTONCES
n : n+1
FIN SI
HASTA Que aux=4
ESCRIBIR "Porcentaje de votos:"
ESCRIBIR " a =",(a/n)*100
ESCRIBIR " b =",(b/n)*100
ESCRIBIR " c =",(c/n)*100
FIN

Código en C
#include <stdio.h>
int main ()
{
float a=0,b=0,c=0,n=0;
int aux;
do
{
printf("Ejerza su voto:\n");
printf("1) Opcion 1\n");
printf("2) Opcion 2\n");
printf("3) Opcion 3\n");
printf("4) Terminar recuento\n\n\n");
scanf("%d",&aux);
switch (aux)
{
case 1:
a++;
break;
case 2:
b++;
break;
case 3:
c++;
break;
}
if(aux!=4)
n++;
} while (aux!=4);
printf("Porcentaje de votos:\n");
printf(" a = %f \n",(a/n)*100);
printf(" b = %f \n",(b/n)*100);
printf(" c = %f \n",(c/n)*100);
return 0;
}
Ejercicio 34
Genere un número aleatorio
Diagrama de Flujo

Pseudocódigo
INICIO
x: ENTERO
x: AZAR(10)+1
ESCRIBIR x
FIN

Código en C
#include <stdio.h>
int main ()
{
int x;
srand(time(NULL));
x= rand()%11;
printf("El numero aleatorio es %d",x);
return 0;
}
Ejercicio 35
Pedir dos números al usuario, el primero es el monto a pagar, el segundo es el
monto entregado por el usuario. Imprimir el subtotal, el iva, el total y el cambio a
entregar.
Diagrama de Flujo

Pseudocódigo
INICIO
m : ENTERO
n : ENTERO
ESCRIBIR "Ingrese el monto a pagar:"
LEER m
ESCRIBIR "Ingrese el monto entregado por el usuario:"
LEER n
ESCRIBIR "Subtotal:",m/1.16
ESCRIBIR "IVA:",m-m/1.16
ESCRIBIR "Total:",m
ESCRIBIR "Cambio:",n-m
FIN
Código en C
#include <stdio.h>
int main ()
{
float n,m;
printf("Ingrese el monto a pagar: \n");
scanf("%f",&m);
printf("Ingrese el monto entregado por el usuario: \n");
scanf ("%f",&n);
printf("Subtotal: %f\n",m/1.16);
printf("IVA: %f\n",m-m/1.16);
printf("Total: %f\n",m);
printf("Cambio: %f\n",n-m);
return 0;
}
Ejercicio 36
Pedir los coeficientes de una ecuación de segundo grado y obtener las raíces. Si
son imaginarias indicar un error.
Diagrama de Flujo

Pseudocódigo
INICIO
a : REAL
b : REAL
c : REAL
d : REAL
ESCRIBIR "Ingrese los coeficientes de la ecuacion de segundo grado
ax^2+bx+c:"
ESCRIBIR "a = "
LEER a
ESCRIBIR "b = "
LEER b
ESCRIBIR "c = "
LEER c
d : b*b-4*a*c
Si d<0 ENTONCES
ESCRIBIR "ERROR-Raices imaginarias"
DE LO CONTRARIO
ESCRIBIR "x1 = ",(-b+raiz(d))/(2*a)
ESCRIBIR "x2 = ",(-b-raiz(d))/(2*a)
FIN SI
FIN

Código en C
#include <stdio.h>
#include <math.h>
int main ()
{
float a,b,c,d;
printf("Ingrese los coeficientes de la ecuacion de segundo grado ax^2+bx+c:
\n");
printf("a = " );
scanf("%f",&a);
printf("b = " );
scanf("%f",&b);
printf("c = " );
scanf("%f",&c);
d=b*b-4*a*c;
if (d<0)
{
printf ("ERROR-Raices imaginarias");
}
else
{
printf("x1 = %f\n", (-b+sqrt(d))/(2*a));
printf("x2 = %f\n", (-b-sqrt(d))/(2*a));
}
return 0;
}
Ejercicio 37
Llene un arreglo de 100 elementos con valores aleatorios
Diagrama de Flujo

Pseudocódigo
INICIO
arr[101] : ENTERO
PARA i:1 HASTA 100 CON PASO 1 HACER
arr[i]: AZAR(100)
FIN PARA
FIN

Código en C
#include <stdio.h>
int main()
{
srand(time(NULL));
int arr[101];
for (int i=0;i<100;i++)
{
arr[i]= rand()%101;
}
return 0;
}
Ejercicio 38
Imprima los valores de este arreglo
Diagrama de Flujo

Pseudocódigo
INICIO
arr[101] : ENTERO
PARA i:1 HASTA 100 CON PASO 1 HACER
arr[i] : AZAR(100)
FIN PARA
PARA i:1 HASTA 100 CON PASO 1 HACER
ESCRIBIR i,".-",arr[i]
FIN PARA
FIN

Código en C
#include <stdio.h>
int main()
{
srand(time(NULL));
int arr[101];
for (int i=0;i<100;i++)
{
arr[i]= rand()%101;
}
for (int i=0;i<100;i++)
{
printf("%d .- %d\n",i,arr[i]);
}
return 0;
}
Ejercicio 39
Calcule el promedio de estos 100 elementos
Diagrama de Flujo

Pseudocódigo
INICIO
arr[101] : ENTERO
aux : REAL
aux : 0
PARA i:1 HASTA 100 CON PASO 1 HACER
arr[i] : AZAR(100)
aux : aux+arr[i]
FIN PARA
ESCRIBIR "El promedio de los valores aleatorios generados es: ", aux/100
FIN

Código en C
#include <stdio.h>
int main()
{
srand(time(NULL));
int arr[101];
float aux=0;
for (int i=0;i<100;i++)
{
arr[i]= rand()%101;
aux=aux+arr[i];
}
printf("El promedio de los valores aleatorios generados es: %f",aux/100);
return 0;
}
Ejercicio 40
Imprima los valores de este arreglo en orden inverso
Diagrama de Flujo

Pseudocódigo
INICIO
arr[101] : ENTERO
PARA i:1 HASTA 100 CON PASO 1 HACER
arr[i] : AZAR(100)
FIN PARA
PARA i:100 HASTA 1 CON PASO 1 HACER
ESCRIBIR i,".-",arr[i]
FIN PARA
FIN

Código en C
#include <stdio.h>
int main()
{
srand(time(NULL));
int arr[101];
for (int i=0;i<100;i++)
{
arr[i]= rand()%101;
}
for (int i=100;i=0;i--)
{
printf("%d .- %d\n",i,arr[i]);
}
return 0;
}
Ejercicio 41
Ordene los valores de este arreglo de menor a mayor
Diagrama de Flujo

Pseudocódigo
INICIO
arr[101] : ENTERO
PARA i:1 HASTA 100 CON PASO 1 HACER
arr[i] : AZAR(100)
ESCRIBIR i,".-",arr[i]
FIN PARA
PARA i:1 HASTA 100 CON PASO 1 HACER
PARA j:1 HASTA 100-i CON PASO 1 HACER
Si arr[j+1]<arr[j] ENTONCES
aux : arr[j]
arr[j] : arr[j+1]
arr[j+1]:aux
FIN SI
FIN PARA
FIN PARA
PARA i:1 HASTA 100 CON PASO 1 HACER
ESCRIBIR i,".-",arr[i]
FIN PARA
FIN

Código en C
#include <stdio.h>
int main()
{
srand(time(NULL));
int arr[101];
int aux;
for (int i=0;i<100;i++)
{
arr[i]= rand()%101;
printf("%d .- %d\n",i,arr[i]);
}
for (int i=0;i<100;i++)
{
for (int j=0;j<100-i;j++)
{
if(arr[j+1]<arr[j])
{
aux=arr[j];
arr[j]=arr[j+1];
arr[j+1]=aux;
}
}
}
for (int i=0;i<100;i++)
{
printf("%d .- %d\n",i,arr[i]);
}
return 0;
}