Anda di halaman 1dari 18

EJERCICIOS

1. Hacer el DFD y el pseudocódigo de un programa que sume dos números.

Inicio
“Escriba número1, número2”
Lea número1, número2
Suma = número1 + número2
“Imprima suma”
Fin

2. Hacer el DFD y el pseudocódigo de un programa que calcule el número de


baldosas que se necesita para cubrir el piso de un salón cuadrado.

Inicio
“Ingrese Lado baldosas, Lado salón”
Lea Área salón, Área baldosa
Área salón = Ls*Ls
Área baldosa = Lb*Lb
Cbaldosas = As/Ab
“Imprima número de baldosas”
Fin

3. Calcular el nuevo salario de un obrero si tuvo un incremento del 25% sobre su


salario anterior. Hacer el DFD y el pseudocódigo.

Inicio
“Ingresar salario”
Lea salario
Sant
Snuevo = Sant + (Sant * 0.25)
“Mostrar salario nuevo”, Snuevo
Fin

4. Un alumno desea saber cuál será su calificación final en la materia de


algoritmos. Dicha calificación se compone de los siguientes porcentajes:

● 55% del promedio de sus tres calificaciones parciales


● 30% de la calificación del examen final
● 15% de la calificación de un trabajo final

Inicio
“Escriba notas”
Lea notas
Parcial1= ((n1+n2+n3)/2)*0.55

1
Examfin = n1*0.30
Ctf = n2 * 0.15
Calificación final = Parcial1 + Examfin + Ctf
“Muestre calificación final”
Fin

5. Halle el cuadrado de un número

Inicio
“Ingrese número”
Lea número
Cuadrado = num*num
“Imprimir cuadrado”
Fin

6. Algoritmo que halle el área de un triángulo.

Inicio
“Ingrese base, altura”
Lea base, altura
Área triángulo = (b*a)/2
“Mostrar área”
Fin

7. Dado el presupuesto de un hospital calcular un 35% para pediatría, un 25%


para ginecología y un 40% para ortopedia. Hacer el DFD y el pseudocódigo.

Inicio
“Digite presupuesto, porcentaje áreas”
Lea presupuesto, porcentaje áreas
Calcule presupuesto áreas
Ped = ppto*0.35
Gin = ppto*0.25
Ort = ppto*0.40
“Mostrar presupuesto áreas”
Fin

8. Un maestro desea saber qué porcentaje de hombres y qué porcentaje de


mujeres hay en un grupo de estudiantes. Hacer el DFD y el pseudocódigo.

Inicio
“Ingrese H, M, TotalEst”
Lea “H, M, TotalEst”
PromH = (H*100)/TotalEst
PromM = (M*100)/TotalEst

2
“Mostrar Porcentaje H y M”
Fin

9. Calcular el número de pulsaciones que una persona debe tener por cada 10
segundos de ejercicio, si la fórmula es: número de pulsaciones = (220-edad)/10.
Hacer el DFD y el pseudocódigo.

Inicio
“Ingrese edad”
Lea edad
Npuls = (220-Edad)/10
“Mostrar Npuls”
Fin

10. Hacer el DFD y el pseudocódigo de un programa que convierta grados


Fahrenheit a grados Celsius según la fórmula C = (F-32)*5/9.

Inicio
“Ingresar datos”
Lea datos
C = (F-32)*5/9
“Mostrar conversión”
Fin

11. Dada una cantidad en pesos, obtener la equivalencia en dólares, asumiendo


que la unidad cambiaria es un dato desconocido. Hacer el DFD y el pseudocódigo.

Inicio
“Ingresar COP”
Lea COP
USD = COP * VUSD
“Mostrar USD”
Fin

12. La presión, el volumen y la temperatura de una masa de aire se relacionan por


la fórmula: masa = (presión * volumen)/(0.37 * (temperatura + 460))

Inicio
“Ingrese presión, vol, temp”
Lea presión, vol, temp
Masa = (presión*vol)/(0.37*(temp+460))
“Mostrar Masa”
Fin

3
13. Hacer el DFD y el pseudocódigo de un programa que calcule el precio total a
pagar por un artículo si se tiene como dato el precio de venta y se sabe que el IVA
es del 15%.

Inicio
“Ingrese Vcomp”
Lea Vcomp
Neto = Vcomp+(Vcomp*0.15)
“Mostrar Neto”
Fin

14. Hacer el DFD y el pseudocódigo de un algoritmo que exprese la capacidad de


un disco duro en megabytes, kilobytes y bytes, conociendo la capacidad del disco
en gigabytes. Considere que:

1 kilobyte = 1024 bytes


megabyte = 1024 kilobyte
gigabyte = 1024 megabytes.

Inicio
“Ingrese Tamaño Disco Duro”
Lea Tamaño Disco Duro
DDMb = NGB * 1024
DDKb = NGB * 1024 * 1024
DDb = NGB * 1024 * 1024 * 1024
“Convertir MB, KB, bytes”
Fin

15. En países de habla inglesa es común dar la estatura de una persona como la
suma de una cantidad entera de pies más una cantidad entera de pulgadas. Así, la
estatura de una persona podría ser 3' 2" (3 pies 2 pulgadas). Hacer el DFD y el
pseudocódigo de un algoritmo que determine la estatura de una persona en
metros, conociendo su estatura en el formato inglés. Considere que:

1 pie = 12 pulg.
1 pulg. = 2.54 cm
1 m = 100 cm

Inicio
“Ingrese estatura”
Lea estatura
Convertir de pies a pulgadas
Convertir pulgadas a centímetros
Convertir centímetros a metros
“Mostrar Estatura”

4
Fin

16. Algoritmo para saber si una persona es mayor o menor de edad.

Inicio
“Ingrese edad”
Leer edad
Si edad mayor o igual a 18
Entonces “mayor de edad”
Sino “menor de edad”
Fin si
Fin

17. Algoritmo para saber si un estudiante aprobó o no aprobó la materia con 3


notas y el promedio mayor a 3.0 (calificación de 1 a 5).

Inicio
“Ingrese notas”
Lea notas
Si promedio igual o mayor a 3.0
Entonces “aprobó la materia”
Sino “reprobó”
Fin si
Fin

18. En un almacén se hace un 20% de descuento, si la compra supera los


$100.000, ¿cuánto pagará por la compra?

Inicio
“Ingrese valor de la compra”
Lea “valor de la compra”
Si valor de la compra es mayor a $100.000
Entonces… neto a pagar = valor de la compra – (valor compra * 0,20)
Sino… neto a pagar = valor de la compra
Fin si
Fin

19. Hacer un algoritmo que calcule el total a pagar por la compra de camisas. Si
se compran 3 camisas o más se aplica un descuento del 30% sobre el total de la
compra y si son menos de 3, un descuento del 15%.

Inicio
“Ingrese número camisas, valor camisa”
Lea número camisas, valor camisa
Vcomp = Ncam * Vcam

5
Si Ncam >= 3
Entonces Neto = Vcomp-(Vcomp*0.30)
Sino Neto = Vcomp-(Vcom*0.15)
“Mostrar Neto”
Fin si
Fin

20. Calcular el total que debe pagar una persona en una llantería, si el precio de
cada llanta es de $80.000 si compra menos de 5 llantas; y de $70.000 si compra 5
o más.

Inicio
“Ingrese número de llantas”
Lea número de llantas
Si número de llantas >=5
Entonces Neto = 70.000*Número de llantas
Sino Neto = 80.000*Número de llantas
“Mostrar Neto”
Fin si
Fin

21. En un parqueadero la tarifa mínima es de $2.000 por dos horas o menos.


Luego cobra $1.200 adicionales por cada hora a partir de 2 horas. Realice un
algoritmo que calcule el valor a pagar por el servicio.

Inicio
“Ingrese número de horas”
Lea número de horas
Entonces neto = número de horas * 2000
Sino neto = (número de horas*1.200) – 2000
“Imprimir Neto”
Fin si
Fin

22. Se desea saber si un trabajador tiene derecho a recibir auxilio de transporte, si


gana menos de 2 smlmv.

Inicio
“Ingrese salario”
Lea salario
AuxT = 72000
Si… Salario<1232000
Entonces…”Tiene derecho AuxT”
Salario = Salario+AuxT
Sino… “No tiene derecho AuxT”

6
“Mostrar Salario”
Fin si
Fin

23. Un obrero necesita calcular su salario semanal, el cual se obtiene de la


siguiente manera: Si trabaja 40 horas o menos se le paga $20.000 por hora; si
trabaja más de 40 horas se le paga $23.000 por hora.

Inicio
“Ingrese NumH”
Leer NumH
Si NumH<=40
Entonces SS = NumH*20000
Sino SS = NumH*23000
“Imprimir Salario Semanal”
Fin si
Fin

24. Hacer el DFD y el pseudocódigo de un algoritmo que averigüe e imprima cual


es el mayor de dos números dados.

Inicio
“Ingrese a, b”
Lea a, b
Si a > b
Entonces “imprimir a”
Sino “imprimir b”
Fin si
Fin

25. Hacer el DFD y el pseudocódigo de un programa que calcule el promedio de


un estudiante dadas tres calificaciones en un rango de 0 a 5. Si el promedio es
mayor de 3.5 se debe imprimir un mensaje que diga “Aprobado”. En caso contrario
el mensaje debe ser “Reprobado”.

Inicio
“Ingrese notas”
Lea notas
Rango de Notas = 0 a 5
Promedio = (n1 + n2 + n3)/3
Si promedio mayor o igual a 3,5
Entonces “imprimir aprobado”
Sino “imprimir reprobado”
Fin si
Fin

7
26. Una tienda ha puesto en oferta la venta al por mayor de cierto producto,
ofreciendo un descuento del 15% por la compra de más de 3 docenas y 10% en
caso contrario. Además por la compra de más de 3 docenas se obsequia una
unidad del producto por cada docena en exceso sobre 3. Hacer el DFD y el
pseudocódigo de un algoritmo que determine el monto de la compra, el monto del
descuento, el monto a pagar y el número de unidades de obsequio por la compra
de cierta cantidad de docenas del producto. Se debe imprimir las docenas
compradas, el monto del descuento, el monto a pagar y el número de unidades de
obsequio.

Inicio
Ingrese número de docenas, valor de docenas
Lea número de docenas, valor de docenas
Si el número de docenas es mayor a 3
Entonces… Monto Compra = Monto Docena * Vdocena
Desc = Monto Compra * 0.15
Número de obsequios = Monto Docenas - 3

Sino… Monto Compra = Monto Docena * Vdocena


Desc = Monto Compra * 0.10
Número de obsequios = 0

Imprimir Número de obsequios


Imprimir Monto Compra
Imprimir Descuento

Monto a Pagar = Monto Compra – Descuento

Imprimir Monto a Pagar

Fin

27. En un supermercado se hace una promoción, mediante la cual el cliente


obtiene un descuento dependiendo de un número que se escoge al azar. Si el
numero escogido es menor que 74 el descuento es del 15% sobre el total de la
compra, si es mayor o igual a 74 el descuento es del 20%. Obtener cuánto dinero
se le descuenta.

Inicio
“Introducir Vcomp, NumA”
Lea Vcomp, NumA
NumA = Random(100)

8
Si NumA < 74 Entonces…. Neto = Vcomp*0,85
Sino Neto = Vcomp * 0,80
“Imprimir Neto”
Fin si
Fin

28. Una empresa de bienes raíces ofrece casas de interés social, bajo las
siguientes condiciones: Si los ingresos del comprador son de U$8.000 o más la
cuota inicial será del 15% del costo de la casa y el resto se distribuirá en pagos
mensuales, a pagar en 10 años. Si los ingresos del comprador son menos de
U$8.000 la cuota inicial será del 30% del costo de la casa y el resto se distribuirá
en pagos mensuales a pagar en 7 años.
La empresa quiere obtener cuanto debe pagar un comprador por concepto de
cuota inicial y cuanto por cada pago mensual.

Inicio
“Introducir Salario”
Lea Salario
Si Salario >=8000USD Entonces… CI = VC*0.75
Sino… CI = VC*0.70
CM = ((VC-CI)/10)*12
CM = ((VC-CI)/7)*12
“Imprimir CI, CM”
Fin si
Fin

29. El gobierno desea reforestar un bosque que mide determinado número de


hectáreas. Si la superficie del terreno excede a 5 HECTÁREAS, entonces decidirá
sembrar de la siguiente manera:
Porcentaje de la superficie del bosque Tipo de árbol
70% pino
20% oyamel
10% cedro

Si la superficie del terreno es menor o igual a 5 HECTÁREAS, entonces decidirá


sembrar de la siguiente manera:

Porcentaje de la superficie del bosque Tipo de árbol


50% pino
30% oyamel
20% cedro

9
El gobierno desea saber el número de pinos, oyameles y cedros que tendrá que
sembrar en el bosque, si se sabe que en 1 HECTÁREA caben 8 pinos, 15
oyameles o 10 cedros.

Inicio
“Ingrese NumHas”
Lea NumHas

Si NumHas > 5
Entonces Pino = NumHas*0.70
Oyamel = NumHas*0.20
Cedro = NumHas*0.10

Sino… Pino = NumHas*0.50


Oyamel = NumHas*0.30
Cedro = NumHas*0.20

TsembP = (Pino/8)*NumHas
TsembO = (Oyamel/15)*NumHas
TsembC = (Cedro/10)*NumHas

“Imprimir TsembP, TsembO, TsembC”


Fin si
Fin

30. Para un equipo de baloncesto se necesitan 10 jugadores pero hay 25 inscritos


entonces el director técnico empezó a seleccionar a quienes quedarían en el
equipo por su estatura y por su edad pasarían hacer de su equipo sino pasaría
hacer descartado de su equipo.
La altura tiene que ser mayor o igual a 1.90 y su edad menor o igual a 22 años

Inicio
“Ingrese Est, Edad”
Lea Est, Edad
Si Est >=1,90
Edad <=22 Entonces… “Está en el Equipo”
Sino… “Fuera del Equipo”
Fin si
Fin

31. En un almacén de zapatos hay n pares de zapatos. Si el 15% son deportivos y


el 30% son sandalias, calcular que cantidad de zapatillas hay en el almacén, si

10
hay menos de 500 zapatillas cada una vale 350000 de lo contrario cada una vale
28000. Calcular el valor de las zapatillas.
Inicio
“IngreseTotalZ”
Lea TotalZ
Deport=TotalZ*0.75
Sandal = TotalZ*0.70
Zapat=TotalZ*0.45
Si Zapat<500 Entonces Zapat=(TotalZ*0.45)*35000
Sino… Zapat=(TotalZ*0.45)*28000
“Mostrar Resultado”
Fin si
Fin

32. Un decreto presidencial permite el aumento del 10% a aquellos trabajadores


que ganen el sueldo mínimo ($616000). Hacer el DFD y el pseudocódigo de un
programa que permita calcular el aumento y el nuevo sueldo. Se debe imprimir el
sueldo, el aumento y el nuevo sueldo

Inicio
“Ingrese Salario”
Lea Salario
Si Salario = 616000
Entonces… SNeto = (Salario*0.10)+Salario
Aumento = Salario*0.10
“Imprimir SNeto, Salario, Aumento’
Fin si
Fin

33. Hacer un algoritmo que imprima el precio original y el precio con descuento de
un artículo. El descuento lo hace en base a una clave, si la clave es 01 el
descuento es del 10% y si la clave es 02 el descuento en del 20% (solo existen
dos claves).

Inicio
“Ingrese precio venta”
Lea precio venta, Clave
Si Clave = 01
Entonces… Precio final = Precio de venta – (Precio de venta * 0,10)
Sino Clave = 02
Si Precio final = Precio de venta – (Precio de venta * 0.20)
Sino “Mostrar error”
“Imprimir precio final, precio con descuento”
Fin

11
34. Calcular el número de pulsaciones que debe tener una persona por cada 10
segundos de ejercicio aeróbico; la fórmula que se aplica cuando el sexo es
femenino es: número pulsaciones = (220 - edad)/10 y si el sexo es masculino:
número pulsaciones = (210 - edad)/10.

Inicio
“Ingrese edad”
Lea edad
“Seleccione Sexo”
Lea Sexo
M = 1; F = 2
Si Sexo = M
Entonces… número pulsaciones = (210 - edad)/10
Si no Sexo = F
Entonces… número pulsaciones = (220 - edad)/10
Sino “Mostrar error”
Fin si
Fin

35. Calcular el porcentaje del 33,33% de dos valores

Inicio
“Ingrese números”
Lea números
Porc1 = num1 * 0,3333
Porc2 = num2 * 0,3333
“Mostrar porcentaje números”
Fin

36. Calcular el peso promedio de 3 estudiantes de ADSI en el SENA de


Bucaramanga

Inicio
Ingreso peso1, peso2, peso3
Lea peso1, peso2, peso3
Prom = (p1+p2+p3)/3
Mostrar peso promedio
Fin

37. Una tienda ofrece un descuento del 15% sobre el total de la compra y un
cliente desea saber cuánto deberá pagar finalmente por su compra

Inicio
Ingrese Vcomp

12
Lea Vcomp
Neto = Vcomp-(Vcomp*0.15)
Imprimir Neto
Fin

38. La presión, el volumen y la temperatura de una masa de aire se relacionan por


la fórmula: masa = (presión * volumen)/(0.37 * (temperatura + 460)) calcular la
masa para una presión, volumen y temperatura dados.

Inicio
Ingrese presión, vol, temp
Lea presión, vol, temp
Masa = (presión*vol)/(0.37*(temp+460))
Mostrar Masa
Fin

39. Hacer el DFD y el pseudocódigo de un programa que calcule el salario neto de


un trabajador a partir de la lectura del nombre, horas trabajadas, precio de la hora,
y sabiendo que los impuestos aplicados son el 25% sobre el salario.

Inicio
“Ingrese nombre, htrab, phora”
Lea nom, htrab, phora
Sneto = (htrab*phora) – ((htrab*phora)*0.25)
“Imprima Sneto”
Fin

40. El sueldo neto de un vendedor se calcula como la suma de un sueldo básico


de $350.000 más el 12% del monto total vendido. Diseñe un algoritmo que
determine el suelo neto de un vendedor sabiendo que hizo tres ventas en el mes.

Inicio
Ingrese Sbas, Tventa
Lea Sbas, Tventa, Sneto
Sneto = Sbas+ (Tventa*0.12)
Imprimir Sneto
Fin

41. Hacer el DFD y el pseudocódigo de un algoritmo que permita ingresar el


número de partidos ganados, perdidos y empatados, por algún equipo en el torneo
apertura, se deben mostrar los partidos jugados y su puntaje total, teniendo en
cuenta que por cada partido ganado obtendrá 3 puntos, empatado 1 punto y
perdido 0 puntos.

Inicio

13
“Ingrese PG, PP, PE”
Lea PG, PP, PE
TotalP = (PG*3)+(PE*1)+0
“Mostrar TotalP”
Fin

42. Hacer el DFD y el pseudocódigo de un algoritmo que solicite el número de


respuestas correctas, incorrectas y en blanco, correspondientes a postulantes, y
muestre el total de respuestas y puntaje final, considerando que por cada
respuesta correcta tendrá 4 puntos, respuestas incorrectas tendrá 1 punto, y
respuestas en blanco 0 puntos.

Inicio
“Ingrese RC, RI, RB”
Lea RC, RI, RB
PuntF = (RC*4)+(RI*1)+0
“Mostrar Puntaje Final”
Fin

1. Hay una pared rectangular que tiene una ventana rectangular; hacer el DFD
y pseudocódigo de un algoritmo que dadas las dimensiones (largo y ancho) de la
ventana y de la pared muestre en la pantalla el tiempo necesario para pintar la
pared si se sabe que se puede pintar 1 mt2 en 10 minutos

Inicio
“Ingrese bp, hpared, bv, hv”
Lea bp, hpared, bv, hv
Ap = bp*hpared
Av = bv * hv
Apintar = Ap-Av
Ttotal = (Apintar*10)/1m^2
“Mostrar Tiempo para pintar la pared”, Ttotal
Fin

2. Diseñe el DFD y el pseudocódigo de un programa que halle el área y el


perímetro de un rectángulo.

Inicio
“Ingrese b, h”

14
Lea b, h
P = (2*b)+(2*h)
“Mostrar Perímetro”, P
Fin

3. Hacer el DFD y el pseudocódigo de un programa que halle el área y el


perímetro de un triángulo.

Inicio
“Ingrese a, b, c, base, h”
Lea a, b, c, base, h
A = (base*h)/2
P =a+b+c
“Muestre Área, Perímetro”, A, P
Fin

4. Diseñe el DFD y el pseudocódigo de un programa que halle el área y el


perímetro de un cuadrado.

Inicio
“Ingrese a”
Lea a
P = 4*a
A = a*a
“Muestre P, A”, P, A
Fin

5. Hacer el DFD y pseudocódigo de un algoritmo que calcule el salario a pagar


a un trabajador. Se debe conocer su nombre, cuántas horas ha trabajado, el valor
que gana por hora y, en caso de que su sueldo supere los quinientos mil pesos, se
le debe hacer un descuento del 15%.

Inicio

15
Ingrese Htrab, Vhora
Lea Htrab, Vhora
SNeto = Htrab*Vhora
Si SNeto > 500000
Entonces… SNeto = SNeto*0.85
Sino… “Mostrar SNeto”
Fin si
Fin

6. Se cuenta con los votos obtenidos por Uribe, Santos y Mockus en una
elección democrática a la presidencia de la República. Para ganar la elección se
debe obtener como mínimo el 50% de los votos más 1. En caso que no haya un
ganador se repite la elección en una segunda vuelta. Van a la segunda vuelta los
dos que obtengan la más alta votación ó, los tres en caso de producirse un
empate doble (entre los dos con menor votación) o un empate triple. Hacer el DFD
y pseudocódigo de un algoritmo que determine el resultado de la elección.

Inicio
“Ingrese C1, C2, C3”
Lea C1, C2, C3
Tvotos = C1+C2+C3
Presid = Tvotos*0.51

Si C1>=Presid AND C1>2 AND C1>C3


Entonces ‘El Presidente es C1’
Sino…
Si C2>=Presid AND C2>C3
Entonces ‘El Presidente es C2’
Sino…
Si C3>=Presid AND C3>C1
Entonces ‘El Presidente es C3’
Sino…
Fin Si
Fin Si
Fin Si

Si C1<Presid AND C1>C3 OR C1<Presid AND C1>C2


Entonces ‘El Vicepresidente es C1’
Sino…
Si C2<Presid AND C2>C3 OR C2<Presid AND C2>C1
Entonces ‘El Vicepresidente es C2’
Sino…
Si C3<Presid AND C3>C2 OR C3<Presid AND C3>C1
Entonces ‘El Vicepresidente es C3’
Sino…

16
Fin Si
Fin Si
Fin Si

Si C1=C2 AND C1=C3 AND C2=C3


Entonces ‘Segunda Vuelta’
Sino…
Fin Si
Fin

7. Hacer el DFD y pseudocódigo de un algoritmo que permita simular el


comportamiento de un reloj digital, imprimiendo la hora, minutos y segundos de un
día desde las 0:00:00 horas hasta las 23:59:59 horas.

Inicio
c0
Para h = 1, 23, 1
c = c+h
Para m = 1, 59, 1
c = c+m
Para s = 1, 59, 1
c = c+s
Mostrar ‘h’, h, ‘m’, ‘s’, s
Fin para
Fin para
Fin para
Fin

8. Una pelota se deja caer desde una altura h, y en cada rebote sube el 10%
menos del anterior. Hacer el DFD y pseudocódigo de un algoritmo que calcule e
imprima en cual rebote la pelota no alcanza a subir la quinta parte de la altura
inicial.

Inicio
“Ingrese H,i,Descto,Hr Como Real;
Leer H;
i<-0;
Descto<-0;
Hr<-H;
Si Hr=H Entonces
Mientras Hr>H/5 Hacer
i<-i+1;
‘Imprimir i’
Descto<-Descto+0.10;
‘Imrpimir Descto’

17
Hr<-H-(H*Descto)
Escribir Hr;
Fin Mientras
Fin Si
Fin

9. En un supermercado un ama de casa pone en su carrito los artículos que


va tomando de los estantes. La señora quiere asegurarse de que el cajero le cobre
bien lo que ella ha comprado, por lo que cada vez que toma un artículo anota su
precio junto con la cantidad de artículos iguales que ha tomado y determina cuánto
dinero gastara en ese artículo; a esto le suma lo que ira gastando en los demás
artículos, hasta que decide que ya tomo todo lo que necesitaba. Ayúdale a esta
señora a obtener el total de sus compras.

Inicio
a=0
a=a+1
c=c+a
Repetir a + (a*num*precio) Hasta
Neto = a

18