Anda di halaman 1dari 8

FUNDAMENTOS DE PROGRAMACIÓN: SELECCIÓN MÚLTIPLE

Prof. Oscar Tinoco G.

La estructura de selección múltiple switch de C++ nos permite comparar una expresión con
una lista de constantes(enteras o caracteres) establecidas por el programador para la
ejecución de múltiples flujos. El switch es especialmente útil para la creación de menús en
programación.

A continuación observaremos su definición:

La palabra reservada case indica el comienzo de una nueva constante a comprobar, luego de
ello se indica con el operador: que se ejecutaran las sentencias en caso de coincidir la
expresión con la constante. La palabra break indica que el caso se rompe hasta esa parte.
Finalmente va default o caso por defecto, que como habíamos dicho se da si la expresión no
coincide con ninguna constante.

La orden default no lleva break por ser la última sentencia.


Seleccíon Múltiple con PSEINT

Se desea elaborar un menú con cuatro opciones, referidas a las estaciones temporales en el
año (verano, invierno, otoño y primavera).

Seudocódigo

Ejecución del seudocódigo


Representación simbólica
Código en CodeBlocks

#include<iostream>
using namespace std;
main()
{
int n;
cout<<"Menú de estaciones"<<endl;
cout<<"1: Verano"<<endl;
cout<<"2: Otoño"<<endl;
cout<<"3: Invierno"<<endl;
cout<<"5: Primavera"<<endl;
cout<<"Ingrese un numero entre 1 y 4"<<endl;
cin>>n;
switch(n)
{
case 1:
cout<<"Verano"<<endl;
break;
case 2:
cout<<"Otoño"<<endl;
break;
case 3:
cout<<"Invierno"<<endl;
break;
case 4:
cout<<"Primavera"<<endl;
break;
default:
cout<<"Numero incorrecto"<<endl;
break;
}
}

PREGUNTA TIPO EXAMEN


Escribe un programa que al introducir el resultado de un partido de futbol entre los equipos A
y B, emita mensajes del tipo: “El equipo A derrotó ampliamente al B” si la diferencia de goles
es mayor o igual que 3 (y al contrario), “El equipo A derrotó al B” si la diferencia de puntos es
menor que 3 y mayor que 1 (y al contrario); el equipo A derrotó ajustadamente al B (y al
contrario) y “El equipo A empató con el B”, cuando marcaron igual número de goles.
Solución

Proceso goles
Definir a, b,d como enteros
Escribir "Ingrese los goles marcados por A"
Leer a
Escribir "Ingrese los goles marcados por B"
Leer b
d<-a-b
Si d>=3 Entonces
op<-1
Fin Si
Si d>1 y d<3 Entonces
op<-2
Fin Si
Si d=1 Entonces
op<-3
Fin Si
Si d=-1 Entonces
op<-4
Fin Si
Si d>=-3 y d<-1 Entonces
op<-5
Fin Si
Si d<=-3 Entonces
op<-6
Fin Si
Si d=0 Entonces
op<-7
Fin Si
Segun op Hacer
1:
Escribir "A ganó holgadamente a B"
2:
Escribir "A derrotó a B"
3:
Escribir "A derrotó ajustadamente a B"
4:
Escribir "B derrotó ajustadamente a A"
5:
Escribir "B derrotó a A"
6:
Escribir "B derrotó holgadamente a A"
7:
Escribir "A y B empataron"
De Otro Modo:
Escribir "No procede"
Fin Segun

FinProceso
Propuestos

1. Escribir un programa que lea dos enteros desde teclado, ambos menores que 41. Si alguno no
esté entre 0 y 40 (incluidos) debe mostrar el mensaje “Fuera de Rango”, en caso contrario debe
clasificarlos de acuerdo a la media aritmética de ambos, según el criterio siguiente:
Rango (Media) Tipo

0 – 10 A

11 – 20 B

21 – 30 C

31 – 40 D

Además, en el caso de que estuvieran dentro del rango debe MOSTRAR la media (real) de ambos.

2. La Empresa Shedapal presentó a los usuarios su nueva tarifa por consumo de agua (ver
tabla). Elaborar un programa en C++ en donde se ingrese por teclado el consumo de agua y se
visualice el importe a pagar. (i)

Ejemplo: Si el consumo de agua fue 620, su importe se calculara así

Importe = 100*0.25+200*0.35+200*0.40+120*0.50

METROS CUBICOS S/. x MT. CUBICO


1 a 100 0.25
101 a 300 0.35
301 a 500 0.40
501 a 800 0.50
801 a mas 0.60

3. Un establecimiento comercial ofrece crédito a sus clientes en tres formas como lo indica la
siguiente tabla: (ii)

TIPO FINANCIAMIENTO % INTERES % CUOTA INICIAL NUMERO LETRAS


1 4 60 3
2 8 40 6
3 12 30 9

El cliente deberá firmar antes de la financiación el monto de la compra, el cual es afecto


a un 12% de impuesto, por lo que el monto a pagar será el monto de la compra mas el
importe del impuesto. Luego el cliente elige el tipo de financiamiento que le convenga,
se mostrara el monto de la factura, el monto e los intereses, el nuevo monto de la
factura (incluye los intereses), monto de la cuota inicial y el monto de cada letra a pagar
(nuevo monto de la factura menos el monto de la cuota inicial entre el numero de
letras).

Para esto se deberá digitar el nombre del cliente, el monto de compra y el tipo de
financiamiento elegido.

4. Una librería muy famosa ofrece descuentos dependiendo de la editorial y del tipo de
comprador, según la siguiente tabla: (iii)

EDITORIAL ESTUDIANTE PUBLICO EN GENERAL


San Marcos 25% 10%
Amauta 30% 13%
Otros 35% 15%

Elaborar un programa que ingrese el importe de la compra, el tipo de comprador y la


editorial, muestre el descuento e importe total a pagar. Asuma que el monto total de la
compra es de una misma editora.

5. Cree un programa que pida al usuario un entero (1-9), luego muestre si ese número es:
(deberá validarse el ingreso del número en cuestión) (iv)

* Un par menor de 10

* Un impar menor de 6

* Un impar mayor que 5.

6. Permita al usuario escoger solamente una de estas 3 figuras geométricas (Esfera, Cubo o
Cilindro). Luego el programa solicita los datos apropiados, para así calcular y mostrar en
pantalla el área total (superficie) de la figura seleccionada.

7. Solicite un número entero al usuario y determine si el número es par o impar. Utilice switch.
(v)
8. A partir del siguiente pseudocódigo elaborar el código correspondiente: (vi)

Pseudocódigo

INICIO
X<—0
IMPRIMIR 'Calificaciones Idioma Inglés'
IMPRIMIR '1. De 0-49'
IMPRIMIR '2. De 50-69'
IMPRIMIR '3. De 70-89'
IMPRIMIR '4. De 90 - 99'
IMPRIMIR '5. De 100'
IMPRIMIR 'Escriba el número de la opción que contenga tu calificación: '
LEER x
SELECCIONAR
CASO 1 IMPRIMIR 'Tu calificación es: No_aprobado'
CASO 2 IMPRIMIR 'Tu calificación es: Aprobado'
CASO 3 IMPRIMIR 'Tu calificación es: Notable'
CASO 4 IMPRIMIR 'Tu calificación es: Sobresaliente'
CASO 5 IMPRIMIR 'Tu calificación es: Excelente'
DEFAULT IMPRIMIR 'Esto no es una opción'
FIN SELECCIONAR
FIN

9. Realizar un programa, utilizando la sentencia switch, que aconseje qué ropa se debe poner
el usuario en función de los datos de temperatura y humedad introducidos por el teclado. La
tabla de valores que debe seguir el programa para aconsejar, es la siguiente: (vii)