Anda di halaman 1dari 27

SIMPLEX

No modo Simplex, o fluxo de transmiss�o flui somente em um sentido, ou seja,

um dispositivo s� envia os dados e o outro s� recebe. Como exemplo,


podemos citar uma emissora de R�dio,
onde ela s� transmite.

HALF-DUPLEX
No modo Half-duplex ambos os dispositivos transmitem nos dois sentidos, mas,
n�o simultaneamente.
Ou seja, um transmite enquanto o outro espera e vise versa. Esse modo usa
um �nico canal bidirecional.
Como exemplos, podemos citar um r�dio Walk-Talk, onde ambas as pessoas
podem falar e escutar,
mas n�o ao mesmo tempo.

FULL-DUPLEX
No modo de transmiss�o Full-duplex, h� duas linhas independentes,
onde uma � usada para transmitir e a outra para receber os dados.
Ambos os dispositivos taransmitem simultaneamente. Como exemplo, podemos
citar uma
auto-estrada de duas vias onde os ve�culos rodam nos dois sentidos.
A porta Serial RS232 trabalha em modo Full-duplex, atrav�s das duas linhas
TX-RX.

////////////////////////////// Half Duplex//////////////////////////

Half duplex: A comunica��o em half duplex depende do fluxo de dados unidirecional


quando o envio e o recebimento de dados n�o s�o executados ao mesmo tempo. Isso �
semelhante � forma de funcionamento de walkie-talkies ou r�dios bidirecionais �
medida que apenas uma pessoa pode falar por vez. Se algu�m fala com outra pessoa j�
falando, ocorre uma colis�o. Dessa forma, a comunica��o em half duplex implementa
CSMA/CD para ajudar a reduzir o potencial de colis�es e as detectar quando elas
acontecerem. A comunica��o em half duplex tem problemas de desempenho devido �
espera constante, porque os dados s� podem fluir em uma dire��o por vez. A conex�o
em half duplex costuma ser vista em hardwares mais antigos, como hubs. Os n�s
acoplados a hubs que compartilham sua conex�o com uma porta de switch devem
funcionar em modo half duplex porque os computadores finais devem ser capazes de
detectar colis�es. Os n�s poder�o funcionar em um modo half duplex se a placa de
rede n�o puder ser configurada para opera��es em full duplex.
Nesse caso, a porta no switch tamb�m usa como padr�o um modo half duplex. Por causa
dessas limita��es, a comunica��o em full duplex substituiu half duplex nos
hardwares mais atuais.

///////////////// Full duplex/////////////////////////////

Full duplex: Na comunica��o em full duplex, como o fluxo de dados � bidirecional,


os dados podem ser enviados e recebidos ao mesmo tempo. O suporte bidirecional
aprimora o desempenho, reduzindo o tempo de espera entre as transmiss�es. Grande
parte das placas de rede Ethernet, Fast Ethernet e Gigabit Ethernet vendidas
atualmente oferece recursos em full duplex. No modo full duplex, o circuito de
detec��o de colis�es � desabilitado. Os quadros enviados pelos dois n�s finais
conectados n�o podem colidir porque os n�s finais usam dois circuitos separados no
cabo de rede. Cada conex�o em full duplex usa apenas uma porta. As conex�es em full
duplex exigem um switch que suporte full duplex ou uma conex�o direta entre dois
n�s em que cada um suporte full duplex. Os n�s acoplados diretamente a uma porta de
switch dedicada com placas de rede que suportam full duplex devem ser conectados a
portas de switch configuradas para funcionar no modo full duplex.

///////////////////// Q-in-Q /////////////////////////

Conhecido tamb�m como Stacked VLAN, o QinQ suporta a utiliza��o de duas TAGs 802.1q
no mesmo frame para trafegar uma VLAN dentro de outra VLAN � sem alterar a TAG
original.

O Q-in-Q permite o uso de um n�mero maior de vlans (4096�4096=16777216).


Para os provedores de servi�os essa funcionalidade � muito �til pois com ela �
poss�vel ter uma vlan para cada cliente e dentro desta vlan o cliente pode usar
todas as suas vlans (de 1 a 4094) sem interferir com o outro cliente ou com
provedor de servi�o. Essa vlan, que � definida para o cliente, chamamos de �tunnel
port�

O segundo tag � inserido na porta do cliente no �ingress� e retirado na outra ponta


no �egress� da porta do cliente. Links entre �802.1q trunk� e �tunnel ports (double
tagging) s�o chamados de �asymmetric link�.
Vlans de clientes que usam protocolos que usam PDUs (Layer 2 protocol data units),
ex. CDP, STP ou VTP, precisam que seja habilitado o L2 Protocol Tunneling no
provedor de servi�os para que seja transportado esses PDUs para o outro site do
cliente.

Para o Q-in-Q funcionar tamb�m � necess�rio aumentar o tamanho do frame para no


m�nimo 1526 bytes (pacote ip = 1500 bytes + ethernet header = 18 bytes + 802.1q = 4
+ 802.1q = 4 bytes).

SHOW
OBS: SE O CLIENTE RECLAMAR DE VOIP, E VERIFIRCAR NA VERS�O QUE N�O TEM VOIP N�O �
PROBLEMA NOSSO.
nome router #sh version ==> mostra a vers�o e o modelo do router (( QUANTIDADE
DE PORTAS DISPONIVEIS)Mostra a vers�o do IOS e informa��es de hardware

nome router #sh run == > mosta todas as configura��oes do router

nome router #sh run int (serial,eth,hssi,Multilink) ==> mosta as configura��es


da interface

nome router #sh clock ==> mostra a data e hora configurada no router

nome router #sh ip int brief ==> mostra o resumo das interfaces
nome router #sh ip int brief | i (IP wan remoto) ==> mostra a interface do link se
esta up ou down

nome router #sh int (serial,eth,hssi,Multilink) ==> mostra as informa��es da


interface

nome router #sh int summary ==> mostra a transfer�ncia de dados na rede do cliente
tx-rx

nome router #sh int (serial,eth,hssi,Multilink) | i err ==> mostra os erros e o


traf�go de dados

nome router #sh arp ==> para ver os ip das maquinas conectadas na rede do cliente

nome router #sh log ==> mostra log's de alarmes/quedas do roteador

nome router #sh log | i (serial) ==> mostra as quedas com data e horario e qual
status foi alterado

nome router #sh processes cpu ==> mostra o processamento do router ( ver somente a
1a. linha )

nome router #sh frame-relay pvc ==> mostra a quanto tempo o link frame relay esta
up

nome router #sh ip accounting ==> mostra os acessos do cliente (ip origem/destino)

nome router #sh ip access-lists ==> mostra os ips na lista de acesso

nome router #sh user ==> mostra os usu�rios que estam acessado o console do router

nome router #sh int crb | i (IDVTV) ==> mostra se o link esta up ou donw pelo
idvtv

Verifica��o b�sica

comandos

show processes cpu - motra utiliza��o da processador do router.


show diag - Mostra informa��es dos m�dulos
show history - Mostra os �ltimos comandos digitados

show running-config - Mostra a configura��o


show interface - Mostra informa��es das interfaces
show ip interface - Mostra informa��es do protocolo IP na interface
show ip route - Mostra a tabela de rotas
show users - Mostra os usu�rios conectados
show tech-support - Informa��o completa do sistema

PING NORMAL
nome router #ping ip ( URL ou IP a ser pingado) ==> teste ping
EX
nome router #ping ip
Target IP address: 201.91.235.142 ==> IP de Destino (Unidade Provedora)
Repeat count [5]: 1000 ==> Quantidade de vezes para pingar ( para testar um
circuito 1000 vezes )
Datagram size [100]: 100 ==> Tamanho do pacote em Bytes ( para testar um
circuito utilize 1000 )
Timeout in seconds [2]:
Extended commands [n]: n ==> Comando Extendido (no)
Sweep range of sizes [n]: n
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 201.91.235.142, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/40/44 ms

PING ESTENDIDO
EX
nome router #ping ip ==> Comando: ping ip
Target IP address: 10.200.3.129 ==> IP de Destino (Unidade Provedora)
Repeat count [5]:5 ==> Quantidade de pacotes
Datagram size [100]:100 ==> Tamanho do pacote em Bytes ( para testar um
circuito utilize 1000 )
Timeout in seconds [2]:
Extended commands [n]: y ==> Comando Extendido (Yes)
Source address or interface: 10.112.26.129 ==> IP de Origem (Gateway)
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.200.3.129, timeout is 2 seconds:
Packet sent with a source address of 10.112.26.129
!!!!! � Ping Completado com Sucesso
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/34/44 ms

***********************************************************************************
******************************************

-----------------------------------------------------------------------------------
----

MODO USUARIO E PRIVILEGIADO


Modo usu�rio: ( no caso do Cisco n�o tem muitos recursos)
nome router >

Modo privilegiado:
Para acessar o modo privil�giado digite <ena>
nome router #

Modo privilegiado.

766522_RAIA_DROGASIL_A#conf
Command authorization failed.
766522_RAIA_DROGASIL_A#enable vi
766522_RAIA_DROGASIL_A#enable view
Password: te2003

766522_RAIA_DROGASIL_A#conf
***********************************************************************************
*****************************

tEMPO PARA REINICIAR ROUTER.

habilitar tempo
reload in 5
reload cance

***********************************************************************************
****************************************
aLTERANDO TEMPO DE ATUALIZA��O DO TRAFEGO.

CONSTRUTORA_FALEIROS_852896#conf
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.

CONSTRUTORA_FALEIROS(config)#int g0/0
CONSTRUTORA_FALEIROS(config-if)#lo
CONSTRUTORA_FALEIROS(config-if)#loa
CONSTRUTORA_FALEIROS(config-if)#load-interval 30
CONSTRUTORA_FALEIROS(config-if)#exit
CONSTRUTORA_FALEIROS(config)#int g0/1
CONSTRUTORA_FALEIROS(config-if)#load
CONSTRUTORA_FALEIROS(config-if)#load-interval 30
CONSTRUTORA_FALEIROS(config-if)#^Z

***********************************************************************************
***************************************

nome router #clear counters ==> zerar os contadores do roteador

nome router #clear arp ==> zerar contadores arp

###################################################################################
#############

VERIFICA��O DO ALRME NO ROUTER.

Modelo do router

cisco ASR1001 (1RU) processor with 1163580K/6147K bytes of memory.


-----------------------------------------------------------------------------------
----

UP-INTRA-SAPTELE-STB#show facility-alarm status


System Totals Critical: 1 Major: 0 Minor: 0

Source Severity Description [Index]


------ -------- -------------------
xcvr container 0/0/3 INFO Transceiver Missing [0]
GigabitEthernet0 CRITICAL Physical Port Link Down [1]

UP-INTRA-SAPTELE-STB#sh ip int bri


Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0/0 200.144.25.98 YES NVRAM up up
GigabitEthernet0/0/1 201.61.101.2 YES NVRAM up up
GigabitEthernet0/0/2 201.61.43.202 YES NVRAM up up
GigabitEthernet0/0/3 unassigned YES NVRAM administratively down down
GigabitEthernet0 unassigned YES NVRAM down down
Loopback0 201.60.100.10 YES NVRAM up up

Verificado que GigabitEthernet0 n�o esta sendo usado resolvi shuta esta interface.

-----------------------------------------------------------------------------------
----
UP-INTRA-SAPTELE-STB#sh ip int bri
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0/0 200.144.25.98 YES NVRAM up up
GigabitEthernet0/0/1 201.61.101.2 YES NVRAM up up
GigabitEthernet0/0/2 201.61.43.202 YES NVRAM up up
GigabitEthernet0/0/3 unassigned YES NVRAM administratively down down
GigabitEthernet0 unassigned YES NVRAM administratively down down
Loopback0 201.60.100.10 YES NVRAM up up

UP-INTRA-SAPTELE-STB#show facility-alarm status


System Totals Critical: 0 Major: 0 Minor: 0

Source Severity Description [Index]


------ -------- -------------------
xcvr container 0/0/3 INFO Transceiver Missing [0]
GigabitEthernet0 INFO Physical Port Administrative State Down
[2]

Em contato com Diego informa que apos esta procediemnto luz critical apagou.

-----------------------------------------------------------------------------------
----

--------------------------
Fechando loop na porta do router.

***CISCO - LOOPBACK NA PORTA LAN***


conf t
inter "interface lan"
loopback/keepalive
end
quit
sh ip int br
conf t
inter "interface lan"
no loopback/no keepalive
end

***********************************************************************************
******************************************

CONFIGURANDO PORTA SPEEDY AUTO - SOMENTE EM LINK DE ALTA.

Monitora_VPG_CLIMEDE_CASA#configure t
Enter configuration commands, one per line. End with CNTL/Z.
Monitora_VPG_CLIMEDE(config)#
Monitora_VPG_CLIMEDE(config)#interface FastEthernet0/0
Monitora_VPG_CLIMEDE(config-if)#
Monitora_VPG_CLIMEDE(config-if)#speed auto
Monitora_VPG_CLIMEDE(config-if)#^Z

***********************************************************************************
***************************************

VPG_EDITORA_MODERNA#show processes cpu sorted


(processamento do roteador)

CPU utilization for five seconds: 3%/2%; one minute: 8%;(five minutes: 4%)
(Em 5 minutos a m�dia � 4% de utiliza��o)
PID Runtime(uS) Invoked uSecs 5Sec 1Min 5Min TTY Process
62 4988000 332 15024 0.55% 4.73% 1.47% 194 Virtual Exec
256 18236000 366678838 0 0.23% 0.21% 0.20% 0 PPP manager
100 3414532000 10155824 336 0.23% 0.19% 0.16% 0 IP Input
96 12316000 366430235 0 0.15% 0.16% 0.16% 0 IPAM Manager
269 8568000 11781206 0 0.07% 0.01% 0.00% 0 NTP
45 2736000 11735121 0 0.07% 0.02% 0.00% 0 Per-Second Jobs
162 2488000 11733008 0 0.07% 0.00% 0.00% 0 PfR BR Learn
148 188812000 13010734 14 0.07% 0.05% 0.06% 0 CEF: IPv4 proces
257 16404000 366679053 0 0.07% 0.10% 0.08% 0 PPP Events
9 0 1 0 0.00% 0.00% 0.00% 0 License Client N
10 0 1 0 0.00% 0.00% 0.00% 0 OIR Handler
8 0 2 0 0.00% 0.00% 0.00% 0 Timers
13 0 1 0 0.00% 0.00% 0.00% 0 IPC Zone Manager

VPG_EDITORA_MODERNA#show processes cpu history


(Grafico do processamento do link)

VPG_EDITORA_MODERNA 10:44:00 AM Tuesday Aug 21 2012 GMT

11111 7777711111
222223333322222333334444455555333331111133333888883333333333
100
90
80 *****
70 *****
60 *****
50 *****
40 *****
30 *****
20 *****
10 ***** ***** **********
0....5....1....1....2....2....3....3....4....4....5....5....6
0 5 0 5 0 5 0 5 0 5 0
CPU% per second (last 60 seconds)

***********************************************************************************
***************************************______________

TRACERT
VPG__COVABRA_CAMPINA_AV_RUY#traceroute 200.154.56.80 source 192.168.13.254

Type escape sequence to abort.


Tracing the route to 200.154.56.80

1 186.200.233.201 16 msec 20 msec 24 msec (IP DO


BACKBONE)
2 189.56.213.89 24 msec 24 msec 28 msec (IP DO BACKBONE
DO PONTO CONCENTRADOR)
3 192.168.1.253 [AS 65001] 32 msec 28 msec 32 msec (IP DA REDE LAN
DO PONTO CONCENTRADOR)
4 200.205.211.153 [AS 65001] 28 msec 32 msec 28 msec (IP DA REDE LAN
DO IP DEDICADO)
5 189.56.200.145 [AS 65001] 40 msec 32 msec 36 msec (IP DO BACKBONE
DO IP DEDICADO)
6 187.100.20.118 [AS 65001] 52 msec 60 msec 64 msec
7 187.51.228.10 [AS 65001] 60 msec 64 msec 76 msec
8 200.176.8.197 [AS 65001] 60 msec
200.176.8.169 [AS 65001] 60 msec
200.176.8.197 [AS 65001] 68 msec
9 200.154.56.80 [AS 65001] 68 msec 56 msec 60 msec

VPG__COVABRA_CAMPINA_AV_RUY#show ip int b
Interface IP-Address OK? Method Status
Protocol
FastEthernet0/0 192.168.13.254 YES NVRAM up up
FastEthernet0/1 unassigned YES NVRAM administratively down down
Serial0/0/0 186.200.233.202 YES NVRAM up up
Serial0/1/0 unassigned YES NVRAM up up
Serial0/1/0.16 172.24.174.13 YES NVRAM up up
Serial0/1/0.400 172.26.35.161 YES TFTP up up
Loopback0 187.50.144.211 YES NVRAM up up
Loopback400 172.26.35.161 YES NVRAM up up

_**********************************************************************************
****************************************________

***********************************************************************************
***************************************
Verificar funcionamento do cooler

VPG_MANFRIN#show environment

Fan 1 OK

Fan 2 OK

ILP Power Supply -Absent

Fan Speed Setting: Normal

Senha de enable

RAIA_DROGASIL_797114#enable view
Password: te2003
access-list barrando acesso do cliente para
monitoramento e outros servi�os.

access-list 52 permit 187.50.58.0 0.0.0.255


***********************************************************************************
***************************************

VPG_EDITORA_MODERNA#clear logging
(Zerar o hist�rico de log)
Clear logging buffer [confirm]
VPG_EDITORA_MODERNA#show logging
Syslog logging: enabled (0 messages dropped, 3 messages rate-limited,
0 flushes, 0 overruns, xml disabled, filtering disabled)

No Active Message Discriminator.

No Inactive Message Discriminator.

Console logging: level debugging, 68966 messages logged, xml disabled,


filtering disabled
Monitor logging: level debugging, 0 messages logged, xml disabled,
filtering disabled
Buffer logging: level debugging, 68966 messages logged, xml disabled,
filtering disabled
Logging Exception size (4096 bytes)
Count and timestamp logging messages: disabled
Persistent logging: disabled

No active filter modules.

ESM: 0 messages dropped

Trap logging: level informational, 68970 message lines logged

Log Buffer (4096 bytes):

VPG_AHLSTROM_708209(config)#logging buffered
(Habilitar o hist�rico de log)

______________________________________

VPG_EDITORA_MODERNA#terminal monitor
(Monitorar log's do router em tempo real)
______________________________________

***********************************************************************************
***************************************
Escrever mensagem dentro do roteador

E-COMMERCE-JOENVILE-ID737711#send *
Enter message, end with CTRL/Z; abort with CTRL/C: (CTRL/Z para
finalizar)

Jun 5 12:39:52.293 UTC: %IP-4-DUPADDR: Duplicate address 172.19.0.8 on


GigabitEthernet0/0, sourced by 0217.c515.7282
^Z
Send message? [confirm]
E-COMMERCE-JOENVILE-ID737711#

***
***
*** Message from tty132 to all terminals:
***

***********************************************************************************
**************************
1594726 defeito bgP FOI RECONFIGURADO O MESMO E VOLTOU A FUNCIONAR.
BGP

Backbone.

c-br-sp-soc-as-rav-02#sh ip bgp vpnv4 vrf V7563:VPN05_Santander_MPLS_NEW summary |


i 186.201.6.66
186.201.6.66 4 65069 12735 11810 0 0 0 1w1d Active

c-br-sp-soc-as-rav-02#sh ip bgp vpnv4 vrf V7563:VPN05_Santander_MPLS_NEW neighbors


186.201.6.66 routes

Total number of prefixes 0

c-br-sp-soc-as-rav-02#sh conf | i 186.201.6.66

neighbor chamando CPE via as remota - 65069 CPE.

neighbor 186.201.6.66 remote-as 65069


neighbor 186.201.6.66 activate
neighbor 186.201.6.66 as-override
neighbor 186.201.6.66 prefix-list SANTANDER_PRAPS_WiMAX_DEFAULT out
neighbor 186.201.6.66 route-map SANTANDER_PRAPS_WiMAX_LOCAL_PREF in

CPE

AGE13644-CEL_QUIRINO_CAMPINAS_SP_R1#sh run | s bgp


router bgp 65069
no synchronization
bgp router-id 10.160.12.23
bgp log-neighbor-changes
redistribute connected

neighbor chamando wan do backbone as remota- 10429 da vivo.

neighbor 186.201.6.65 remote-as 10429


neighbor 186.201.6.65 timers 20 60
neighbor 186.201.6.65 advertisement-interval 1
neighbor 186.201.6.65 allowas-in
neighbor 186.201.6.65 soft-reconfiguration inbound
neighbor 186.201.6.65 weight 4000
neighbor 186.201.6.65 prefix-list SANTADER-DEFAULT in
no auto-summary
permit tcp any eq bgp any
AGE13644-CEL_QUIRINO_CAMPINAS_SP_R1#

***********************************************************************************
**************************
***********************************************************************************
******************************************
configurando hora no cisco.

VPG_PAULI_GOLD_LTDA_721956#clock set 16:18:00 05 ?


MONTH Month of the year

VPG_PAULI_GOLD_LTDA_721956#clock set 16:18:00 05 08 ?


% Unrecognized command
VPG_PAULI_GOLD_LTDA_721956#clock set 16:18:00 05 sep ?
<1993-2035> Year

VPG_PAULI_GOLD_LTDA_721956#clock set 21:29:00 25 sep 2014

***********************************************************************************

como proceder com nat

cliente que possuem nat - n�o pinga para fora a partir da lan - para testar se est�
ok - pinga o nat do cmd e verificar se pinga
se pingar verificar com o comando sh run | i nat (cisco) ou dis cu | i nat (3com) e
verificar aonde est� amarrado o nat- se for com um servidor - verificar com o
cliente se esta funcionando ou n�o se n�o estiver pedir para dar um tracert do cmd
do cliente at� a internet.

***********************************************************************************
*****************************************
verificando nat
- Criar NAT est�tico:
configure terminal
ip nat inside source static 10.6.226.30 200.144.26.29
interface FastEthernet0/0
ip nat inside
exit
interface Serial0/0
ip nat outside
do copy running-config startup-config
end

"NAT CISCO"
CPE#configure terminal
CPE(config)#ip nat inside source static 10.6.226.30 200.144.26.29
CPE(config)#interface FastEthernet0/0
CPE(config-if)#ip nat inside
CPE(config-if)#exit
CPE(config)#interface Serial0/0
CPE(config-if)ip nat outside
CPE(config-if)#do copy running-config startup-config
CPE(config-if)#end
CPE

<br_bruac_gov_pci_22381_a>dis ip int bri


*down: administratively down
(s): spoofing (l): loopback
Interface Physical Protocol IP Address Description
Aux0 up up -- --
Cellular0/0 down down -- --
Eth0/0 up up 10.75.234.241 CNX LAN - REDE INTERNA C...
Eth0/1 up up 189.56.226.174 CNX WAN - LP 36223189 - ...
Loop1 up up(s) 201.60.99.173 GERENCIA VIVO
S0/0 down down -- --

#
interface Ethernet0/1
port link-mode route
description CNX WAN - LP 36223189 - ID 838871 - PE c-br-sp-bru-ac-rav-01
nat server protocol udp global 201.60.99.173 65500 inside 187.100.14.197 65500
nat server protocol udp global 201.60.99.173 65100 inside 201.60.47.18 65100
bandwidth 4096
load-bandwidth 4196
ip address 189.56.226.174 255.255.255.252

configura��o de nat ping somente para nat.

<br_bruac_gov_pci_22381_a>ping -a 201.60.99.173 189.56.226.174


PING 189.56.226.174: 56 data bytes, press CTRL_C to break
Reply from 189.56.226.174: bytes=56 Sequence=0 ttl=255 time=1 ms
Reply from 189.56.226.174: bytes=56 Sequence=1 ttl=255 time=1 ms
Reply from 189.56.226.174: bytes=56 Sequence=2 ttl=255 time=1 ms
Reply from 189.56.226.174: bytes=56 Sequence=3 ttl=255 time=1 ms
Reply from 189.56.226.174: bytes=56 Sequence=4 ttl=255 time=1 ms

--- 189.56.226.174 ping statistics ---


5 packet(s) transmitted
5 packet(s) received
0.00% packet loss
round-trip min/avg/max = 1/1/1 ms

###################################################################################
############################

###################################################################################
############################

Verificar Redundancia.

###################################################################################
############################
Protocolos de redundancia.
funciona como ACTIVE, Standby, Listen.

HSRP
COMGAS_CORMSP_ACT_A_770444#sh standby brief
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Gi0/0 30 110 P Active local 172.18.129.14 172.18.129.12

COMGAS_CORMSP_STB_B_816700#sh standby brief


P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Gi0/0 30 106 P Standby 172.18.129.13 local 172.18.129.12

COMGAS_CORMSP_STB_C_816699#sh standby brief


P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Gi0/0 30 105 P Listen 172.18.129.13 172.18.129.14 172.18.129.12

---------------------------------------------------------------------------------

Outro protocolo como redundancia VRRP que funciona do mesmo jeito.

ACTIVE, Standby, Listen.

[br_stswl_gov_tri_02079_b]dis cu int Eth0/0


#
interface Ethernet0/0
port link-mode route
description CNX LAN - REDE INTERNA CLIENTE
firewall packet-filter 3000 inbound
ip address 10.96.133.3 255.255.255.128
vrrp vrid 1 virtual-ip 10.96.133.1 <------------- VRRP.
undo ip fast-forwarding

Piority 115 principal


Piority 95 segundario
Piority 100 sempre � defalt.

----------------------------------------------------------------------------------

BGLP.

Todas interface ativas, e n�o funciona via BGP.

###################################################################################
############################

Conforme foi verificado cliente informa que possui balanceamento dos tres links no
local.
Porem foi verificado qeu os tr�s links no local funcionam por protocolo HSRP ande
funciona como redundancia.
Existe prioridade nos routers e funciona como ACTIVE, Standby, Listen.
conforme testes realizado.
Rotuer A
Router B
Este router n�o estava arprendendo o mesmo enrere�os que os router A e C est�o.
Este router tem prioridade menos que o A e C portanto sempre esta em STADby.
Este Router A essta ok.
Lembrando que redundancia para os 3 routers poder ser como protocolo BGLP para
realizar balanciamento dos tres link
porem n�o esta configurado.
Protocolo que aparece no router, route-map BALANCEAMENTO permit 10 esta configurado
errado, pois protocolo que esta
no router � o HSRP e n�o permite balanciamento e sim redundancia.
Conforme outro teste.
Foi shutado interface do router A
E o router Reclamado router B
Quando Router A e C n�o estiverem funcionado, router B em Standby fica Active.
Informar para o cliente que numca houve balanceamento nestes links.
E sim Redundancia, com protocolo HSRP para redundancia, para balanceamento
necessario utiliar prolocolo diferente
um exemplo seria BGLP esse sim faz reduncia do liks e n�o fica como o protocolo
atial um ativo, standby, e listen.

***********************************************************************************

Habilitar DHCP:
ip dhcp pool 2962-2004 (nome do pool de identifica��o)
network 10.75.15.32 255.255.255.240 (rede que quer distribuir)
dns-server 10.200.36.7 10.200.36.8 (ips de dns)
default-router 10.75.15.33 (ip da pr�pria interface lan)
ip dhcp excluded-address 10.75.15.33 255.255.255.252 (Range de IP Excluido)
#### Configurar DHCP NO CISCO

## Configura��o para restringir ip�s que n�o seram fornecidos via DHCP

no ip dhcp use vrf connected


ip dhcp excluded-address 10.10.78.2 10.10.78.70
ip dhcp excluded-address 10.10.78.73
ip dhcp excluded-address 10.10.78.83
ip dhcp excluded-address 10.10.78.84
ip dhcp excluded-address 10.10.78.117
ip dhcp excluded-address 10.10.78.194
ip dhcp excluded-address 10.10.78.239
ip dhcp excluded-address 10.10.78.107
ip dhcp excluded-address 10.10.78.137
ip dhcp excluded-address 10.10.78.155
!
Int_Sp_665874_75_76_77#sh ip dhcp ?
binding DHCP address bindings <<<< IP�s fornecidos
conflict DHCP address conflicts <<<< Verificar conflitos
database DHCP database agents <<<<<
import Show Imported Parameters
pool DHCP pools information <<<<< Informa��es sobre um pool
relay Miscellaneous DHCP relay information
server Miscellaneous DHCP server information

## Criar o pool com as config�s de DHCP

ip dhcp pool Intermedica.com.br


network 10.10.78.0 255.255.255.0 --- RANGE
default-router 10.10.78.1 ------------- Gateway padrao
domain-name intermedica.com.br -- Dominio
dns-server 172.17.0.32 172.17.0.34 -- DNS
netbios-name-server 172.17.0.32 172.17.0.34 --- Sei La que porra kkkk
netbios-node-type h-node --- Sei La que porra kkkk
lease 360 23 50 ---- tempo de Atualizado e outras coisas que n�o manjo

***********************************************************************************
############## Monitoramento remoto

Configurando SNMP em equipamentos Cisco

Configura��o permitindo que qualquer esta��o de gerenciamento SNMP (NMS) possa


acessar todos os objetos com permiss�es somente leitura usando a string de
comunidade �roteadores�.

snmp-server community "community solicitada ex intragov2" ro

VEDACIT_DOUTORALTINOT(config)#no snmp-server community V&d@MrTg RO 52


VEDACIT_DOUTORALTINOT(config)#snmp-server community V&d@MrTg RO

Router>enable

Router#configure terminal

Router(config)#hostname ti-redes

ti-redes(config)# snmp-server community roteadores (habilita o SNMP com a


comunidade "roteadores")

ti-redes(config)# snmp-server location Roteador Core, Senac-TI, Florianopolis SC


(opcional: Configura a localidade)

ti-redes(config)# snmp-server contact Rodrigo Salvo, rsalvo@prof.sc.senac.br


(opcional: Configura o contato da localidade)

O exemplo a seguir permite que qualquer esta��o de gerenciamento SNMP (NMS) possa
acessar todos os objetos com permiss�o somente leitura usando a string de
comunidade "roteadores". O roteador tamb�m ir� enviar traps hsrp (Hot Standby
Router Protocol) para o host 172.16.1.1 e 172.16.1.2 usando SNMPv1 para o host
172.16.1.3 usando SNMPv2c.
Router>enable

Router#configure terminal

Router(config)#hostname ti-redes

ti-redes(config)#snmp-server community roteadores

ti-redes(config)#snmp-server enable traps hsrp

ti-redes(config)#snmp-server host 172.16.1.1 version 1 public

ti-redes(config)#snmp-server host 172.16.1.2 public

ti-redes(config)#snmp-server host 172.16.1.3 version 2c public

O exemplo abaixo permite o acesso somente de leitura para todos os objetos para os
membros da lista de acesso "4" e que especifique a string de comunidade "acesso".
Sem outros gerentes SNMP ter acesso a quaisquer objetos. Na falha de autentica��o
SNMP, traps ser�o enviados por SNMPv2c para ti-redes.com utilizando a string de
comunidade "roteadores".

Router>enable

Router#configure terminal

Router(config)#hostname ti-redes

ti-redes(config)#snmp-server community acesso ro 4

ti-redes(config)#snmp-server enable traps snmp authentication


ti-redes(config)#snmp-server ti-redes.com version 2c public

Ler mais: http://www.ti-redes.com/gerenciamento/snmp/equipamentos-cisco/


Crie o seu website gr�tis: http://www.webnode.pt

snmp-server community 200.204.184.49 RO


snmp-server community GESTION RO
snmp-server community ESCRITO RW
snmp-server community public RO
snmp-server community oabinternet RO <<<<< nome da community com permiss�o de
leitura (RO) ou leitura e escrita (RW)
snmp-server ifindex persist
snmp-server trap-source Loopback0
snmp-server location OABSP
snmp-server contact mresende@oabsp.org.br
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps aaa_server
snmp-server enable traps config
snmp-server enable traps entity
snmp-server enable traps frame-relay multilink bundle-mismatch
snmp-server enable traps frame-relay
snmp-server enable traps frame-relay subif
snmp-server enable traps hsrp
snmp-server enable traps cpu threshold
snmp-server enable traps syslog
snmp-server host 200.153.1.150 ESCRITO
snmp-server host 200.153.1.150 GESTION
***********************************************************************************
***************************

EXEMPLOS DE CONFIGURA��O DE SHAPE.

output wan.

input shape lan.

Depende da forma como equipamento interpreta.

1 GIGA
1.000 Mbits / exemplo: 10 + 1024= 10240 em Mbits fica 1.0240
1000.000 Kbits / exemplo: 10 + 1024= 10240 em kbits fica 1024.000
1000.000.000 Bits / exemplo: 10 + 1024= 10240 em bits fica 10.240.000
40.960
544.078.000
***********************************************************************************
******************************************

oBS: NO BACKBONE TEM QUE TER SHAPE TBEM.

ESTOK_SHOP_IGUATEMI_BRA_836295#conf ter
ESTOK_SHOP_IGUATEMI_BRA_836295#conf terminal
Enter configuration commands, one per line. End with CNTL/Z.
ESTOK_SHOP_IGUATEMI_(config)#policy-map MORETI_100MBPN-IP_MPLS_WAN -------------->
configurado policy Shape
ESTOK_SHOP_IGUATEMI_(config-pmap)#class class-default
ESTOK_SHOP_IGUATEMI_(config-pmap-c)#shape average 512000
ESTOK_SHOP_IGUATEMI_(config-pmap-c)#exit
ESTOK_SHOP_IGUATEMI_(config)#exit

ESTOK_SHOP_IGUATEMI_BRA_836295#sh run
***********************************************************************************
******************************************
!
policy-map ESTOK_512K_VPN-IP_MPLS_WAN
class Suporte_VPN-IP
bandwidth 8
class class-default
fair-queue
random-detect dscp-based
shape average 512000

interface GigabitEthernet0/0
description CNX LAN
bandwidth 512
ip address 10.1.47.1 255.255.255.0 secondary
ip address 10.0.47.82 255.255.255.0
load-interval 30
duplex full
speed 100
no cdp enable
!
interface GigabitEthernet0/1
bandwidth 512
no ip address
duplex auto
speed auto
no cdp enable
max-reserved-bandwidth 90
service-policy output ESTOK_512K_VPN-IP_MPLS_WAN

i-br-sp-bre-al-rai-01#sh policy-map IPD_SECURITY_IN_6Mbps


Policy Map IPD_SECURITY_IN_6Mbps
Class REDES_PROIBIDAS
police cir 2000000 bc 62500
conform-action drop
exceed-action drop
Class FILTRO_INFRA_VIP
police cir 2000000 bc 62500
conform-action drop
exceed-action drop
Class FILTRO_ICMP
police cir 6144000 bc 192000
conform-action set-dscp-transmit default
exceed-action drop
Class class-default
police cir 6144000 bc 192000
conform-action set-dscp-transmit default
exceed-action drop
i-br-sp-bre-al-rai-01#

***********************************************************************************
******************************************
Outro exemplo.

CLIENTE RECLAMAVA DE PERCAS DE PACOTES PARA FILIAL E LATENCIA ALTA.

ESTAVA CONFIGURADA NA WAN 128, MAIS CERTO � 512 CONFORME LINK CONTRATADO.

conf t
policy-map ESTOK_512K_VPN-IP_MPLS_LAN
class VoIP_IN
police 128000 conform-action set-dscp-transmit ef exceed-action drop
class Video_IN
class Ouro_IN
class Prata_IN
class Platino_IN
class class-default
set ip dscp af11

policy-map ESTOK_512K_VPN-IP_MPLS_WAN
class Multimidia_VPN-IP
priority 128
police 128000 conform-action transmit exceed-action drop
class Ouro_VPN-IP
class Prata_VPN-IP
class Platino_VPN-IP
class Suporte_VPN-IP
bandwidth 20
class class-default
fair-queue
random-detect dscp-based
!
****************************************************************************

policy-map ESTOK_512K_VPN-IP_MPLS_LAN
class VoIP_IN
police 128000 conform-action set-dscp-transmit ef exceed-action drop
class Video_IN
class Ouro_IN
class Prata_IN
class Platino_IN
class class-default
set ip dscp af11

policy-map ESTOK_512K_VPN-IP_MPLS_WAN
class Multimidia_VPN-IP
priority 512
police 512000 conform-action transmit exceed-action drop
class Ouro_VPN-IP
class Prata_VPN-IP
class Platino_VPN-IP
class Suporte_VPN-IP
bandwidth 512
class class-default
fair-queue
random-detect dscp-based
!

analizar..

VPG_CODERP-INTERNET-ACT#SH POlicy-maP
VPG_CODERP-INTERNET-ACT#SH POlicy-maP BGPLT_SECURITY_OUT_CODERP_CIA_DESEL_ECON
Policy Map BGPLT_SECURITY_OUT_CODERP_CIA_DESEL_ECON
Class class-default
police cir 204800000 bc 6400000
conform-action set-dscp-transmit default
exceed-action drop

***********************************************************************************
******************************************

###################################################################################
########################################

ex: cliente n�o consegue chegar em um ip de lan dentro do firwel.

Matriz_Concentrador_(config)#lop
Matriz_Concentrador_(config)#inter
Matriz_Concentrador_(config)#interface lo
Matriz_Concentrador_(config)#interface loopback 1000
Matriz_Concentrador_(config-if)#ip address 10.79.4.1 ?
A.B.C.D IP subnet mask

Matriz_Concentrador_(config-if)#ip address 10.79.4.1 255.255.255.255


Matriz_Concentrador_(config-if)#do sh ip int bri
Interface IP-Address OK? Method Status
Protocol
GigabitEthernet0/0 189.108.148.90 YES NVRAM up up
GigabitEthernet0/1 10.96.64.51 YES manual up up
FastEthernet0/0/0 100.100.100.2 YES NVRAM up up
GigabitEthernet0/1/0 10.150.6.5 YES NVRAM up up
NVI0 unassigned NO unset up up
Loopback0 189.108.144.74 YES NVRAM up up
Loopback11 192.168.235.20 YES NVRAM up up
Loopback1000 10.79.4.1 YES manual up up
Matriz_Concentrador_(config)#no interface Loopback1000

Matriz_Concentrador_MPL_Principal_ID788975#sh ip int bri


Interface IP-Address OK? Method Status
Protocol
GigabitEthernet0/0 189.108.148.90 YES NVRAM up up
GigabitEthernet0/1 10.96.64.51 YES manual up up
FastEthernet0/0/0 100.100.100.2 YES NVRAM up up
GigabitEthernet0/1/0 10.150.6.5 YES NVRAM up up
NVI0 unassigned NO unset up up
Loopback0 189.108.144.74 YES NVRAM up up
Loopback11 192.168.235.20 YES NVRAM up up
Matriz_Concentrador_(config)#no interface Loopback1000

Caso lan esteja fora

Nega ip de lan no ip andres e criar uma loopback.

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
VERIFICIAR CLEINTE SATURANDO BANDA.

conf term
interface "interface lan"
ip accounting
end

show ip accounting
//depois tem que retirar//

conf term
interface "interface lan"
no ip accounting
end

Monitora_VPG_CLIMEDE_CASA#sh ip int b
Interface IP-Address OK? Method Status
Protocol
FastEthernet0/0 187.9.221.57 YES NVRAM up up
FastEthernet0/1 187.93.255.6 YES NVRAM up up
Serial0/0/0 unassigned YES NVRAM administratively down down
Loopback0 187.9.189.132 YES NVRAM up up
Monitora_VPG_CLIMEDE_CASA#
Monitora_VPG_CLIMEDE_CASA#
Monitora_VPG_CLIMEDE_CASA#conf
Monitora_VPG_CLIMEDE_CASA#configure t -------> entrando no momd conf
Enter configuration commands, one per line. End with CNTL/Z. --->para sair.
Monitora_VPG_CLIMEDE(config)#interface FastEthernet0/0 --lan do cliente
Monitora_VPG_CLIMEDE(config-if)#
Monitora_VPG_CLIMEDE(config-if)#ip accounting ----> para habilitar
Accounting will exclude mls traffic when mls is enabled.

Monitora_VPG_CLIMEDE(config-if)#^Z ----->tecla control-Z , sair do modo


configurado.
Monitora_VPG_CLIMEDE_CASA#
Monitora_VPG_CLIMEDE_CASA#sh ip accou
Monitora_VPG_CLIMEDE_CASA#sh ip accounting -----> realizar o comando para ver
maquinas subindo.
Source Destination Packets Bytes
31.170.148.115 187.9.221.61 10 812
213.248.115.13 187.9.221.61 5 276
24.213.122.228 187.9.221.61 1 62
84.45.76.100 187.9.221.61 15 1413
67.215.65.132 187.9.221.61 8 710
61.174.50.240 187.9.221.61 6 991
50.93.204.245 187.9.221.61 65 4195
91.201.118.176 187.9.221.61 5 200
182.119.25.140 187.9.221.61 107 13778

Monitora_VPG_CLIMEDE_CASA#sh ip int b
Interface IP-Address OK? Method Status
Protocol
FastEthernet0/0 187.9.221.57 YES NVRAM up up
FastEthernet0/1 187.93.255.6 YES NVRAM up up
Serial0/0/0 unassigned YES NVRAM administratively down down
Loopback0 187.9.189.132 YES NVRAM up up
Monitora_VPG_CLIMEDE_CASA#
Monitora_VPG_CLIMEDE_CASA#
Monitora_VPG_CLIMEDE_CASA#conf
Monitora_VPG_CLIMEDE_CASA#configure t ------> realizar comando para sair do mod
pois esta consumindo banda do cliente.
Enter configuration commands, one per line. End with CNTL/Z.
Monitora_VPG_CLIMEDE(config)#
Monitora_VPG_CLIMEDE(config)#
Monitora_VPG_CLIMEDE(config)#
Monitora_VPG_CLIMEDE(config)#interface FastEthernet0/0
Monitora_VPG_CLIMEDE(config-if)#
Monitora_VPG_CLIMEDE(config-if)#no ip acco
Monitora_VPG_CLIMEDE(config-if)#no ip accounting ----Para sair dele.
Monitora_VPG_CLIMEDE(config-if)#
Monitora_VPG_CLIMEDE(config-if)#
Monitora_VPG_CLIMEDE(config-if)#^Z tecla control-Z , sair do modo configurado.
Monitora_VPG_CLIMEDE_CASA#
Monitora_VPG_CLIMEDE_CASA#ip accounting ----pode tentar realizar o cmd ele da erro.
^
% Invalid input detected at '^' marker.

Monitora_VPG_CLIMEDE_CASA#
<VPG_AFFINIA_BLUMENA(config-if)#ip accounting output-packets
(Habilitar comando para monitorar trafego das maquinas na rede LAN)
Accounting will exclude mls traffic when mls is enabled.

<VPG_AFFINIA_BLUMENAU>#show ip accounting
(Verificar trafego)
Source Destination Packets Bytes
10.72.48.22 10.72.50.22 90 25485
10.66.41.100 10.72.50.113 2 80
10.72.58.22 10.72.50.22 4 3274
10.66.41.106 10.72.50.113 8 7108
10.66.41.106 10.72.50.107 46 34345
10.66.41.106 10.72.50.106 8 7080
10.66.41.100 10.72.50.100 3 120
10.66.41.106 10.72.50.105 3 2121
10.66.41.100 10.72.50.102 2 80
10.66.41.106 10.72.50.111 3 2130
10.72.38.11 10.72.50.11 4 368
10.66.41.106 10.72.50.110 7 5681
169.254.134.161 10.72.50.22 2 96
10.66.41.100 10.72.50.108 1 40
10.66.41.100 10.72.50.111 5 264
10.66.41.100 10.72.50.110 5 200
10.66.41.100 10.72.50.105 3 120
10.66.41.100 10.72.50.107 8 384
10.66.41.100 10.72.50.106 1 40
10.66.41.106 10.72.50.100 4 2156
10.66.41.106 10.72.50.94 3 2128
169.254.250.226 10.72.50.22 2 96
10.66.41.100 10.72.50.94 3 184
10.72.0.139 10.72.50.253 4 242
10.72.1.97 10.72.50.22 100 16932
10.72.0.124 10.72.50.9 4 184
10.72.54.93 10.72.50.22 44 8724
169.254.67.34 10.72.50.22 1 48

***********************************************************************************
***************************************

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

###################################################################################
####################################
VPG_749383_SIND_EMPREG_HOTELEIRO_SP_A#show run | in route
no ip source-route
ip local policy route-map Gerencia_CE
ip route 0.0.0.0 0.0.0.0 200.232.85.165
ip route 192.168.13.0 255.255.255.0 121.4.13.2
ip route 200.153.1.0 255.255.255.0 200.232.85.165
ip route 200.204.1.4 255.255.255.255 200.232.85.165
route-map Gerencia_CE permit 10
route-map Gerencia_CE deny 20

VPG_749383_SIND_EMPREG_HOTELEIRO_SP_A#show ip cef
Prefix Next Hop Interface
0.0.0.0/0 200.232.85.165 FastEthernet0/1
0.0.0.0/32 receive
121.4.13.0/24 attached FastEthernet0/0
121.4.13.0/32 receive
121.4.13.1/32 receive
121.4.13.2/32 121.4.13.2 FastEthernet0/0
121.4.13.255/32 receive
189.109.222.237/32 receive
192.168.13.0/24 121.4.13.2 FastEthernet0/0
200.153.1.0/24 200.232.85.165 FastEthernet0/1
200.204.1.4/32 200.232.85.165 FastEthernet0/1
200.232.85.164/30 attached FastEthernet0/1
200.232.85.164/32 receive
200.232.85.165/32 200.232.85.165 FastEthernet0/1
200.232.85.166/32 receive
200.232.85.167/32 receive
224.0.0.0/4 drop
224.0.0.0/24 receive
255.255.255.255/32 receive

SINDICATO_834507#show run | include route


no ip source-route
ip local policy route-map Gerencia_CE
ip route 0.0.0.0 0.0.0.0 121.4.11.2
ip route 121.4.0.0 255.255.0.0 200.148.173.25
ip route 121.4.13.0 255.255.255.0 200.148.173.25
ip route 192.168.11.0 255.255.255.0 121.4.11.2
ip route 192.168.12.0 255.255.255.0 200.148.173.25
ip route 192.168.13.0 255.255.255.0 200.148.173.25
ip route 192.168.14.0 255.255.255.0 200.148.173.25
ip route 200.153.1.0 255.255.255.0 200.148.173.25
ip route 200.204.1.4 255.255.255.255 200.148.173.25
route-map Gerencia_CE permit 10
route-map Gerencia_CE deny 20

###################################################################################
####################################

###################################################################################
#################################################3
BGP

ABB-GUARULHOS-100MB-VPN_735289#show ip bgp summary


BGP router identifier 186.238.166.66, local AS number 65001
BGP table version is 18620, main routing table version 18620
747 network entries using 101592 bytes of memory
776 path entries using 43456 bytes of memory
162/161 BGP path/bestpath attribute entries using 20736 bytes of memory
131 BGP AS-PATH entries using 9282 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 175066 total bytes of memory
BGP activity 2803/2056 prefixes, 5430/4654 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down


State/PfxRcd
189.56.201.233 4 10429 145262 138261 18620 0 0 12w3d 746
###################################################################################
###############################################

Ol� Pessoal,

Quase todo mundo que trabalha com roteadores e switches Cisco ou que est� estudando
para a certifica��o CCNA j� utilizou, pelo menos alguma vez, o comando show
interface. Esse comando � bem conhecido, mas na maioria das vezes � utilizado
apenas para ver se a interface est� up/down. No entanto, muitas outras informa��es
�teis podem ser retiradas da sa�da desse comando. No artigo de hoje iremos ver
algumas das mais importantes.

O comando pode ser utilizado para exibir informa��es de todas as interfaces (show
interfaces) ou para uma interface espec�fica (show interfaces serial 0/1 � ou
simplesmente sh int s0/1).
Router#sh int s0/1
Serial0/1 is up, line protocol is up
Hardware is PowerQUICC Serial
Internet address is 192.168.1.1/24
MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, loopback not set
Keepalive set (10 sec)
Last input 00:00:02, output 00:00:00, output hang never
Last clearing of �show interface� counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 1158 kilobits/sec
5 minute input rate 8000 bits/sec, 1 packets/sec
5 minute output rate 8000 bits/sec, 1 packets/sec
31468 packets input, 2394818 bytes, 0 no buffer
Received 31263 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
31475 packets output, 2398672 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
109 carrier transitions
DCD=up DSR=up DTR=up RTS=up CTS=up

Router#

Vamos agora ver as informa��es mais importantes.

Serial0/1 is up, line protocol is up: essa informa��o � bem conhecida. A primeira
parte refere-se a camada 1 e mostra que a interface est� �up� e operando. A segunda
parte refere-se a camada 2, �line protocol is up� nos diz que temos conectividade
tamb�m na camada 2. Existem 04 poss�veis sa�das que podemos encontrar.

Serial0/0/0 is up, line protocol is up: Camadas 1 e 2 funcionando


perfeitamente.
Serial0/0/0 is down, line protocol is down: Essa sa�da indica problema na
camada f�sica. Pode ser, por exemplo, cabo desconetaco nessa interface ou na
interface remota.
Serial0/0/0 is up, line protocol is down: Nesse caso a camada f�sica est� ok,
mas a camada de enlace n�o. Poss�veis raz�es para isso podem ser problema na
configura��o do encapsulamento ou clock rate.
Serial0/0/0 is administratively down, line protocol is down: Essa sa�da indica
que a sua interface foi localmente colocada no estado de shutdown. Entre na
configura��o da interface e d� um �no shutdown�.

Internet address is 192.168.1.1/24 - esse campo nos diz o endere�o IP configurado


na interface.

MTU � A MTU (Maximum Transmission Unit ou Unidade M�xima de Transmiss�o) � 1500


bytes. A MTU refere-se ao tamanho do maior datagrama que uma camada de um protocolo
de comunica��o pode transmitir.

BW 1544 Kbit/sec � essa parte nos mostra a largura de banda configurada na


interface (comando bandwidth). Caso esse par�metro n�o seja configurado na
interface ser� adotado o valor padr�o de 1544 Kbit/sec. Lembrem-se que o par�metro
bandwidth � utilizado por alguns protocolos de roteamento (EIGRP, por exemplo) para
calcular a m�trica de uma rota.

Encapsulation HDLC � mostra o tipo de encapsulamento utilizado. Como estamos com


uma interface serial e deixamos no padr�o da interface, est� mostrando HDLC.
Poderia ser tamb�m Frame-Relay ou PPP (no escopo do CCNA).

Last input, output - n�mero de horas, minutos e segundos desde que o �ltimo pacote
voi recebido ou transmitido com sucesso. Essa informa��o � �til nos casos de falha
da interface.

Input queue � exibe informa��o sobre o n�mero de pacotes na fila de entrada.


Size/max/drops = n�mero atual de quadros na fila / n�mero de m�ximo permitido de
quadros na fila antes de come�ar a descartar quadros / n�mero atual de quadros
descartados devido a ter excedido o m�ximo permitido.

Total output drops � n�mero de pacotes descartados devido a fila est� cheia. Por
exemplo, imagine que uma grande quantidade de tr�fego est� chegando no seu roteador
atrav�s de interfaces com largura de banda de 2Mbit/s e que todo esse tr�fego est�
saindo por uma outra interface com um link de 64Kbit/s. Esse excesso de tr�fego na
interface de 64Kbit/s pode fazer com que o par�metro total output drops aumente.

Output queue � ap�s os pacotes serem processados, eles s�o enviados para fila de
sa�da da interface de sa�da. Essa linha nos mostra o tamanho da fila de sa�da, o
n�mero m�ximo permitido e os descartados.

5 minute input/output rate � exibe a m�dia da taxa de entrada e sa�da na interface


nos �ltimos 5 minutos.

A �ltima parte do comando exibe informa��es dos contadores de erros. S�o esses
campos que o comando clear counters ir� zerar, quando executado. Vamos ver os tipos
de erros.
5 minute output rate 8000 bits/sec, 1 packets/sec
31468 packets input, 2394818 bytes, 0 no buffer
Received 31263 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
31475 packets output, 2398672 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
109 carrier transitions
DCD=up DSR=up DTR=up RTS=up CTS=up

Packets input/output � n�mero de total de pacotes recebidos/transmitidos pela


interface. Monitorar o incremento desse contador � �til para verificarmos se o
tr�fego est� fluindo corretamente pela interface.

Broadcasts - n�mero total de pacotes de broadcast ou multicast recebidos.

Runts - n�mero de quadros recebidos que s�o menores do que o tamanho de quadro
m�nimo do IEEE 802.3 (64 bytes para Ethernet) e com inconsist�ncia no CRC. Poss�vel
causa podem ser incompatibilidade no modo duplex ou problemas f�sicos, como
cabeamento, porta ou placa de rede no dispositivo conectado.

Giants - n�mero de quadros recebidos que superam o tamanho m�ximo permitido pelo
IEEE 802.3. Na maioria dos casos esse erro � causado por problema na placa de rede
de algum dispositivo (NIC). Procure pelo dispositivo com problema e retire-o da
rede.

Throttles - n�mero de vezes que a recep��o na porta foi desabilitada, possivelmente


devido a uma sobrecarga no buffer do processador. Se exibir um asterisco (*) logo
ap�s o valor, significa que a interface est� apresentando o problema no exato
momento que o comando foi rodado. Exemplos de pacotes que podem sobrecarregar o
buffer do processador s�o, pacotes IP com op��es, TTL expirado, encapsulamento non-
ARPA, fragmenta��o, tunelamento, pacotes ICMP e outros.

Input Errors - somat�rio de todos os erros, incluindo runts, giants, no buffer,


CRC, frame, overrun e ignored counts. Outros tipos de erros tamb�m podem
incrementar esse contador e alguns quadros podem apresentar mais de um tipo de
erro.

CRC - esse contador incrementa quando o CRC gerado pelo dispositivo remoto n�o
coincide com o checksum calculado no receptor. Geralmente � um indicativo de ru�do
ou problema na transmiss�o. Um elevado n�mero de erros de CRC geralemente s�o um
resultado de um elevado n�mero de colis�es, mas tamb�m pode ser um indicativo de
problemas f�sicos (cabeamento, NIC) ou disparidade no modo duplex configurado.

Frame - n�mero de pacotes recebidos incorretamente com erros de CRC e um n�mero n�o
inteirdo de octetos (erro de alinhamento). Geralemente s�o causados por colis�es,
problemas f�sicos (cabeamento, NIC) ou disparidade no modo duplex configurado.

Overrun - n�mero de vezes que o hardware do receptor n�o foi capaz de suportar os
dados recebidos no hardware do buffer. Ou seja, o tr�fego de entrada excedeu a
capacidade do receptor.

Ignored - n�mero de pacotes recebidos e ignorados pela interface devido a uma baixa
na performance do hardware dos buffers internos da interface. Pode ser causado por
tempestades de broadcast e tr�fego com rajadas de ru�dos.

Bytes - n�mero total de bytes transmitido pelo sistema, incluindo dados e


encapsulamento MAC.

Underruns - n�mero de vez que o transmissor do dispositivo remoto operou mais


r�pido do que o receptor do lado local pode suportar. Isso pode ocorrer, por
exemplo, em situa��es onde uma interface esteja recebendo uma grande quantidade de
tr�fego em rajadas vindo de outras interfaces. Durante uma situa��o de overrum a
interface pode reiniciar.

Output Errors � somat�rio dos erros que impediram a transmiss�o final dos
datagramas para fora da interface. Geralmente � causado por um tamanho reduzido da
fila de sa�da.

Collisions - n�mero de vezes que ocorreu uma colis�o antes que a interface pudesse
transmitir o quadro para o meio com sucesso. Colis�es s�o comuns quando a interface
est� configurada com half-duplex e n�o deve ocorrer em interfaces full-duplex. Se o
n�mero de colis�es aumentar drasticamente, pode ser indicativo de alta utiliza��o
do link ou erro na configura��o do modo duplex.

Interface Resets � n�mero de vezes que a interface foi completamente resetada.

Unknown protocol drops � esse contador exibe o n�mero de pacotes descartados com
protocolo desconhecidos ou n�o-configurados na interface. Caso voc� n�o consiga
identificar o erro voc� pode utilizar um sniffer para identificar o protocolo
desconhecido.

Output buffers swapped out � esse n�mero indica o n�mero de pacotes que foram
armazenados na DRAM quando a fila de sa�da lotou. Quando a fila de sa�da da
interface de sa�da est� lotada o pacote � copiado para a DRAM, depois � copiado de
volta para a fila quando essa estiver livre, como forma de evitar o seu descarte.
Normalmente esse n�mero incrementa quando estamos em situa��o de rajadas de
tr�fego.

Carrier Transitions � n�mero de vezes que houve a interrup��o no sinal da


portadora. Pode ser causado por reset na interface ou desconex�o do cabo, por
exemplo.

Bem pessoal, como vimos o n�mero de informa��es que podem ser obtidas � grande e
podem variar dependendo do tipo de interface que voc� est� analisando. De qualquer
forma, a sa�da do comando ser� bem semelhante ao que foi ilustrado. O importante �
termos em mente que existe muito mais do que um simples �serial is up / line
protocol is up�.
- See more at: http://www.dltec.com.br/blog/cisco/dicas-de-troubleshooting-com-o-
comando-show-interface-curso-ccna/#sthash.bcdbccCb.dpuf