Anda di halaman 1dari 7

Frame Relay Lab

Hub and Spoke: Multipoint


Headquarters
Hub City
172.25.10.1

172.25.1.1
DLCI 100 DLCI 200

Multipoint
subinterface
172.25.0.0/24
S0
Frame Relay
Network
S1 S2

DLCI 101 Frame Switch DLCI 201


Interfaces

172.25.1.2 172.25.1.3
Point-to-point
subinterfaces
172.25.20.1 172.25.30.1

Satellite Office 1 Satellite Office 2


Spokane Spokomo

Note: If not using Cisco IOS 11.2 or later, be sure to configure the LMI type on each
serial interface.

Multipoint subinterfaces on the HubCity router:


• Multipoint interface on the hub router is used when hub and spoke routers are on the
same subnet.
• Spoke routers must use point-to-point subinterfaces, as there will be no way to map
routes in the routing table with dlci’s.
• Without point-to-point subinterfaces, all networks will show in the spoke routers’
routing tables, but they will not be able to ping interfaces on those networks.
• Split Horizon must be disabled on the Hub router.
Router HubCity (DTE)
version 12.0
!
hostname HubCity
!
interface Serial0
no ip address
encapsulation frame-relay
no frame-relay inverse-arp
!
interface Serial0.1 multipoint
ip address 172.25.1.1 255.255.255.0
no ip split-horizon
frame-relay interface-dlci 100
frame-relay interface-dlci 200
!
interface FastEthernet0
ip address 172.25.10.1 255.255.255.0
no ip directed-broadcast
no keepalive
!
router rip
network 172.25.0.0
!

Router Spokane (DTE)


version 12.0
!
hostname Spokane
!
interface Serial0
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
ip address 172.25.1.2 255.255.255.0
no ip directed-broadcast
frame-relay interface-dlci 101
!
interface FastEthernet0
ip address 172.25.20.1 255.255.255.0
no ip directed-broadcast
no keepalive
!
router rip
network 172.25.0.0
!
Router Spokomo (DTE)
version 12.0
!
hostname Spokomo
!
interface Serial0
no ip address
encapsulation frame-relay
!
interface Serial0.1 point-to-point
ip address 172.25.1.3 255.255.255.0
frame-relay interface-dlci 201
!
interface FastEthernet0
ip address 172.25.30.1 255.255.255.0
no ip directed-broadcast
no keepalive
!
router rip
network 172.25.0.0
!

Frame Relay Switch (DCE)


version 12.0
!
hostname FrameSwitchE
!
frame-relay switching
!
interface Serial0
no ip address
encapsulation frame-relay
clockrate 56000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 100 interface Serial1 101
frame-relay route 200 interface Serial2 201
!
interface Serial1
no ip address
encapsulation frame-relay
clockrate 56000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 101 interface Serial0 100
!
Frame Relay Switch (continued)
interface Serial2
no ip address
encapsulation frame-relay
clockrate 56000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 201 interface Serial0 200

Notes:
1. A router is not normally used as a Frame Relay switch. This feature is typically sued
in test and demonstration situations.
2. Loopback interface can be used to simulate actual physical interfaces.
3. The Frame Relay switch is acting as the DCE device, which would be a normal
situation.

1. Examine the FrameSwith router:

FrameSwitchE#show frame-relay route


Input Intf Input Dlci Output Intf Output Dlci Status
Serial0 100 Serial1 101 active
Serial0 200 Serial2 201 active
Serial1 101 Serial0 100 active
Serial2 201 Serial0 200 active

2. Each router should see every network and be able to ping each network. On each of
the routers perform the following commands:
HubCity
HubCity#show frame-relay map
Serial0.1 (up): ip 172.25.1.2 dlci 100(0x64,0x1840), dynamic,
broadcast,, status defined, active
Serial0.1 (up): ip 172.25.1.3 dlci 200(0xC8,0x3080), dynamic,
broadcast,, status defined, active

HubCity#show frame-relay pvc

PVC Statistics for interface Serial0 (Frame Relay DTE)

Active Inactive Deleted Static


Local 2 0 0 0
Switched 0 0 0 0
Unused 0 0 0 0

DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE =


Serial0.1

input pkts 140 output pkts 77 in bytes 24656


out bytes 7774 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 69 out bcast bytes 7038
pvc create time 00:31:06, last time pvc status changed 00:30:36

DLCI = 200, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE =


Serial0.1

input pkts 128 output pkts 103 in bytes 18760


out bytes 11810 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 72 out bcast bytes 8594
pvc create time 00:31:07, last time pvc status changed 00:30:37

HubCity#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP

Gateway of last resort is not set

172.25.0.0/24 is subnetted, 4 subnets


R 172.25.20.0 [120/1] via 172.25.1.2, 00:00:06, Serial0.1
R 172.25.30.0 [120/1] via 172.25.1.3, 00:00:02, Serial0.1
C 172.25.1.0 is directly connected, Serial0.1
C 172.25.10.0 is directly connected, FastEthernet0

HubCity#ping 172.25.20.1
Sending 5, 100-byte ICMP Echos to 172.25.20.1, timeout is 2 seconds:
!!!!!

HubCity#ping 172.25.30.1
Sending 5, 100-byte ICMP Echos to 172.25.30.1, timeout is 2 seconds:
!!!!!
Spokane
Spokane#show frame-relay map
Serial0.1 (up): point-to-point dlci, dlci 101(0x65,0x1850), broadcast
status defined, active

Spokane#show frame-relay pvc

PVC Statistics for interface Serial0 (Frame Relay DTE)

Active Inactive Deleted Static


Local 1 0 0 0
Switched 0 0 0 0
Unused 0 0 0 0

DLCI = 101, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE =


Serial0.1

input pkts 58 output pkts 65 in bytes 6252


out bytes 9602 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 55 out bcast bytes 8562
pvc create time 00:20:34, last time pvc status changed 00:20:34

Spokane#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP,

Gateway of last resort is not set

172.25.0.0/24 is subnetted, 4 subnets


C 172.25.20.0 is directly connected, FastEthernet0
R 172.25.30.0 [120/2] via 172.25.1.1, 00:00:05, Serial0.1
C 172.25.1.0 is directly connected, Serial0.1
R 172.25.10.0 [120/1] via 172.25.1.1, 00:00:05, Serial0.1

Spokane#ping 172.25.10.1
Sending 5, 100-byte ICMP Echos to 172.25.10.1, timeout is 2 seconds:
!!!!!

Spokane#ping 172.25.30.1
Sending 5, 100-byte ICMP Echos to 172.25.30.1, timeout is 2 seconds:
!!!!!
Spokomo
Spokomo#show frame-relay map
Serial0.1 (up): point-to-point dlci, dlci 201(0xC9,0x3090), broadcast
status defined, active

Spokomo#show frame-relay pvc

PVC Statistics for interface Serial0 (Frame Relay DTE)

Active Inactive Deleted Static


Local 1 0 0 0
Switched 0 0 0 0
Unused 0 0 0 0

DLCI = 201, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE =


Serial0.1

input pkts 59 output pkts 78 in bytes 6484


out bytes 9496 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 63 out bcast bytes 7936
pvc create time 00:19:30, last time pvc status changed 00:19:30

Spokomo#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP

Gateway of last resort is not set

172.25.0.0/24 is subnetted, 4 subnets


R 172.25.20.0 [120/2] via 172.25.1.1, 00:00:18, Serial0.1
C 172.25.30.0 is directly connected, FastEthernet0
C 172.25.1.0 is directly connected, Serial0.1
R 172.25.10.0 [120/1] via 172.25.1.1, 00:00:18, Serial0.1

Spokomo#ping 172.25.10.1
Sending 5, 100-byte ICMP Echos to 172.25.10.1, timeout is 2 seconds:
!!!!!

Spokomo#ping 172.25.20.1
Sending 5, 100-byte ICMP Echos to 172.25.20.1, timeout is 2 seconds:
!!!!!

Anda mungkin juga menyukai