Anda di halaman 1dari 4

Algoritmo Ejemplo01

Escribir “Ingresar una nota”


Leer NOTA
Si NOTA>=10.5 Entonces
Escribir “Aprobado”
Sino
Escribir “Desaprobado”
Fin_si
FinAlgoritmo

Ejemplo:
Ingresar 3 notas, indicar de acuerdo al promedio si el estudiante está
aprobado o desaprobado
Algoritmo Ejemplo02
Escribir “Ingresar tres notas”
Leer N1, N2, N3
Prom=(n1+n2+N3)/3
Escribir “El promedio final es: ”, Prom
Si Prom<10.5 Entonces
Escribir “Desaprobado”
Sino
Escribir “Aprobado”
Fin_Si
FinAlgoritmo
Ejemplo:
Ingresar el año de nacimiento de una persona, determinar si es apto para
votar, si este año fueran las elecciones.
Algoritmo Ejemplo03
Escribir “Ingresar su año de nacimiento”
Leer ANAC
Edad=2016-anac
Escribir “Su edad actual es: ”, Edad
Si edad>=18 entonces
Escribir “Apto para votar”
Sino
Escribir “No vota”
Fin_si
Fin_Algoritmo

Ejemplo:
Ingresar un número, determinar si es par o impar
Algoritmo Ejemplo04
Escribir “Ingresar un número”
Leer NUM
RES = NUM Mod 2
Si RES=0 Entonces
Escribir “Número par”
Sino
Escribir “Número impar”
Fin_Si
FinAlgoritmo

Ejemplo:
Ingresar un número, indique si es Negativo, Positivo o cero
Algoritmo Ejemplo05
Escribir “Ingrese un número”
Leer NUM
Si NUM=0 Entonces
Escribir “El valor ingresado es cero”
Sino
Si NUM>0 Entonces
Escribir “Número Positivo”
Sino
Escribir “Número Negativo”
Fin_si
Fin_Si
FinAlgoritmo

Ejemplo:
Ingresar una nota, de acuerdo a ello indicar:
00 – 05 Conocimiento Básico
06 – 10 Conocimiento Intermedio
11 - 15 Conocimiento Avanzado
16 - 20 Conocimiento Excelente

Algoritmo Ejemplo06
Escribir “Ingresar nota”
Leer NOTA
Si nota<=5 Entonces
Escribir “Conocimiento básico”
Sino
Si Nota<=10 Entonces
Escribir “Conocimiento Intermedio”
Sino
Si Nota<=15 Entonces
Escribir “Conocimiento Avanzado”
Sino
Escribir “Conocimiento Excelente”
Fin_si
Fin_si
Fin_si