Anda di halaman 1dari 4

Topic: Procedure to add a new edge Switch in Fabric through ISL.

Scenario: I am adding a new Cisco switch in existing Fabric using CLI. Here I used 4 port as a Trunk and
in between “code – Edge” relationship using 8GB speed for each port.
Consequently we can establish aggregate trunk of 32 GB

Login to “Core Switch” using CLI and run below commands:

interface fc 1/1
switchport description ISL to Edge-switch-name Fc1/1
switchprot speed 8000
switch port rate-mode dedicated
switchport mode auto
no shut

interface fc 1/7
switchport description ISL to Edge-switch-name fc1/2
switchprot speed 8000
switch port rate-mode dedicated
switchport mode auto
no shut

interface fc 1/13
switchport description ISL to Edge-switch-name fc1/3
switchprot speed 8000
switch port rate-mode dedicated
switchport mode auto
no shut

interface fc 1/19
switchport description ISL to Edge-switch-name fc1/4
switchprot speed 8000
switch port rate-mode dedicated
switchport mode auto
no shut

Login to Edge switch using CLI and execute below commands:

int mgmt0
ip address 10.64.241.226 255.255.255.128
ip default-gateway 10.3.241.129

ntp server 10.3.249.25 prefer

radius-server timeout 30
radius-server retransmit 5
radius-server deadtime 30
radius-server host 10.3.249.20 key 7 "<removed>" authentication accounting timeout 10 retransmit 3
radius-server host 10.3.249.30 key 7 "<removed>" authentication accounting timeout 3 retransmit 1
radius-server host 10.3.249.20 test idle-time 30
radius-server host 10.3.249.30 test idle-time 30
aaa group server radius radius

call home
switch-priority 2
email-contact infra-storage@xyz.com
phone-contact +91XXXXXXXXX
streetaddress XXXXX
destination-profile full_txt message-level 6
destination-profile short_txt message-level 6
destination-profile xml message-size 500000
destination-profile xml message-level 6
destination-profile full_txt email-addr infra-sicd-storage@xyz.com
transport email smtp-server < smtp server > port 25
transport email from switch-name@xyz.com
transport email reply-to infra-storage@xyz.com
enable
periodic-inventory notification interval 30

config# vsan database


vsan 400 name DC1_Prod_400
vsan 420 name DC1_Backup_420

username admin password cisco123 role network-admin


username admin role network-admin
username operator password cisco123 role network-operator
username operator role network-operator

fcdomain domain 3 static vsan 400


fcdomain restart vsan 400

fcdomain domain 53 static vsan 420


fcdomain restart vsan 420

fcdomain priority 3 vsan 400


fcdomain priority 3 vsan 110
fcdomain priority 3 vsan 420

system default switchport mode F

clock timezone UST 2 0


switchname switch-abc
interface fc 1/1
switchport description ISL to Core-switch-name fc1/1
switchprot speed 8000
switch port rate-mode dedicated
switchport mode auto
no shut

interface fc 1/2
switchport description ISL to Core-switch-name fc2/1
switchprot speed 8000
switch port rate-mode dedicated
switchport mode FX
no shut

interface fc 1/3
switchport description ISL to core-switch-name fc3/1
switchprot speed 8000
switch port rate-mode dedicated
switchport mode auto
no shut

interface fc 1/4
switchport description ISL to core-switch-name fc4/1
switchprot speed 8000
switch port rate-mode dedicated
switchport mode FX
no shut

device-alias database
device-alias name < name > pwwn <from pool>
..
device-alias commit

zone mode enhanced vsan 400


zone mode enhanced vsan 420

interface fc1/1
switchmode trunk auto
channel-group 3

interface fc1/2
switchmode trunk auto
channel-group 3

interface fc1/3
switchmode trunk auto
channel-group 3

interface fc1/4
switchmode trunk auto
channel-group 3

interface port-channel 3
channel-mode active
switchport trunk allowed vsan 1
switchport trunk add vsan 400
switchport trunk add vsan 420
switchport description Port channel between core-switch-name and edge-switch-name
no shutdown

Anda mungkin juga menyukai