Anda di halaman 1dari 10

MPLS-LITE & OSPF

Beberapa waktu lalu seorang rekan saya menanyakan tentang implementasi konfigurasi OSPF untuk
diterapkan pada jaringan yang membutuhkan banyak kostumisasi routing untuk masing masing client /
pelanggan, Berikut ini adalah contoh sederhana dari implementasi MPLS – Lite OSPF pada layanan
pelanggan ISP.

Pada langkah awal kita lakukan setting untuk konektivitas standar, alokasi IP dan loopback interface,
selanjutnya lakukan setting untuk VRF, apabila VRF telah di set pada perangkat selanjutnya adalah
melakukan test konektifitas, sebagaimana contoh berikut :

*** Verifikasi VRF pada client C1 & C2 ke PE :

C1#ping 10.7.7.1

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 10.7.7.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/195/352 ms
C1#trace 10.7.7.1

Type escape sequence to abort.


Tracing the route to 10.7.7.1

1 10.7.7.1 164 msec 300 msec *


C1#

C2#ping 10.7.7.1

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 10.7.7.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/182/376 ms
C2#trace 10.7.7.1

Type escape sequence to abort.


Tracing the route to 10.7.7.1

1 10.7.7.1 284 msec 792 msec 512 msec


C2#

PE>en
PE#ping vrf VRF-C1 10.7.7.2

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 10.7.7.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/294/964 ms
PE#ping vrf VRF-C2 10.7.7.2

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 10.7.7.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/255/504 ms
PE#

Apabila proses konfigurasi VRF telah selesai selanjutnya adalah melakukan konfigurasi OSPF, routing VRF
akan di advertise oleh OSPF sesuai dengan konfigurasi routing VRF masing masing. Detail konfigurasi
pada tiap perangkat adalah sebagai berikut :
*** CLIENT C1 *** :

!
hostname C1
!
ip cef
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
description TO-PE
ip address 10.7.7.2 255.255.255.252
duplex auto
speed auto
!
router ospf 10
router-id 2.2.2.2
log-adjacency-changes
network 10.3.16.0 0.0.0.15 area 1
network 10.7.7.0 0.0.0.3 area 1
!
!
End

*** CLIENT C2 *** :

!
hostname C2
!
ip cef
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
description TO-PE
ip address 10.7.7.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 20
router-id 4.4.4.4
log-adjacency-changes
network 10.3.10.0 0.0.0.3 area 2
network 10.7.7.0 0.0.0.3 area 2
!
end

*** PE *** :

!
hostname PE
!
ip cef
!
ip vrf VRF-C1
rd 10.7.7.1:2
!
ip vrf VRF-C2
rd 10.7.7.1:3
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
description TO-SC
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.2
description TO-C1
encapsulation dot1Q 2
ip vrf forwarding VRF-C1
ip address 10.7.7.1 255.255.255.252
!
interface FastEthernet0/0.3
description TO-C2
encapsulation dot1Q 3
ip vrf forwarding VRF-C2
ip address 10.7.7.1 255.255.255.252
!
interface FastEthernet0/1
!
interface FastEthernet1/0
description TO-UPSTREAM-VRF-C1
no switchport
ip vrf forwarding VRF-C1
ip address 10.3.16.2 255.255.255.240
!
interface FastEthernet1/1
description TO-UPSTREAM-VRF-C2
no switchport
ip vrf forwarding VRF-C2
ip address 10.3.10.2 255.255.255.252
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
no ip address
!
router ospf 10 vrf VRF-C1
router-id 1.1.1.1
log-adjacency-changes
capability vrf-lite
network 10.3.16.0 0.0.0.15 area 1
network 10.7.7.0 0.0.0.3 area 1
!
router ospf 20 vrf VRF-C2
router-id 3.3.3.3
log-adjacency-changes
capability vrf-lite
network 10.3.10.0 0.0.0.3 area 2
network 10.7.7.0 0.0.0.3 area 2
!
end

*** UPSTREAM *** :

!
hostname UPSTREAM
!
ip cef
!
ip vrf VRF-C1
rd 10.7.7.1:2
!
ip vrf VRF-C2
rd 10.7.7.1:3
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface Loopback1
ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
description TO-PE-VRF-C1
ip vrf forwarding VRF-C1
ip address 10.3.16.1 255.255.255.240
duplex auto
speed auto
!
interface FastEthernet0/1
description TO-PE-VRF-C2
ip vrf forwarding VRF-C2
ip address 10.3.10.1 255.255.255.252
duplex auto
speed auto
!
router ospf 10 vrf VRF-C1
router-id 5.5.5.5
log-adjacency-changes
network 10.3.16.0 0.0.0.15 area 1
network 10.7.7.0 0.0.0.3 area 1
!
router ospf 20 vrf VRF-C2
router-id 6.6.6.6
log-adjacency-changes
network 10.3.10.0 0.0.0.15 area 2
network 10.7.7.0 0.0.0.3 area 2
!
end
*** Verifikasi konektifitas dari C1 & C2 ke masing masing interface UPSTREAM :

C1#ping 10.3.16.1 repeat 10

Type escape sequence to abort.


Sending 10, 100-byte ICMP Echos to 10.3.16.1, timeout is 2 seconds:
!!!!!!!!!!
Success rate is 100 percent (10/10), round-trip min/avg/max = 412/581/688 ms
C1#
C1#trace 10.3.16.1

Type escape sequence to abort.


Tracing the route to 10.3.16.1

1 10.7.7.1 188 msec 372 msec 404 msec


2 10.3.16.1 1000 msec 624 msec 884 msec
C1#
C1#ping 10.3.10.1

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 10.3.10.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
C1#trace 10.3.10.1

Type escape sequence to abort.


Tracing the route to 10.3.10.1

1 * * *
2 * * *
3 * * *
C1#

C1#sh ip route ospf


10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O 10.3.16.0/28 [110/11] via 10.7.7.1, 01:00:36, FastEthernet0/0

C2#ping 10.3.10.1 repeat 10

Type escape sequence to abort.


Sending 10, 100-byte ICMP Echos to 10.3.10.1, timeout is 2 seconds:
!!!!!!!!!!
Success rate is 100 percent (10/10), round-trip min/avg/max = 404/625/1000 ms
C2#trace 10.3.10.1

Type escape sequence to abort.


Tracing the route to 10.3.10.1

1 10.7.7.1 696 msec 896 msec 348 msec


2 10.3.10.1 644 msec 604 msec 604 msec
C2#
C2#ping 10.3.16.1

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 10.3.16.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
C2#trace 10.3.16.1

Type escape sequence to abort.


Tracing the route to 10.3.16.1

1 * * *
2 * * *
3 * * *
C2#

C2#sh ip route ospf


10.0.0.0/30 is subnetted, 2 subnets
O 10.3.10.0 [110/11] via 10.7.7.1, 01:00:02, FastEthernet0/0

UPSTREAM#sh ip route ospf 10

Routing Table: VRF-C1

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks


O 10.7.7.0/30 [110/20] via 10.3.16.2, 01:07:44, FastEthernet0/0
UPSTREAM#sh ip route ospf 20

Routing Table: VRF-C2


10.0.0.0/30 is subnetted, 2 subnets
O 10.7.7.0 [110/20] via 10.3.10.2, 01:07:46, FastEthernet0/1
UPSTREAM#

PE#sh ip route ospf 10

Routing Table: VRF-C1

PE#sh ip route ospf 20

Routing Table: VRF-C2

PE#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets


C 1.1.1.1 is directly connected, Loopback0
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback1

Dari informasi diatas terlihat bahwa setiap client memiliki tabel routing yang terpisah dan berbeda beda
sesuai dengan konfigurasi yang diinginkan.

Semoga informasi sederhana ini dapat bermanfaat.