Anda di halaman 1dari 8

MPLS – BGP ( VPN Layer 3 over MPLS )

Integrasi MPLS dan BGP membentuk Layer 3 VPN over MPLS, berfungsi memberikan kemudahan
memisahkan traffic dari banyak network subscriber melalui single core network. Implementasi dari
teknologi ini umumnya dipergunakan oleh service provider dalam memberikan layanan ke pelanggan.

Keuntungan lainnya :
1. Membangun network LAN, MAN dan WAN yang scalable, manageable, dan aman
2. Menyediakan SLA yang tepat untuk IP traffic.
3. Memberikan layanan konektivitas terpadu.
4. Support teknologi remote access.
5. Kemudahan migrasi dari Frame Relay atau ATM ke Jaringan VPN layer 3.

Berikut ini adalah contoh implementasi sederhana :

Sebagai langkah awal adalah melakukan konfigurasi untuk konektivitas standar pada tiap router,
termasuk didalamnya adalah mengaktifkan loopback interface yang akan digunakan sebagai router –id
untuk OSPF dan BGP.
Kemudian aktifkan routing OSPF dan lakukan pengecheckan konektifitas standar :

LRO#ping 10.10.10.10

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 10.10.10.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/152/300 ms
LRO#traceroute 10.10.10.10

Type escape sequence to abort.


Tracing the route to 10.10.10.10

1 192.168.100.1 84 msec 104 msec *


LRO#

MRO#tracer 20.20.20.20

Type escape sequence to abort.


Tracing the route to 20.20.20.20

1 192.168.100.2 92 msec 84 msec *


MRO#ping 20.20.20.20

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 20.20.20.20, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/88/200 ms
MRO#

Selanjutnya adalah mengaktifkan BGP, ketika BGP sudah terjalin tabel route akan diupdate pada setiap
peer, namun router PE tidak akan dapat melakukan ping ke IP 71.252.0.1 pada router MRO begitu juga
sebaliknya, hal ini terjadi karena router LRO tidak memiliki informasi routing untuk destinasi tersebut,
sehingga traffic di drop. MPLS berfungsi untuk memberikan informasi routing tersebut.

LRO#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

20.0.0.0/32 is subnetted, 1 subnets


C 20.20.20.20 is directly connected, Loopback0
C 192.168.200.0/24 is directly connected, FastEthernet0/1
10.0.0.0/32 is subnetted, 1 subnets
O 10.10.10.10 [110/11] via 192.168.100.1, 01:40:53, FastEthernet0/0
C 192.168.100.0/24 is directly connected, FastEthernet0/0
30.0.0.0/32 is subnetted, 1 subnets
O 30.30.30.30 [110/11] via 192.168.200.2, 01:40:53, FastEthernet0/1
LRO#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface


30.30.30.30 1 FULL/DR 00:00:38 192.168.200.2 FastEthernet0/1
10.10.10.10 1 FULL/BDR 00:00:38 192.168.100.1 FastEthernet0/0

*** Verifikasi status MPLS :

MRO#sh mpls ldp nei


Peer LDP Ident: 20.20.20.20:0; Local LDP Ident 10.10.10.10:0
TCP connection: 20.20.20.20.64042 - 10.10.10.10.646
State: Oper; Msgs sent/rcvd: 93/91; Downstream
Up time: 01:14:18
LDP discovery sources:
FastEthernet0/1, Src IP addr: 192.168.100.2
Addresses bound to peer LDP Ident:
192.168.100.2 20.20.20.20 192.168.200.1

LRO#sh mpls ldp neighbor


Peer LDP Ident: 30.30.30.30:0; Local LDP Ident 20.20.20.20:0
TCP connection: 30.30.30.30.49820 - 20.20.20.20.646
State: Oper; Msgs sent/rcvd: 94/94; Downstream
Up time: 01:14:25
LDP discovery sources:
FastEthernet0/1, Src IP addr: 192.168.200.2
Addresses bound to peer LDP Ident:
192.168.200.2 30.30.30.30 71.252.1.1
Peer LDP Ident: 10.10.10.10:0; Local LDP Ident 20.20.20.20:0
TCP connection: 10.10.10.10.646 - 20.20.20.20.64042
State: Oper; Msgs sent/rcvd: 91/93; Downstream
Up time: 01:13:57
LDP discovery sources:
FastEthernet0/0, Src IP addr: 192.168.100.1
Addresses bound to peer LDP Ident:
71.252.0.1 192.168.100.1 10.10.10.10

PE#sh mpls ldp nei


Peer LDP Ident: 20.20.20.20:0; Local LDP Ident 30.30.30.30:0
TCP connection: 20.20.20.20.646 - 30.30.30.30.49820
State: Oper; Msgs sent/rcvd: 94/94; Downstream
Up time: 01:14:38
LDP discovery sources:
FastEthernet0/0, Src IP addr: 192.168.200.1
Addresses bound to peer LDP Ident:
192.168.100.2 20.20.20.20 192.168.200.1

*** Verifikasi status BGP :

MRO#sh ip bgp
BGP table version is 3, local router ID is 10.10.10.10
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path


*> 71.252.0.0/24 0.0.0.0 0 32768 i
*>i71.252.1.0/24 30.30.30.30 0 100 0 i

PE#sh ip bgp
BGP table version is 3, local router ID is 30.30.30.30
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path


*>i71.252.0.0/24 10.10.10.10 0 100 0 i
*> 71.252.1.0/24 0.0.0.0 0 32768 i
PE#
*** Verifikasi konektifitas :

MRO#ping 71.252.1.1

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 71.252.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/130/244 ms
MRO#tracer 71.252.1.1

Type escape sequence to abort.


Tracing the route to 71.252.1.1

1 192.168.100.2 [MPLS: Label 16 Exp 0] 96 msec 120 msec 84 msec


2 192.168.200.2 68 msec 116 msec *
MRO#

PE#ping 71.252.0.1

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 71.252.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 96/125/164 ms
PE#trace
PE#traceroute 71.252.0.1

Type escape sequence to abort.


Tracing the route to 71.252.0.1

1 192.168.200.1 [MPLS: Label 17 Exp 0] 188 msec 148 msec 60 msec


2 192.168.100.1 28 msec 132 msec *
PE#

*** Konfigurasi detail router :

# ROUTER MRO :
hostname MRO
!
ip cef
!
mpls label protocol ldp
!
interface Loopback0
ip address 10.10.10.10 255.255.255.255
!
interface FastEthernet0/0
description TO-CLOUD
ip address 71.252.0.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
description TO-LRO
ip address 192.168.100.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
router ospf 24
router-id 10.10.10.10
log-adjacency-changes
network 10.10.10.10 0.0.0.0 area 1
network 20.20.20.20 0.0.0.0 area 1
network 30.30.30.30 0.0.0.0 area 1
network 192.168.100.0 0.0.0.255 area 1
!
router bgp 26
no synchronization
bgp log-neighbor-changes
network 71.252.0.0 mask 255.255.255.0
neighbor 30.30.30.30 remote-as 26
neighbor 30.30.30.30 update-source Loopback0
no auto-summary
!
mpls ldp router-id Loopback0
!
end

# ROUTER LRO :
hostname LRO
!
ip cef
!
mpls label protocol ldp
!
interface Loopback0
ip address 20.20.20.20 255.255.255.255
!
interface FastEthernet0/0
description TO-MRO
ip address 192.168.100.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
description TO-PE
ip address 192.168.200.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
router ospf 24
router-id 20.20.20.20
log-adjacency-changes
network 10.10.10.10 0.0.0.0 area 1
network 20.20.20.20 0.0.0.0 area 1
network 30.30.30.30 0.0.0.0 area 1
network 192.168.100.0 0.0.0.255 area 1
network 192.168.200.0 0.0.0.255 area 1
!
mpls ldp router-id Loopback0
!
end

# ROUTER PE :
hostname PE
!
ip cef
!
mpls label protocol ldp
!
interface Loopback0
ip address 30.30.30.30 255.255.255.255
!
interface FastEthernet0/0
description TO-LRO
ip address 192.168.200.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip address 71.252.1.1 255.255.255.0
duplex auto
speed auto
!
router ospf 24
router-id 30.30.30.30
log-adjacency-changes
network 10.10.10.10 0.0.0.0 area 1
network 20.20.20.20 0.0.0.0 area 1
network 30.30.30.30 0.0.0.0 area 1
network 192.168.200.0 0.0.0.255 area 1
!
router bgp 26
no synchronization
bgp log-neighbor-changes
network 71.252.1.0 mask 255.255.255.0
neighbor 10.10.10.10 remote-as 26
neighbor 10.10.10.10 update-source Loopback0
no auto-summary
!
mpls ldp router-id Loopback0
!
end