Anda di halaman 1dari 13

How To Configure Frame Relay in GNS3 – Step By Step

Consider a scenario where XYZ WAN Solutions has a central office that uses a high -end
Cisco router to connect branch office routers using the point-to-point frame relay circuits. The
organization wants that each branch office’s router should treat the circuit as a point -to-point
circuit. However, all the branch office routers should also be able to communicate to other
branch offices’ routers through the router placed in the central office. You have been hired to
provide the solution for the same. You decide to configure frame relay using the Hub and
Spoke topology. Before implementing frame relay configuration on the production network,
first, you plan to configure and test frame relay in GNS3.

If you want to configure frame relay on Cisco Packet Tracer, visit the following link.

Configure Frame Relay in Cisco Packet Tracer

Steps to Configure Frame Relay in GNs3


In this post, we will explain how to configure Frame relay in Gns3. However, we will not
cover the concept of frame relay in this post. We assume that you have already familiar with
the frame relay features and components. We will use the following GNS3 topology to
configure Frame Relay.

Add three routers and a Frame Relay Switch in the GNS3 console and connect them as pe r the
preceding topology. Now, open the Frame Relay Switch properties and specify the source and
destination ports and DLCI numbers. Please refer the following figure to set the desired ports
and DLCI numbers on the node properties.
Once you have specified the ports and DLCI numbers for all the routers, let’s begin the frame
relay configuration in GNS3.

Step by Step Frame Relay Configuration in GNS3


To configure Fame Relay in GNS3, you need to perform the following steps:

1. On R1, execute the following commands.


2. R1#config t
3. R1(config)#interface se0/0
4. R1(config-if)#ip add 172.168.10.1 255.255.255.0
5. R1(config-if)#encapsulation frame -relay
6. R1(config-if)#frame-relay map ip 172.16.10.2 105 broadcast
7. R1(config-if)#frame-relay map ip 172.16.10.3 106 broadcast
8. R1(config-if)#no shutdown
R1(config-if)#exit
9. The following figure shows the frame relay configuration of R1.

10. On R2, execute the following commands.


11. R2#config t
12. R2(config)#interface se0/0
13. R2(config-if)#ip add 172.168.10.2 255.255.255.0
14. R2(config-if)#encapsulation frame-relay
15. R2(config-if)#frame-relay map ip 172.16.10.1 501 broadcast
16. R2(config-if)#frame-relay map ip 172.16.10.3 501 broadcast
17. R2(config-if)#no shutdown
R2(config-if)#exit

18. The following figure shows the frame relay configuration on R2.

19. On R3, execute the following commands.

R3#config t
R3(config)#interface se0/0
R3(config-if)#ip add 172.168.10.3 255.255.255.0
R3(config-if)#encapsulation frame -relay
R3(config-if)#frame-relay map ip 172.16.10.1 601 broadcast
R3(config-if)#frame-relay map ip 172.16.10.2 601 broadcast
R3(config-if)#no shutdown
R3(config-if)#exit
Verifying Frame Relay Configuration
To verify your frame relay configuration, execute the following command on R3 and examine
the output.

R1#show frame-relay
In the preceding figure, you can see that the frame relay encapsulation is configured. Notice
the frame relay MAP, status, and DLCI numbers.

https://protechgurus.com/using-vmware-guest-isolation-copy-paste/
How to Configure IS-IS in GNS3

In the previous posts, we explained the IS-IS routing protocol in detail. We recommend you to
read those posts if you missed. In this post, we will learn how to configure IS-IS
on Cisco router using GNS3.

To configure IS-IS routing protocol, we will use the following network topology. In the
following network topology, R1 and R2 are connected through the Fa0/0 interfaces, while R2
and R3 are connected through the Fa0/1 interfaces.

120% thưởng chào mừng


chuyên viên tư vấn 24/7 chơi cá cược hợp pháp 100%

Steps to Configure IS-IS


Let’s begin how to configure IS-IS on Cisco router. To configure IS-IS, you need to perform
the following steps:

1. On R1, execute the following commands to assign 1.1.1.1/24 IP address to the


Loopback0 interface.
R1(config)#interface Loopback0
R1(config-if)#ip add 1.1.1.1 255.255.255.0

2. Next, execute the following commands to assign 10.10.10.1/24 IP address to the


FastEthernet0/0 interface and enable IS -IS for IP on the FastEthernet0/0 interface.

R1(config)#interface fa0/0
R1(config-if)#ip address 10.10.10.1 255.255.255.0
R1(config-if)#ip router isis
R1(config-if)#exit

3. Next, execute the following commands to enable the IS-IS process and assign an area
and a system ID. In this example, we will use 49.0001.1111.1111.1111.00 as a system ID.

R1(config)#router isis
R1(config-router)#net 49.0001.1111.1111.1111.00

4. The following figure displays the IS -IS configuration of R1.

5. Once you have configured R1, next, move on to R2, and execute the
following commands to assign 2.2.2.2/24 IP address to the Loopback0 interface.

R2(config)#interface loopback0
R2(config-if)#ip add 2.2.2.2 255.255.255.0

6. Next, execute the following commands to assign the IP address to the FastEthernet0/0
interface and enable IS -IS for IP to the FastEthernet0/0 interface.

R2(config)#interface fa0/0
R2(config-if)#ip address 10.10.10.2 255.255.255.0
R2(config-if)#ip router isis
R2(config-if)#exit

7. Next, execute the following commands to assign 20.20.20.1/24 IP address to the


FastEthernet0/1 interface and enable IS -IS for IP to the FastEthernet0/1 interface.
R2(config)#interface fa0/1
R2(config-if)#ip address 20.20.20.1 255.255.255.0
R2(config-if)#ip router isis
R2(config-if)#exit

8. Next, execute the following commands to enable the IS-IS process, assign an area and
a system ID. In this example, we will use 49.0002.22 22.2222.2222.00 as a system ID.

R2(config)#router isis
R2(config-router)#net 49.0002.2222.2222.2222.00

9. Next, move on to R3 and execute the following commands to assign 3.3.3.3/24 IP


address to the Loopback0 interface.

R3(config)#interface Loopback0
R3(config-if)#ip add 3.3.3.3 255.255.255.0

10. Next, execute the following commands to assign 20.20.20.2/24 IP address to the
FastEthernet0/1 interface and enable IS -IS for IP to the FastEthernet0/1 interface.

R3(config)#interface fa0/1
R3(config-if)#ip address 20.20.20.2 255.255.255.0
R3(config-if)#ip router isis
R3(config-if)#exit

11. Next, execute the following commands to enable the IS-IS process, assign an area and
a system ID. In this example, we will use 49.0003.3333.3333.333300 as a system ID.

R3(config)#router isis
R3(config-router)#net 49.0003.3333.3333.3333.00
Verify IS-IS Configuration
Once you have configured IS-IS on all the routers, now verify your configuration. To verify
the IS-IS routing configuration, execute the show ip route command and verify the routing
table. You should be able to see the routes added by the IS -IS routing protocol. In addition,
you can also test the network connectivity between R3 and R1 by executing the ping
1.1.1.1 command on R3.
In the following figure, you can see the routing information added by the IS-IS routing

protocol.

One more important command you need to consider is show clns neighbors. It displays the
IS-IS neighbor routers. In the following figure, you can see that R2 has two neighbors R1 and
R3. R1 is connected to R2 via the Fa0/0 interface and R3 is connected to R2 via the Fa0/1
interface.

In this post, you have learned how to configure IS-IS on Cisco routers using GNS3. We would
love to hear your suggestions. In the upcoming posts, we will configure IS-IS using a complex
network topology.
How To Configure BGP Step By Step Lab

Border Gateway Protocol (BGP) is a complex routing protocol and the configuration of BGP
is really complicated. Before configuring BGP protocol, you should have at least the basic
idea of BGP, iBGP, and eBGP. Please refer the following link to learn the basics of BGP
protocol.

 Introduction to Border Gateway Routing (BGP)

In this post, we will explain how to configure BGP in GNS3 using a simple network topology.
To configure BGP routing protocol, we will use the following network topology.

In the preceding topology, we will configure iBGP (routers within an AS) between R1 and R2
while R2 and R3 need to be configured with eBGP (routers between ASs).

Steps to Configure BGP


To configure BGP, you need to perform the following steps:

1. First, configure the appropriate IP addresses on all the routers.


2. On R1, execute the following command to enable the BGP process and specify
an Autonomous System Number (ASN). For example, 1000.

R1(config)#router bgp 1000

4. Next, execute the following command to specify the address of the neighbor router and
its ASN.
5. R1(config-router)#neighbor 10.10.10.2 remote -as 1000
R1(config-router)#exit
6. The following figure shows the BGP configuration of R1.

7. Next, move on to R2 and execute the following commands to enable the BGP process
and specify its ASN.

R2(config)#router bgp 1000

8. Next, execute the following command to specify the address of neighbor router for
iBGP.

R2(config-router)#neighbor 10.10.10.1 remote -as 1000

9. Next, execute the following command to specify the neighbor router for eBGP.

R2(config-router)#neighbor 20.20.20.2 remote-as 2000


Note: It is recommended to use a loopback interface as an update source for stability
purpose. Physical interfaces may shut down or cable may be disconnected. However, the
loopback interface remains active regardless the status of cable, con nector, and link.

10. Next, execute the following command to specify the update source interface
of the neighbor router.
11. R2(config-router)#neighbor 20.20.20.2 update -source
loopback0
R2(config-router)#exit
The following figure shows the BGP configuration of R2.

12. Next, move on to R3 and execute the following command to enable BGP process and
specify ASN.

R3(config)#router bgp 2000


13. Next, execute the following command to specify the neighbor router and its ASN.

R3(config-router)#neighbor 1.1.1.1 remote -as 1000

14. Since we have used the loopback0 interface of R2 as an update source interface, it will
put R2 two hops away from R3. However, by default, BGP assumes that external peers are
only one hop away. You can change this behavior by enabling the eBGP multihop feature. To
specify the custom number of hops manually, execute the following command.
15. R3(config-router)#neighbor 1.1.1.1 ebgp -multihop 2
R3(config-router)#exit

16. In order to use a loopback interface as an update source interface, R3 must have a
route to R2’s loopback in its routing table. This can be done by adding a static route. To do
so, execute the following command.

R3(config)#ip route 1.1.1.0 255.255.255.0 20.20.20.1

17. The following figure shows the BGP configuration of R3.

18. Once you have successfully configured BGP on all the routers, now it’s time to verify
your configuration. To do so, execute the following command on any router
and examine the output as shown in the following figure.

R3#show ip bgp neighbors


Configuring BGP Timers
By default, the Keepalive and Hold Down timer values for BGP protocol are 60 and 180
seconds, respectively. However, you can change it globally for all the neighbor routers as per
network requirement.

For example, to set the Keepalive BGP timers value as 10 seconds and Ho ld Down timer value
as 30 seconds, you need to execute the following commands.

R3(config)#router bgp 2000


R3(config-router)#timers bgp 10 30
The following figure shows how to change the BGP timers.
In this post, we have learned the basic configuration of BGP routing protocol. Hope, it helped
you. Please like and share this post if you think it can help others too. Please also subscribe
us to get auto alerts of daily new posts.

Share this:

https://protechgurus.com/download-gns3-ios-images/

Anda mungkin juga menyukai