Anda di halaman 1dari 5

Función CONSULTAV

explicada
La función CONSULTAV es la manera en que Excel nos permite
encontrar “una aguja en un pajar”. Esta función nos permite realizar
búsquedas verticales en nuestros datos es decir, búsquedas sobre una
columna de nuestra hoja.

Ejemplo de la función CONSULTAV


Supongamos que tenemos una lista de empleados de nuestra compañía
en donde la primera columna contiene el número de empleado y la
segunda columna es el nombre.

Ahora necesitamos encontrar el nombre de la persona que tiene el


número de empleado 45362 ¿Cómo lo hacemos? Lo adivinaste bien,
utilizando la función CONSULTAV podemos encontrar el nombre del
empleado basados en el número de empleado. Observa la siguiente
imagen:

Mi lista de empleados (que es muy pequeña para este ejemplo) se


encuentra en el rango A2:B10 y en la celda D1 he colocado el número de
empleado que deseo buscar. La fórmula que utilizo para la búsqueda es
la siguiente:
=CONSULTAV(D1, A2:B10, 2, FALSO)

Argumentos de la función CONSULTAV


La función CONSULTAV tiene cuatro argumentos y los revisaremos a
continuación poniendo como ejemplo la fórmula de nuestro ejemplo.

El primer argumento de la función CONSULTAV es el valor que estoy


buscando. Ese valor lo puedo indicar directamente en el argumento o
puedo indicar una referencia a la celda que lo contiene. En nuestro
ejemplo he colocado una referencia a la celda D1 la cual contiene el
número de empleado a buscar.

=CONSULTAV(D1

El segundo argumento de la función es el rango de datos sobre el cual se


realizará la búsqueda. Es importante que este rango incluya la columna
que deseo obtener como resultado. El rango A2:B10 nos asegura que
podremos pedir la función CONSULTAV que nos devuelva
el Nombre después de buscar sobre la columna de números de
empelado.

=CONSULTAV(D1, A2:B10

Nombre que corresponda al número de empleado encontrado.

=CONSULTAV(D1, A2:B10, 2

Es muy importante mencionar que la función CONSULTAV siempre hará


la búsqueda sobre la primera columna (de la izquierda) del rango de
búsqueda especificado y eso no se puede cambiar. Al haber indicado el
rango A2:B10, las búsquedas siempre se realizarán sobre los valores de
la columna A.

El cuarto argumento de la función CONSULTAV es un valor booleano es


decir, falso o verdadero. El valor FALSO le indica a la función que
queremos hacer una búsqueda exacta y es el valor que te recomiendo
utilizar siempre.

=CONSULTAV(D1, A2:B10, 2, FALSO)


Ya que el valor buscado se encuentra en la celda D1, bastará con
cambiar el valor de dicha celda para que la función haga una nueva
búsqueda y nos devuelva el resultado. En la siguiente imagen puedes
observar el resultado después de haber cambiado el número de
empleado en la celda D1.

Función Excel CONSULTAH


Categoría: Búsqueda y referencia
Nombre en inglés: HLOOKUP

¿Qué hace?
Busca un valor dentro de una fila y regresa el valor en la misma posición
de una segunda fila. Siempre busca en la primera fila del rango
especificado.

Sintaxis
CONSULTAH(valor_buscado, rango, valor_regresado, [aproximado])

 valor_buscado (obligatorio): Valor que se buscará en el rango


 rango (obligatorio): El rango de celdas que contiene la fila de
valores y la fila de resultados.
 valor_regresado (obligatorio): Número de fila (dentro del rango) que
contiene los resultados.
 aproximado (opcional): Indica si será una coincidencia aproximada.
Si se omite se toma como verdadero.
Ejemplos
CONSULTAH(“Excel”, A1:J2, 2) = Encuentra “Excel” en la fila 1 y regresa
el valor que le corresponde de la fila 2