Anda di halaman 1dari 5

COREROUTER CONFIG:

------------------

hostname COREROUTER
!
int gig0/0
ip address 192.168.2.1 255.255.255.0
description connected to Core network
no shutdown
exit
!
int gig0/2
ip address 192.168.1.1 255.255.255.0
description connected to Server network
no shutdown
exit
!
int gig0/1.100
encapsulation dot1q 100
ip address 192.168.100.1 255.255.255.0
description connected to VLAN 100
exit
!
int gig0/1.500
encapsulation dot1q 500
ip address 192.168.50.1 255.255.255.0
description connected to VLAN 500
exit
!
int gig0/1
no shutdown
exit
!

SRV SWITCH CONFIG:


------------------

hostname SRVSWITCH
!
int vlan 1
ip address 192.168.1.2 255.255.255.0
no shutdown
exit
!
ip default-gateway 192.168.1.1
!

USER SWITCH CONFIG:


------------------

hostname USERSWITCH
!
vlan 100
name EMPLOYEEVLAN
vlan 500
name GUESTVLAN
exit
!
int fa0/9
switchport mode access
switchport access vlan 100
exit
!
int fa0/15
switchport mode access
switchport access vlan 500
exit
!
int fa0/24
switchport mode trunk
exit
!
!

COREROUTER DHCP SERVER CONFIG:


------------------------------

!
ip dhcp pool DHCPVLAN500
network 192.168.50.0 255.255.255.0
default-router 192.168.50.1
dns-server 8.8.8.8
exit
!
ip dhcp excluded-address 192.168.50.1 192.168.50.10
!

ISP ROUTER CONFIG:


-------------------

hostname PLDT
!
int fa0/0
ip address 198.8.8.1 255.255.255.0
no shutdown
exit
!
int fa0/1
ip address 195.5.5.1 255.255.255.0
no shutdown
exit
!

--------------------

hostname SKYCABLE
!
int fa0/0
ip address 202.2.2.1 255.255.255.0
no shut
exit
!
int fa0/1
ip address 201.1.1.1 255.255.255.0
no shut
exit
!

EDGEROUTER CONFIG:
------------------

hostname EDGEROUTER
!
int gig0/0
ip address 192.168.2.2 255.255.255.0
no shutdown
exit
!
int gig0/1
ip address 195.5.5.11 255.255.255.0
no shutdown
exit
!
!
ip route 0.0.0.0 0.0.0.0 gig0/1
!
access-list 1 permit any
!
ip nat inside source list 1 interface gig0/1 overload
!
int gig0/1
ip nat outside
!
int gig0/0
ip nat inside
exit
!

----------------------------------------------------------------
Dynamic Routing using RIPv2
-----------------------------------------------------------------

hostname COREROUTER
!
router rip
version 2
network 192.168.1.0
network 192.168.2.0
network 192.168.100.0
network 192.168.50.0
no auto-summary
!

-------------------------

hostname EDGEROUTER
!
router rip
version 2
network 192.168.2.0
no auto-summary
default-information originate
exit
!

--------------------------

hostname VPNGATEWAY
!
int fa0/0
ip address 192.168.2.3 255.255.255.0
no shutdown
exit
!
int fa0/1
ip address 201.1.1.11 255.255.255.0
no shutdown
exit
!
int s0/0/0
ip address 172.16.1.1 255.255.255.252
clock rate 128000
no shutdown
exit
!
router rip
version 2
network 192.168.2.0
network 172.16.0.0
no auto-summary
exit
!

-----------------------------

hostname REMOTEDC
!
int s0/0/0
ip address 172.16.1.2 255.255.255.252
no shutdown
exit
!
int fa0/0
ip address 172.16.2.1 255.255.255.0
no shutdown
exit
!
router rip
version 2
network 172.16.0.0
no auto-summary
exit
!

----------------------------------

hostname BRANCH1
!
int fa0/0
ip address 202.2.2.11 255.255.255.0
no shut
exit
!
int fa0/1
ip address 10.10.10.1 255.255.255.0
no shut
exit
!