Anda di halaman 1dari 7

Planteamiento del problema a resolver: Usted es seleccionado para Construir un algoritmo que

permita identificar de 120 estudiantes, cuántos de ellos han pasado un curso (superior o = a 3),
deben habilitar (superior a 2) y cuantos definitivamente los han perdido (inferior a 2.0), además
cual es el promedio del total del curso.

Que datos Que Tipo Formulas Requiere Requiere


no datos no Variables a condicional ciclos (si
conozco y conozco, requeridas aplicar si (si / / no) _
se pero se no) cuales
deben los puedo requieren
solicitar calcular Tipo Variable
(si se
requiere
más filas
por
favor
anexarlas)
Notas de Cuantos FLOTANTE NOTA NO Si, un
cada ganan ciclo
estudiante PARA
Cuantos ENTERA GANARON SI NO
habilitan
Cuantos ENTERA HABILITAR SI NO
pierden
Promedio ENTERA PERDER SI NO
total
FLOTANTE NOTAFINAL,PROM SI NO NO

Algoritmo ESTUDIANTES

Para I<-1 Hasta 120 Con Paso 1 Hacer

Escribir "INGRESE LA NOTA DEL ESTUDIANTE","...", I

Leer NOTA

Si NOTA>=3 Entonces

GANARON<-GANARON+1;

Fin Si

Si NOTA>=2&&NOTA<3 Entonces

HABILITAR<-HABILITAR+1;

Fin Si
Si NOTA<2 Entonces

PERDER<-PERDER+1;

Fin Si

NOTAFINAL<-NOTAFINAL+NOTA;

Fin Para

PROM<-NOTAFINAL/120

Escribir "GANARON LA MATERIA","...",GANARON

Escribir "HABILITAN LA MATERIA","...",HABILITAR

Escribir "PERDIERON LA MATERIA","...",PERDER

Escribir "PROMEDIO DEL CURSO","...",PROM

Escribir "Jose Elias Aranda","Dofus SAS"

FinAlgoritmo
¿En qué aspectos ha cambiado el análisis de ejercicio desde el diseño inicial o este ha permanecido
consistente?

En este algoritmo se usó un ciclo repetitivo, para almacenar todas las notas y tomar decisiones
acerca de cada nota, como son 120 estudiantes, se usan 120 reiteraciones para el diseño del
algoritmo

9. Planteamiento del problema a resolver: Se debe Construya un algoritmo que permita realizar
una encuesta a N personas, de los cuales se pretende identificar lo siguiente:

a- Estrato social al que pertenece (1 a 6), no se deben permitir otro

b- Salario mensual, no se aceptan salarios negativos

c- Tipo de trabajo (1- sin trabajo, 2- independiente, 3- empleado público,

4 – empleo privado), no se admite otra opción El programa garantiza que los datos ingresados
sean correctos y al final debe reportar lo siguiente:

1. Cantidad de persona encuestada

2. El estrato promedio de las personas encuetadas.

3. Promedio del salario de las personas encuestadas

4. Cuál es el tipo de trabajo más predominante.


Que Que datos Tipo Formul Requiere Requie
datos no Variables as a condicio re
no conozco, requeridas aplicar nal (si / ciclos
conozco pero si se no) (si
y se los puedo requier / no) _
deben calcular Tipo Variable en cuales
solicitar
(si se
requiere
más
filas por
favor
anexarla
s)
Persona Estrato ENTERA PERSONAS A ENCUESTAR NO si Si, un
sa promedio ciclo
encuest for
ar
Estrato Salario ENTERA ESTRATO,SALARIO NO NO
social promedio
Salario Trabajo ENTERA DESEMPLEO,IND,PUBLICO SI SI
mensual predomina ,PRIV
nte
Tipo de FLOTAN promEstrato SI NO
trabajo TE
FLOTAN promSalario SI NO
TE

Algoritmo ENCUESTA

Escribir "INGRESE EL NUMERO DE PERSONA A ENCUESTAR"

Leer N

Para I<-1 Hasta N Con Paso 1 Hacer

Escribir "INGRESE ESTRATO SOCIAL DEL 1 AL 6"

Leer ESTRATO

Escribir "INGRESE SALARIO MENSUAL"

Leer SALARIO

Escribir "TIPO DE TRABAJO INGRESE "

Escribir "1. SI ES DESEMPLEADO"


Escribir "2. SI ES INDEPENDIENTE"

Escribir "3. SI ES EMPLEADO PUBLICO"

Escribir "4. SI ES EMPLEADO PRIVADO"

Leer EMPLEO

Si EMPLEO=1 Entonces

DESEMPLEO<-DESEMPLEO+1;

Fin Si

Si EMPLEO=2 Entonces

IND<-IND+1;

Fin Si

Si EMPLEO=3 Entonces

PUBLICO<-PUBLICO+1;

Fin Si

Si EMPLEO=4 Entonces

PRIV<-PRIV+1;

Fin Si

totalEstrato<-totalEstrato+ESTRATO

totalSalario<-totalSalario+SALARIO

Fin Para

promEstrato<-totalEstrato/N

promSalario<-totalSalario/N

Escribir "CANTIDAD DE PERSONAS ENCUESTADA ","...",N

ESCRIBIR "EL ESTRATO PROMEDIO DE LAS PERSONAS ENCUESTADAS ES","...",promEstrato

Escribir "EL SALARIO PROMEDIO DE LAS PERSONAS ENCUESTADAS ES","...",promSalario

Si (DESEMPLEO>IND) y (DESEMPLEO>PUBLICO) Y (DESEMPLEO>PRIV) Entonces

Escribir "EL DESEMPLEO ES EL TIPO DE TRABAJO MAS PREDOMINANTE"

Fin Si
Si (IND>PUBLICO) Y (IND>PRIVADO) Entonces

Escribir "EL INDEPENDIENTE ES EL TIPO DE TRABAJO MAS PREDOMINANTE"

Fin Si

Si (PUBLICO>PRIV) Entonces

Escribir "EL TIPO DE TRABAJO PUBLICO ES EL TRABAJO MAS PREDOMINANTE"

SiNo

Escribir "EL TIPO DE TRABAJO MAS PREDOMINANTE ES EL PRIVADO"

Fin Si

Escribir "Jose Elias Aranda","Dofus SAS"

FinAlgoritmo
¿En qué aspectos ha cambiado el análisis de ejercicio desde el diseño inicial o este ha
permanecido consistente?

Se usó un ciclo PARA para encuestar a un total de personas