Anda di halaman 1dari 24

A.

Cara Setting Hotspot di MikroTik Dengan Winbox

Step 1 - Login ke winbox, klik Menu "IP > Hotspot" dalam contoh ini menggunakan Hotspot Wizard yang sudah
disediakan agar menjadi lebih mudah, klik "Hotspot Setup"

Step 2 - Pilih Interface/Port dalam routerboard Anda, contoh di artikel ini saya menggunakan ether5.
Step 3 - Input IP Address yang digunakan untuk jaringan hotspot mikrotik Anda, defaultnya10.5.50.1/24.

Step 4 - Pada bagian ini masukan range IP Address yang akan di terima User. Defaultnya user akan mendapatkan IP
Address 10.5.50.2 s/d 10.5.50.254.

Step 5 - Klik Next


Step 6 - Klik Next

Step 7 - Isi dengan nama lokal domain yang Anda inginkan. Nama domain ini yang akan muncul di address bar
browser user Anda. Jadi misalnya jika user akan login, di address bar browser mereka akan terlihat
"http://modalsemangat.hotspot".
Step 8 - Masukan username dan password, biasanya di awal untuk login sang network admin.

Step 9 - Klik "OK", dan anda sudah berhasil mengaktifkan fitur hotspot mikrotik dalam jaringan Anda.

Test dengan komputer yang dimasukin ke jaringan hotspot agan di interface hotspotnya sudah ditentukan. Buka
aplikasi browser kesayangan agan (firefox, chrome) trus buka misalnya detik.com, Jika sukses agan akan di
redirect/diarahkan ke Login Page Hotspot Mikrotik.
B. Cara Membuat Username dengan Limitasi
Bandwidth/Kecepatan Internet

Anggap saja kita akan membuat batasan kategori user hotspot sebagai berikut :
 Kategori user VIP, dengan batasan kecepatan koneksi internet Download 1Mbps dan Upload
384Kbps.
 Kategori user Gold, dengan batasan kecepatan koneksi internet Download 512Kbps dan
Upload 256Kbps.
 Kategori user Silver, dengan batasan kecepatan koneksi internet Download 256Kbps dan
Upload 128Kbps.

Yang pertama kita lakukan adalah membuat User Profile pada hotspot mikrotik kita, untuk setting
limitasi masing-masing kategori User.

# jun/30/2014 14:33:16 by RouterOS 5.26


# Adam Rachmad - http://adamonline.web.id
/ip hotspot user profile
add advertise=no idle-timeout=none keepalive-timeout=2m name=VIP \
open-status-page=always rate-limit=512k/1m shared-users=1 \
status-autorefresh=1m transparent-proxy=yes
add advertise=no idle-timeout=none keepalive-timeout=2m name=Gold \
open-status-page=always rate-limit=256k/512k shared-users=1 \
status-autorefresh=1m transparent-proxy=yes
add advertise=no idle-timeout=none keepalive-timeout=2m name=Silver \
open-status-page=always rate-limit=128k/256k shared-users=1 \
status-autorefresh=1m transparent-proxy=yes

Di Winbox akan terlihat seperti ini IP > Hotspot > User Profiles :

Setelah itu baru kita buat username dan password untuk kategori user hotspot yang barusan kita
buat.
# jun/30/2014 14:33:16 by RouterOS 5.26
# Adam Rachmad - http://adamonline.web.id
/ip hotspot user
add disabled=no name=udin password=123456 profile=VIP server=hotspot1
add disabled=no name=petot password=123456 profile=Gold server=hotspot1
add disabled=no name=jiung password=123456 profile=Silver server=hotspot1

Di menu IP > Hotspot > Users terdapat opsi konfigurasi user / password klien kita yang bisa di
konfigurasi.

Tab “General”

 Server, nama server Hotspot yang diperbolehkan login untuk user.


 Name, Username untuk login user HotSpot, jika otentikasi dengan MAC-addressdi aktifkan,
di isi dengan mac address client.
 Password, password user.
 Address, masukan IP address yang kita tentukan untuk didapat oleh client dari server
hotspot.
 MAC Address, username diperbolehkan untuk login hanya dari MAC Address yang
ditentukan.
 Profile, User profile yang sudah di konfigurasi di /ip hotspot user profile.
 Routes, Routing yang ditambahkan jika client terkoneksi. Format routingnya adalah dst-
address gateway metric (contoh, 192.168.1.0/24 192.168.88.1 1)
 Email, alamat email pengguna hotspot.

Tab “Limits”

 Limit Uptime, Batas Uptime untuk klien HotSpot, client akan terputus dari HotSpot jika
uptime tercapai.
 Limit Bytes In, Jumlah maksimal byte (total quota download) yang dapat diterima oleh
client. Client akan terputus dari HotSpot setelah batas tersebut tercapai.
 Limit Bytes Out, Jumlah maksimal byte (total quota upload) yang dapat diterima oleh
client. Client akan terputus dari HotSpot setelah batas tersebut tercapai.
 Limit Bytes Total, Jumlah maksimal byte (total quota download & upload) yang dapat
diterima oleh client. Client akan terputus dari HotSpot setelah batas tersebut tercapai.
Untuk opsi lainnya Anda bisa mencobanya, untuk kasus ini kita hanya membatasi kecepatan
internet untuk user hotspot.
Terlihat di winbox akan seperti ini IP > Hotspot > Users :

Sekarang coba login dengan salah satu username passsword tersebut, contoh saya coba login
dengan user hotspot “udin” kategori user hotspot VIP.

Terlihat pada gambar di atas bahwa client yang login dengan username “udin” ter limit
kecepatannya disesuaikan user profile yang sebelumnya kita buat. Ini berlaku untuk user hotspot
lainnya. Di winbox kita bisa lihat di Queues > Simple Queues.

Jika anda memberikan layanan koneksi gratis / free trial, dalam mikrotik terdapat fitur Free Trial
yang bisa Anda gunakan. User tidak perlu mempunyai username password untuk mengakses
koneksi internet via hotspot Anda, cukup 1 klik tombol di halaman login Anda. Fitur ini juga bisa
juga digunakan hanya untuk pembatasan penggunaan/uptime internet gratis di lokasi public wifi.

Tentu saja kita tidak memberikan koneksi unlimited untuk user free trial, di mikrotik kita bisa
membuat batasan berapa lama bisa terkoneksi (uptime) dan berapa lama bisa digunakan kembali
(laptop/gadget yg sama) bisa menggunakan kembali layanan Free Trial (Uptime Reset) jika jatah
gratisan sudah habis.

Pada winbox masuk menu IP > Hotspot > Server Profiles. Pilih server profiles yang aktif, jika
menggunakan wizard (Hotspot Setup) biasanya namanya "hsprof1". Klik tab "Login" kemudian
centang "Trial" untuk mengaktifkan fitur Free Trial (1).
(2)Opsi pada fitur trial

 Trial Uptime Limit : Tentukan waktu gratis / free akses yang diberikan ke trial user agan
untuk mencoba koneksi hotspot mikrotik agan.
 Trial Uptime Reset : Tentukan waktu reset trial user, ini maksudnya jika trial user agan
sudah memakai semua waktu yang digunakan untuk trial, trial user itu harus menunggu
misalnya “1d 00:00:00” atau 24 jam dengan mac address yg sama untuk bisa kembali login
menggunakan fungsi Free Trial hotspot mikrotik agan lagi.
 Trial User Profile : User profile yang digunakan untuk user trial.
Pada halaman login hotspot, akan muncul tombol/link untuk user Free trial :
C. KONFIGURASI BYPASS USER DAN WEB

Semua router OS Mikrotik jenis apapun sudah dilengkapi fitur untuk membuat
hotspot. Pada fitur Hotspot yang telah disediakan pada Mikrotik terdapat diantaranya adalah
Management user/pengguna, Management bandwidth setiap user, Management waktu lama
pengguna akses Hotspot, Bypass user login Hotspot, Monitoring menggunaan bandwidth
setiap user, dan masih banyak lagi.

Bypass maksudnya untuk akses ke hotspot tidak perlu lagi


memasukkan username dan password pada login hotspot. Pastikan bisa masuk ke routerOS
Mikrotik melalui WINBOX. Setelah bisa masuk ke routerOS Mikrotik, pilih menu IP >>
Hotspot.

Pada layar hotspot ada banyak sekali menu. Untuk mem-bypass login hotspot, kita bisa
menggunakan IP Bindings, Walled Garden atau bisa juga menggunakan IP-Walled Garden.

IP Bindings
Bagaimana jika ada user yang diistimewakan sehingga untuk terkoneksi tidak melewati
proses autentikasi dari hotspot login, hal ini bisa dilakukan dengan menggunakan fitur IP
bindings. Cara menggunakannya adalah kita harus tahu Mac Address dari perangkat yang
akan terkoneksi sehingga kita bisa tambahkan rule di IP bindings tersebut.
Misalkan "Mac Address 1C:C1:DE:91:AA:BE" akan di-bypass, sehingga user yang memiliki
mac address tersebut jika ingin terkoneksi ke internet tidak akan melewati proses autentikasi
dari hotspot login.

Pilih IP >> Hotspot >> IP Bindings. Kemudian tambahkan Mac Address dari user yang akan
di-bypass.
Pada opsi type terdapat 3 macam parameter yaitu :

 Blocked = Mac address yang didaftarkan dengan type ini otomatis tidak akan
mendapatkan layanan hotspot.
 Bypassed = Mac address yang didaftarkan dengan type ini akan dibypass sehingga
tidak perlu melewati proses autentikasi.
 Regular = Mac address yang didaftarkan dengan type ini akan melewati proses
autentikasi seperti user biasa, misalkan digunakan hanya untuk mengalokasikan ip
address khusus ke host tertentu.

Kita juga bisa melakukan IP-Bindings terhadap host yang aktif. Caranya cukup mudah yaitu
pilih host yang akan dilakukan IP-bindings, kemudian klik dua kali dan pilih "Make
Binding"

Selanjutnya akan muncul Hotspot IP Bindings, pada parameter type pilih bypassed.
Walled Garden
User yang belum melewati proses autentikasi tapi bisa mengakses website tertentu, dalam hal
ini bisa mengunakan walled garden. Misal, user yang belum terautentikasi bisa membuka
website "www.mikrotik.co.id".

Pilih IP >> Hotspot >> Wallaed Garden. Kemudian pada


parameter Dst.Host isikan *mikrotik.co.id dan pada Action, pilih allow.
IP-Walled Garden

Fungsinya hampir sama seperti Walled Garden tetapi dapat melakukan bypass terhadap
resource yang lebih spesifik pada protocol dan port tertentu. Biasanya digunakan untuk
melakukan bypass terhadap server local yang tidak memerlukan autentikasi.

Misalnya kita akan melakukan bypass terhadap trafik dengan protokol tcp dan tujuan port 20-
21 (FTP)

D. USER MANAGER DI MIKROTIK

Konsep Topologi

Misalkan pada sebuah area kampus memberlakukan sistem hotspot untuk koneksi
internetnya. Dan autentikasi user menggunakan fitur User Manager yang ada di MikroTik.
kemudain dibagi untuk jenis akunnya, ada akun khusus untuk Dosen & Mahasiswa.

 Dosen -> mendapatkan limitasi bandwith sebesar 1M dengan full akses.


 Mahasiswa -> mendpatkan limitasi bandwith sebesar 512kbps dengan pembatasan
akses untuk ke data server dosen, akses youtube dan facebook.
Konfigurasi User Manager

Setelah kita mengetahui konsep topologinya, saatnya kita akan melakukan konfigurasi router.
Pertama kita akan melakukan konfigurasi User Manager. User Manager ini kita akan
membuat 2 profile, yaitu untuk Dosen dan Mahasiswa.
Kemudian untuk masing-masing profile tersebut kita akan beri limitasi sesuai topologi diatas.
Nah, supaya bisa melakukan filtering akses menggunakan firewall secara dinamic untuk
client-client yang terkoneksi ke User Manager maka kita akan melakukan konfigurasi di
parameter 'Constraints'. Kita akan menambahkan pada 'address list' yang mana ketika ada
perangkat yang terkoneksi melalui User Manager akan di list secara otomatis ke dalam
address list di router. Dari Address List inilah kita akan melakukan management akses user
menggunakan firewall.
Kita tambahkan untuk masing-masing profile (Dosen & Mahasiswa) dengan nama address-
list yang berbeda.

Konfigurasi Firewall

Setelah konfigurasi pada User Manager telah selesai, selanjutnya kita akan mengelola user
tersebut menggunakan firewall. Apabila kita lihat pada menu Ip -> Firewall -> Address List,
seharusnya akan terdapat list IP Address dari perangkat-perangkat yang berhasil login
menggunakan akun di User Manager yang telah kita buat sebelumnya.
Selanjutnya kita akan melakukan filtering berdasarkan IP Address yang terdapat pada
Address list sesuai dengan konsep diatas.
Contoh konfigurasi pada firewall filter sebagai berikut:

/ip firewall filter


add action=drop chain=forward content=www.facebook.com protocol=tcp src-address-
list=!IPnya-Dosen
add action=drop chain=forward content=www.youtube.com protocol=tcp src-address-
list=!IPnya-Dosen
add action=drop chain=forward dst-address=172.16.1.100 src-address-list=IPnya-Mahasiswa

E. KONFIGURASI REPEATER DI ACCESS POINT

Cara men-Setup TL-WR700N/TL-WR702N sebagai Repeater


Cocok untuk: TL-WR700N, TL-WR702N

Aplikasi skenario

Informasi utama router (contoh):

 LAN IP: 192.168.0.1


 SSID (nama jaringan Wireless): TL-WR841ND
 Nirkabel keamanan Mode: WPA-PSK
 Enkripsi Type: AES
 Passphrase: 12345678
Persiapan

 Pastikan Router utama di Internet dan Anda mendapatkan informasi yang diperlukan itu
seperti di atas.
 Karena modus default TL-WR700N/TL-WR702N AP, fungsi DHCP pada mereka
dinonaktifkan secara default. Kita harus secara manual menetapkan alamat IP
sebagai 192.168.0.X ke komputer untuk mencocokkan alamat IP default (192.168.0.254)
dari Repeater. Silahkan klik di sini untuk petunjuk rinci.
 Sambungkan komputer ke TL-WR700N/TL-WR702N dengan kabel Ethernet.

Step1 mengubah modus bekerja untuk Repeater.

1. Menetapkan IP statis sebagai 192.168.0.X untuk komputer Anda . Jika Anda tidak tahu
bagaimana untuk mengubahnya, silakan klik di sini.

2. Buka Internet Explorer dan ketik alamat IP akses titik (Default adalah 192.168.0.254) ke
address bar dan tekan Enter:

3. Ketik username dan password ke dalam kotak halaman login, default nama pengguna dan
sandi yang kedua admin,kemudian tekan Enter:

4. Pada halaman manajemen, klik Bekerja Mode dan pilih Repeater mode.
Kemudian Simpan. Klik OK untuk reboot.
Setelah reboot, halaman akan kembali. Jika tidak, silakan refresh halaman atau
masukkan http://192.168.0.254 pada browser.

Step2 konfigurasi pada Repeater (AP 11n TP-Link):

1. Pada halaman manajemen, klik jaringan. Pastikan alamat IP Repeater adalah


dalam segmen IP yang sama dengan Router utama dan menghindari konflik IP. Apakah IP
router utama juga 192.168.0.254, yang sama untuk repeater, kita harus mengubah IP repeater
untuk "192.168.0.250". Kemudian klik Simpan .
2. Klik Wireless - > pengaturan nirkabel. Kemudian klik survei .

3. Menemukan Router utama SSID (nama jaringan nirkabel Anda) pada daftar, dan kemudian
klik Connect .
4. Halaman akan kembali Wireless Settings - > Repeater, dan SSID dan MAC AP akan diisi
dengan informasi dari router utama.

Kemudian untuk Opsi keamanan dan Password, masukkan info yang sama sebagai router
utama. Silakan konfirmasi opsi keamanan dan Password dari router utama. Di sini kita
mengambil WPA-PSK sebagai contoh. Pilih WPA-PSK/WPA2-PSK, dan masukan password
"12345678" di lapangan Password . Kemudian klik Simpan .

5. Maka akan ada pemberitahuan "perubahan konfigurasi nirkabel tidak akan efek sampai
Router reboot, silakan klik di sini untuk reboot." Silahkan klik di sana dan pergi ke reboot
repeater.

Setelah Anda pergi melalui semua langkah-langkah di atas, Repeater harus mendapatkan
bekerja dengan benar dengan Router utama.

Jika komputer masih terhubung ke Repeater dengan kabel, Anda dapat memeriksa
konektivitas dengan menggunakan Pingpada komputer. Klik Start - > Run,
ketik cmd. Kemudian OK.
Pada jendela hitam, dimasukkan ke dalam: ping + ruang IP router utama. Di sini, kami
menempatkan: ping 192.168.0.1.

Anda mungkin mendapatkan "dikirim = 4, menerima = 4, Lost = 0", yang menunjukkan


repeater bekerja dengan baik. Untuk mengaktifkan PC untuk mengakses Internet, mengubah
alamat IP dari PC ke mendapatkan IP Address/DNS server secara otomatis.
Jika Ping tidak berhasil, periksa semua di atas pengaturan dengan hati-hati, atau hubungi TP-
Link mendukung bantuan.

F. KONFIGURASI CLIENT ACCESS POINT

Cara setting AP sebagai Penerima atau Client. Contoh AP TP-LINK Model No. TL-
WA701N / TL-WA701ND, dan Berikut ini adalah langkah-langkahnya

 Pertama seting dulu alamat IP komputer kita,sesuaikan dengan alamat IP pada Access Point
milik kita. ( biasanya alamat ip tersebut terletak di bawah AP )
 Setelah setting alamat IP, lagkah selanjutnya yaitu membuka browser ( Internet
Exploler,Mozilla Firefox,dll )
 Masukan IP tersebut pada address browser

 Setelah itu kamu diminta memasukan User Name, dan Passwordnya !!


( User name, dan passwordnya biasanya terletak sama dengan alamat ip )

 Setelah itu kamu akan masuk ke tampilan system AP

 Setelah itu masuk ke menu Wirelss–>Wireless Setting


 Ganti Operation Mode menjadi “Client”
 Masukan SSID ( nama Hotspot ) tersebut
 Ganti Region dengan Indonesia
 Channel Width boleh diganti ataupun tidak
 Kik survey untuk melihat hotspot yang tersedia
 pilih nama hotspot dan klik “Connect”
 Simpan ( save ) seting yang telah kita buat tersebut
 Lalu Reboot AP kamu
Nah, akhirnya selesai deh,,, sekarang AP kamu sudah bisa jadi penerima sinyal hotspot,
Eittzz.. jangan buru-buru dulu, kamu bisa connect internet jika IP nya disetting Automatic (
DHCP )
Nah Jika IP Hotspotnya tidak DHCP maka kamu harus seting secara manual, yakni :

 Klik Start–>Control Panel–>Network Connection–>Local Area Network


 Pilih Proprties
 Lalu Pilih Internet Protocol (TCP/IP)
 Lalu Masukan alamat IPnya
 Klik OK