Anda di halaman 1dari 7

http://www.adaobraga.com.

br Parece-me que proibido publicar na internet respostas dos exerccios pois, no encontrei nenhum blog, frum em que se possa ter respostas para os exerccios, nem para facilitar, ento, como fonte de auxilio, eis abaixo, em pseudo-cdigo: portugol, programado em VISUALG os seguintes exerccios. 1. Faa um algoritmo para ler uma matriz de 34 de nmeros reais e depois exibir o elemento do canto superior esquerdo e do canto inferior algoritmo "Estudando Matriz" // Funo : Faa um algoritmo para ler uma matriz de 34 de nmeros reais // e depois exibir o elemento do canto superior esquerdo e do canto inferior direito // Autor : Ado Braga // Data : 26/6/2011 // Seo de Declaraes var matriz : vetor[1..3,1..4] de real i,j:inteiro inicio // Seo de Comandos para i de 1 ate 3 faca para j de 1 ate 4 faca escreva("Digite um nmero inteiro: [", i, ",", j, "] ") leia(matriz[i,j]) fimpara fimpara para i de 1 ate 3 faca para j de 1 ate 4 faca escreva(matriz[i,j]:3) fimpara escreval("") fimpara escreval("") escreval("linha 1 e coluna 1", matriz[1,1]) escreval("linha 3 e coluna 4", matriz[3,4]) fimalgoritmo

http://www.adaobraga.com.br 2. Ler uma matriz 5X5 e gerar outra em que cada elemento o cubo do elemento respectivo na matriz original. Imprima depois o elemento do meio desta nova matriz; algoritmo "Criar Matriz 55 e elevar ao cubo" // Funo Ler uma matriz 5X5 e gerar outra em que cada elemento o cubo // do elemento respectivo na matriz original. // Imprima depois o elemento do meio desta nova matriz; // Autor : Adao Braga // Data : 26/6/2011 // Seo de Declaraes var vetA:vetor[1..5,1..5] de real vetB:vetor[1..5,1..5] de real i,j:inteiro inicio // Seo de Comandos para i de 1 ate 5 faca para j de 1 ate 5 faca escreva("Digite os numeros: [",i, " + ", j, " ] ") leia(vetA[i,j]) fimpara fimpara para i de 1 ate 5 faca para j de 1 ate 5 faca escreva(vetA[i,j]:7) fimpara escreval("") fimpara para i de 1 ate 5 faca para j de 1 ate 5 faca vetB[i,j]<- (vetA[i,j]^3) fimpara fimpara para i de 1 ate 5 faca para j de 1 ate 5 faca escreva(vetB[i,j]:7) fimpara escreval("") fimpara fimalgoritmo

http://www.adaobraga.com.br 3. Faa um algoritmo para ler uma matriz 2X3 real e depois gerar e imprimir sua transposta (matriz 3X2 equivalente); algoritmo "Matriz: TRANSPORTA" // Funo : Faa um algoritmo para ler uma matriz 2X3 real e depois gerar // e imprimir sua transposta (matriz 3X2 equivalente); // Autor : Ado Braga // Data : 26/6/2011 // Seo de Declaraes var matrizA : vetor[1..2,1..3] de real matrizB : vetor[1..3,1..2] de real i,j:inteiro inicio // Seo de Comandos para i de 1 ate 2 faca para j de 1 ate 3 faca escreva("Digite um nmero inteiro: [", i, ",", j, "] ") leia(matrizA[i,j]) fimpara fimpara escreval(" - MATRIZ A -") para i de 1 ate 2 faca para j de 1 ate 3 faca escreva(matrizA[i,j]," ") fimpara escreval(" ") fimpara para i de 1 ate 3 faca para j de 1 ate 2 faca matrizB[i,j]<-(matrizA[j,i]) fimpara fimpara escreval(" - MATRIZ B -") para j de 1 ate 3 faca para i de 1 ate 2 faca escreva(matrizB[j,i]," ") fimpara escreval(" ") fimpara escreval(" ") fimalgoritmo

http://www.adaobraga.com.br 4. Faa um algoritmo para ler uma matriz 3X3 real e imprimir a soma dos elementos da Diagonal principal. Generaliza para uma matriz NXN; algoritmo "Matriz 33 Somar Diagonal" // Funo Faa um algoritmo para ler uma matriz 3X3 real e imprimir // a soma dos elementos da Diagonal principal. Generaliza para uma matriz NXN; // Autor : Adao Braga // Data : 26/6/2011 // Seo de Declaraes var matrizA:vetor[1..3,1..3] de real somaDiag1:real i,j:inteiro inicio // Seo de Comandos para i de 1 ate 3 faca para j de 1 ate 3 faca escreva("Digite os numeros: [",i, " + ", j, " ] ") leia(matrizA[i,j]) fimpara fimpara para i de 1 ate 3 faca para j de 1 ate 3 faca escreva(matrizA[i,j]) fimpara escreval("") fimpara para i de 1 ate 3 faca para j de 1 ate 3 faca somaDiag1<-(matrizA[1,1] + matrizA[2,2] + matrizA[3,3]) fimpara fimpara escreval("") escreval("Soma da Diagonal 1 = ", somaDiag1) escreval("") fimalgoritmo

http://www.adaobraga.com.br 5. Ler uma matriz 4X3 real e imprimir a soma dos elementos de uma linha L fornecida pelo usurio; algoritmo "Criar Matriz 43 Somar Linha" // 5. Ler uma matriz 4X3 real e imprimir a soma dos elementos de uma linha L fornecida pelo usurio // Autor : Adao Braga // Data : 30/6/2011 // Seo de Declaraes var vet4x3:vetor[1..4,1..3] de real linha,i,j:inteiro SomarLinha:real inicio // Seo de Comandos para i de 1 ate 4 faca para j de 1 ate 3 faca escreva("Digite os numeros: [",i, " + ", j, " ] ") leia(vet4x3[i,j]) fimpara fimpara escreva(" ") escreval(" - MATRIZ 4 X 3 -") para i de 1 ate 4 faca para j de 1 ate 3 faca escreva(vet4x3[i,j]," ") fimpara escreval(" ") fimpara escreval(" ") escreva("Qual linha quer somar? ") leia(linha) somarlinha<-0 para i de linha ate linha faca para j de 1 ate 3 faca somarlinha <- somarlinha + vet4x3[linha,j] fimpara fimpara escreval("Linha somada.: ", linha) escreval("Total da soma da linha: ", somarlinha) fimalgoritmo

http://www.adaobraga.com.br 6. Ler uma matriz 4X3 real. Depois, mostre qual o elemento armazenado em uma linha e coluna C fornecidos pelo usurio; algoritmo "Matriz 43 Mostrar dados solicitado" // 6. Ler uma matriz 4X3 real. Depois, mostre qual o elemento armazenado // em uma linha e coluna C fornecidos pelo usurio; // Autor : Adao Braga // Data : 30/6/2011 // Seo de Declaraes var vet4x3:vetor[1..4,1..3] de real linha,coluna,i,j:inteiro inicio // Seo de Comandos para i de 1 ate 4 faca para j de 1 ate 3 faca escreva("Digite os numeros: [",i, " + ", j, " ] ") leia(vet4x3[i,j]) fimpara fimpara escreva(" ") escreval(" - MATRIZ 4 X 3 -") para i de 1 ate 4 faca para j de 1 ate 3 faca escreva(vet4x3[i,j]," ") fimpara escreval(" ") fimpara escreval(" ") escreva("Qual linha voc quer ver? ") leia(linha) escreva("Qual coluna quer ver? ") leia(coluna) para i de linha ate linha faca para j de coluna ate coluna faca escreval("O numro armazenado na linha ",linha, " e na coluna ",coluna, " : ", vet4x3[linha,coluna]) fimpara fimpara fimalgoritmo

http://www.adaobraga.com.br 7. Crie uma matriz 7X8 onde cada elemento a soma dos ndices de sua posio dentro da matriz; algoritmo "Matriz 78 soma de seus indices" // 7. Crie uma matriz 7X8 onde cada elemento a soma // dos ndices de sua posio dentro da matriz; // Autor : Adao Braga // Data : 30/6/2011 // Seo de Declaraes var vet7x8:vetor[1..7,1..8] de inteiro i,j:inteiro inicio // Seo de Comandos para i de 1 ate 7 faca para j de 1 ate 8 faca vet7x8[i,j]<-i+i fimpara fimpara para i de 1 ate 7 faca para j de 1 ate 8 faca escreva(vet7x8[i,j]," ") fimpara escreval(" ") fimpara fimalgoritmo

Read more: http://www.adaobraga.com.br/#ixzz1QrlS5USi